x

Capítulos principais

  1. LimeSurvey Cloud vs LimeSurvey CE
  2. Guia de início rápido - LimeSurvey 3.0+
  3. Instalação - LimeSurvey CE
  4. Como criar um bom inquérito (guia)
  5. Começando
  6. Administração do LimeSurvey
  7. Inquéritos - introdução
  8. Configurações do inquérito
  9. Menu de inquérito
  10. Estrutura do inquérito
  11. Perguntas - introdução
  12. Grupos de perguntas - introdução
  13. Pesquisas - gestão
  14. Opções da barra de ferramentas do inquérito
  15. Inquérito multilingue
  16. ExpressionScript Engine - Guia de início rápido
  17. Recursos não categorizados e avançados
  18. Perguntas frequentes gerais
  19. Resolução de problemas
  20. Soluções alternativas
  21. Licença
  22. Registo de alterações das versões
  23. Plugins
 Actions

Exportar resultados

From LimeSurvey Manual

Esta página pode ter sido traduzida automaticamente e conter erros. Ver o original em inglês · Melhorar esta tradução
This page is a translated version of the page Exporting results and the translation is 100% complete.
  Atenção : A secção seguinte está desatualizada. Para obter informações atualizadas, consulte:




Depois de o inquérito estar ativo, pode começar a ver as respostas e a exportá-las. Para aceder à vista geral das respostas ao inquérito, clique em: Respostas -> Respostas e estatísticas

Exportar para aplicação (Excel/.csv)

Na parte superior da página são apresentadas várias opções de exportação.

Ao exportar resultados, existem várias opções de filtro:

  • Geral
    • Definir um intervalo (por exemplo, "exportar os registos X a Y")
    • Definir para exportar todos os registos OU apenas os registos completos OU apenas os registos incompletos
  • Perguntas
    • Determinar como o cabeçalho deve aparecer: cabeçalho abreviado OU cabeçalhos completos OU códigos das perguntas
    • Converter espaços no texto da pergunta em sublinhados
  • Opções de respostas
    • Pode exportar respostas completas ou converter os códigos de resposta Y e N numa variável definida
  • Formato
    • Microsoft Word (conjunto de caracteres latino)
    • Microsoft Excel (todos os conjuntos de caracteres)
    • Ficheiro CSV (todos os conjuntos de caracteres)
    • HTML
    • PDF
  • Controlo de colunas
    • Definir quais as respostas que devem ser exportadas. Todas as respostas desta lista são representadas pelo respetivo identificador SGQA
    • Definir quais os dados de código que devem ser exportados. Esta opção só está disponível se o seu inquérito não for anónimo!

Exportação para SPSS

Geral

O SPSS Statistics é um software utilizado para análise estatística lógica, em lote e não em lote. Pode utilizar o pacote oficial SPSS ou o GNU PSPP, uma alternativa ao programa proprietário SPSS.

Para exportar os dados das respostas para o SPSS, aceda à secção Respostas e estatísticas e clique no ícone de exportação para SPSS.

Exportar e filtrar dados

Ao exportar dados para o SPSS, existem duas opções de filtro. Pode selecionar quais os dados que devem ser selecionados (todos os registos/apenas registos completos/apenas registos incompletos) e para que versão do SPSS serão utilizados os ficheiros exportados (versão anterior à 16/16 ou acima).

A exportação para SPSS inclui dois ficheiros:

  1. um ficheiro de sintaxe (survey_xxxx_SPSS_syntax_file.sps)
  2. e um ficheiro de dados (survey_xxxx_SPSS_data_file.dat).

Depois de descarregar estes ficheiros, pode abri-los com um editor de texto simples, como o Bloco de notas, para ver o aspeto dos dados exportados. O ficheiro de sintaxe contém os comandos que devem ser executados para importar os dados. É como uma linguagem de programação dentro do SPSS. O ficheiro de dados contém um ficheiro separado por vírgulas com todos os dados. Se importar estes dados apenas como CSV através de um assistente, perde informação sobre perguntas, conjuntos de etiquetas, etc., pelo que não o fazemos.

Importar dados no SPSS

Coloque os dois ficheiros na mesma pasta do seu disco (exemplo: c:\data\survey_xxxx_SPSS_syntax_file.sps e c:\data\survey_xxxx_SPSS_data_file.dat)

Existem agora duas opções:

1. Se utilizar o Windows, use o explorador para navegar até à pasta indicada acima. Se o SPSS estiver associado à extensão de ficheiro .sps, pode abrir o ficheiro com um duplo clique:

Agora pode escolher Run->All na janela aberta e, passado algum tempo, terá o conjunto de dados de saída, que pode guardar como um ficheiro .sav normal.

2. Por vezes, a solução simples acima não funciona. Nesse caso, pode proceder da seguinte forma:

  • Abra o SPSS
  • Escolha File->Open->Syntax
  • Escolha o ficheiro apropriado: c:\data\survey_xxxx_SPSS_syntax_file.sps
  • Agora a sintaxe abre.
  • Altere a linha que indica /FILE='survey_xxxx_SPSS_data_file.dat' para incluir o caminho onde se encontram os ficheiros: /FILE='c:\data\survey_xxxx_SPSS_data_file.dat' , para utilizadores de Mac: /FILE='HD/Users/username/survey_xxxx_SPSS_data_file.dat'
  • Agora selecione todo o texto do comando e escolha Run->All no menu e, passado algum tempo (seja paciente), terá o conjunto de dados com toda a informação, como perguntas, etiquetas, etc.

Exportação para R

Sinta-se à vontade para acrescentar mais informações, se as tiver!

O software gratuito R é uma alternativa ao SPSS. No LimeSurvey, trata-se de uma exportação para aplicação.

Instruções para importar o seu conjunto de dados no R:

  1. Descarregue o ficheiro de sintaxe e o ficheiro de dados.
  2. Guarde ambos os ficheiros na pasta de trabalho do R (utilize getwd() e setwd() numa janela de comandos do R para obter e definir).
  3. No seu código, introduza source("Surveydata_syntax.R", encoding = "UTF-8") na janela de comandos do R, o que importará os dados no formato correto para uma tabela de dados chamada "data".


As respostas com opções limitadas serão convertidas em fatores, com os níveis correspondentes ao código da pergunta e as etiquetas correspondentes às opções.

As perguntas com a opção "Outro" terão o campo da pergunta com o sufixo _Other acrescentado como uma nova coluna para os dados de "Outro".

Nota: A exportação para R é um plugin do LimeSurvey. Se não encontrar as opções de exportação para R (R (Ficheiro de sintaxe), Ficheiro de dados do R) em Exportar resultados para aplicação, certifique-se de que o plugin de exportação para R está ativado no menu de plugins.

Exportação STATA-xml

O STATA é um pacote de software comercial de análise de dados e estatística.

Esta rotina de exportação foi criada para facilitar a análise rápida dos dados recolhidos com o LimeSurvey. Cria um ficheiro XML no formato proprietário do STATA, que pode ser importado independentemente da plataforma em que o STATA é executado. A utilização deste formato oferece várias vantagens em relação à importação de ficheiros CSV simples:

  • Os conjuntos de dados ficam totalmente etiquetados, incluindo as etiquetas das variáveis (pergunta, pergunta secundária) e as etiquetas dos valores (respostas, se aplicável).
  • As datas já são transformadas para o formato de data interno do STATA e, por isso, podem ser usadas diretamente para calcular diferenças entre dias, etc.
  • Os nomes das variáveis são, se necessário, convertidos para um formato compatível com o STATA.
  • Os formatos de dados das variáveis (cadeia de caracteres, inteiro, vírgula flutuante, etc.) já estão definidos de acordo com os dados subjacentes. (Acabaram-se os números codificados como cadeias de caracteres!).

Como carregar o ficheiro no STATA: As versões do Stata até à 14 ofereciam para isso uma entrada de menu File → Import → XML data. A partir do Stata 15, essa entrada de menu deixou de existir. Em vez disso, escreva o seguinte comando na janela de comandos (Command) do STATA:

xmluse "survey_123456_STATA.xml", doctype(dta)

(substitua o nome do ficheiro pelo caminho do seu próprio ficheiro exportado). Depois de os dados serem carregados, pode guardá-los no formato binário .dta do STATA, para não ter de repetir a importação:

save "survey_123456.dta"


Nota: Os comandos xmluse/xmlsave usados acima foram removidos do conjunto de comandos oficialmente documentados e suportados do STATA a partir do Stata 15, embora ainda funcionem nas versões atuais como uma funcionalidade legada não documentada. Como uma futura versão do STATA pode eliminá-los sem aviso prévio, recomendamos que guarde os seus dados como ficheiro .dta (ver acima) imediatamente após a importação, em vez de depender do ficheiro XML como armazenamento a longo prazo. Se o xmluse não estiver disponível na sua instalação do STATA, utilize a exportação CSV do LimeSurvey em conjunto com o comando import delimited do STATA.

Tenha em atenção:

  • Devido a uma limitação do formato de dados do STATA, o comprimento das variáveis de cadeia de caracteres (texto) tem um máximo de 244 caracteres (versões 8-12 do Stata) e 2045 caracteres (versão 13 do Stata e posteriores). Indique a sua versão do Stata nas definições do plugin de exportação.
  • O STATA só suporta a atribuição de etiquetas de valor a valores numéricos. Assim, para obter respostas curtas (normalmente um ou dois dígitos) e com as devidas etiquetas, deve utilizar códigos de resposta numéricos no LimeSurvey (1=Concordo totalmente). Se forem utilizados códigos de resposta não numéricos (A=Concordo totalmente), será usado como resposta o texto completo da resposta (p. ex.: 'Concordo totalmente').

VVExport e VVImport

 Hint: This feature changed with version 2.05


Depois de começar a recolher respostas, pode haver ocasiões em que precise de editar e modificar diretamente grandes quantidades de dados da sua tabela de respostas, e em que uma folha de cálculo pode ser mais útil.

O VVExport (o "VV" significa verificação vertical) permite exportar a sua tabela de respostas para um ficheiro .csv. Desde que a estrutura geral do ficheiro se mantenha intacta, pode editar os valores no seu interior e, depois, importar novamente o ficheiro para a sua tabela de respostas através da funcionalidade "VVImport".

Coisas a que deve estar atento:

  • Se quiser importar respostas com o "VVImport", verifique se as respostas devem ser adicionadas às respostas existentes ou se todas as respostas devem ser substituídas.
  • Se estiver a tentar importar respostas de um inquérito diferente mas idêntico (p. ex., perguntas/respostas idênticas de outro inquérito), certifique-se de que está a utilizar o ficheiro vv correto e de que as duas primeiras linhas do ficheiro .csv estão corretas.
  • Se importar um inquérito para a sua instalação do LimeSurvey, o SID não será alterado (se possível). No entanto, o identificador do grupo de perguntas e o identificador da pergunta podem mudar. Por isso, poderá ter de ajustar as duas primeiras linhas de cabeçalho para corresponderem ao novo identificador do grupo/da pergunta. Consulte Adjusting vv file headings

<span id="VVExport_file_version_2_ (New in 2.05 )">Ficheiro VVExport versão 2 (New in 2.05 )

Esta nova funcionalidade permite usar nomes de colunas diferentes dos da base de dados. Se os códigos das suas perguntas forem únicos, é selecionada a nova versão. Na nova versão, cada nome de coluna utiliza a nomenclatura de variáveis Qcode. Por exemplo, isto permite atualizar mais facilmente um inquérito existente numa instalação diferente.

Exportar um ficheiro de inquérito VV

File:LimesurveyExportVVen.jpg

Quando escolhe exportar respostas com o VVExport, é-lhe dada a opção de escolher qual o inquérito a exportar e se pretende exportar todas as respostas, apenas as respostas completas ou apenas as respostas incompletas. A extensão do ficheiro permite escolher a extensão que o ficheiro exportado terá. Para facilitar a utilização, deve ser escolhido .csv.

Um 'ficheiro de inquérito vv' permite importar as respostas de um inquérito quando as combinações de pergunta/resposta foram alteradas. Na prática, isto permite adicionar ou eliminar perguntas num inquérito ativo.

Ao clicar em "Exportar inquérito VV para ficheiro", será produzido um ficheiro delimitado por tabulações que pode ser aberto pelo Excel ou por um programa de folha de cálculo semelhante. As duas primeiras linhas da folha de cálculo são as etiquetas das colunas. A primeira linha é um cabeçalho de coluna "legível por humanos" que detalha o nome do campo da pergunta/resposta. A segunda linha é o nome interno da coluna PHP/base de dados dessa resposta.

Não deve modificar as duas primeiras linhas desta folha de cálculo se quiser poder "importar" os dados novamente para o LimeSurvey mais tarde.

<span id="Exporting_a_VV_survey_file_ (New in 2.05 )">

Exportar um ficheiro de inquérito VV (New in 2.05 )

 Hint: This feature is available starting in version 2.05


  • Exportar inquérito : O ID do inquérito a exportar (só de leitura)
  • Exportar : O estado de conclusão das respostas a exportar
  • Extensão do ficheiro : A extensão do ficheiro. O ficheiro é um ficheiro TSV (valores separados por tabulações). Para abrir facilmente no MS-Excel, defina a extensão como .txt; com o LibreOffice, o OpenOffice ou outro programa de folha de cálculo, pode deixá-la como .csv.
  • Versão de exportação VV : A versão 1.0 utiliza os cabeçalhos de coluna da base de dados, a versão 2.0 utiliza a nomenclatura de variáveis Qcode. A versão 2.0 é selecionada por defeito se todos os códigos das suas perguntas forem únicos.

As duas primeiras linhas da folha de cálculo são as etiquetas das colunas. A primeira linha é um cabeçalho de coluna "legível por humanos" que detalha o nome da pergunta. A segunda linha é o nome real da coluna (nome interno da base de dados ou Qcode) dessa resposta.

Editar um ficheiro de inquérito VV

Depois de um ficheiro .vv ter sido exportado com sucesso, pode utilizar uma folha de cálculo para o abrir e editar. Se tiver de escolher um separador de colunas ao abrir o ficheiro, utilize o caractere "Aba" (tabulação). Se estiver a utilizar caracteres não ASCII, certifique-se de que define "UTF-8" como conjunto de caracteres.

  Se estiver a utilizar o Microsoft Excel para editar o ficheiro vv exportado, saiba que o Excel destrói a estrutura de dados original do ficheiro. Isto provoca um erro quando tenta voltar a importar o ficheiro .vv editado.


Por defeito, as duas primeiras linhas do ficheiro .vv são cabeçalhos. Se necessário, pode eliminar a primeira linha para obter um verdadeiro ficheiro TSV. Existem diferentes casos de utilização para importar um ficheiro .vv, pelo que iremos distinguir entre adicionar novas respostas a um inquérito e substituir todas as respostas do inquérito.

Exemplo de estrutura de um ficheiro .vv:

Ficheiro TSV da versão 1 do VV

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	46492X40X1991
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1

Ficheiro TSV da versão 2 do VV

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	QCODE
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1


Aqui não são utilizados identificadores SGQA; em vez disso, é utilizada na segunda linha a nomenclatura de variáveis Qcode QCODE.

Nomes reservados

O ficheiro .VV utiliza chavetas esquerda e direita para nomes reservados. Ao importar, esta cadeia de caracteres é substituída por:

  • {question_not_shown} : valor NULL na base de dados. O LimeSurvey utiliza [cadeia de caracteres vazia] para uma pergunta sem resposta e o valor NULL para uma pergunta não apresentada (pelo Gestor de expressões ou pelo passo máximo no inquérito).
  • {quote} : " (aspas duplas)
  • {cr} : Retorno de carro
  • {newline} : Uma nova linha
  • {lbrace} : Chaveta esquerda (por exemplo, se quiser ter {cr} na resposta: utilize {lbrace}cr} )

Edição da versão 1 do VV

Adicionar novas respostas às respostas existentes de um inquérito

Isto não é suportado na versão 1 do formato, pois facilmente pode originar vários problemas, incluindo dados importados para as colunas erradas. A versão 1 do ficheiro .vv foi sempre concebida para a verificação vertical de dados numa ferramenta externa como o Excel, e não como meio de reunir dados de diferentes origens (por exemplo, o mesmo inquérito a decorrer noutro servidor).

Modificar todas as respostas de um inquérito

Se quiser modificar as respostas de um inquérito, basta editar o ficheiro.

Exemplo:

Passo 1: Abrir o ficheiro

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
183	09.11.11 11:44	3	de	4
184	09.11.11 11:53	3	de	2
190	09.11.11 11:44	3	de	1


Passo 2: Modificar as respostas

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
1000	09.11.11 11:44	3	de	3
1001	09.11.11 11:53	3	de	3
1002	09.11.11 11:44	3	de	3

Pode então importar o inquérito, certificando-se de que substitui as respostas existentes (consulte "Importar um ficheiro de inquérito VV").

Importar um ficheiro de inquérito VV

File:LimeSurveyImportVVen.jpg

Desde que as duas primeiras linhas estejam intactas, pode importar os dados do seu ficheiro de inquérito vv de volta para um inquérito ativo do LimeSurvey.

Se utilizou o Microsoft Excel para editar o ficheiro vv exportado, a estrutura de dados deste ficheiro pode ficar corrompida, pelo que o LimeSurvey não consegue importar o ficheiro editado. Pode experimentar a seguinte solução alternativa para que a importação funcione sem erros:

  • Abra o seu ficheiro vv exportado no Excel e faça as alterações (presumimos que já o fez)
  • Guarde-o como ficheiro de texto separado por tabulações (é criado um novo ficheiro com a extensão .txt)
  • Faça outra exportação vv "limpa" a partir do LimeSurvey
  • Abra este novo ficheiro vv exportado com um editor de texto como o bloco de notas ou outro (eu utilizei o TextWrangler no Mac)
  • Prima CTRL + A para selecionar todo o conteúdo e elimine-o
  • Abra o ficheiro vv editado no Excel (o ficheiro .txt separado por tabulações) com um editor de texto e prima CTRL + A para selecionar todo o conteúdo
  • Prima CTRL + C para copiar o conteúdo e cole-o no novo ficheiro vv (agora vazio)
  • Prima CTRL + S para guardar o ficheiro tal como está (como .csv)
  • Agora tente importar este ficheiro

Em seguida, no ecrã de navegação, escolha o ícone "Importar um ficheiro de inquérito VV".

O ecrã "Importar um ficheiro de inquérito VV" pede-lhe que escolha o ficheiro "vvexport" que está a importar. Se escolher "Excluir IDs dos registos?", os registos serão importados e serão gerados novos IDs de registo para eles (utilize esta opção no caso de utilização "Adicionar novas respostas às respostas existentes de um inquérito"). Se desmarcar esta caixa, serão importados os IDs de registo originais (utilize esta opção no caso de utilização "Substituir todas as respostas do inquérito").

Existe um conjunto de opções que pode escolher para indicar ao LimeSurvey como tratar entradas duplas ou múltiplas.

  • Reportar um erro (e passar à frente o novo registo).
  • Renumerar o novo registo
  • Substituir o registo existente (utilize esta opção no caso de utilização "Substituir todas as respostas do inquérito")

<span id="Importing_a_VV_survey_file_ (New in 2.05 )">

Importar um ficheiro de inquérito VV (New in 2.05 )

  • Ficheiro : Selecione o ficheiro a carregar. O ficheiro tem de ser um ficheiro TSV: um ficheiro de texto com cada coluna separada por TAB.
  • Excluir IDs dos registos? : Se a coluna 'id' existir no ficheiro, pode excluir esta linha ou não. Se esta opção estiver marcada, é adicionado um novo registo por cada linha do ficheiro .vv. Se estiver desmarcada, pode escolher:
  • Quando um registo importado coincide com o ID de um registo existente:
    • skip : Reportar e passar à frente o novo registo. Após o carregamento, verá se o registo já existia - se existia, não é importado.
    • renumber : Renumerar o novo registo. É adicionado um novo registo à tabela de respostas com a resposta do ficheiro VV.
    • replace : Substituir o registo existente. O registo antigo é eliminado e completamente substituído pelo registo do ficheiro VV.
    • replaceanswer : Substituir os detalhes da resposta do registo existente pelos do ficheiro. O registo antigo é atualizado com a nova resposta do ficheiro VV. Isto permite substituir apenas uma pergunta na tabela de respostas.
  • Importar como resposta não finalizada? : Se estiver marcada, a data de submissão (submitdate) é definida como NULL, pelo que a resposta fica como incompleta.
  • Código de caracteres do ficheiro : Pode escolher o código de caracteres do ficheiro - o valor predefinido e recomendado é UTF-8, mas alguns programas de folhas de cálculo não permitem escolher um código de caracteres.
  • A primeira linha contém códigos das perguntas : Por predefinição, a primeira linha do ficheiro VV contém a pergunta legível por humanos e os nomes reais das colunas estão na segunda linha. Isto permite utilizar a primeira linha como nomes reais das colunas.
  • Forçar importação : Se os códigos das perguntas não forem encontrados no nome da base de dados nem na nomenclatura de variáveis Qcode, as colunas são atribuídas por ordem. Isto pode ser utilizado para importar um ficheiro VV de outra instância do LimeSurvey, mas cada inquérito tem de ser exatamente igual. Recomendamos vivamente que utilize esta opção apenas se souber o que está a fazer. Pode ser muito perigoso e fazer com que os resultados acabem na coluna errada.

Outras opções de exportação

Exportar uma única resposta

Se quiser exportar uma resposta individual, pode fazê-lo de 3 formas:

1. Inicie sessão no back-end de administração do LimeSurvey, escolha o seu inquérito, vá a "Editar configurações do inquérito" -> "Notificação e gestão de dados" e certifique-se de que recebe as notificações básicas por e-mail.

Sempre que alguém concluir um inquérito, receberá um e-mail com uma hiperligação: "Clique na seguinte hiperligação para ver a resposta individual"

Será conduzido para uma página com um botão por cima dos dados com o texto "Exportar esta resposta"

2. Inicie sessão no backend de administração do LimeSurvey, escolha o seu inquérito e "Navegar respostas". Clique em "Mostrar respostas" e no número de ID que pretende exportar na coluna da esquerda. Depois, pode clicar em "Exportar este inquérito" por cima dos dados.

3. Inicie sessão no backend de administração do LimeSurvey, escolha o seu inquérito e "Exportar resultados" para aplicação. No último campo, por cima de "Exportar dados", pode escolher qual a entrada que pretende exportar.

Fazer corresponder respostas de diferentes inquéritos

Se pretende acompanhar ao longo do tempo as respostas ao inquérito de determinadas pessoas, o LimeSurvey pode ajudá-lo a fazê-lo. Um caso de utilização possível é acompanhar as respostas de um grupo antes e depois de este frequentar um determinado seminário.

Os passos para implementar esta funcionalidade são os seguintes:

1. Crie o inquérito

2. Certifique-se de que o inquérito não é anónimo e utiliza códigos (tokens). Para criar um inquérito não anónimo:

a - Clique no ícone Definições globais.

b - Depois, no separador Códigos (Tokens), selecione "Não" em Anonimizar respostas.

3. Ative o inquérito.

Ao ativar o inquérito, clique no botão "Mudar para modo de acesso restrito" para criar a tabela de códigos:

4. Preencha a tabela de códigos pelo método que preferir (siga as instruções que se encontram na página Códigos).

5. Exporte os resultados do inquérito e certifique-se de que inclui a informação dos códigos.

Para exportar, clique em navegar resultados...

...e depois em exportar:

Lembre-se de escolher um ou mais elementos da tabela de códigos para associar às respostas ao inquérito:

6. Quando executar novamente o inquérito, o que pode ser feito facilmente copiando o inquérito e a tabela de códigos através de exportação/importação, repita os passos e certifique-se de que é utilizada a mesma consulta para criar o ficheiro CSV de importação de códigos.

Problemas e soluções

Excel

Modificar respostas no Excel antes da importação

Para fazer várias alterações às respostas, pode optar por exportar e abrir um ficheiro no Excel. Faça as alterações aos dados (exceto às primeiras linhas) e guarde depois como ficheiro .txt. Se guardar como .csv, o Excel utiliza vírgulas como delimitador, o que não poderá ser importado para o LimeSurvey. Ao guardar como ficheiro .txt, o Excel guarda-o como ficheiro delimitado por tabulações, que pode ser importado novamente para o LimeSurvey.

Editar .csv com o Excel

Em geral, não recomendamos a utilização do Excel para editar os ficheiros .csv exportados, porque o Excel faz algumas alterações à estrutura interna dos dados, o que faz com que a importação falhe. Se, mesmo assim, quiser utilizar o Excel, tem de definir o separador do Excel como vírgula no Painel de Controlo (sistemas Windows):

Painel de Controlo|Opções de Região e Idioma|Definições Regionais, personalizar...|Separador Números|Símbolo de agrupamento de dígitos| substituir ; por ,

Solução alternativa para editar ficheiros .csv com o Excel

Utilizar o Excel para editar perguntas pode impedir que as consiga voltar a importar. No entanto, a edição no Excel é a melhor opção se tiver mais de 5 opções (ou opções de ordenação) ou se pretender utilizar funcionalidades do Excel, como a ordenação, etc.

Esta é uma solução alternativa parcial que parece funcionar na versão 1.82 - basicamente, utilize o Excel apenas na parte do ficheiro que contém os dados:

  • Exporte para um ficheiro .csv uma pergunta semelhante àquela que pretende reutilizar
  • Abra o ficheiro CSV num editor de texto simples
  • Copie a parte que contém as respostas para o Excel e separe-a em colunas com "Texto para colunas" ou equivalente.
  • Aproveite a capacidade do Excel de colar texto em colunas para colar 20, 50, 100 respostas, conforme pretender
  • Guarde o ficheiro como CSV do Excel, que provavelmente não terá aspas.
  • Abra este ficheiro no editor, selecione tudo e copie
  • Volte ao ficheiro que abriu no editor de texto simples
  • Cole por cima das respostas existentes
  • Utilize "Guardar como" com um nome diferente, talvez um que se lembre para reutilização
  • Importe este ficheiro.

Excel - exportação limitada a 255 colunas

Devido a limitações do Excel (versões iguais ou anteriores a 2003), o LimeSurvey só consegue exportar 255 colunas em simultâneo. A Microsoft propôs uma solução alternativa através de uma macro VB.

Embora as folhas de cálculo mais recentes (Excel >= 2007, OpenOffice) consigam apresentar mais de 255 colunas, o módulo interno utilizado pelo LimeSurvey continua a não conseguir exportar mais de 255 colunas.

No entanto, são possíveis duas soluções alternativas, utilize uma das seguintes:

  • Exportar para CSV e importar na sua folha de cálculo
  • Ou utilizar várias exportações (selecionando no máximo 250 colunas de cada vez) e depois juntar os resultados exportados

Excel/.csv - a exportação falha

Se não conseguir exportar os seus dados para o Excel ou para um ficheiro .csv, tente limpar a cache e os cookies do seu navegador.

CSV

O CSV assume por omissão 255 colunas

Ao exportar inquéritos grandes, a interface limita por omissão a exportação às primeiras 255 colunas. Para contornar esta limitação, basta marcar todos os conjuntos de dados para exportação.

Exportação para SPSS

Passos gerais

Para importar os dados das respostas do LimeSurvey, siga os passos seguintes:

  1. Clique no ícone 'Exportar para SPSS'.
  2. Nas caixas de seleção, escolha as respostas que pretende exportar e a sua Versão SPSS.
  3. Descarregue ambos os ficheiros, o .sps (ficheiro de comandos de sintaxe do SPSS) e o ficheiro .dat (ficheiro de dados)
  4. Abra o ficheiro .sps com o SPSS: abra o SPSS, selecione 'Choose another type of file' e escolha o ficheiro .sps descarregado.
  5. Será aberto um editor dentro do SPSS onde pode editar os comandos desse ficheiro. Procure a linha que começa por '/FILE=...'
  6. Edite essa linha e ajuste o caminho para que aponte para o seu ficheiro .dat. Exemplo: se o seu ficheiro *.dat estiver em c:\temp, defina esta linha como /FILE='c:\temp\survey_(xxxx)_SPSS_data_file.dat'
  7. Agora selecione todos os comandos no editor premindo CTRL-A.
  8. No menu do SPSS, selecione Run/All.
  9. Seja paciente, a importação de todos os dados e etiquetas demora algum tempo. Verifique o progresso na barra de estado.
  10. Concluído!

Possíveis mensagens de erro no SPSS

ERROR. command name:Get Data

Se receber a mensagem de erro ERROR. command name:Get Data. 2267 Unexpected Token missing., edite a quarta linha do seu ficheiro de sintaxe para que aponte para o caminho absoluto do ficheiro de dados, como em

C:\spss\Data\limesurvey\SPSS\survey_35276_SPSS_data_file.dat

Erro: "Text value unmappable in the current server locale"

Este erro pode ocorrer se tentar abrir um ficheiro de sintaxe exportado no SPSS 16. A solução é forçar o SPSS a interpretar o ficheiro de sintaxe como unicode.

Abra o SPSS. Vá a Edit > Options > Character encoding for data and syntax. Altere a opção para "unicode".

Os dados do LimeSurvey podem agora ser exportados para o SPSS 16 sem qualquer problema.

Definir a escala a utilizar para a sua variável

É possível substituir a escala predefinida utilizada para uma variável, definindo o Atributo da pergunta scale_export com o valor adequado.

Exportação/Importação VV

VV - Problemas com a importação VV

Se tiver dificuldades em importar um ficheiro vv, experimente um ficheiro delimitado por tabulações e deverá funcionar corretamente.

Outros problemas e soluções

Copiar respostas para um inquérito diferente (utilizando códigos)

  1. Crie um Novo inquérito, adicione uma resposta fictícia, exporte o ficheiro de respostas e abra-o no Excel. Isto cria o formato do novo ficheiro de importação.
  2. Exporte as respostas do inquérito antigo, incluindo os códigos, e abra-as no Excel.
  3. Utilize estes dados para criar uma folha do Excel para a importação padrão do ficheiro de códigos (p. ex.: Firstname, Lastname, Token, Endereço de email, Estado do email (OK), Language (En)). Guarde como .csv e importe os códigos para o novo inquérito no LimeSurvey.
  4. No Excel, copie os campos de resposta das respostas do inquérito antigo que pretende no novo inquérito (incluindo o código) para a coluna adequada do Excel no formato do novo inquérito.
  5. Guarde como ficheiro .txt.
  6. Utilize o VVImport para importar os novos dados para o novo inquérito.
  7. Os possíveis erros de importação incluem o Formato da data - alguns campos de data do sistema não permitem um valor NULL, outros permitem. Se a data parecer correta mas der erro, utilize o formato de célula do Excel "2009-12-01".