x

Үндсэн бүлгүүд

  1. LimeSurvey Cloud ба LimeSurvey CE-ийн харьцуулалт
  2. Хурдан эхлэх гарын авлага - LimeSurvey 3.0+
  3. Суулгалт - LimeSurvey CE
  4. Сайн судалгааг хэрхэн зохиох вэ (гарын авлага)
  5. Эхлэх нь
  6. LimeSurvey-г удирдах
  7. Судалгаа - танилцуулга
  8. Судалгааны тохируулга
  9. Судалгааны цэс
  10. Судалгааны бүтэц
  11. Асуултууд - танилцуулга
  12. Асуултын бүлэг - танилцуулга
  13. Судалгаа - удирдлага
  14. Судалгааны хэрэгслийн самбарын сонголтууд
  15. Олон хэлтэй судалгаа
  16. ExpressionScript Engine - Хурдан эхлэх гарын авлага
  17. Ангилагдаагүй болон нарийвчилсан боломжууд
  18. Түгээмэл асуултууд
  19. Алдаа засварлах
  20. Түр шийдлүүд
  21. Лиценз
  22. Хувилбарын өөрчлөлтүүдийн жагсаалт
  23. Плагинууд
 Actions

Үр дүнг экспортлох

From LimeSurvey Manual

Энэ хуудсыг машинаар орчуулсан байж магадгүй тул алдаа агуулж болзошгүй. Англи эх хувийг харах · Энэ орчуулгыг сайжруулах
This page is a translated version of the page Exporting results and the translation is 100% complete.
  Анхааруулга : Дараах хэсэг хуучирсан байна. Хамгийн сүүлийн мэдээллийг дараах хуудсуудаас үзнэ үү:




Судалгаа идэвхтэй болсны дараа хариултуудыг үзэж, экспортлох боломжтой. Судалгааны хариултын тойм руу орохын тулд дараахыг дарна уу: үр дүнгүүд -> хариу дүнгүү ба статистик

Программ руу экспортлох (Excel/.csv)

Хуудасны дээд хэсэгт экспортын хэд хэдэн сонголт жагсаагдсан байдаг.

Үр дүнг экспортлохдоо дараах шүүлтүүрийн сонголтууд байдаг:

  • Ерөнхий
    • Мужийг тохируулах (жишээ нь, "X-ээс Y хүртэлх бичлэгийг экспортлох")
    • Бүх бичлэг ЭСВЭЛ зөвхөн дууссан бичлэг ЭСВЭЛ зөвхөн бүрэн бус бичлэгийг экспортлохоор тохируулах
  • Асуултууд
    • Гарчиг хэрхэн харагдахыг тодорхойлох: товчилсон гарчиг ЭСВЭЛ бүтэн гарчиг ЭСВЭЛ асуултын код
    • Асуултын текст дах хоосон зайг доогуур зураас болгох
  • Харгиултууд
    • Бүрэн хариулт экспортлох эсвэл Y болон N хариултын кодыг тодорхойлсон утга болгон хөрвүүлэх боломжтой
  • Форматлах
    • Микрософт Ворд (латин тэмдэгтийн багц)
    • Микрософт Эксель (бүх тэмдэгтийн багц)
    • CSV файл (бүх тэмдэгтийн багц)
    • HTML
    • PDF
  • Баганы удирдлага
    • Аль хариултуудыг экспортлохыг сонгох. Энэ жагсаалт дахь бүх хариултыг SGQA танигч-аар нь илэрхийлнэ
    • Аль токен өгөгдлийг экспортлохыг сонгох. Энэ сонголт зөвхөн таны судалгаа нэргүй биш үед боломжтой!

SPSS экспорт

Ерөнхий

SPSS Statistics нь багц болон багц бус логик статистик шинжилгээнд ашиглагддаг программ хангамж юм. Та албан ёсны SPSS багцыг ашиглах эсвэл өмчлөгдсөн SPSS программын оронд GNU PSPP-г ашиглаж болно.

Хариултын өгөгдлөө SPSS руу экспортлохын тулд хариу дүнгүү ба статистик хэсэгт очоод SPSS руу экспортлох дүрс тэмдэг дээр дарна уу.

Өгөгдлийг экспортлох ба шүүх

SPSS руу өгөгдөл экспортлохдоо хоёр шүүлтүүрийн сонголт байдаг. Та аль өгөгдлийг сонгохыг (бүх бичлэг/зөвхөн дууссан бичлэг/зөвхөн бүрэн бус бичлэг) болон экспортолсон файлуудыг SPSS-ийн аль хувилбарт ашиглахыг (16-аас өмнөх хувилбар/16 эсвэл дээшээ) сонгож болно.

SPSS экспорт хоёр файл агуулдаг:

  1. синтакс файл (survey_xxxx_SPSS_syntax_file.sps)
  2. болон өгөгдлийн файл (survey_xxxx_SPSS_data_file.dat).

Эдгээр файлыг татаж авсны дараа notepad зэрэг энгийн текст засварлагчаар нээж, экспортолсон өгөгдөл ямар харагдаж байгааг үзэж болно. Синтакс файл нь өгөгдлийг импортлохын тулд ажиллуулах командуудыг агуулдаг. Энэ нь SPSS доторх программчлалын хэл шиг юм. Өгөгдлийн файл нь бүх өгөгдлийг агуулсан таслалаар тусгаарласан файл юм. Хэрэв та энэ өгөгдлийг csv хэлбэрээр wizard-аар шууд импортлавол асуулт, шошгын багц зэрэг мэдээлэл алдагдах тул бид ингэж хийдэггүй.

SPSS-д өгөгдөл импортлох

Хоёр файлыг дискийнхээ нэг фолдерт байрлуулна уу (жишээ нь: c:\data\survey_xxxx_SPSS_syntax_file.sps ба c:\data\survey_xxxx_SPSS_data_file.dat)

Одоо бидэнд хоёр сонголт бий:

1. Windows ашиглаж байгаа бол explorer-ээр дээрх фолдер руу орно уу. Хэрэв SPSS нь .sps файлын өргөтгөлтэй холбогдсон бол файлыг хоёр удаа дарж шууд нээж болно:

Одоо нээгдсэн цонхноос Run->All-ийг сонгоод хэсэг хугацааны дараа гаралтын өгөгдлийн багцаа авах бөгөөд үүнийг энгийн .sav файл болгон хадгалах боломжтой.

2. Заримдаа дээрх хялбар арга ажиллахгүй байж болно. Тэр тохиолдолд дараах байдлаар үргэлжлүүлнэ үү:

  • SPSS-ийг нээнэ
  • File->Open->Syntax-ийг сонгоно
  • Тохирох файлыг сонгоно: c:\data\survey_xxxx_SPSS_syntax_file.sps
  • Одоо синтакс нээгдэнэ.
  • /FILE='survey_xxxx_SPSS_data_file.dat' гэсэн мөрийг файлууд байгаа замыг агуулахаар өөрчилнө: /FILE='c:\data\survey_xxxx_SPSS_data_file.dat' , mac хэрэглэгчийн хувьд: /FILE='HD/Users/username/survey_xxxx_SPSS_data_file.dat'
  • Одоо командын бүх текстийг тэмдэглээд цэснээс Run->All-ийг сонгоно. Хэсэг хугацааны дараа (тэвчээртэй байна уу) асуулт, шошго зэрэг бүх мэдээллийг агуулсан өгөгдлийн багц гарна.

R экспорт

Танд нэмэлт мэдээлэл байвал чөлөөтэй нэмээрэй!

Үнэгүй программ хангамж R нь SPSS-ийн оронд ашиглах хувилбар юм. Энэ нь Limesurvey дахь программ руу экспортлох төрлийн экспорт юм.

Өгөгдлийн багцаа R-д импортлох заавар:

  1. Синтакс файл болон өгөгдлийн файл хоёуланг татаж авна.
  2. Хоёр файлыг R-ийн ажлын санд хадгална (авах, тохируулахын тулд R командын цонхонд getwd() болон setwd()-ийг ашиглана).
  3. Өөрийн кодод R командын цонхонд source("Surveydata_syntax.R", encoding = "UTF-8") гэж оруулснаар өгөгдөл зөв форматаар "data" нэртэй data frame-д импортлогдоно.


Хязгаарлагдмал сонголттой хариултууд нь түвшин нь асуултын кодтой, шошго нь сонголттой таарсан factor болгон хөрвүүлэгдэнэ.

"Бусад" сонголттой асуултууд нь бусад өгөгдөлд зориулсан шинэ багана болгон асуултын талбарын нэрийн ард _Other залгасан талбартай байна.

Анхаарна уу: R-экспорт нь LimeSurvey дахь плагин юм. Хэрэв Export results to application доороос R-экспортын сонголтуудыг (R (синтаксийн файл), R (өгөгдлийн файл)) олохгүй бол плагины цэсэнд R-экспорт плагин идэвхжсэн эсэхийг шалгана уу.

STATA-xml экспорт

STATA нь өгөгдөл шинжлэх, статистикийн арилжааны программ хангамжийн багц юм.

Энэ экспортын функц нь LimeSurvey-ээр цуглуулсан өгөгдлийг хурдан шинжлэхэд зориулан бүтээгдсэн. Энэ нь STATA-н өөрийн форматаар XML файл үүсгэдэг бөгөөд STATA ажиллаж буй платформоос үл хамааран импортлох боломжтой. Энэ формат нь энгийн CSV файлыг импортлохоос хэд хэдэн давуу талтай:

  • Өгөгдлийн багц нь хувьсагчийн шошго (асуулт, дэд асуулт) болон утгын шошго (боломжтой бол хариулт)-той бүрэн шошгологдсон байна.
  • Огноо нь STATA-н дотоод огнооны формат руу аль хэдийн хөрвүүлэгдсэн тул өдрүүдийн зөрүү гэх мэтийг шууд тооцоолоход ашиглах боломжтой.
  • Хувьсагчийн нэрсийг шаардлагатай бол STATA-тай нийцтэй формат руу хөрвүүлнэ.
  • Хувьсагчийн өгөгдлийн формат (тэмдэгт мөр, бүхэл тоо, бутархай тоо гэх мэт) нь үндсэн өгөгдөлд тохируулан аль хэдийн тохируулагдсан. (Тэмдэгт мөр болгон кодлогдсон тоо цаашид байхгүй!).

Файлыг STATA-д хэрхэн ачаалах вэ: Stata-н 14 хүртэлх хувилбарууд үүний тулд File → Import → XML data цэсийн сонголттой байсан. Stata 15-аас эхлэн тэр цэсний сонголт байхаа больсон. Оронд нь STATA-н Command цонхонд дараах тушаалыг бичнэ үү:

xmluse "survey_123456_STATA.xml", doctype(dta)

(файлын нэрийг өөрийн экспортолсон файлын замаар солино уу). Өгөгдөл ачаалагдсаны дараа импортыг давтахгүйн тулд STATA-н хоёртын .dta форматаар хадгалах боломжтой:

save "survey_123456.dta"


Тэмдэглэл: Дээр ашигласан xmluse/xmlsave тушаалуудыг Stata 15-аас эхлэн STATA-н албан ёсоор баримтжуулсан, дэмжигдсэн тушаалын жагсаалтаас хассан боловч одоогийн хувилбаруудад баримтжуулаагүй хуучин боломж болон ажиллсаар байна. Ирээдүйн STATA хувилбар тэдгээрийг мэдэгдэлгүйгээр хасаж болзошгүй тул XML файлыг удаан хугацааны хадгалалт болгон ашиглахын оронд импортлосны дараа даруй өгөгдлөө .dta файл болгон хадгалахыг (дээрхийг үзнэ үү) зөвлөж байна. Хэрэв таны STATA-д xmluse байхгүй бол оронд нь LimeSurvey-н CSV экспортыг STATA-н import delimited тушаалтай хамт ашиглана уу.

Анхаарах зүйл:

  • STATA-н өгөгдлийн форматын хязгаарлалтаас шалтгаалан тэмдэгт мөр (текст) хувьсагчийн урт хамгийн ихдээ 244 тэмдэгт (Stata 8-12 хувилбар) болон 2045 тэмдэгт (Stata 13 ба түүнээс дээш хувилбар) байна. Экспорт плагины тохиргоонд өөрийн Stata хувилбарыг зааж өгнө үү.
  • STATA нь утгын шошгыг зөвхөн тоон утгад хавсаргахыг дэмждэг. Тиймээс богино хариулт (ихэвчлэн нэг эсвэл хоёр орон) авч, тэдгээрийг зөв шошголохын тулд LimeSurvey-д тоон хариултын код ашиглах хэрэгтэй (1=Бүрэн санал нийлнэ). Хэрэв тоон бус хариултын код ашигласан бол (A=Бүрэн санал нийлнэ) хариулт болгон хариултын бүтэн текстийг ашиглана (жишээ нь: 'Бүрэн санал нийлнэ').

VVExport болон VVImport

 Hint: This feature changed with version 2.05


Хариулт цуглуулж эхэлсний дараа хариултын хүснэгтээс их хэмжээний өгөгдлийг шууд засах, өөрчлөх шаардлага гарч болох бөгөөд ийм үед хүснэгтийн программ илүү тохиромжтой байж болно.

VVExport ("VV" нь vertical verification буюу босоо баталгаажуулалтыг илэрхийлнэ) нь хариултын хүснэгтээ .csv файл руу экспортлох боломжийг олгодог. Файлын ерөнхий бүтэц хэвээр байвал доторх утгуудыг засаад, дараа нь "VVImport" боломжийг ашиглан файлыг хариултын хүснэгт рүүгээ дахин импортлох боломжтой.

Анхаарах зүйлс:

  • "VVImport" ашиглан хариултыг импортлохдоо хариултуудыг одоо байгаа хариултад нэмэх үү, эсвэл бүх хариултыг дарж бичих үү гэдгийг заавал шалгана уу.
  • Хэрэв өөр боловч ижил (жишээ нь өөр судалгааны ижил асуулт/хариулт) судалгаанаас хариулт импортлох гэж байгаа бол зөв vv файл ашиглаж байгаа эсэх болон .csv файлын эхний хоёр мөр зөв эсэхийг шалгана уу.
  • Хэрэв та судалгааг LimeSurvey суулгацдаа импортлох бол SID (боломжтой бол) өөрчлөгдөхгүй. Харин бүлгийн id болон асуултын id өөрчлөгдөж болно. Тиймээс шинэ бүлгийн id/асуултын id-д тохируулан эхний хоёр толгой мөрийг засах шаардлагатай байж болно. vv файлын толгойг тохируулах хэсгийг үзнэ үү.

<span id="VVExport_file_version_2_ (New in 2.05 )">VVExport файлын 2-р хувилбар (New in 2.05 )

Энэ шинэ боломж нь өгөгдлийн сангийнхаас өөр баганын нэр ашиглах боломжийг олгодог. Хэрэв таны асуултын кодууд давтагдашгүй бол шинэ хувилбар сонгогдоно. Шинэ хувилбарт багана бүрийн нэр Qcode хувьсагчийн нэршил-ийг ашигладаг. Жишээ нь энэ нь өөр суулгац дахь одоо байгаа судалгааг илүү хялбар шинэчлэх боломжийг олгодог.

vv файл судалгааг експортлох

File:LimesurveyExportVVen.jpg

VVExport ашиглан хариултыг экспортлохоор сонгоход аль судалгааг экспортлохыг, бүх хариултыг, зөвхөн бүрэн хариултыг эсвэл зөвхөн бүрэн бус хариултыг экспортлохыг сонгох боломж танд олгогдоно. Файлын өргөтгөл нь экспортлогдсон файл ямар өргөтгөлтэй байхыг сонгох боломжийг олгодог. Хялбар хэрэглээний үүднээс .csv-г сонгох хэрэгтэй.

'vv survey file' нь асуулт/хариултын хослол өөрчлөгдсөн үед судалгааны хариултыг импортлох боломжийг олгодог. Үнэн хэрэгтээ энэ нь идэвхтэй судалгаанд асуулт нэмэх эсвэл устгах боломжийг олгодог.

"vv файл судалгааг експортлох" дээр дарснаар Excel эсвэл төстэй хүснэгтийн программаар нээж болох табаар тусгаарлагдсан файл үүснэ. Хүснэгтийн эхний хоёр мөр нь баганын шошго юм. Эхний мөр нь асуулт/хариултын талбарын нэрийг тодорхойлсон "хүнд ойлгомжтой" баганын гарчиг юм. Хоёр дахь мөр нь тухайн хариултын PHP/өгөгдлийн сангийн дотоод баганын нэр юм.

Хэрэв дараа нь өгөгдлийг LimeSurvey руу буцаан "импортлох" хүсэлтэй бол энэ хүснэгтийн эхний хоёр мөрийг бүү өөрчил.

<span id="Exporting_a_VV_survey_file_ (New in 2.05 )">

vv файл судалгааг експортлох (New in 2.05 )

 Hint: This feature is available starting in version 2.05


  • Судалгааг экспортдлох : Экспортлох судалгааны ID (зөвхөн унших)
  • Экспортлох : Экспортлох хариултуудын гүйцэтгэлийн явц
  • Файлын өргөтгөл : Файлын өргөтгөл. Файл нь TSV (Табаар тусгаарласан утгууд) файл юм. MS-Excel-ээр хялбар нээхийн тулд өргөтгөлийг .txt болгож тохируулна, LibreOffice, OpenOffice эсвэл бусад хүснэгтийн программд .csv хэвээр орхиж болно.
  • VV экспортын хувилбар : 1.0 хувилбар нь өгөгдлийн сангийн баганын толгойг ашигладаг, 2.0 хувилбар нь Qcode хувьсагчийн нэршил-ийг ашигладаг. Хэрэв таны бүх асуултын код давтагдашгүй бол 2.0 хувилбар анхдагчаар сонгогдоно.

Хүснэгтийн эхний хоёр мөр нь баганын шошго юм. Эхний мөр нь асуултын нэрийг тодорхойлсон "хүнд ойлгомжтой" баганын гарчиг юм. Хоёр дахь мөр нь тухайн хариултын жинхэнэ баганын нэр (дотоод өгөгдлийн сан эсвэл Qcode-ийн нэр) юм.

vv файл судалгааг засах

.vv файлыг амжилттай экспортолсны дараа хүснэгтийн программ ашиглан файлыг нээж засах боломжтой. Файлыг нээхдээ баганын тусгаарлагч сонгох шаардлагатай бол "Таб" тэмдэгтийг ашиглана уу. Хэрэв ASCII бус тэмдэгт ашиглаж байгаа бол тэмдэгтийн багцыг "UTF-8" болгож тохируулсан эсэхээ шалгана уу.

  Хэрэв та экспортолсон vv файлыг засахдаа Microsoft Excel ашиглаж байгаа бол Excel файлын анхны өгөгдлийн бүтцийг эвддэгийг мэдэж байх хэрэгтэй. Үүнээс болж засварласан .vv файлыг дахин импортлох үед алдаа гарна.


Анхдагчаар .vv файлын эхний хоёр мөр нь толгой байдаг. Шаардлагатай бол жинхэнэ TSV файл болгохын тулд эхний мөрийг устгаж болно. .vv файлыг импортлох хэд хэдэн хэрэглээ байдаг тул судалгаанд шинэ хариулт нэмэх болон судалгааны бүх хариултыг дарж бичихийг ялгаж үзүүлнэ.

.vv файлын бүтцийн жишээ:

VV 1-р хувилбарын TSV файл

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	46492X40X1991
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1

VV 2-р хувилбарын TSV файл

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	QCODE
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1


Энд SGQA тодорхойлогч ашиглагдахгүй, оронд нь хоёр дахь мөрөнд Qcode хувьсагчийн нэршил QCODE ашиглагдана.

Нөөцлөгдсөн нэрс

.VV файл нь нөөцлөгдсөн нэрсэд зүүн болон баруун хаалт ашигладаг бөгөөд импортлох үед эдгээр тэмдэгт мөрийг дараах утгаар сольдог:

  • {question_not_shown} : Мэдээллийн сан дахь NULL утга. LimeSurvey нь хариулаагүй асуултад [хоосон тэмдэгт мөр], харин харуулаагүй асуултад (Илэрхийлэл удирдагчаар эсвэл судалгааны хамгийн их алхмаар) NULL утга ашигладаг.
  • {quote} : " (давхар хашилт)
  • {cr} : Carriage return
  • {newline} : Шинэ мөр
  • {lbrace} : Зүүн хаалт (жишээ нь, хариултад {cr} гэж байлгахыг хүсвэл {lbrace}cr} гэж ашиглана)

VV 1-р хувилбарыг засах

Судалгааны одоо байгаа хариултуудад шинэ хариулт нэмэх

Энэ нь форматын 1-р хувилбарт дэмжигдэхгүй, учир нь өгөгдөл буруу баганад импортлогдох зэрэг олон асуудалд амархан хүргэдэг. .vv файлын 1-р хувилбар нь Excel зэрэг гадны хэрэгсэлд өгөгдлийг босоо баталгаажуулахад зориулагдсан болохоос өөр эх сурвалжаас (жишээ нь, өөр сервер дээр ажиллаж буй ижил судалгаанаас) өгөгдөл нэгтгэх зорилгоор бүтээгдээгүй.

Судалгааны бүх хариултыг өөрчлөх

Судалгааны хариултуудыг өөрчлөхийг хүсвэл файлыг шууд засахад хангалттай.

Жишээ:

Алхам 1: Файлыг нээх

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
183	09.11.11 11:44	3	de	4
184	09.11.11 11:53	3	de	2
190	09.11.11 11:44	3	de	1


Алхам 2: Хариултуудыг өөрчлөх

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
1000	09.11.11 11:44	3	de	3
1001	09.11.11 11:53	3	de	3
1002	09.11.11 11:44	3	de	3

Дараа нь судалгааг импортлох боломжтой. Одоо байгаа хариултуудыг дарж бичихээ мартуузай ("vv файл судалгааг импортлох" хэсгийг үзнэ үү).

vv файл судалгааг импортлох

File:LimeSurveyImportVVen.jpg

Эхний хоёр мөр бүрэн бүтэн байвал vv судалгааны файл доторх өгөгдлийг идэвхтэй LimeSurvey судалгаанд буцаан импортлох боломжтой.

Хэрэв экспортолсон vv файлыг засахдаа Микрософт Эксель ашигласан бол файлын өгөгдлийн бүтэц эвдэрч, LimeSurvey засварласан файлыг импортлох боломжгүй болж магадгүй. Алдаагүй импортлохын тулд дараах тойрон гарах аргыг туршиж болно:

  • Экспортолсон vv файлаа Excel-ээр нээж өөрчлөлтөө хийнэ (та үүнийг аль хэдийн хийсэн байх)
  • Үүнийг табаар тусгаарласан текст файл болгон хадгална (.txt өргөтгөлтэй шинэ файл үүснэ)
  • LimeSurvey-ээс дахин "цэвэр" vv экспорт хийнэ
  • Шинээр экспортолсон vv файлыг notepad зэрэг текст засварлагчаар нээнэ (би mac дээр textwrangler ашигласан)
  • CTRL + A дарж бүх агуулгыг сонгоод устгана
  • Excel-ээр засварласан vv файлыг (табаар тусгаарласан .txt файл) текст засварлагчаар нээгээд CTRL + A дарж бүх агуулгыг сонгоно
  • CTRL + C дарж агуулгыг хуулаад шинэ (одоо хоосон) vv файл руу буулгана
  • CTRL + S дарж файлыг хэвээр нь (.csv хэлбэрээр) хадгална
  • Одоо энэ файлыг импортлоод үзнэ

Дараа нь үр дүн үзэх дэлгэцээс "vv файл судалгааг импортлох" дүрсийг сонгоно.

"vv файл судалгааг импортлох" дэлгэц дээр импортлох "vvexport" файлаа сонгох шаардлагатай. Хэрэв "Нэрийн бичлэгийг хасах" сонголтыг сонговол бичлэгүүд импортлогдож, тэдэнд цоо шинэ бичлэгийн ID үүснэ ("Судалгааны одоо байгаа хариултуудад шинэ хариулт нэмэх" тохиолдолд энэ сонголтыг ашиглана). Хэрэв энэ чагтыг авбал анхны бичлэгийн ID-ууд импортлогдоно ("Судалгааны бүх хариултыг дарж бичих" тохиолдолд энэ сонголтыг ашиглана).

LimeSurvey давхардсан буюу олон бичлэгийг хэрхэн зохицуулахыг заах хэд хэдэн сонголт байдаг.

  • Алдааг мэдээлэх (мөн шинэ бичлэгийг алгасах).
  • Шинэ бичлэгийг дахин дугаарлах
  • Байж байгаа бичлэгийг дахин байршуулах ("Судалгааны бүх хариултыг дарж бичих" тохиолдолд үүнийг ашиглана)

<span id="Importing_a_VV_survey_file_ (New in 2.05 )">

vv файл судалгааг импортлох (New in 2.05 )

  • файл : Байршуулах файлыг сонгоно. Файл нь TSV файл байх ёстой: багана бүр TAB-аар тусгаарлагдсан текст файл.
  • Нэрийн бичлэгийг хасах : Файлд 'id' багана байгаа бол энэ мөрийг хасаж эсвэл хасахгүй байж болно. Хэрэв энэ тохиргоо идэвхжсэн бол .vv файлын мөр бүрт шинэ бичлэг нэмэгдэнэ. Идэвхжээгүй бол дараахыг сонгож болно:
  • импортлосон бичлэг нь байж байгаа нэрийн бичлэгтэй таарж байх:
    • skip : Шинэ бичлэгийг алгас мөн мэдээл. Байршуулсны дараа бичлэг өмнө нь байсан эсэхийг харах боломжтой бөгөөд байсан бол импортлогдохгүй.
    • renumber : Шинэ бичлэгийг дахин дугаарла. VV файлын хариулттай шинэ бичлэг хариултын хүснэгтэд нэмэгдэнэ.
    • replace : Байж байгаа бичлэгийг дахин байршуул. Хуучин бичлэг устгагдаж, VV файлын бичлэгээр бүрэн солигдоно.
    • replaceanswer : Байж байгаа бичлэг дэх хариултын мэдээллийг файлаас солих. Хуучин бичлэг VV файлын шинэ хариултаар шинэчлэгдэнэ. Энэ нь хариултын хүснэгтэд зөвхөн нэг асуултыг солих боломж олгоно.
  • Дуусаагүй хариулт болгон импортлох уу? : Сонгосон бол submitdate нь NULL болж, хариулт дуусаагүй гэж тооцогдоно.
  • файлийн бусдаас ялгарах шинжийг тавих : Файлын тэмдэгтийн багцыг сонгож болно. Үндсэн бөгөөд зөвлөмж болгох утга нь UTF-8 боловч зарим хүснэгтийн программ тэмдэгтийн багц сонгохыг зөвшөөрдөггүй.
  • Эхний мөр асуултын кодуудыг агуулсан : Анхдагчаар VV файлын эхний мөр хүнд ойлгомжтой асуултыг агуулдаг бөгөөд жинхэнэ баганын нэрс хоёр дахь мөрөнд байдаг. Энэ нь эхний мөрийг жинхэнэ баганын нэр болгон ашиглах боломжийг олгоно.
  • Хүчээр импортлох : Хэрэв асуултын кодууд мэдээллийн сангийн нэр эсвэл Qcode хувьсагчийн нэршил-д олдохгүй бол баганууд дарааллаар нь оноогдоно. Үүнийг өөр LimeSurvey суулгацаас VV файл импортлоход ашиглаж болох ч судалгаа бүр яг ижил байх ёстой. Та юу хийж байгаагаа сайн мэдэж байгаа тохиолдолд л үүнийг ашиглахыг бид хүчтэй зөвлөж байна. Энэ нь маш аюултай бөгөөд үр дүн буруу баганад орох магадлалтай.

Экспортын бусад сонголтууд

Нэг хариултыг экспортлох

Хэрэв тусдаа нэг хариултыг экспортлохыг хүсвэл 3 аргаар хийж болно:

1. LimeSurvey-н админ хэсэгт нэвтэрч, судалгаагаа сонгоод "судалгааны тохиргоог засварлах" -> "Мэдэгдэл ба өгөгдлийн удирдлага" хэсэгт очиж, үндсэн цахим шуудангийн мэдэгдлийг хүлээн авч байгаагаа шалгана уу.

Хэн нэгэн судалгааг бөглөж дуусгах болгонд танд дараах холбоос бүхий цахим шуудан ирнэ: "Хариултыг тусад нь харахын тулд дараах холбоос дээр дарна уу"

Энэ нь таныг мэдээллийн дээд талд "Энэ хариултыг экспортлох" товчтой хуудас руу аваачна.

2. LimeSurvey-н админ хэсэгт нэвтэрч, судалгаагаа сонгоод "Энэ судалгааны хариултыг үзэх" (Browse responses) хэсэгт орно. "Хариултуудыг харуулах" дээр дарж, зүүн баганаас экспортлохыг хүссэн ID дугаараа сонгоно. Дараа нь мэдээллийн дээд талд байгаа "Энэ судалгааг экспортлох" дээр дарна.

3. LimeSurvey-н админ хэсэгт нэвтэрч, судалгаагаа сонгоод "Экспортын хариу дүнгүүд" (Export results to application) хэсэгт орно. "Мэдээлэл экспортлох" товчны дээрх сүүлийн талбараас аль бичлэгийг экспортлохоо сонгож болно.

Өөр өөр судалгааны хариултуудыг тохируулах

Тодорхой хүмүүсийн судалгааны хариултыг цаг хугацааны туршид хянахыг хүсвэл LimeSurvey танд тусална. Жишээ нь, бүлэг тодорхой семинарт оролцохоос өмнө болон дараа өгсөн хариултуудыг хянах боломжтой.

Үүнийг хэрэгжүүлэх алхмууд дараах байдалтай байна:

1. Судалгаа үүсгэнэ.

2. Судалгаа нэргүй биш бөгөөд токен ашиглаж байгаа эсэхийг шалгана. Нэргүй биш судалгаа үүсгэхийн тулд:

a - ерөнхий тохиргоо дүрс дээр дарна.

b - Дараа нь Токен табын доорх "Нэргүй хариу дүнгүүд" тохиргоонд "Үгүй" гэж сонгоно.

3. Судалгааг идэвхжүүлнэ.

Судалгааг идэвхжүүлэх үед токений хүснэгт үүсгэхийн тулд "Хаалттай хандалтын горимд шилжих" товч дээр дарна:

4. Токений хүснэгтийг өөрт тохирох аливаа аргаар бөглөнө (Токен хуудсанд байгаа зааврыг дагана уу).

5. Судалгааны хариу дүнг экспортлох бөгөөд токений мэдээллийг оруулсан эсэхээ шалгана.

Экспортлохын тулд броузын үр дүн дээр дарна...

...дараа нь экспортлох дээр дарна:

Судалгааны хариултуудтай холбохын тулд токений хүснэгтээс нэг буюу хэд хэдэн элемент сонгохоо мартуузай:

6. Судалгааг дахин ажиллуулах үед (судалгаа болон токений хүснэгтийг экспорт/импортоор хуулж хялбархан хийж болно) алхмуудыг давтаж, csv токен импортын файлыг үүсгэхдээ адил хүсэлтийг ашиглаж байгаагаа шалгана.

Асуудал ба шийдлүүд

Excel

Импортлохын өмнө Excel дээр хариултуудыг өөрчлөх

Хариултуудад олон өөрчлөлт хийхийн тулд файлыг экспортлоод Excel дээр нээж болно. Мэдээлэлд (дээд мөрүүдээс бусад хэсэгт) өөрчлөлт хийгээд .txt файлаар хадгална. Хэрэв .csv хэлбэрээр хадгалбал Excel таслалаар тусгаарлах тул LimeSurvey руу импортлогдохгүй. .txt файлаар хадгалснаар Excel табаар тусгаарласан файл үүсгэх бөгөөд энэ нь LimeSurvey руу буцаж импортлогдоно.

Excel-ээр .csv файлыг засах

Ерөнхийдөө экспортолсон .csv файлуудыг засахад Excel ашиглахыг бид зөвлөдөггүй, учир нь Excel дотоод өгөгдлийн бүтцэд өөрчлөлт оруулдаг тул импорт амжилтгүй болдог. Гэсэн ч Excel ашиглахыг хүсвэл Excel-ийн тусгаарлагчийг Удирдлагын самбарт (Windows системд) таслал болгож тохируулах хэрэгтэй:

System Control|Region- Languageoptions|Regional Settings, customize...|Tab Numbers|Digit grouping symbol| replace ; with ,

Excel ашиглан .csv файлыг засах түр шийдэл

Асуултыг засахдаа Excel ашиглавал тэдгээрийг дахин импортлох боломжгүй болгож магадгүй. Гэхдээ 5-аас дээш сонголттой эсвэл зэрэглэлийн сонголттой бол, мөн эрэмбэлэх зэрэг Excel-ийн боломжийг ашиглахыг хүсвэл засах нь зөв арга юм.

Энэ нь 1.82 хувилбарт ажилладаг бололтой хэсэгчилсэн түр шийдэл юм. Үндсэндээ Excel-ийг зөвхөн файлын өгөгдөл агуулсан хэсэгт ашиглана:

  • Дахин ашиглахыг хүсэж буй асуулттай төстэй асуултыг .csv файл болгон экспортлоно
  • CSV файлыг энгийн текст засварлагчаар нээнэ
  • Хариултуудыг агуулсан хэсгийг Excel рүү хуулж, "Text to Columns" эсвэл түүнтэй адил функцээр задлана
  • Excel-ийн баганад текст буулгах чадварыг ашиглан 20, 50, 100 хариултыг хүссэнээрээ буулгана
  • Файлыг Excel CSV хэлбэрээр хадгална, ихэвчлэн хашилтгүй байна
  • Энэ файлыг засварлагчаар нээгээд бүгдийг сонгож, хуулна
  • Энгийн текст засварлагчаар нээсэн анхны файл руугаа буцна
  • Хариултуудын оронд буулгана
  • Өөр нэрээр хадгална, дахин ашиглахад санахад хялбар нэр өгч болно
  • Энэ файлыг импортлоно.

Excel - экспорт 255 баганаар хязгаарлагдах

Excel-ийн (2003 ба түүнээс доош хувилбарууд) хязгаарлалтаас шалтгаалан LimeSurvey нэг дор зөвхөн 255 баганыг экспортлох боломжтой. Microsoft VB макро ашиглах түр шийдэл санал болгосон.

Шинэ хүснэгтийн программууд (Excel >= 2007, OpenOffice) 255-аас олон баганыг харуулж чадах ч LimeSurvey-ийн ашигладаг дотоод модуль 255-аас олон баганыг экспортлох боломжгүй хэвээр байна.

Гэхдээ дараах хоёр түр шийдлийн аль нэгийг ашиглаж болно:

  • CSV руу экспортлоод хүснэгтийн программдаа импортлох
  • Эсвэл хэд хэдэн удаа экспортлоод (нэг удаад дээд тал нь 250 багана сонгож), экспортолсон үр дүнг нэгтгэх

Excel/.csv - экспорт амжилтгүй болох

Хэрэв өгөгдлөө Excel эсвэл .csv файл руу экспортлох боломжгүй байвал хөтчийнхөө кэш болон күүкиг цэвэрлэнэ үү.

CSV

CSV анхдагчаар 255 баганатай

Том судалгааг экспортлоход GUI анхдагчаар экспортыг эхний 255 баганаар хязгаарладаг. Үүнийг тойрохын тулд бүх өгөгдлийн багцыг экспортод сонгоход хангалттай.

SPSS экспорт

Ерөнхий алхмууд

LimeSurvey-ийн хариултын өгөгдлийг импортлохын тулд дараах алхмуудыг хийнэ үү:

  1. 'Export to SPSS' дүрс дээр дарна.
  2. Сонгох талбаруудаас экспортлохыг хүсэж буй хариултууд болон SPSS хувилбараа сонгоно.
  3. Хоёр файлыг хоёуланг нь татаж авна: .sps (SPSS syntax командын файл) болон .dat файл (өгөгдлийн файл)
  4. SPSS-ийг нээгээд 'Choose another type of file' гэснийг сонгож, татаж авсан .sps файлыг сонгон нээнэ.
  5. Одоо SPSS дотор засварлагч нээгдэж, тухайн файл дахь командуудыг засах боломжтой болно. '/FILE=...' гэж эхэлсэн мөрийг хайна.
  6. Тэр мөрийг засаж, замыг .dat файл руугаа заадаг болгон тохируулна. Жишээ нь: Таны *.dat файл c:\temp хавтаст байвал энэ мөрийг /FILE='c:\temp\survey_(xxxx)_SPSS_data_file.dat' гэж тохируулна
  7. Дараа нь CTRL-A дарж засварлагч доторх бүх командыг сонгоно.
  8. SPSS цэснээс Run/All гэснийг сонгоно.
  9. Тэвчээртэй байна уу, бүх өгөгдөл болон шошгыг импортлоход хэсэг хугацаа шаардагдана. Явцыг төлөвийн мөрөөс харна уу.
  10. Дууслаа!

SPSS дэх боломжит алдааны зурвасууд

ERROR. command name:Get Data

Хэрэв ERROR. command name:Get Data. 2267 Unexpected Token missing. гэсэн алдааны зурвас гарвал syntax файлынхаа дөрөв дэх мөрийг өгөгдлийн файлын абсолют зам руу заадаг болгож засна уу. Жишээ нь:

C:\spss\Data\limesurvey\SPSS\survey_35276_SPSS_data_file.dat

Error: "Text value unmappable in the current server locale"

Экспортолсон syntax файлыг SPSS 16-д нээх гэхэд энэ алдаа гарч болно. Шийдэл нь SPSS-ийг syntax файлыг unicode гэж тайлбарлахад хүчээр тохируулах явдал юм.

SPSS-ийг нээнэ. Edit > Options > Character encoding for data and syntax рүү очно. Сонголтыг "unicode" болгож өөрчилнө.

Одоо LimeSurvey-ийн өгөгдлийг SPSS 16 руу ямар ч асуудалгүй экспортлох боломжтой.

Хувьсагчдаа ашиглах хэмжүүрийг тодорхойлох

Хувьсагчид ашиглагдах анхдагч хэмжүүрийг асуултын шинж чанар scale_export-ийг тохирох утгад тохируулах замаар дарж бичиж болно.

VV экспорт/импорт

VV - vv импорттой холбоотой асуудлууд

Хэрэв vv файл импортлоход бэрхшээл гарвал Tab-аар тусгаарласан файлыг оролдоорой, ажиллах ёстой.

Бусад асуудал ба шийдлүүд

Хариултуудыг өөр судалгаа руу хуулах (токен ашиглан)

  1. Шинэ судалгаа үүсгэж, туршилтын хариулт нэмээд, хариултын файлыг экспортлож, Excel-ээр нээнэ. Энэ нь шинэ импорт файлын форматыг үүсгэнэ.
  2. Хуучин судалгааны хариултуудыг токенуудын хамт экспортлож, Excel-ээр нээнэ.
  3. Энэ өгөгдлийг ашиглан стандарт токен файл импортлох Excel хуудас үүсгэнэ (жишээ нь: Firstname, Lastname, Token, Email address, Email status (OK), Language (En)). .csv хэлбэрээр хадгалаад токенуудыг LimeSurvey дахь шинэ судалгаа руу импортлоно.
  4. Excel дээр хуучин судалгааны хариултуудаас шинэ судалгаанд хэрэгтэй хариултын талбаруудыг (токенийг оролцуулан) шинэ судалгааны форматын тохирох Excel баганад хуулна.
  5. .txt файл болгон хадгална.
  6. VVImport ашиглан шинэ өгөгдлийг шинэ судалгаа руу импортлоно.
  7. Импортын боломжит алдаанд огнооны формат орно - зарим системийн огнооны талбар NULL утга зөвшөөрдөггүй, зарим нь зөвшөөрдөг. Хэрэв огноо зөв харагдаж байгаа ч алдаа өгвөл Excel-ийн нүдний форматыг "2009-12-01" болгоно.