x

Hovedkapitler

  1. LimeSurvey Cloud vs LimeSurvey CE
  2. Hurtigstartveiledning - LimeSurvey 3.0+
  3. Installasjon - LimeSurvey CE
  4. Hvordan lage en god undersøkelse (veiledning)
  5. Komme i gang
  6. Administrere LimeSurvey
  7. Undersøkelser - introduksjon
  8. Innstillinger for undersøkelse
  9. Meny for undersøkelse
  10. Undersøkelsesstruktur
  11. Spørsmål - introduksjon
  12. Spørsmålsgrupper - introduksjon
  13. Undersøkelser - administrasjon
  14. Verktøylinjen for undersøkelsen
  15. Flerspråklig undersøkelse
  16. ExpressionScript-motor – Hurtigstartguide
  17. Ukategoriserte og avanserte funksjoner
  18. Vanlige spørsmål (generelt)
  19. Feilsøking
  20. Løsninger og omveier
  21. Lisens
  22. Versjonsendringer
  23. Tillegg
 Actions

Eksportere besvarelser

From LimeSurvey Manual

Denne siden kan være maskinoversatt og kan inneholde feil. Vis den engelske originalen · Forbedre denne oversettelsen
This page is a translated version of the page Exporting results and the translation is 100% complete.
  Obs : Følgende avsnitt er utdatert. For oppdatert informasjon, se:




Når undersøkelsen din er aktiv, kan du begynne å se på besvarelsene og eksportere dem. For å komme til oversikten over besvarelser klikker du: Besvarelser -> Besvarelser og statistikk

Eksporter til program (Excel/.csv)

Øverst på siden vises flere eksportalternativer.

Når du eksporterer resultater, finnes det flere filteralternativer:

  • Generelt
    • Angi et område (for eksempel «eksporter poster X til Y»)
    • Velg å eksportere alle poster ELLER bare fullførte poster ELLER bare ufullstendige poster
  • Spørsmål
    • Bestem hvordan overskriften skal vises: forkortet overskrift ELLER fulle overskrifter ELLER spørsmålskoder
    • Konverter mellomrom i spørsmålstekst til understreker
  • Svar
    • Du kan enten eksportere fullstendige svar eller konvertere svarkodene Y og N til en definert variabel
  • Format
    • Microsoft Word (latinsk tegnsett)
    • Microsoft Excel (alle tegnsett)
    • CSV-fil (alle tegnsett)
    • HTML
    • PDF
  • Kolonnekontroll
    • Angi hvilke svar som skal eksporteres. Alle svar i denne listen er representert ved sin SGQA-identifikator
    • Angi hvilke token-data som skal eksporteres. Dette alternativet er bare tilgjengelig hvis undersøkelsen din ikke er anonym!

SPSS-eksport

Generelt

SPSS Statistics er programvare som brukes til logisk batch- og ikke-batch-basert statistisk analyse. Du kan bruke den offisielle SPSS-pakken eller bruke GNU PSPP, en erstatning for det proprietære programmet SPSS.

For å eksportere besvarelsesdataene dine til SPSS går du til delen Besvarelser og statistikk og klikker på ikonet for eksport til SPSS.

Eksporter og filtrer data

Når du eksporterer data til SPSS, finnes det to filteralternativer. Du kan velge hvilke data som skal velges (alle poster/bare fullførte poster/bare ufullstendige poster) og hvilken SPSS-versjon eksportfilene skal brukes i (tidligere versjon enn 16/16 og over).

SPSS-eksporten inneholder to filer:

  1. en syntaksfil (survey_xxxx_SPSS_syntax_file.sps)
  2. og en datafil (survey_xxxx_SPSS_data_file.dat).

Etter at du har lastet ned filene, kan du åpne dem i et rent tekstredigeringsprogram som Notisblokk for å se hvordan de eksporterte dataene ser ut. Syntaksfilen inneholder kommandoene som må kjøres for å importere dataene. Det er som et programmeringsspråk i SPSS. Datafilen er en kommaseparert fil med alle dataene. Hvis du bare importerer disse dataene som csv via en veiviser, mister du informasjon om spørsmål, etikettsett osv., så det gjør vi ikke.

Importer data i SPSS

Plasser de to filene i samme mappe på stasjonen din (eksempel: c:\data\survey_xxxx_SPSS_syntax_file.sps og c:\data\survey_xxxx_SPSS_data_file.dat)

Nå har vi to alternativer:

1. Hvis du bruker Windows, bruk Utforsker til å gå til mappen som ble brukt ovenfor. Hvis SPSS er tilknyttet filtypen .sps, kan du bare åpne filen ved å dobbeltklikke på den:

Nå kan du velge Run->All i det åpnede vinduet, og etter en stund har du det ferdige datasettet, som du kan lagre som en vanlig .sav-fil.

2. Noen ganger fungerer ikke den enkle løsningen ovenfor. Da kan du gå frem slik:

  • Åpne SPSS
  • Velg File->Open->Syntax
  • Velg riktig fil: c:\data\survey_xxxx_SPSS_syntax_file.sps
  • Nå åpnes syntaksen.
  • Endre linjen som lyder /FILE='survey_xxxx_SPSS_data_file.dat' slik at den inkluderer stien til filene: /FILE='c:\data\survey_xxxx_SPSS_data_file.dat' , for Mac-brukere: /FILE='HD/Users/username/survey_xxxx_SPSS_data_file.dat'
  • Marker nå hele kommandoteksten og velg Run->All fra menyen, og etter en stund (vær tålmodig) har du datasettet med all informasjon som spørsmål, etiketter osv.

R-eksport

Legg gjerne til mer informasjon hvis du har noe!

Gratisprogrammet R er et alternativ til SPSS. Det er en eksport til program i LimeSurvey.

Slik importerer du datasettet ditt i R:

  1. Last ned både syntaksfilen og datafilen.
  2. Lagre begge filene i arbeidsmappen til R (bruk getwd() og setwd() i et R-kommandovindu for å hente og angi den).
  3. Skriv source("Surveydata_syntax.R", encoding = "UTF-8") i kode i R-kommandovinduet, som importerer dataene i riktig format til en dataramme som heter «data».


Besvarelser med begrensede valgmuligheter blir faktorisert, der nivåene tilsvarer spørsmålets kode og etikettene tilsvarer valgmulighetene.

Spørsmål med «Annet» som alternativ får spørsmålsfeltet med _Other lagt til som en ny kolonne for de andre dataene.

NB: R-eksport er et tillegg i LimeSurvey. Hvis du ikke finner R-eksportalternativene (R (syntaksfil), R (datafil)) under Eksporter resultater til program, må du kontrollere at R-eksporttillegget er aktivert i tilleggsmenyen.

Eksport til STATA-xml

STATA er en kommersiell programvarepakke for dataanalyse og statistikk.

Denne eksportrutinen ble laget for å gjøre det enklere å raskt analysere data som er samlet inn med LimeSurvey. Den lager en XML-fil i STATAs eget format, som kan importeres uavhengig av plattformen STATA kjører på. Dette formatet har flere fordeler sammenlignet med import av vanlige CSV-filer:

  • Datasettene er fullt merket, inkludert variabeletiketter (spørsmål, underspørsmål) og verdietiketter (svar, hvis aktuelt).
  • Datoer er allerede omformet til STATAs interne datoformat og kan dermed brukes direkte til å beregne forskjeller mellom dager osv.
  • Variabelnavn konverteres om nødvendig til et format som er kompatibelt med STATA.
  • Dataformatene til variablene (streng, heltall, flyttall osv.) er allerede satt i samsvar med de underliggende dataene. (Ikke flere tall som er kodet som strenger!).

Slik laster du inn filen i STATA: Stata-versjoner opp til 14 hadde menyoppføringen File → Import → XML data for dette. Fra og med Stata 15 finnes ikke denne menyoppføringen lenger. Skriv i stedet inn følgende kommando i STATAs kommandovindu:

xmluse "survey_123456_STATA.xml", doctype(dta)

(erstatt filnavnet med stien til din egen eksporterte fil). Når dataene er lastet inn, kan du lagre dem i STATAs binære .dta-format, slik at du slipper å gjenta importen:

save "survey_123456.dta"


Merk: Kommandoene xmluse/xmlsave som er brukt ovenfor, ble fjernet fra STATAs offisielt dokumenterte og støttede kommandosett fra og med Stata 15, selv om de fortsatt fungerer i gjeldende versjoner som en udokumentert eldre funksjon. Fordi en fremtidig STATA-versjon kan fjerne dem uten varsel, anbefaler vi at du lagrer dataene som en .dta-fil (se ovenfor) rett etter importen, i stedet for å bruke XML-filen som langtidslagring. Hvis xmluse ikke er tilgjengelig i din STATA-installasjon, kan du bruke LimeSurveys CSV-eksport sammen med STATAs kommando import delimited i stedet.

Vær oppmerksom på:

  • På grunn av en begrensning i STATAs dataformat har strengvariabler (tekst) en maksimal lengde på 244 tegn (Stata-versjon 8–12) og 2045 tegn (Stata-versjon 13 og nyere). Oppgi Stata-versjonen din i innstillingene for eksporttillegget.
  • STATA støtter bare å knytte verdietiketter til numeriske verdier. For å få korte svar (vanligvis ett eller to sifre) som er riktig merket, bør du bruke numeriske svarkoder i LimeSurvey (1=Helt enig). Hvis det brukes ikke-numeriske svarkoder (A=Helt enig), brukes hele svarteksten som svar (f.eks. «Helt enig»).

VVExport og VVImport

 Hint: This feature changed with version 2.05


Når du har begynt å samle inn besvarelser, kan det oppstå situasjoner der du trenger å redigere og endre store mengder data direkte fra besvarelsestabellen, og da kan et regnearkverktøy være mer nyttig.

VVExport («VV» står for vertikal verifisering) lar deg eksportere besvarelsestabellen til en .csv-fil. Så lenge den overordnede strukturen i filen er intakt, kan du redigere verdiene i den og deretter importere filen tilbake til besvarelsestabellen ved hjelp av funksjonen «VVImport».

Ting du bør være oppmerksom på:

  • Hvis du vil importere besvarelser med «VVImport», må du kontrollere om besvarelsene skal legges til de eksisterende besvarelsene, eller om alle besvarelser skal overskrives.
  • Hvis du prøver å importere besvarelser fra en annen, men identisk undersøkelse (f.eks. identiske spørsmål/svar fra en annen undersøkelse), må du sørge for at du bruker riktig vv-fil og at de to første linjene i .csv-filen er riktige.
  • Hvis du importerer en undersøkelse til LimeSurvey-installasjonen din, endres ikke SID (hvis mulig). Gruppe-ID-en og spørsmåls-ID-en kan imidlertid endres. Da må du kanskje justere de to første overskriftslinjene slik at de samsvarer med den nye gruppe-ID-en/spørsmåls-ID-en. Se Tilpasse overskriftene i vv-filen

<span id="VVExport_file_version_2_ (New in 2.05 )">VVExport-filversjon 2 (New in 2.05 )

Denne nye funksjonen tillater andre kolonnenavn enn databasen. Hvis spørsmålskodene dine er unike, velges den nye versjonen. I den nye versjonen bruker hvert kolonnenavn Qcode-variabelnavn. Dette gjør det for eksempel enklere å oppdatere en eksisterende undersøkelse i en annen installasjon.

Eksportere en VV-undersøkelsesfil

File:LimesurveyExportVVen.jpg

Når du velger å eksportere besvarelser med VVExport, kan du velge hvilken undersøkelse som skal eksporteres, og om du vil eksportere alle besvarelser, kun fullførte besvarelser eller kun ufullstendige besvarelser. Med filetternavnet velger du hvilket etternavn den eksporterte filen skal ha. For enkel bruk bør .csv velges.

En «vv-undersøkelsesfil» lar deg importere besvarelsene til en undersøkelse når kombinasjonene av spørsmål og svar har endret seg. Dette gjør det i praksis mulig å legge til eller fjerne spørsmål i en aktiv undersøkelse.

Når du klikker på «Eksporter en VV-undersøkelefil», lages det en tabulatorseparert fil som kan åpnes i Excel eller et lignende regnearkprogram. De to første radene i regnearket er kolonneetikettene. Den første raden er en «lesbar» kolonneoverskrift som beskriver navnet på spørsmåls-/svarfeltet. Den andre raden er det interne PHP-/databasekolonnenavnet for den besvarelsen.

Du bør ikke endre de to første radene i dette regnearket hvis du vil kunne «importere» dataene tilbake til LimeSurvey senere.

<span id="Exporting_a_VV_survey_file_ (New in 2.05 )">

Eksportere en VV-undersøkelsesfil (New in 2.05 )

 Hint: This feature is available starting in version 2.05


  • Eksporter undersøkelse : ID-en til undersøkelsen som skal eksporteres (skrivebeskyttet)
  • Eksporter : Fullføringsstatusen til besvarelsene som skal eksporteres
  • Filetternavn : Filetternavnet. Filen er en TSV-fil (tabulatorseparerte verdier). For enkel åpning i MS Excel setter du etternavnet til .txt. Med LibreOffice, OpenOffice eller andre regnearkprogrammer kan du la det stå som .csv.
  • VV-eksportversjon : Versjon 1.0 bruker databasens kolonneoverskrifter, versjon 2.0 bruker Qcode-variabelnavn. Versjon 2.0 er valgt som standard hvis alle spørsmålskodene dine er unike.

De to første radene i regnearket er kolonneetikettene. Den første raden er en «lesbar» kolonneoverskrift som beskriver navnet på spørsmålet. Den andre raden er det faktiske kolonnenavnet (internt DB- eller Qcode-navn) for den besvarelsen.

Redigere en VV-undersøkelsesfil

Når en .vv-fil er eksportert, kan du åpne og redigere den i et regnearkverktøy. Hvis du må velge kolonneskilletegn når du åpner filen, bruker du «Tabulator»-tegnet. Hvis du bruker tegn utenfor ASCII, må du sørge for at du velger «UTF-8» som tegnsett.

  Hvis du bruker Microsoft Excel til å redigere den eksporterte vv-filen, bør du vite at Excel ødelegger filens opprinnelige datastruktur. Dette fører til en feil når du prøver å importere den redigerte .vv-filen på nytt.


Som standard er de to første radene i .vv-filen overskrifter. Om nødvendig kan du fjerne den første linjen for å få en ekte TSV-fil. Det finnes ulike bruksområder for import av en .vv-fil, så vi skiller mellom å legge til nye besvarelser i en undersøkelse og å overskrive alle besvarelsene i undersøkelsen.

Eksempel på strukturen i en .vv-fil:

VV versjon 1 TSV-fil

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	46492X40X1991
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1

VV versjon 2 TSV-fil

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	QCODE
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1


Her brukes ikke SGQA-identifikatorer – i stedet brukes Qcode-variabelnavn QCODE på den andre linjen.

Reserverte navn

.VV-filen bruker venstre og høyre klammeparentes for reserverte navn. Ved import erstattes disse strengene med:

  • {question_not_shown} : NULL-verdi i databasen. LimeSurvey bruker [tom streng] for et spørsmål som ikke er besvart, og NULL-verdi for et spørsmål som ikke er vist (av uttrykksbehandleren eller på grunn av maks. trinn i undersøkelsen).
  • {quote} : " (et dobbelt anførselstegn)
  • {cr} : Linjeskift (carriage return)
  • {newline} : En ny linje
  • {lbrace} : Venstre klammeparentes (for eksempel hvis du vil ha {cr} i en besvarelse: bruk {lbrace}cr} )

Redigering av VV versjon 1

Legge til nye besvarelser i eksisterende besvarelser i en undersøkelse

Dette støttes ikke i versjon 1 av formatet, siden det lett kan føre til ulike problemer, blant annet at data importeres i feil kolonner. Versjon 1 av .vv-filen var alltid ment for vertikal verifisering av data i et eksternt verktøy som Excel, ikke som en måte å samle data fra ulike kilder (for eksempel den samme undersøkelsen kjørt på en annen server).

Endre alle besvarelser i en undersøkelse

Hvis du vil endre besvarelser i en undersøkelse, kan du ganske enkelt redigere filen.

Eksempel:

Trinn 1: Åpne filen

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
183	09.11.11 11:44	3	de	4
184	09.11.11 11:53	3	de	2
190	09.11.11 11:44	3	de	1


Trinn 2: Endre besvarelsene

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
1000	09.11.11 11:44	3	de	3
1001	09.11.11 11:53	3	de	3
1002	09.11.11 11:44	3	de	3

Deretter kan du importere undersøkelsen. Sørg for å overskrive de eksisterende besvarelsene (se «Importere en VV-undersøkelsefil»).

Importere en VV-undersøkelsefil

File:LimeSurveyImportVVen.jpg

Så lenge de to første linjene er intakte, kan du importere dataene i VV-undersøkelsesfilen tilbake i en aktiv LimeSurvey-undersøkelse.

Hvis du brukte Microsoft Excel til å redigere den eksporterte vv-filen, kan datastrukturen i filen være ødelagt, slik at LimeSurvey ikke kan importere den redigerte filen. Du kan prøve følgende løsning for å få importen til å fungere uten feil:

  • Åpne den eksporterte vv-filen i Excel og gjør endringene dine (du har sannsynligvis allerede gjort det)
  • Lagre den som en tabulatorseparert tekstfil (dette oppretter en ny fil med filtypen .txt)
  • Gjør en ny «ren» vv-eksport fra LimeSurvey
  • Åpne denne nye eksporterte vv-filen i et tekstredigeringsprogram som Notisblokk eller lignende (jeg brukte TextWrangler på Mac)
  • Trykk CTRL + A for å markere hele innholdet, og slett det
  • Åpne den Excel-redigerte vv-filen (den tabulatorseparerte .txt-filen) i et tekstredigeringsprogram og trykk CTRL + A for å markere hele innholdet
  • Trykk CTRL + C for å kopiere innholdet og lim det inn i den nye (nå tomme) vv-filen
  • Trykk CTRL + S for å lagre filen som den er (som .csv)
  • Prøv nå å importere denne filen

Velg deretter ikonet «Importer en VV-undersøkelsefil» fra visningen for besvarelser.

På skjermbildet «Importer en VV-undersøkelsefil» må du velge «vvexport»-filen du importerer. Hvis du velger «Utelat oppførings-ID?», importeres oppføringene og det genereres helt nye oppførings-ID-er for dem (bruk dette alternativet for bruksområdet «Legge til nye besvarelser i eksisterende besvarelser i en undersøkelse»). Hvis du fjerner merket i denne boksen, importeres de opprinnelige oppførings-ID-ene (bruk dette alternativet for bruksområdet «Overskrive alle besvarelser i undersøkelsen»).

Du kan velge mellom flere alternativer som forteller LimeSurvey hvordan doble eller flere oppføringer skal håndteres.

  • Rapporter en feil (og hopp over den nye posten).
  • Endre nummer på den nye posten
  • Overskriv den eksisterende posten (bruk dette for bruksområdet «Overskrive alle besvarelser i undersøkelsen»)

<span id="Importing_a_VV_survey_file_ (New in 2.05 )">

Importere en VV-undersøkelsefil (New in 2.05 )

  • Fil : Velg filen som skal lastes opp. Filen må være en TSV-fil: en tekstfil der hver kolonne er atskilt med TAB.
  • Utelat oppførings-ID? : Hvis kolonnen «id» finnes i filen, kan du velge om denne linjen skal utelates. Hvis denne innstillingen er avmerket, legges det til en ny oppføring for hver linje i .vv-filen. Hvis den ikke er avmerket, kan du velge:
  • Når en importert oppføring samsvarer med en eksisterende ID:
    • skip : Rapporter og hopp over den nye besvarelsen. Etter opplastingen ser du om oppføringen allerede fantes – hvis den fantes, blir den ikke importert.
    • renumber : Endre nummer på den nye posten. En ny oppføring legges til i svartabellen med svarene fra VV-filen.
    • replace : Overskriv den eksisterende posten. Den gamle oppføringen slettes og erstattes helt av oppføringen fra VV-filen.
    • replaceanswer : Erstatt besvarelsesdetaljer fra filen i den eksisterende oppføringen. Den gamle oppføringen oppdateres med den nye besvarelsen fra VV-filen. Dette gjør det mulig å erstatte bare ett spørsmål i svartabellen.
  • Importer som ikke-ferdigstilt besvarelse? : Hvis dette er avmerket, settes submitdate til NULL, slik at besvarelsen settes som ikke fullført.
  • Tegnsett i denne filen : Du kan velge tegnsettet for filen. Standard og anbefalt verdi er UTF-8, men noen regnearkprogrammer lar deg ikke velge tegnsett.
  • Første linje inneholder spørsmålskoder : Som standard inneholder den første linjen i VV-filen lesbare spørsmål, mens de faktiske kolonnenavnene står på den andre linjen. Med dette alternativet kan den første linjen brukes som de faktiske kolonnenavnene.
  • Tving import : Hvis spørsmålskodene ikke finnes i databasenavnet eller i Qcode-variabelnavn, tildeles kolonnene etter rekkefølge. Dette kan brukes til å importere en VV-fil fra en annen LimeSurvey-installasjon, men hver undersøkelse må da være helt lik. Vi anbefaler på det sterkeste at du bare bruker dette hvis du vet hva du gjør. Det kan være svært farlig og føre til at resultater havner i feil kolonne.

Andre eksportalternativer

Eksportere én enkelt besvarelse

Hvis du vil eksportere en enkeltbesvarelse, kan du gjøre det på tre måter:

1. Logg inn i LimeSurvey-administrasjonen, velg undersøkelsen din, gå til «Endre innstillingene i undersøkelsen» -> «Notification and data management» og sørg for at du mottar grunnleggende e-postvarsler.

Hver gang noen har fullført en undersøkelse, får du en e-post med en lenke: «Klikk på følgende lenke for å se den enkelte besvarelsen»

Du kommer da til en side med en knapp over dataene som heter «Eksporter denne besvarelsen»

2. Logg inn på administrasjonsgrensesnittet i LimeSurvey, velg undersøkelsen din og «Se gjennom besvarelser». Klikk på «Vis besvarelser» og på ID-nummeret du vil eksportere i kolonnen til venstre. Deretter kan du klikke på «Eksporter denne undersøkelsen» over dataene.

3. Logg inn på administrasjonsgrensesnittet i LimeSurvey, velg undersøkelsen din og «Eksporter resultater». I det siste feltet over «Eksporter data» kan du velge hvilken oppføring du vil eksportere.

Samsvar mellom besvarelser fra ulike undersøkelser

Hvis du vil følge besvarelsene til bestemte personer over tid, kan LimeSurvey hjelpe deg med det. Et mulig bruksområde er å følge en gruppes besvarelser før og etter at gruppen har deltatt på et bestemt seminar.

Fremgangsmåten er som følger:

1. Opprett undersøkelsen

2. Pass på at undersøkelsen ikke er anonym og bruker tokens. Slik oppretter du en undersøkelse som ikke er anonym:

a - Klikk på ikonet Generelle innstillinger.

b - Under fanen Tokens velger du «Nei» for Anonyme besvarelser.

3. Aktiver undersøkelsen.

Når du aktiverer undersøkelsen, klikker du på knappen «Endre til lukket tilgangsmodus» for å opprette token-tabellen:

4. Fyll token-tabellen på den måten du foretrekker (følg instruksjonene på siden Tokens).

5. Eksporter undersøkelsesresultatene, og pass på at du tar med token-informasjonen.

For å eksportere klikker du på Se gjennom besvarelser...

...og deretter på Eksporter:

Husk å velge ett eller flere elementer fra token-tabellen som skal knyttes til besvarelsene:

6. Når du kjører undersøkelsen på nytt, noe som enkelt kan gjøres ved å kopiere undersøkelsen og token-tabellen via eksport/import, gjentar du bare trinnene og passer på at samme spørring brukes til å bygge CSV-filen for token-import.

Problemer og løsninger

Excel

Endre besvarelser i Excel før import

For å gjøre flere endringer i besvarelsene kan du eksportere og åpne en fil i Excel. Gjør endringer i dataene (unntatt de øverste linjene), og lagre deretter som en .txt-fil. Hvis du lagrer som .csv, bruker Excel komma som skilletegn, og da kan filen ikke importeres i LimeSurvey. Når du lagrer som .txt-fil, lagrer Excel en tabulatorskilt fil som kan importeres tilbake i LimeSurvey.

Rediger .csv-filer med Excel

Generelt anbefaler vi ikke å bruke Excel til å redigere eksporterte .csv-filer, fordi Excel gjør endringer i den interne datastrukturen som fører til at importen mislykkes. Hvis du likevel vil bruke Excel, må du sette skilletegnet i Excel til komma i Kontrollpanel (Windows-systemer):

Kontrollpanel|Region- og språkalternativer|Regionale innstillinger, tilpass...|Fanen Tall|Skilletegn for tallgruppering| erstatt ; med ,

Omvei for å redigere .csv-filer med Excel

Hvis du bruker Excel til å redigere spørsmål, kan det hende at du ikke får importert dem på nytt. Redigering er likevel den beste løsningen hvis du har mer enn omtrent 5 alternativer eller rangeringsalternativer, eller hvis du vil bruke Excels funksjoner, for eksempel sortering.

Dette er en delvis omvei som ser ut til å fungere i 1.82. I korte trekk: Bruk bare Excel på den delen av filen som inneholder dataene:

  • Eksporter et spørsmål som ligner på det du vil gjenbruke, som .csv-fil
  • Åpne CSV-filen i et rent tekstredigeringsprogram
  • Kopier delen med svarene til Excel, og del den opp i kolonner med Tekst til kolonner eller tilsvarende
  • Bruk Excels muligheter til å lime inn tekst i kolonner for å lime inn 20, 50 eller 100 svar, slik du ønsker
  • Lagre filen som Excel CSV, som sannsynligvis ikke har anførselstegn.
  • Åpne denne filen i tekstredigeringsprogrammet, og velg alle og kopier
  • Gå tilbake til filen du åpnet i det rene tekstredigeringsprogrammet
  • Lim inn over svarene der
  • Lagre som, med et annet navn, gjerne et du husker for senere bruk
  • Importer denne filen.

Excel – eksport er begrenset til 255 kolonner

På grunn av begrensninger i Excel (versjon 2003 og eldre) kan LimeSurvey bare eksportere 255 kolonner om gangen. Microsoft har foreslått en omvei som en VB-makro.

Selv om nyere regneark (Excel 2007 og nyere, OpenOffice) kan vise mer enn 255 kolonner, kan den interne modulen som LimeSurvey bruker, fortsatt ikke eksportere mer enn 255 kolonner.

Det finnes imidlertid to omveier. Bruk en av følgende løsninger:

  • Enten eksporter til CSV og importer i regnearket ditt
  • Eller bruk flere eksporter (velg maksimalt 250 kolonner om gangen), og slå deretter sammen de eksporterte resultatene

Excel/.csv – eksporten mislykkes

Hvis du ikke klarer å eksportere dataene dine til Excel eller til en .csv-fil, kan du prøve å tømme nettleserens hurtigbuffer og informasjonskapsler.

CSV

CSV er som standard begrenset til 255 kolonner

Ved eksport av store undersøkelser begrenser brukergrensesnittet som standard eksporten til de første 255 kolonnene. For å komme rundt dette kan du ganske enkelt merke alle datasett for eksport.

SPSS-eksport

Generelle trinn

Følg disse trinnene for å importere besvarelsesdataene fra LimeSurvey:

  1. Klikk på ikonet «Eksporter til SPSS».
  2. Velg i valgboksene hvilke besvarelser du vil eksportere, og din SPSS-versjon.
  3. Last ned begge filene: .sps-filen (SPSS-syntaksfil med kommandoer) og .dat-filen (datafil)
  4. Åpne .sps-filen med SPSS ved å starte SPSS, velge «Choose another type of file» og deretter velge den nedlastede .sps-filen.
  5. Nå åpnes et redigeringsvindu i SPSS der du kan redigere kommandoene i filen. Finn linjen som starter med '/FILE=...'
  6. Rediger linjen og juster stien slik at den peker til .dat-filen din. Eksempel: Hvis *.dat-filen din ligger i c:\temp, setter du linjen til /FILE='c:\temp\survey_(xxxx)_SPSS_data_file.dat'
  7. Velg nå alle kommandoene i redigeringsvinduet ved å trykke CTRL-A.
  8. Velg Run/All i SPSS-menyen.
  9. Ha tålmodighet, det tar litt tid å importere alle data og etiketter. Følg med på fremdriften i statuslinjen.
  10. Ferdig!

Mulige feilmeldinger i SPSS

ERROR. command name:Get Data

Hvis du får feilmeldingen ERROR. command name:Get Data. 2267 Unexpected Token missing., må du redigere den fjerde linjen i syntaksfilen slik at den peker til den absolutte stien til datafilen, for eksempel

C:\spss\Data\limesurvey\SPSS\survey_35276_SPSS_data_file.dat

Feil: «Text value unmappable in the current server locale»

Denne feilen kan oppstå hvis du prøver å åpne en eksportert syntaksfil i SPSS 16. Løsningen er å tvinge SPSS til å tolke syntaksfilen som unicode.

Åpne SPSS. Gå til Edit > Options > Character encoding for data and syntax. Endre alternativet til «unicode».

LimeSurvey-data kan nå eksporteres til SPSS 16 uten problemer.

Definer skalaen som skal brukes for variabelen

Du kan overstyre standardskalaen som brukes for en variabel, ved å sette spørsmålsattributtet scale_export til riktig verdi.

VV-eksport/-import

VV – problemer med VV-import

Hvis du har problemer med å importere en vv-fil, kan du prøve en tabulatordelt fil, så skal det fungere fint.

Andre problemer og løsninger

Kopiere besvarelser til en annen undersøkelse (med tokens)

  1. Opprett en ny undersøkelse, legg til en prøvebesvarelse, eksporter besvarelsesfilen og åpne den i Excel. Dette oppretter formatet for den nye importfilen.
  2. Eksporter besvarelsene fra den gamle undersøkelsen, inkludert tokens, og åpne dem i Excel.
  3. Bruk disse dataene til å opprette et Excel-regneark for standard import av tokenfil (f.eks. fornavn, etternavn, token, e-postadresse, status (OK), språk (En)). Lagre som .csv og importer tokens til den nye undersøkelsen i LimeSurvey.
  4. Kopier i Excel besvarelsesfeltene fra den gamle undersøkelsen som du vil ha i den nye undersøkelsen (inkludert token), inn i den aktuelle Excel-kolonnen i det nye undersøkelsesformatet.
  5. Lagre som .txt-fil.
  6. Bruk VVImport til å importere de nye dataene til den nye undersøkelsen.
  7. Mulige importfeil gjelder blant annet datoformat – noen systemdatofelt tillater ikke NULL-verdi, andre gjør det. Hvis datoen ser riktig ut, men gir en feil, kan du bruke Excel-cellformatet «2009-12-01».