x

Hlavné kapitoly

  1. LimeSurvey Cloud vs LimeSurvey CE
  2. Rýchly sprievodca - LimeSurvey 3.0+
  3. Inštalácia - LimeSurvey CE
  4. Ako vytvoriť dobrý prieskum (príručka)
  5. Začíname
  6. Správa LimeSurvey
  7. Prieskumy - úvod
  8. Nastavenia prieskumu
  9. Menu prieskumu
  10. Štruktúra prieskumu
  11. Otázky – úvod
  12. Skupiny otázok - úvod
  13. Prieskumy - správa
  14. Možnosti panela nástrojov prieskumu
  15. Viacjazyčný prieskum
  16. ExpressionScript Engine - Príručka rýchleho štartu
  17. Nezaradené a pokročilé funkcie
  18. Všeobecné časté otázky
  19. Riešenie problémov
  20. Riešenia a obchádzky
  21. Licencia
  22. Záznam zmien verzií
  23. Doplnky
 Actions

Export výsledkov

From LimeSurvey Manual

Táto stránka mohla byť preložená strojovo a môže obsahovať chyby. Zobraziť anglický originál · Vylepšiť tento preklad
This page is a translated version of the page Exporting results and the translation is 100% complete.
  Pozor : Nasledujúca časť je zastaraná. Aktuálne informácie nájdete na týchto stránkach:




Keď je váš prieskum aktívny, môžete si začať zobrazovať odpovede a exportovať ich. Prehľad odpovedí na prieskum otvoríte kliknutím na: Odpovede -> Odpovede a štatistiky

Export do aplikácie (Excel/.csv)

V hornej časti stránky je uvedených niekoľko možností exportu.

Pri exporte výsledkov je k dispozícii niekoľko možností filtra:

  • Všeobecné
    • Nastavte rozsah (napríklad „exportovať záznamy X až Y“)
    • Nastavte export všetkých záznamov ALEBO iba dokončených záznamov ALEBO iba nekompletných záznamov
  • Otázky
    • Určite, ako sa má zobraziť hlavička: skrátená hlavička ALEBO úplné hlavičky ALEBO kódy otázok
    • Previesť medzery v texte otázky na podčiarkovníky
  • Odpovede
    • Môžete exportovať celé odpovede alebo previesť kódy odpovedí Y a N na definovanú premennú
  • Formát
    • Microsoft Word (latinská znaková sada)
    • Microsoft Excel (všetky znakové sady)
    • CSV súbor (všetky znakové sady)
    • HTML
    • PDF
  • Ovládanie stĺpcov
    • Nastavte, ktoré odpovede sa majú exportovať. Všetky odpovede v tomto zozname sú reprezentované svojím identifikátorom SGQA
    • Nastavte, ktoré údaje tokenov sa majú exportovať. Táto možnosť je dostupná iba vtedy, ak váš prieskum nie je anonymný!

Export do SPSS

Všeobecné

SPSS Statistics je softvér používaný na dávkovú aj nedávkovú logickú štatistickú analýzu. Môžete použiť oficiálny balík SPSS alebo GNU PSPP, ktorý nahrádza proprietárny program SPSS.

Ak chcete exportovať údaje odpovedí do SPSS, prejdite do sekcie Odpovede a štatistiky a kliknite na ikonu exportu do SPSS.

Export a filtrovanie údajov

Pri exporte údajov do SPSS sú k dispozícii dve možnosti filtra. Môžete vybrať, ktoré údaje sa majú vybrať (všetky záznamy/iba dokončené záznamy/iba nekompletné záznamy) a pre akú verziu SPSS sa budú exportované súbory používať (staršia verzia ako 16/16 alebo viac).

Export do SPSS obsahuje dva súbory:

  1. súbor syntaxe (survey_xxxx_SPSS_syntax_file.sps)
  2. a dátový súbor (survey_xxxx_SPSS_data_file.dat).

Po stiahnutí týchto súborov ich môžete otvoriť v textovom editore, napríklad v Poznámkovom bloku, a pozrieť si, ako exportované údaje vyzerajú. Súbor syntaxe obsahuje príkazy, ktoré treba spustiť na import údajov. Je to akoby programovací jazyk v rámci SPSS. Dátový súbor obsahuje súbor s hodnotami oddelenými čiarkami so všetkými údajmi. Ak tieto údaje jednoducho importujete ako csv pomocou sprievodcu, stratíte informácie o otázkach, množinách štítkov atď., preto to nerobíme.

Import údajov do SPSS

Umiestnite oba súbory do rovnakého priečinka na disku (príklad: c:\data\survey_xxxx_SPSS_syntax_file.sps a c:\data\survey_xxxx_SPSS_data_file.dat)

Teraz máme dve možnosti:

1. Ak používate Windows, v Prieskumníkovi prejdite do priečinka použitého vyššie. Ak je SPSS spojený s príponou súboru .sps, súbor môžete otvoriť jednoducho dvojitým kliknutím:

Teraz môžete v otvorenom okne zvoliť Run->All a po chvíli získate výstupný súbor údajov, ktorý môžete uložiť ako bežný súbor .sav.

2. Niekedy jednoduché riešenie vyššie nefunguje. Potom môžete postupovať takto:

  • Otvorte SPSS
  • Zvoľte File->Open->Syntax
  • Vyberte príslušný súbor: c:\data\survey_xxxx_SPSS_syntax_file.sps
  • Teraz sa otvorí syntax.
  • Zmeňte riadok /FILE='survey_xxxx_SPSS_data_file.dat' tak, aby obsahoval cestu k umiestneniu súborov: /FILE='c:\data\survey_xxxx_SPSS_data_file.dat' , pre používateľov Macu: /FILE='HD/Users/username/survey_xxxx_SPSS_data_file.dat'
  • Teraz označte celý text príkazov, v ponuke zvoľte Run->All a po chvíli (buďte trpezliví) získate súbor údajov so všetkými informáciami, ako sú otázky, štítky atď.

Export do R

Ak máte ďalšie informácie, pokojne ich pridajte!

Freeware softvér R je alternatívou k SPSS. V LimeSurvey ide o export do aplikácie.

Pokyny na import vašej množiny údajov do R:

  1. Stiahnite si súbor syntaxe aj dátový súbor.
  2. Uložte oba súbory do pracovného adresára R (na zistenie a nastavenie použite getwd() a setwd() v príkazovom okne R).
  3. Vo svojom kóde zadajte do príkazového okna R source("Surveydata_syntax.R", encoding = "UTF-8"), čo importuje údaje v správnom formáte do dátového rámca s názvom „data“.


Odpovede s obmedzenými možnosťami budú faktorizované tak, že úrovne budú zodpovedať kódu otázky a štítky budú zodpovedať možnostiam.

Otázky s možnosťou „Iné“ budú mať pole otázky s pripojeným _Other ako nový stĺpec pre údaje z tejto možnosti.

Pozn.: Export do R je doplnok v LimeSurvey. Ak nemôžete nájsť možnosti exportu do R (R (súbor syntaxe), R (dátový súbor)) v časti Exportovať výsledky do aplikácie, skontrolujte, či je doplnok pre export do R povolený v ponuke doplnkov.

Export STATA-xml

STATA je komerčný softvérový balík na analýzu údajov a štatistiku.

Tento exportný nástroj bol vytvorený na uľahčenie rýchlej analýzy údajov zozbieraných pomocou LimeSurvey. Vytvára súbor XML vo formáte vlastnom pre STATA, ktorý možno importovať nezávisle od platformy, na ktorej STATA beží. Použitie tohto formátu má oproti importu obyčajných súborov CSV niekoľko výhod:

  • Súbory údajov sú plne označené vrátane označení premenných (otázka, podotázka) a označení hodnôt (odpovede, ak sú k dispozícii).
  • Dátumy sú už prevedené do interného formátu dátumu STATA, a preto ich možno priamo použiť napríklad na výpočet rozdielu medzi dňami.
  • Názvy premenných sú v prípade potreby prevedené do formátu kompatibilného so STATA.
  • Dátové formáty premenných (reťazec, celé číslo, desatinné číslo atď.) sú už nastavené podľa podkladových údajov. (Už žiadne čísla uložené ako reťazce!).

Ako načítať súbor v STATA: Verzie Stata do 14 na to ponúkali položku ponuky File → Import → XML data. Od verzie Stata 15 táto položka ponuky už neexistuje. Namiesto toho zadajte do okna Command v STATA nasledujúci príkaz:

xmluse "survey_123456_STATA.xml", doctype(dta)

(názov súboru nahraďte cestou k vlastnému exportovanému súboru). Po načítaní údajov ich môžete uložiť v binárnom formáte .dta programu STATA, aby ste nemuseli import opakovať:

save "survey_123456.dta"


Poznámka: Príkazy xmluse/xmlsave použité vyššie boli od verzie Stata 15 odstránené z oficiálne zdokumentovanej a podporovanej sady príkazov STATA, hoci v aktuálnych verziách stále fungujú ako nezdokumentovaná staršia funkcia. Keďže by ich budúce vydanie STATA mohlo bez upozornenia odstrániť, odporúčame uložiť údaje ihneď po importe ako súbor .dta, namiesto spoliehania sa na súbor XML ako dlhodobé úložisko. Ak xmluse nie je vo vašej inštalácii STATA dostupný, použite namiesto toho export CSV z LimeSurvey spolu s príkazom import delimited programu STATA.

Upozornenie:

  • Kvôli obmedzeniu dátového formátu STATA je dĺžka reťazcových (textových) premenných maximálne 244 znakov (verzie Stata 8-12) a 2045 znakov (verzia Stata 13 a novšie). Uveďte, prosím, svoju verziu Stata v nastaveniach exportného doplnku.
  • STATA podporuje priraďovanie označení hodnôt iba k číselným hodnotám. Ak chcete mať krátke odpovede (zvyčajne jedna alebo dve číslice) a správne ich označiť, použite v LimeSurvey číselné kódy odpovedí (1=Úplne súhlasím). Ak sa použijú nečíselné kódy odpovedí (A=Úplne súhlasím), ako odpoveď sa použije celý text odpovede (napr.: „Úplne súhlasím“).

VVExport a VVImport

 Hint: This feature changed with version 2.05


Keď začnete zbierať odpovede, môžu nastať situácie, kedy potrebujete priamo upravovať a meniť veľké množstvo údajov z tabuľky odpovedí, pričom môže byť užitočnejší tabuľkový nástroj.

VVExport („VV“ znamená vertikálna verifikácia) umožňuje exportovať tabuľku odpovedí do súboru .csv. Ak zostane celková štruktúra súboru zachovaná, môžete v ňom upravovať hodnoty a potom súbor opäť importovať do tabuľky odpovedí pomocou funkcie „VVImport“.

Na čo by ste si mali dať pozor:

  • Ak chcete importovať odpovede pomocou „VVImport“, skontrolujte, či sa majú odpovede pridať k existujúcim odpovediam, alebo sa majú všetky odpovede prepísať.
  • Ak sa pokúšate importovať odpovede z iného, no identického prieskumu (napr. identické otázky/odpovede z iného prieskumu), uistite sa, že používate správny súbor vv a že prvé dva riadky súboru .csv sú správne.
  • Ak importujete prieskum do svojej inštalácie LimeSurvey, SID sa (ak je to možné) nezmení. ID skupiny a ID otázky sa však môžu zmeniť. Možno preto budete musieť upraviť prvé dva riadky hlavičky tak, aby zodpovedali novému ID skupiny/ID otázky. Pozrite si Adjusting vv file headings

<span id="VVExport_file_version_2_ (New in 2.05 )">Súbor VVExport verzia 2 (New in 2.05 )

Táto nová funkcia umožňuje používať iné názvy stĺpcov ako v databáze. Ak sú kódy vašich otázok jedinečné, vyberie sa nová verzia. V novej verzii každý názov stĺpca používa pomenovanie premenných Qcode. To napríklad umožňuje jednoduchšie aktualizovať existujúci prieskum v inej inštalácii.

Export VV súboru prieskumu

File:LimesurveyExportVVen.jpg

Keď sa rozhodnete exportovať odpovede pomocou VVExport, budete môcť vybrať, ktorý prieskum sa má exportovať a či chcete exportovať všetky odpovede, iba úplné odpovede, alebo iba nekompletné odpovede. Prípona súboru vám umožňuje zvoliť príponu exportovaného súboru. Pre jednoduché použitie odporúčame zvoliť .csv.

„VV súbor prieskumu“ umožňuje importovať odpovede do prieskumu, keď sa zmenili kombinácie otázok/odpovedí. V praxi to umožňuje pridávať alebo odstraňovať otázky v aktívnom prieskume.

Kliknutím na „Exportovať VV súbor dotazníka“ sa vytvorí súbor oddelený tabulátormi, ktorý možno otvoriť v programe Excel alebo podobnom tabuľkovom procesore. Prvé dva riadky tabuľky tvoria označenia stĺpcov. Prvý riadok je „ľudsky čitateľná“ hlavička stĺpca, ktorá podrobne uvádza názov poľa otázky/odpovede. Druhý riadok je interný názov stĺpca PHP/databázy pre danú odpoveď.

Prvé dva riadky tejto tabuľky by ste nemali upravovať, ak chcete mať možnosť údaje neskôr „importovať“ späť do LimeSurvey.

<span id="Exporting_a_VV_survey_file_ (New in 2.05 )">

Export VV súboru prieskumu (New in 2.05 )

 Hint: This feature is available starting in version 2.05


  • Exportuj prieskum : ID prieskumu, ktorý sa má exportovať (iba na čítanie)
  • Export : Stav dokončenosti odpovedí, ktoré sa majú exportovať
  • Prípona súboru : Prípona súboru. Súbor je typu TSV (hodnoty oddelené tabulátormi). Pre jednoduché otvorenie v MS Excel nastavte príponu .txt, v LibreOffice, OpenOffice alebo inom tabuľkovom procesore môžete ponechať .csv.
  • Exportná verzia VV : Verzia 1.0 používa hlavičky stĺpcov z databázy, verzia 2.0 používa pomenovanie premenných Qcode. Verzia 2.0 je predvolene vybraná, ak sú všetky kódy vašich otázok jedinečné.

Prvé dva riadky tabuľky tvoria označenia stĺpcov. Prvý riadok je „ľudsky čitateľná“ hlavička stĺpca, ktorá podrobne uvádza názov otázky. Druhý riadok je skutočný názov stĺpca (interný názov v databáze alebo Qcode) pre danú odpoveď.

Úprava VV súboru prieskumu

Keď sa súbor .vv úspešne exportuje, môžete ho otvoriť a upraviť v tabuľkovom nástroji. Ak si pri otváraní súboru musíte vybrať oddeľovač stĺpcov, použite znak „Tab“. Ak používate znaky mimo ASCII, uistite sa, že ste ako znakovú sadu nastavili „UTF-8“.

  Ak na úpravu exportovaného súboru vv používate Microsoft Excel, mali by ste vedieť, že Excel zničí pôvodnú dátovú štruktúru súboru. Pri pokuse o opätovný import upraveného súboru .vv to spôsobí chybu.


Predvolene sú prvé dva riadky súboru .vv hlavičky. Ak je to potrebné, môžete odstrániť prvý riadok, aby ste získali skutočný súbor TSV. Existujú rôzne prípady použitia importu súboru .vv, preto rozlíšime medzi pridávaním nových odpovedí do prieskumu a prepísaním všetkých odpovedí prieskumu.

Príklad štruktúry súboru .vv:

VV súbor TSV verzie 1

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	46492X40X1991
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1

VV súbor TSV verzie 2

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	QCODE
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1


Identifikátory SGQA sa tu nepoužívajú – namiesto nich sa v druhom riadku používa pomenovanie premenných Qcode QCODE.

Vyhradené názvy

Súbor .VV používa pre vyhradené názvy ľavé a pravé zátvorky. Pri importe sa tento reťazec nahradí:

  • {question_not_shown} : hodnota NULL v databáze. LimeSurvey používa [prázdny reťazec] pre nezodpovedanú otázku a hodnotu NULL pre otázku, ktorá sa nezobrazila (kvôli Správcovi výrazov alebo maximálnemu kroku v prieskume).
  • {quote} : " (dvojitá úvodzovka)
  • {cr} : návrat vozíka
  • {newline} : nový riadok
  • {lbrace} : ľavá zátvorka (ak chcete mať napríklad {cr} v odpovedi, použite {lbrace}cr} )

Úprava VV verzie 1

Pridanie nových odpovedí k existujúcim odpovediam prieskumu

Verzia 1 formátu to nepodporuje, pretože to môže ľahko spôsobiť rôzne problémy vrátane importu údajov do nesprávnych stĺpcov. Verzia 1 súboru .vv bola vždy určená na vertikálnu verifikáciu údajov v externom nástroji, ako je Excel, nie na zlučovanie údajov z rôznych zdrojov (napríklad z rovnakého prieskumu bežiaceho na inom serveri).

Úprava všetkých odpovedí prieskumu

Ak chcete upraviť odpovede prieskumu, môžete súbor jednoducho upraviť.

Príklad:

Krok 1: Otvorte súbor

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
183	09.11.11 11:44	3	de	4
184	09.11.11 11:53	3	de	2
190	09.11.11 11:44	3	de	1


Krok 2: Upravte odpovede

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
1000	09.11.11 11:44	3	de	3
1001	09.11.11 11:53	3	de	3
1002	09.11.11 11:44	3	de	3

Potom môžete prieskum importovať. Nezabudnite prepísať existujúce odpovede (pozri "Importovanie VV súboru prieskumu").

Importovanie VV súboru prieskumu

File:LimeSurveyImportVVen.jpg

Pokiaľ sú prvé dva riadky neporušené, môžete údaje zo svojho VV súboru prieskumu importovať späť do aktívneho prieskumu LimeSurvey.

Ak ste exportovaný súbor vv upravovali v programe Microsoft Excel, dátová štruktúra tohto súboru môže byť poškodená, takže LimeSurvey nedokáže upravený súbor importovať. Pomocou nasledujúceho postupu môžete dosiahnuť, aby import fungoval bez chyby:

  • Otvorte exportovaný súbor vv v programe Excel a vykonajte zmeny (pravdepodobne ste to už urobili)
  • Uložte ho ako textový súbor oddelený tabulátormi (vytvorí sa nový súbor s príponou .txt)
  • Vykonajte z LimeSurvey ďalší „čistý“ export vv
  • Otvorte tento nový exportovaný súbor vv v textovom editore, napríklad v Poznámkovom bloku alebo inom editore (ja som použil textwrangler na Macu)
  • Stlačením CTRL + A označte celý obsah a vymažte ho
  • Otvorte súbor vv upravený v Exceli (textový súbor .txt oddelený tabulátormi) v textovom editore a stlačením CTRL + A označte celý obsah
  • Stlačením CTRL + C obsah skopírujte a vložte ho do nového (teraz prázdneho) súboru vv
  • Stlačením CTRL + S súbor uložte tak, ako je (ako .csv)
  • Teraz skúste tento súbor importovať

Potom na obrazovke prehliadania vyberte ikonu "Importovať VV súbor dotazníka".

Na obrazovke "Importovať VV súbor dotazníka" musíte vybrať súbor "vvexport", ktorý importujete. Ak vyberiete možnosť "Vylúčiť ID záznamov", záznamy sa importujú a pre každý z nich sa vygeneruje nové ID záznamu (túto možnosť použite pri scenári "Pridanie nových odpovedí k existujúcim odpovediam prieskumu"). Ak toto políčko zrušíte, importujú sa pôvodné ID záznamov (túto možnosť použite pri scenári "Prepísanie všetkých odpovedí prieskumu").

Môžete si vybrať z viacerých možností, ktoré určujú, ako má LimeSurvey nakladať s duplicitnými alebo viacnásobnými záznamami.

  • Nahlásiť chybu (a preskočiť nový záznam).
  • Zapametaj si nový záznam
  • Nahradiť existujúci záznam (túto možnosť použite pri scenári "Prepísanie všetkých odpovedí prieskumu")

<span id="Importing_a_VV_survey_file_ (New in 2.05 )">

Importovanie VV súboru prieskumu (New in 2.05 )

  • Súbor : Vyberte súbor, ktorý sa má nahrať. Súbor musí byť súbor TSV: textový súbor, v ktorom sú jednotlivé stĺpce oddelené tabulátorom.
  • Vylúčiť ID záznamov? : Ak sa v súbore nachádza stĺpec 'id', tento riadok môžete vylúčiť alebo nie. Ak je toto nastavenie zaškrtnuté, pre každý riadok súboru .vv sa pridá nový záznam. Ak nie je zaškrtnuté, môžete si vybrať:
  • Ak sa importovaný záznam zhoduje s existujúcim ID záznamu:
    • skip : Zaznamenaj a preskoč nový záznam. Po nahratí uvidíte, či záznam už existoval – ak existoval, neimportuje sa.
    • renumber : Zapametaj si nový záznam. Do tabuľky odpovedí sa pridá nový záznam s odpoveďou zo súboru VV.
    • replace : Nahradiť existujúci záznam. Starý záznam sa odstráni a úplne nahradí záznamom zo súboru VV.
    • replaceanswer : Nahradiť podrobnosti odpovede zo súboru v existujúcom zázname. Starý záznam sa aktualizuje novou odpoveďou zo súboru VV. Takto je možné nahradiť iba jednu otázku v tabuľke odpovedí.
  • Importovať ako nedokončenú odpoveď? : Ak je zaškrtnuté, submitdate sa nastaví na NULL, takže odpoveď bude označená ako nedokončená.
  • Znaková sada súboru : Môžete zvoliť znakovú sadu súboru – predvolená a odporúčaná hodnota je UTF-8, ale niektoré tabuľkové procesory neumožňujú znakovú sadu zvoliť.
  • Prvý riadok obsahuje kódy otázok : Prvý riadok súboru VV štandardne obsahuje otázky v čitateľnej podobe a skutočné názvy stĺpcov sú v druhom riadku. Táto možnosť umožňuje použiť prvý riadok ako skutočné názvy stĺpcov.
  • Vynútený import : Ak sa kódy otázok nenájdu v názve databázy ani v pomenovaní premenných Qcode, stĺpce sa priradia podľa poradia. Takto je možné importovať súbor VV z inej inštancie LimeSurvey, ale každý prieskum musí byť úplne rovnaký. Dôrazne odporúčame použiť to, iba ak viete, čo robíte. Môže to byť veľmi nebezpečné a môže to viesť k tomu, že sa výsledky ocitnú v nesprávnom stĺpci.

Ďalšie možnosti exportu

Export jednej odpovede

Ak chcete exportovať jednotlivú odpoveď, môžete to urobiť tromi spôsobmi:

1. Prihláste sa do administrácie LimeSurvey, vyberte svoj prieskum, prejdite na "Upraviť nastavenia prieskumu" -> "Notification and data management" a uistite sa, že dostávate základné e-mailové upozornenia.

Zakaždým, keď niekto dokončí prieskum, dostanete e-mail s odkazom: "Kliknutím na nasledujúci odkaz zobrazíte jednotlivú odpoveď"

Odkaz vás presmeruje na stránku s tlačidlom nad údajmi s názvom "Exportovať túto odpoveď"

2. Prihláste sa do administrácie LimeSurvey, vyberte svoj prieskum a "Prehľadávať odpovede" tohto prieskumu. Kliknite na "Zobraziť odpovede" a v ľavom stĺpci na číslo ID, ktoré chcete exportovať. Potom môžete kliknúť na "Exportovať túto odpoveď" nad údajmi.

3. Prihláste sa do administrácie LimeSurvey, vyberte svoj prieskum a "Exportovať výsledky" do aplikácie. V poslednom poli nad tlačidlom "Exportovať dáta" môžete vybrať, ktorý záznam chcete exportovať.

Párovanie odpovedí z rôznych prieskumov

Ak chcete sledovať odpovede konkrétnych osôb v priebehu času, LimeSurvey vám s tým môže pomôcť. Možným použitím je sledovanie odpovedí skupiny pred absolvovaním určitého seminára a po ňom.

Postup je nasledovný:

1. Vytvorte prieskum

2. Uistite sa, že prieskum nie je anonymný a používa tokeny. Vytvorenie neanonymného prieskumu:

a - Kliknite na ikonu Hlavné nastavenia.

b - Potom na karte Tokeny vyberte pri možnosti Anonimizované odpovede hodnotu "Nie".

3. Aktivujte prieskum.

Keď prieskum aktivujete, kliknite na tlačidlo "Prepnúť na uzavretý prístup", čím sa vytvorí tabuľka tokenov:

4. Naplňte tabuľku tokenov ľubovoľným spôsobom (postupujte podľa pokynov na stránke Tokeny).

5. Exportujte výsledky prieskumu a uistite sa, že zahŕňajú informácie o tokenoch.

Na export kliknite na prehľadávať výsledky...

...a potom na exportovať:

Nezabudnite vybrať jeden alebo viac prvkov z tabuľky tokenov, ktoré sa majú priradiť k odpovediam prieskumu:

6. Keď prieskum spustíte znova, čo možno jednoducho urobiť skopírovaním prieskumu a tabuľky tokenov pomocou exportu/importu, jednoducho zopakujte tieto kroky a uistite sa, že na vytvorenie importného súboru csv s tokenmi sa použije rovnaký dotaz.

Problémy a riešenia

Excel

Úprava odpovedí v Exceli pred importom

Ak chcete vykonať viacero zmien v odpovediach, môžete súbor exportovať a otvoriť v Exceli. Upravte údaje (okrem horných riadkov) a potom ich uložte ako súbor .txt. Ak súbor uložíte ako .csv, Excel použije čiarku ako oddeľovač, takže sa nedá importovať do LimeSurvey. Uložením ako .txt Excel vytvorí súbor oddelený tabulátormi, ktorý sa do LimeSurvey dá importovať späť.

Úprava súboru .csv v Exceli

Vo všeobecnosti neodporúčame používať Excel na úpravu exportovaných súborov .csv, pretože Excel mení vnútornú štruktúru údajov, čo spôsobuje zlyhanie importu. Ak ho napriek tomu chcete použiť, musíte v Ovládacích paneloch (systémy Windows) nastaviť oddeľovač pre Excel na čiarku:

Ovládacie panely|Región a jazyk|Regionálne nastavenia, prispôsobiť...|Čísla|Symbol zoskupovania číslic| nahraďte ; znakom ,

Riešenie na úpravu súborov .csv v programe Excel

Úprava otázok v programe Excel vám môže zabrániť v ich opätovnom importe. Úprava v Exceli je však vhodná, ak máte viac ako 5 možností alebo možností poradia, alebo ak chcete využiť funkcie Excelu, ako je napríklad triedenie.

Ide o čiastočné riešenie, ktoré podľa všetkého funguje vo verzii 1.82. V podstate používajte Excel len na tú časť súboru, ktorá obsahuje dáta:

  • Exportujte otázku podobnú tej, ktorú chcete znovu použiť, ako súbor .csv
  • Otvorte súbor CSV v textovom editore
  • Skopírujte časť s odpoveďami do Excelu a rozdeľte ju pomocou funkcie Text na stĺpce alebo jej ekvivalentu.
  • Využite schopnosti Excelu na vkladanie textu do stĺpcov a vložte 20, 50 alebo 100 odpovedí, koľko potrebujete
  • Uložte súbor ako Excel CSV, ktorý pravdepodobne nebude obsahovať úvodzovky.
  • Otvorte tento súbor v editore, vyberte všetko a skopírujte
  • Vráťte sa k súboru, ktorý ste otvorili v textovom editore
  • Prepíšte tam odpovede vloženým textom
  • Uložte ako pod iným názvom, napríklad takým, ktorý si zapamätáte na ďalšie použitie
  • Importujte tento súbor.

Excel - export obmedzený na 255 stĺpcov

Kvôli obmedzeniam programu Excel (verzie 2003 a staršie) môže LimeSurvey exportovať naraz iba 255 stĺpcov. Spoločnosť Microsoft navrhla riešenie vo forme makra VB.

Hoci novšie tabuľkové procesory (Excel >= 2007, OpenOffice) dokážu zobraziť viac ako 255 stĺpcov, interný modul, ktorý LimeSurvey používa, stále nedokáže exportovať viac ako 255 stĺpcov.

Možné sú však dve riešenia, použite jedno z nasledujúcich:

  • Exportujte do CSV a importujte do svojho tabuľkového procesora
  • Alebo použite viacero exportov (vždy vyberte najviac 250 stĺpcov) a exportované výsledky potom zlúčte

Excel/.csv - export zlyhá

Ak nemôžete exportovať dáta do Excelu alebo do súboru .csv, skúste vymazať vyrovnávaciu pamäť a súbory cookie prehliadača.

CSV

CSV je predvolene obmedzený na 255 stĺpcov

Pri exporte rozsiahlych prieskumov grafické rozhranie predvolene obmedzuje export na prvých 255 stĺpcov. Ak to chcete obísť, jednoducho označte všetky množiny dát na export.

Export do SPSS

Všeobecné kroky

Ak chcete importovať dáta odpovedí z LimeSurvey, postupujte podľa nasledujúcich krokov:

  1. Kliknite na ikonu 'Export do SPSS'.
  2. Vo výberových poliach vyberte, ktoré odpovede chcete exportovať, a svoju verziu SPSS.
  3. Stiahnite si oba súbory, .sps (súbor so syntaxou príkazov SPSS) a .dat (dátový súbor)
  4. Otvorte súbor .sps v SPSS tak, že spustíte SPSS, vyberiete 'Choose another type of file' a vyberiete stiahnutý súbor .sps.
  5. Teraz sa v SPSS otvorí editor, v ktorom môžete upraviť príkazy v tomto súbore. Nájdite riadok, ktorý začína '/FILE=...'
  6. Upravte tento riadok a nastavte cestu tak, aby ukazovala na váš súbor .dat. Príklad: Ak je váš súbor *.dat v c:\temp, nastavte tento riadok na /FILE='c:\temp\survey_(xxxx)_SPSS_data_file.dat'
  7. Teraz vyberte všetky príkazy v editore stlačením CTRL-A.
  8. V ponuke SPSS vyberte Run/All.
  9. Buďte trpezliví, import všetkých dát a popisiek chvíľu potrvá. Priebeh môžete sledovať na stavovom riadku.
  10. Hotovo!

Možné chybové správy v SPSS

ERROR. command name:Get Data

Ak sa zobrazí chybová správa ERROR. command name:Get Data. 2267 Unexpected Token missing., upravte štvrtý riadok súboru so syntaxou tak, aby ukazoval na absolútnu cestu k dátovému súboru, napríklad

C:\spss\Data\limesurvey\SPSS\survey_35276_SPSS_data_file.dat

Error: "Text value unmappable in the current server locale"

Táto chyba sa môže vyskytnúť, ak sa pokúsite otvoriť exportovaný súbor so syntaxou v SPSS 16. Riešením je prinútiť SPSS, aby súbor so syntaxou interpretoval ako unicode.

Open SPSS. Go to Edit > Options > Character encoding for data and syntax. Change the option to "unicode".

Dáta z LimeSurvey je teraz možné exportovať do SPSS 16 bez problémov.

Definovanie škály pre vašu premennú

Predvolenú škálu použitú pre premennú je možné prepísať nastavením atribútu otázky scale_export na príslušnú hodnotu.

Export/Import VV

VV - problémy s importom vv

Ak máte problémy s importom súboru vv, skúste súbor s oddeľovačmi tabulátorom a mal by fungovať bez problémov.

Ďalšie problémy a riešenia

Kopírovanie odpovedí do iného prieskumu (pomocou tokenov)

  1. Vytvorte nový prieskum, pridajte fiktívnu odpoveď, exportujte súbor s odpoveďami a otvorte ho v Exceli. Tým sa vytvorí formát pre nový importný súbor.
  2. Exportujte odpovede zo starého prieskumu vrátane tokenov a otvorte ich v Exceli.
  3. Pomocou týchto dát vytvorte hárok Excelu pre štandardný import súboru tokenov (napr. Firstname, Lastname, Token, Emailová adresa, Status emailu (OK), Language (En)). Uložte ako .csv a importujte tokeny do nového prieskumu v LimeSurvey.
  4. V Exceli skopírujte polia odpovedí zo starého prieskumu, ktoré chcete mať v novom prieskume (vrátane tokenu), do príslušného stĺpca Excelu vo formáte nového prieskumu.
  5. Uložte ako súbor .txt.
  6. Pomocou VVImport importujte nové dáta do nového prieskumu.
  7. Medzi možné chyby importu patrí formát dátumu - niektoré systémové polia dátumu nepovoľujú hodnotu NULL, iné áno. Ak dátum vyzerá správne, ale zobrazí sa chyba, použite formát bunky Excelu "2009-12-01".