x

Huvudkapitel

  1. LimeSurvey Cloud vs LimeSurvey CE
  2. Snabbstartsguide - LimeSurvey 3.0+
  3. Installation - LimeSurvey CE
  4. Så utformar du en bra enkät (guide)
  5. Komma igång
  6. Administrera LimeSurvey
  7. Enkäter - introduktion
  8. Enkätinställningar
  9. Enkätmeny
  10. Enkätens struktur
  11. Frågor - introduktion
  12. Frågegrupper - introduktion
  13. Enkäter - hantering
  14. Alternativ i enkätverktygsfältet
  15. Flerspråkig enkät
  16. ExpressionScript-motorn – Snabbstartsguide
  17. Okategoriserade och avancerade funktioner
  18. FAQ
  19. Felsökning
  20. Lösningar och genvägar
  21. Licens
  22. Ändringslogg för versioner
  23. Plugins
 Actions

Exportera resultat

From LimeSurvey Manual

Den här sidan kan ha maskinöversatts och kan innehålla fel. Visa det engelska originalet · Förbättra den här översättningen
This page is a translated version of the page Exporting results and the translation is 100% complete.
  Observera : Följande avsnitt är föråldrat. För aktuell information, se:




När din enkät är aktiv kan du börja visa svar och exportera dem. För att komma till översikten över enkätsvar klickar du på: Svar -> Svar och statistik

Exportera till program (Excel/.csv)

Högst upp på sidan visas flera exportalternativ.

När du exporterar resultat finns flera filteralternativ:

  • Allmän
    • Ange ett intervall (till exempel "exportera poster X till Y")
    • Välj att exportera alla poster ELLER endast slutförda poster ELLER endast ofullständiga poster
  • Frågor
    • Bestäm hur rubriken ska visas: förkortad rubrik ELLER fullständiga rubriker ELLER frågekoder
    • Konvertera alla mellanslag i frågornas texter till understreck
  • Svar
    • Du kan antingen exportera fullständiga svar eller konvertera svarskoderna Y och N till en definierad variabel
  • Format
    • Microsoft Word (latinsk teckenuppsättning)
    • Microsoft Excel (alla teckenuppsättningar)
    • CSV-fil (alla teckenuppsättningar)
    • HTML
    • PDF
  • Kolumnkontroll
    • Ange vilka svar som ska exporteras. Alla svar i listan representeras av sin SGQA-identifierare
    • Ange vilka token-data som ska exporteras. Det här alternativet är bara tillgängligt om din enkät inte är anonym!

SPSS-export

Allmänt

SPSS Statistics är ett program för logisk satsvis och icke-satsvis statistisk analys. Du kan använda det officiella SPSS-paketet eller GNU PSPP, som är en ersättning för det proprietära programmet SPSS.

För att exportera dina svarsdata till SPSS går du till avsnittet Svar och statistik och klickar på ikonen för export till SPSS.

Exportera och filtrera data

När du exporterar data till SPSS finns det två filteralternativ. Du kan välja vilka data som ska väljas (alla poster/endast slutförda poster/endast ofullständiga poster) och för vilken SPSS-version exportfilerna ska användas (äldre än version 16/16 eller nyare).

SPSS-exporten innehåller två filer:

  1. en syntaxfil (survey_xxxx_SPSS_syntax_file.sps)
  2. och en datafil (survey_xxxx_SPSS_data_file.dat).

När du har laddat ner filerna kan du öppna dem i en vanlig textredigerare som Anteckningar för att se hur de exporterade data ser ut. Syntaxfilen innehåller de kommandon som ska köras för att importera data. Den fungerar som ett programmeringsspråk inne i SPSS. Datafilen är en kommaseparerad fil med alla data. Om du bara importerar dessa data som csv via en guide förlorar du information om frågor, etikettuppsättningar med mera, så det gör vi inte.

Importera data i SPSS

Placera de två filerna i samma mapp på din enhet (exempel: c:\data\survey_xxxx_SPSS_syntax_file.sps och c:\data\survey_xxxx_SPSS_data_file.dat)

Nu har vi två alternativ:

1. Om du använder Windows bläddrar du med Utforskaren till mappen ovan. Om SPSS är kopplat till filändelsen .sps kan du öppna filen genom att dubbelklicka på den:

Nu kan du välja Run->All i det öppnade fönstret, och efter en stund får du din utdatamängd som du kan spara som en vanlig .sav-fil.

2. Ibland fungerar inte den enkla lösningen ovan. Då kan du gå tillväga så här:

  • Öppna SPSS
  • Välj File->Open->Syntax
  • Välj lämplig fil: c:\data\survey_xxxx_SPSS_syntax_file.sps
  • Nu öppnas syntaxen.
  • Ändra raden som lyder /FILE='survey_xxxx_SPSS_data_file.dat' så att den innehåller sökvägen till filerna: /FILE='c:\data\survey_xxxx_SPSS_data_file.dat' , för Mac-användare: /FILE='HD/Users/username/survey_xxxx_SPSS_data_file.dat'
  • Markera nu hela kommandotexten och välj Run->All i menyn. Efter en stund (ha tålamod) har du datamängden med all information som frågor, etiketter med mera.

R-export

Lägg gärna till mer information om du har någon!

Programvaran R är ett gratisalternativ till SPSS. Det är en export till program i LimeSurvey.

Instruktioner för hur du importerar din datamängd i R:

  1. Ladda ner både syntaxfilen och datafilen.
  2. Spara båda filerna i R:s arbetskatalog (använd getwd() och setwd() i ett R-kommandofönster för att hämta och ange den).
  3. Skriv source("Surveydata_syntax.R", encoding = "UTF-8") i kod i R-kommandofönstret, vilket importerar data i rätt format till en dataram som heter "data".


Svar med begränsade alternativ faktoriseras med nivåer som motsvarar frågans kod och etiketter som motsvarar alternativen.

Frågor med alternativet "Annat" får fältet för frågan med _Other tillagt som en ny kolumn för de övriga uppgifterna.

OBS: R-export är ett plugin i LimeSurvey. Om du inte hittar R-exportalternativen (R (syntaxfil), R (datafil)) under Exportera svar till program, kontrollera att R-export-pluginet är aktiverat i pluginmenyn.

STATA-xml-export

STATA är ett kommersiellt programpaket för dataanalys och statistik.

Den här exportrutinen skapades för att underlätta snabb analys av data som samlats in med LimeSurvey. Den skapar en XML-fil i STATAs egna format, som kan importeras oberoende av vilken plattform STATA körs på. Det här formatet har flera fördelar jämfört med att importera vanliga CSV-filer:

  • Datamängder är fullständigt etiketterade, inklusive variabeletiketter (fråga, delfråga) och värdeetiketter (svar, i förekommande fall).
  • Datum är redan omvandlade till STATAs interna datumformat och kan därför användas direkt för att beräkna skillnader mellan dagar och liknande.
  • Variabelnamn konverteras vid behov till ett format som är kompatibelt med STATA.
  • Dataformat för variabler (sträng, heltal, flyttal osv.) är redan inställda utifrån underliggande data. (Inga fler tal som kodas som strängar!).

Så här läser du in filen i STATA: Stata-versioner upp till 14 hade menyposten File → Import → XML data för detta. Från och med Stata 15 finns den menyposten inte längre. Skriv i stället följande kommando i STATAs kommandofönster:

xmluse "survey_123456_STATA.xml", doctype(dta)

(ersätt filnamnet med sökvägen till din egen exporterade fil). När data har lästs in kan du spara dem i STATAs binära .dta-format så att du inte behöver upprepa importen:

save "survey_123456.dta"


Observera: Kommandona xmluse/xmlsave som används ovan togs bort från STATAs officiellt dokumenterade och understödda kommandouppsättning från och med Stata 15, men de fungerar fortfarande i aktuella versioner som en odokumenterad äldre funktion. Eftersom en framtida STATA-version kan ta bort dem utan förvarning rekommenderar vi att du sparar dina data som en .dta-fil (se ovan) direkt efter importen i stället för att förlita dig på XML-filen som långtidslagring. Om xmluse inte är tillgängligt i din STATA-installation kan du i stället använda LimeSurveys CSV-export tillsammans med STATAs kommando import delimited.

Observera:

  • På grund av en begränsning i STATAs dataformat har strängvariabler (text) en maximal längd på 244 tecken (Stata-versionerna 8–12) och 2045 tecken (Stata version 13 och senare). Ange din Stata-version i inställningarna för exportpluginet.
  • STATA stöder endast värdeetiketter för numeriska värden. För att få korta svar (oftast en eller två siffror) som är korrekt etiketterade bör du använda numeriska svarskoder i LimeSurvey (1=Instämmer helt). Om icke-numeriska svarskoder används (A=Instämmer helt) används hela svarstexten som svar (t.ex. 'Instämmer helt').

VV-export och VV-import

 Hint: This feature changed with version 2.05


När du har börjat samla in svar kan det finnas tillfällen då du direkt behöver redigera och ändra stora mängder data i din svarstabell, där ett kalkylprogram kan vara mer användbart.

Med VV-export ("VV" står för vertical verification) kan du exportera din svarstabell till en .csv-fil. Så länge filens allmänna struktur är intakt kan du redigera värdena i den och sedan importera filen till svarstabellen igen med funktionen "VV-import".

Saker att tänka på:

  • Om du vill importera svar med "VV-import" ska du kontrollera om svaren ska läggas till bland de befintliga svaren eller om alla svar ska skrivas över.
  • Om du försöker importera svar från en annan men identisk enkät (t.ex. identiska frågor/svar från en annan enkät) ska du se till att du använder rätt vv-fil och att de två första raderna i .csv-filen är korrekta.
  • Om du importerar en enkät till din LimeSurvey-installation ändras enkätens ID (SID) inte, om det är möjligt. Grupp-ID och fråge-ID kan dock ändras. Du kan därför behöva justera de två första rubrikraderna så att de matchar det nya grupp-ID:t/fråge-ID:t. Se Adjusting vv file headings

<span id="VVExport_file_version_2_ (New in 2.05 )">VV-exportfil version 2 (New in 2.05 )

Den här nya funktionen tillåter andra kolumnnamn än databasens. Om dina frågekoder är unika väljs den nya versionen. I den nya versionen använder varje kolumnnamn Qcode Variable Naming. Det gör det till exempel enklare att uppdatera en befintlig enkät i en annan installation.

Exportera en VV-enkätfil

File:LimesurveyExportVVen.jpg

När du väljer att exportera svar med VV-export får du välja vilken enkät som ska exporteras och om du vill exportera alla svar, endast kompletta svar eller endast ofullständiga svar. Med filändelsen väljer du vilken filändelse den exporterade filen ska ha. För enkel användning bör .csv väljas.

En "vv-enkätfil" gör det möjligt att importera svaren till en enkät när kombinationerna av frågor och svar har ändrats. I praktiken kan du därmed lägga till eller ta bort frågor i en aktiv enkät.

När du klickar på "Exportera en VV-enkätfil" skapas en tabbavgränsad fil som kan öppnas i Excel eller ett liknande kalkylprogram. De två första raderna i kalkylbladet är kolumnetiketter. Den första raden är en "läsbar" kolumnrubrik som beskriver namnet på fråge-/svarsfältet. Den andra raden är det interna PHP-/databaskolumnnamnet för det svaret.

Du bör inte ändra de två första raderna i kalkylbladet om du vill kunna "importera" data tillbaka till LimeSurvey vid ett senare tillfälle.

<span id="Exporting_a_VV_survey_file_ (New in 2.05 )">

Exportera en VV-enkätfil (New in 2.05 )

 Hint: This feature is available starting in version 2.05


  • Exportera enkät : ID för den enkät som ska exporteras (skrivskyddat)
  • Exportera : Svarsstatus för de svar som ska exporteras
  • Filändelse : Filändelsen. Filen är en TSV-fil (Tab-separated values). För att enkelt öppna den i MS Excel, ställ in filändelsen till .txt. Med LibreOffice, OpenOffice eller andra kalkylprogram kan du behålla .csv.
  • VV-export-version : Version 1.0 använder databasens kolumnrubriker, version 2.0 använder Qcode Variable Naming. Version 2.0 väljs som standard om alla dina frågekoder är unika.

De två första raderna i kalkylbladet är kolumnetiketter. Den första raden är en "läsbar" kolumnrubrik som beskriver namnet på frågan. Den andra raden är det verkliga kolumnnamnet (internt databas- eller Qcode-namn) för det svaret.

Redigera en VV-enkätfil

När en .vv-fil har exporterats kan du öppna och redigera den i ett kalkylprogram. Om du måste välja kolumnavgränsare när du öppnar filen, använd tecknet "Flik" (tabb). Om du använder icke-ASCII-tecken ska du ställa in "UTF-8" som teckenuppsättning.

  Om du använder Microsoft Excel för att redigera den exporterade vv-filen bör du veta att Excel förstör filens ursprungliga datastruktur. Det orsakar ett fel när du försöker importera den redigerade .vv-filen igen.


Som standard är de två första raderna i .vv-filen rubriker. Vid behov kan du ta bort den första raden för att få en riktig TSV-fil. Det finns olika användningsfall för att importera en .vv-fil, så vi skiljer mellan att lägga till nya svar i en enkät och att skriva över alla svar i enkäten.

Exempel på strukturen i en .vv-fil:

VV version 1 TSV-fil

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	46492X40X1991
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1

VV version 2 TSV-fil

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	QCODE
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1


Här används inte SGQA-identifierare – i stället används Qcode-variabelnamn QCODE på den andra raden.

Reserverade namn

VV-filen använder vänstra och högra klammerparenteser för reserverade namn. Vid import ersätts dessa strängar med:

  • {question_not_shown} : NULL-värde i databasen. LimeSurvey använder [tom sträng] för en obesvarad fråga och NULL-värde för en fråga som inte visats (av Expression Manager eller på grund av max antal steg i enkäten).
  • {quote} : " (ett dubbelt citattecken)
  • {cr} : Radvagn (carriage return)
  • {newline} : En ny rad
  • {lbrace} : Vänster klammerparentes (om du till exempel vill ha {cr} i ett svar: använd {lbrace}cr} )

Redigering av VV version 1

Lägga till nya svar till enkätens befintliga svar

Detta stöds inte för version 1 av formatet, eftersom det lätt kan leda till olika problem, bland annat att data importeras till fel kolumner. Version 1 av .vv-filen var alltid avsedd för vertikal verifiering av data i ett externt verktyg som Excel, inte som ett sätt att samla data från olika källor (till exempel samma enkät som körs på en annan server).

Ändra alla svar i en enkät

Om du vill ändra svar i en enkät kan du helt enkelt redigera filen.

Exempel:

Steg 1: Öppna filen

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
183	09.11.11 11:44	3	de	4
184	09.11.11 11:53	3	de	2
190	09.11.11 11:44	3	de	1


Steg 2: Ändra svaren

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
1000	09.11.11 11:44	3	de	3
1001	09.11.11 11:53	3	de	3
1002	09.11.11 11:44	3	de	3

Därefter kan du importera enkäten. Se till att de befintliga svaren skrivs över (se "Importera en VV-enkätfil").

Importera en VV-enkätfil

File:LimeSurveyImportVVen.jpg

Så länge de två första raderna är intakta kan du importera data från din VV-enkätfil tillbaka till en aktiv LimeSurvey-enkät.

Om du använde Microsoft Excel för att redigera den exporterade vv-filen kan filens datastruktur ha skadats, så att LimeSurvey inte kan importera den redigerade filen. Du kan prova följande lösning för att få importen att fungera utan fel:

  • Öppna din exporterade vv-fil i Excel och gör dina ändringar (det har du förmodligen redan gjort)
  • Spara den som tabbseparerad textfil (en ny fil med filändelsen .txt skapas)
  • Gör ytterligare en "ren" vv-export från LimeSurvey
  • Öppna den nya exporterade vv-filen i en textredigerare som Anteckningar eller liknande (jag använde TextWrangler på Mac)
  • Tryck på CTRL + A för att markera allt innehåll och radera det
  • Öppna den Excel-redigerade vv-filen (den tabbseparerade .txt-filen) i en textredigerare och tryck på CTRL + A för att markera allt innehåll
  • Tryck på CTRL + C för att kopiera innehållet och klistra in det i den nya (nu tomma) vv-filen
  • Tryck på CTRL + S för att spara filen som den är (som .csv)
  • Försök nu importera den här filen

Välj sedan ikonen "Importera en VV-enkätfil" från svarsöversikten.

På skärmen "Importera en VV-enkätfil" måste du välja den "vvexport"-fil som du vill importera. Om du väljer "Utelämna post-ID?" importeras posterna och helt nya post-ID genereras för dem (använd det här alternativet för användningsfallet "Lägga till nya svar till enkätens befintliga svar"). Om du avmarkerar rutan importeras de ursprungliga post-ID:na (använd det här alternativet för användningsfallet "Skriva över alla svar i enkäten").

Det finns flera alternativ som talar om för LimeSurvey hur dubbla eller flera poster ska hanteras.

  • Rapportera ett fel och hoppa över den nya posten.
  • Numrera om den nya posten
  • Byt ut befintlig post (använd detta för användningsfallet "Skriva över alla svar i enkäten")

<span id="Importing_a_VV_survey_file_ (New in 2.05 )">

Importera en VV-enkätfil (New in 2.05 )

  • Fil : Välj filen som ska laddas upp. Filen måste vara en TSV-fil: en textfil där varje kolumn är separerad med TAB.
  • Utelämna post-ID? : Om kolumnen 'id' finns i filen kan du välja att utelämna den eller inte. Om den här inställningen är markerad läggs en ny post till för varje rad i .vv-filen. Om den inte är markerad kan du välja:
  • När en importerad post har samma ID som en befintlig post:
    • skip : Rapportera ett fel och hoppa över den nya posten. Efter uppladdningen ser du om posten redan fanns – om den fanns importeras den inte.
    • renumber : Numrera om den nya posten. En ny post läggs till i svarstabellen med svaret från VV-filen.
    • replace : Byt ut befintlig post. Den gamla posten raderas och ersätts helt av posten från VV-filen.
    • replaceanswer : Ersätt svarsuppgifterna i den befintliga posten med uppgifterna från filen. Den gamla posten uppdateras med det nya svaret från VV-filen. Detta gör det möjligt att ersätta endast en fråga i svarstabellen.
  • Importera som ej slutfört svar? : Om detta är markerat sätts submitdate till NULL, så att svaret markeras som inte avslutat.
  • Filens textkodning : Du kan välja filens textkodning – standardvärdet och det rekommenderade värdet är UTF-8, men vissa kalkylprogram tillåter inte att man väljer textkodning.
  • Första raden innehåller frågekoder : Som standard innehåller VV-filens första rad läsbara frågor, och de egentliga kolumnnamnen finns på den andra raden. Med detta alternativ kan den första raden användas som de egentliga kolumnnamnen.
  • Tvinga import : Om frågekoderna inte hittas i databasens namn eller i Qcode Variable Naming tilldelas kolumnerna utifrån ordningen. Detta kan användas för att importera en VV-fil från en annan LimeSurvey-installation, men varje enkät måste då vara exakt likadan. Vi rekommenderar starkt att du endast använder detta om du vet vad du gör. Det kan vara mycket riskabelt och leda till att resultat hamnar i fel kolumn.

Andra exportalternativ

Exportera ett enskilt svar

Om du vill exportera ett enskilt svar kan du göra det på tre sätt:

1. Logga in i LimeSurveys administrationsgränssnitt, välj din enkät, gå till "Ändra enkätinställningar" -> "Notification and data management" och se till att du får grundläggande e-postnotifikationer.

Varje gång någon har besvarat en enkät får du ett e-postmeddelande med en länk: "Klicka på följande länk för att se det enskilda svaret"

Du kommer då till en sida med en knapp ovanför data med texten "Exportera detta svar"

2. Logga in i LimeSurveys administrationsgränssnitt, välj din enkät och "Bläddra bland svaren". Klicka på "Visa svar" och på det id-nummer du vill exportera i kolumnen till vänster. Därefter kan du klicka på "Exportera denna enkät" ovanför data.

3. Logga in i LimeSurveys administrationsgränssnitt, välj din enkät och "Exportera svar till program". I det sista fältet ovanför "Exportera data" kan du välja vilken post du vill exportera.

Matcha svar från olika enkäter

Om du vill följa enkätsvar för enskilda personer över tid kan LimeSurvey hjälpa dig med det. Ett möjligt användningsfall är att följa en grupps svar före och efter att gruppen har deltagit i ett visst seminarium.

Stegen för att genomföra detta är följande:

1. Skapa enkäten

2. Se till att enkäten inte är anonym och använder tokens. Så här skapar du en icke-anonym enkät:

a - Klicka på ikonen Allmänna inställningar.

b - Välj sedan under fliken Tokens "Nej" för Anonymiserade svar.

3. Aktivera enkäten.

När du aktiverar enkäten klickar du på knappen "Byt till läget stängd åtkomst" för att skapa token-tabellen:

4. Fyll token-tabellen med den metod du föredrar (följ instruktionerna på sidan Tokens).

5. Exportera enkätsvaren och se till att token-informationen ingår.

Klicka på Bläddra bland svaren för att exportera...

...och sedan på Exportera:

Kom ihåg att välja ett eller flera element från token-tabellen som ska kopplas till enkätsvaren:

6. När du kör enkäten igen, vilket enkelt kan göras genom att kopiera enkäten och token-tabellen med export/import, upprepar du bara stegen och ser till att samma fråga används för att bygga csv-filen för token-import.

Problem och lösningar

Excel

Ändra svar i Excel före import

Om du vill göra många ändringar i svaren kan du exportera och öppna en fil i Excel. Gör ändringar i data (utom i de översta raderna) och spara sedan som en .txt-fil. Om du sparar som .csv använder Excel kommatecken som avgränsare, vilket inte kan importeras i LimeSurvey. Genom att spara som .txt-fil sparar Excel en tabbavgränsad fil som kan importeras tillbaka till LimeSurvey.

Redigera .csv med Excel

I allmänhet rekommenderar vi inte att Excel används för att redigera exporterade .csv-filer, eftersom Excel gör vissa ändringar i den interna datastrukturen som gör att importen misslyckas. Om du ändå vill använda Excel måste du ställa in avgränsaren i Excel till ett kommatecken i Kontrollpanelen (Windows):

Kontrollpanelen|Region och språk|Regionala inställningar, anpassa...|Tal|Siffergrupperingssymbol| ersätt ; med ,

Lösning för att redigera .csv-filer med Excel

Om du använder Excel för att redigera frågor kan det hindra dig från att importera dem igen. Redigering är dock det bästa alternativet om du har fler än ungefär 5 alternativ eller rangordningsalternativ, eller vill använda Excels funktioner som sortering osv.

Det här är en delvis lösning som verkar fungera i 1.82 – i princip använder du bara Excel för den del av filen som utgör data:

  • Exportera en fråga som liknar den du vill återanvända som .csv-fil
  • Öppna CSV-filen i en ren textredigerare
  • Kopiera den del som innehåller svaren till Excel och dela upp den med Text till kolumner eller motsvarande
  • Utnyttja Excels möjlighet att klistra in text i kolumner för att klistra in 20, 50, 100 svar, som du vill
  • Spara filen som Excel-CSV, som sannolikt inte har några citattecken
  • Öppna filen i textredigeraren, markera allt och kopiera
  • Gå tillbaka till filen som du öppnade med textredigeraren
  • Klistra in över svaren där
  • Spara som, med ett annat namn, gärna ett som du kommer ihåg för återanvändning
  • Importera den här filen.

Excel – exporten är begränsad till 255 kolumner

På grund av begränsningar i Excel (version 2003 och tidigare) kan LimeSurvey bara exportera 255 kolumner åt gången. Microsoft har föreslagit en lösning som VB-makro.

Även om nyare kalkylprogram (Excel 2007 eller senare, OpenOffice) kan visa fler än 255 kolumner, kan den interna modul som LimeSurvey använder fortfarande inte exportera fler än 255 kolumner.

Det finns dock två lösningar, använd någon av följande:

  • Antingen exporterar du till CSV och importerar i ditt kalkylprogram
  • Eller använder du flera exporter (välj högst 250 kolumner åt gången) och slår sedan ihop de exporterade resultaten

Excel/.csv – exporten misslyckas

Om du inte kan exportera dina data till Excel eller till en .csv-fil, försök rensa webbläsarens cache och cookies.

CSV

CSV använder som standard 255 kolumner

Vid export av stora enkäter begränsar det grafiska gränssnittet som standard exporten till de första 255 kolumnerna. Du kringgår detta genom att helt enkelt markera alla datamängder för export.

SPSS-export

Allmänna steg

Följ dessa steg för att importera svarsdata från LimeSurvey:

  1. Klicka på ikonen 'Exportera till SPSS'.
  2. Välj i rullgardinslistorna vilka svar du vill exportera och vilken SPSS-version du använder.
  3. Ladda ner båda filerna, .sps-filen (SPSS syntaxkommandofil) och .dat-filen (datafil)
  4. Öppna .sps-filen med SPSS genom att starta SPSS, välj sedan 'Choose another type of file' och välj den nedladdade .sps-filen.
  5. Nu öppnas en redigerare i SPSS där du kan redigera kommandona i filen. Leta efter raden som börjar med '/FILE=...'
  6. Redigera raden och justera sökvägen så att den pekar på din .dat-fil. Exempel: Din *.dat-fil ligger i c:\temp, så ändra raden till /FILE='c:\temp\survey_(xxxx)_SPSS_data_file.dat'
  7. Markera nu alla kommandon i redigeraren genom att trycka på CTRL-A.
  8. Välj Run/All i SPSS-menyn.
  9. Ha tålamod, det tar en stund att importera alla data och etiketter. Kontrollera förloppet i statusfältet.
  10. Klart!

Möjliga felmeddelanden i SPSS

ERROR. command name:Get Data

Om du får felmeddelandet ERROR. command name:Get Data. 2267 Unexpected Token missing. ska du redigera den fjärde raden i din syntaxfil så att den pekar på datafilens absoluta sökväg, till exempel

C:\spss\Data\limesurvey\SPSS\survey_35276_SPSS_data_file.dat

Fel: "Text value unmappable in the current server locale"

Det här felet kan uppstå om du försöker öppna en exporterad syntaxfil i SPSS 16. Lösningen är att tvinga SPSS att tolka syntaxfilen som unicode.

Öppna SPSS. Gå till Edit > Options > Character encoding for data and syntax. Ändra alternativet till "unicode".

LimeSurvey-data kan nu exporteras till SPSS 16 utan problem.

Definiera vilken skala som ska användas för din variabel

Du kan åsidosätta standardskalan för en variabel genom att ställa in frågeattributet scale_export på lämpligt värde.

VV-export/import

VV – problem med VV-import

Om du har problem med att importera en vv-fil, prova en tabbavgränsad fil så fungerar det sannolikt bra.

Andra problem och lösningar

Kopiera svar till en annan enkät (med tokens)

  1. Skapa en ny enkät, lägg till ett testsvar, exportera svarsfilen och öppna den i Excel. Detta skapar formatet för den nya importfilen.
  2. Exportera svaren från den gamla enkäten, inklusive tokens, och öppna i Excel.
  3. Använd dessa data för att skapa ett Excel-kalkylblad för standardimporten av tokenfil (t.ex. Förnamn, Efternamn, Token, E-postadress, E-poststatus (OK), Språk (En)). Spara som .csv och importera tokens till den nya enkäten i LimeSurvey.
  4. Kopiera i Excel de svarsfält från den gamla enkätens svar som du vill ha i den nya enkäten (inklusive token) till lämplig Excel-kolumn i den nya enkätens format.
  5. Spara som .txt-fil.
  6. Använd VVImport för att importera de nya data till den nya enkäten.
  7. Möjliga importfel inkluderar datumformat – vissa systems datumfält tillåter inte NULL-värde, andra gör det. Om datumet ser korrekt ut men ger ett fel, använd Excels cellformat "2009-12-01".