x

Bab utama

  1. LimeSurvey Cloud vs LimeSurvey CE
  2. Panduan memulai cepat - LimeSurvey 3.0+
  3. Instalasi - LimeSurvey CE
  4. Cara merancang survei yang baik (panduan)
  5. Memulai
  6. Mengelola LimeSurvey
  7. Survei - pengantar
  8. Pengaturan survei
  9. Menu survei
  10. Struktur survei
  11. Pertanyaan - pengantar
  12. Grup pertanyaan - pengantar
  13. Survei - manajemen
  14. Opsi toolbar survei
  15. Survei multibahasa
  16. ExpressionScript Engine - Panduan memulai cepat
  17. Fitur tanpa kategori dan fitur lanjutan
  18. FAQ Umum
  19. Pemecahan Masalah
  20. Solusi Sementara
  21. Lisensi
  22. Log perubahan versi
  23. Plugin
 Actions

Mengekspor hasil

From LimeSurvey Manual

Halaman ini mungkin diterjemahkan oleh mesin dan dapat mengandung kesalahan. Tampilkan versi asli bahasa Inggris · Perbaiki terjemahan ini
This page is a translated version of the page Exporting results and the translation is 100% complete.
  Perhatian : Bagian berikut sudah usang. Untuk informasi terbaru, silakan periksa:




Setelah survei Anda aktif, Anda dapat mulai melihat tanggapan dan mengekspornya. Untuk membuka ringkasan tanggapan survei, klik: Tanggapan -> Tanggapan & statistik

Ekspor ke aplikasi (Excel/.csv)

Beberapa opsi ekspor tercantum di bagian atas halaman.

Saat mengekspor hasil, tersedia beberapa opsi filter:

  • Umum
    • Tentukan rentang (misalnya, "ekspor catatan X sampai Y")
    • Atur untuk mengekspor semua catatan ATAU hanya tanggapan selesai ATAU hanya tanggapan tidak lengkap
  • Pertanyaan
    • Tentukan tampilan judul kolom: judul singkat ATAU judul lengkap ATAU kode pertanyaan
    • Konversi spasi pada teks pertanyaan menjadi garis bawah
  • Jawaban
    • Anda dapat mengekspor jawaban lengkap atau mengonversi kode jawaban Y dan N menjadi variabel yang ditentukan
  • Format
    • Microsoft Word (set karakter latin)
    • Microsoft Excel (semua set karakter)
    • Berkas CSV (semua set karakter)
    • HTML
    • PDF
  • Kontrol Kolom
    • Tentukan jawaban mana yang akan diekspor. Semua jawaban dalam daftar ini diwakili oleh pengenal SGQA
    • Tentukan data token mana yang akan diekspor. Opsi ini hanya tersedia jika survei Anda tidak anonim!

Ekspor SPSS

Umum

SPSS Statistics adalah perangkat lunak yang digunakan untuk analisis statistik logis, baik secara batch maupun non-batch. Anda dapat menggunakan paket SPSS resmi atau menggunakan GNU PSPP sebagai pengganti program berpemilik SPSS.

Untuk mengekspor data tanggapan Anda ke SPSS, buka bagian Tanggapan & statistik lalu klik ikon untuk mengekspor ke SPSS.

Mengekspor dan memfilter data

Saat mengekspor data ke SPSS, terdapat dua opsi filter. Anda dapat memilih data mana yang akan dipilih (semua catatan/hanya tanggapan selesai/hanya tanggapan tidak lengkap) dan untuk versi SPSS mana berkas ekspor akan digunakan (sebelum versi 16/16 atau lebih baru).

Ekspor SPSS mencakup dua berkas:

  1. berkas sintaks (survey_xxxx_SPSS_syntax_file.sps)
  2. dan berkas data (survey_xxxx_SPSS_data_file.dat).

Setelah mengunduh berkas-berkas ini, Anda dapat membukanya menggunakan editor teks biasa seperti notepad untuk melihat tampilan data yang diekspor. Berkas sintaks berisi perintah yang harus dijalankan untuk mengimpor data. Isinya seperti bahasa pemrograman di dalam SPSS. Berkas data berisi berkas yang dipisahkan koma dengan semua data. Jika Anda hanya mengimpor data ini sebagai csv melalui wizard, Anda akan kehilangan informasi tentang pertanyaan, labelset, dan sebagainya, sehingga kami tidak melakukannya.

Mengimpor data di SPSS

Letakkan kedua berkas di folder yang sama pada drive Anda (contoh: c:\data\survey_xxxx_SPSS_syntax_file.sps dan c:\data\survey_xxxx_SPSS_data_file.dat)

Sekarang kita punya dua opsi:

1. Jika menggunakan Windows, gunakan explorer untuk membuka folder di atas. Jika SPSS terhubung dengan ekstensi berkas .sps, Anda cukup membuka berkas tersebut dengan klik ganda:

Sekarang Anda dapat memilih Run->All dari jendela yang terbuka, dan setelah beberapa saat Anda akan mendapatkan dataset keluaran yang dapat disimpan sebagai berkas .sav biasa.

2. Terkadang solusi mudah di atas tidak berhasil. Dalam hal ini, Anda dapat melanjutkan sebagai berikut:

  • Buka SPSS
  • Pilih File->Open->Syntax
  • Pilih berkas yang sesuai: c:\data\survey_xxxx_SPSS_syntax_file.sps
  • Sekarang sintaks terbuka.
  • Ubah baris yang berbunyi /FILE='survey_xxxx_SPSS_data_file.dat' agar menyertakan path lokasi berkas: /FILE='c:\data\survey_xxxx_SPSS_data_file.dat' , untuk pengguna mac : /FILE='HD/Users/username/survey_xxxx_SPSS_data_file.dat'
  • Sekarang blok seluruh teks perintah dan pilih Run->All dari menu, dan setelah beberapa saat (harap bersabar) Anda akan memiliki dataset dengan semua informasi seperti pertanyaan, label, dan sebagainya.

Ekspor R

Silakan tambahkan informasi lebih lanjut jika Anda memilikinya!

Perangkat lunak gratis R adalah alternatif untuk SPSS. Ini merupakan salah satu ekspor ke aplikasi di LimeSurvey.

Petunjuk untuk mengimpor dataset Anda di R:

  1. Unduh berkas sintaks dan berkas data.
  2. Simpan kedua berkas di direktori kerja R (gunakan getwd() dan setwd() di jendela perintah R untuk mengetahui dan mengatur direktori).
  3. Pada kode Anda, masukkan source("Surveydata_syntax.R", encoding = "UTF-8") di jendela perintah R, yang akan mengimpor data dalam format yang benar ke data frame bernama "data".


Tanggapan dengan opsi terbatas akan dijadikan faktor dengan level yang sesuai dengan kode pertanyaan dan label yang sesuai dengan opsinya.

Pertanyaan dengan opsi "lainnya" akan memiliki kolom baru berisi bidang pertanyaan dengan tambahan _Other untuk data "lainnya".

Catatan: R-export adalah sebuah plugin di LimeSurvey. Jika Anda tidak dapat menemukan opsi R-export (R (file syntax), R (file data)) di bawah Export results to application, pastikan plugin R-export telah diaktifkan di menu plugin.

Ekspor STATA-xml

STATA adalah paket perangkat lunak komersial untuk analisis data dan statistik.

Rutin ekspor ini dibuat untuk memudahkan analisis cepat atas data yang dikumpulkan dengan LimeSurvey. Rutin ini membuat berkas XML dalam format milik STATA, yang dapat diimpor tanpa bergantung pada platform tempat STATA dijalankan. Menggunakan format ini menawarkan beberapa keuntungan dibandingkan mengimpor berkas CSV biasa:

  • Kumpulan data diberi label lengkap, termasuk label variabel (pertanyaan, subpertanyaan) dan label nilai (jawaban, jika ada).
  • Tanggal sudah diubah ke format tanggal internal STATA sehingga dapat langsung digunakan untuk menghitung selisih hari, dan sebagainya.
  • Nama variabel, jika perlu, diubah ke format yang kompatibel dengan STATA.
  • Format data variabel (string, integer, float, dll.) sudah diatur sesuai dengan data yang mendasarinya. (Tidak ada lagi angka yang disimpan sebagai string!).

Cara memuat berkas di STATA: STATA versi 14 ke bawah menyediakan entri menu File → Import → XML data untuk hal ini. Mulai Stata 15, entri menu tersebut tidak ada lagi. Sebagai gantinya, ketikkan perintah berikut di jendela Command STATA:

xmluse "survey_123456_STATA.xml", doctype(dta)

(ganti nama berkas dengan path menuju berkas hasil ekspor Anda). Setelah data dimuat, Anda dapat menyimpannya dalam format biner .dta STATA agar tidak perlu mengulangi impor:

save "survey_123456.dta"


Catatan: Perintah xmluse/xmlsave yang digunakan di atas telah dihapus dari kumpulan perintah STATA yang didokumentasikan dan didukung secara resmi mulai Stata 15, meskipun perintah tersebut masih berfungsi di versi terbaru sebagai fitur lama yang tidak terdokumentasi. Karena rilis STATA di masa mendatang dapat menghapusnya tanpa pemberitahuan, kami menyarankan Anda menyimpan data sebagai berkas .dta (lihat di atas) segera setelah impor, daripada mengandalkan berkas XML sebagai penyimpanan jangka panjang. Jika xmluse tidak tersedia di instalasi STATA Anda, gunakan ekspor CSV LimeSurvey bersama perintah import delimited dari STATA.

Perhatikan:

  • Karena keterbatasan format data STATA, panjang variabel string (teks) maksimum adalah 244 karakter (Stata versi 8-12) dan 2045 karakter (Stata versi 13 ke atas). Harap tentukan versi Stata Anda di pengaturan plugin ekspor.
  • STATA hanya mendukung penambahan label nilai pada nilai numerik. Jadi, untuk mendapatkan jawaban singkat (biasanya satu atau dua digit) yang diberi label dengan benar, sebaiknya gunakan kode jawaban numerik di LimeSurvey (1=Sangat setuju). Jika kode jawaban non-numerik digunakan (A=Sangat setuju), maka teks jawaban lengkap akan digunakan sebagai jawaban (misalnya: 'Sangat setuju').

VVExport dan VVImport

 Hint: This feature changed with version 2.05


Setelah Anda mulai mengumpulkan tanggapan, mungkin ada saat ketika Anda perlu langsung mengedit dan mengubah data dalam jumlah besar dari tabel tanggapan Anda, di mana alat spreadsheet mungkin lebih berguna.

VVExport ("VV" adalah singkatan dari vertical verification) memungkinkan Anda mengekspor tabel tanggapan ke berkas .csv. Selama struktur umum berkas tetap utuh, Anda dapat mengedit nilai di dalamnya, lalu mengimpor kembali berkas tersebut ke tabel tanggapan Anda menggunakan fitur "VVImport".

Hal-hal yang perlu Anda perhatikan:

  • Jika Anda ingin mengimpor tanggapan menggunakan "VVImport", pastikan untuk memeriksa apakah tanggapan harus ditambahkan ke tanggapan yang sudah ada atau semua tanggapan harus ditimpa.
  • Jika Anda mencoba mengimpor tanggapan dari survei lain yang identik (misalnya pertanyaan/jawaban yang identik dari survei lain), pastikan Anda menggunakan berkas vv yang benar dan bahwa dua baris pertama berkas .csv sudah benar.
  • Jika Anda mengimpor survei ke instalasi LimeSurvey Anda, SID (jika memungkinkan) tidak akan berubah. Namun ID grup dan ID pertanyaan mungkin berubah. Jadi Anda mungkin perlu menyesuaikan dua baris judul pertama agar cocok dengan ID grup/ID pertanyaan yang baru. Lihat Adjusting vv file headings

<span id="VVExport_file_version_2_ (New in 2.05 )">Berkas VVExport versi 2 (New in 2.05 )

Fitur baru ini memungkinkan nama kolom yang berbeda dari database. Jika kode pertanyaan Anda unik, maka versi baru ini akan dipilih. Pada versi baru, setiap nama kolom menggunakan Qcode Variable Naming. Misalnya, hal ini memudahkan pembaruan survei yang sudah ada di instalasi yang berbeda.

Mengekspor berkas survei VV

File:LimesurveyExportVVen.jpg

Saat Anda memilih untuk mengekspor tanggapan menggunakan VVExport, Anda akan diberi opsi untuk memilih survei mana yang akan diekspor, apakah Anda ingin mengekspor semua tanggapan, hanya tanggapan lengkap, atau hanya tanggapan tidak lengkap. Ekstensi berkas memungkinkan Anda memilih ekstensi untuk berkas yang diekspor. Agar mudah digunakan, sebaiknya pilih .csv.

Sebuah 'berkas survei vv' memungkinkan Anda mengimpor tanggapan ke suatu survei ketika kombinasi pertanyaan/jawaban telah berubah. Pada dasarnya, ini memungkinkan Anda menambahkan atau menghapus pertanyaan dalam survei yang aktif.

Mengklik "Ekspor berkas survei VV" akan menghasilkan berkas yang dipisahkan tab yang dapat dibuka dengan Excel atau program spreadsheet sejenis. Dua baris pertama spreadsheet adalah label kolom. Baris pertama adalah judul kolom yang "mudah dibaca manusia" yang merinci nama bidang pertanyaan/jawaban. Baris kedua adalah nama kolom internal PHP/database untuk tanggapan tersebut.

Anda tidak boleh mengubah dua baris pertama spreadsheet ini jika ingin dapat "mengimpor" kembali data tersebut ke LimeSurvey di kemudian hari.

<span id="Exporting_a_VV_survey_file_ (New in 2.05 )">

Mengekspor berkas survei VV (New in 2.05 )

 Hint: This feature is available starting in version 2.05


  • Ekspor survei : ID survei yang akan diekspor (hanya-baca)
  • Ekspor : Status penyelesaian tanggapan yang akan diekspor
  • Ekstensi berkas : Ekstensi berkas. Berkas ini adalah berkas TSV (Tab-separated values). Agar mudah dibuka di MS-Excel, atur ekstensi ke .txt; dengan LibreOffice, OpenOffice, atau program spreadsheet lain, Anda dapat membiarkannya sebagai .csv.
  • Versi ekspor VV : Versi 1.0 menggunakan header kolom database, versi 2.0 menggunakan Qcode Variable Naming. Versi 2.0 dipilih secara default jika semua kode pertanyaan Anda unik.

Dua baris pertama spreadsheet adalah label kolom. Baris pertama adalah judul kolom yang "mudah dibaca manusia" yang merinci nama pertanyaan. Baris kedua adalah nama kolom sebenarnya (nama DB internal atau Qcode) untuk tanggapan tersebut.

Mengedit berkas survei VV

Setelah berkas .vv berhasil diekspor, Anda dapat menggunakan alat spreadsheet untuk membuka dan mengedit berkas tersebut. Jika Anda harus memilih pemisah kolom saat membuka berkas, gunakan karakter "Tab". Jika Anda menggunakan karakter non-ASCII, pastikan Anda mengatur "UTF-8" sebagai set karakter.

  If you are using Microsoft Excel to edit the exported vv file, you should know that excel destroys the original data structure of the file. This causes an error when you try to re-import the edited .vv file.


Secara default, dua baris pertama berkas .vv adalah header. Jika perlu, Anda dapat menghapus baris pertama agar menjadi berkas TSV yang sebenarnya. Ada beberapa kasus penggunaan untuk mengimpor berkas .vv, jadi kami akan membedakan antara menambahkan tanggapan baru ke survei dan menimpa semua tanggapan survei.

Contoh struktur berkas .vv:

Berkas TSV VV versi 1

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	46492X40X1991
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1

Berkas TSV VV versi 2

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	QCODE
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1


Di sini pengidentifikasi SGQA tidak digunakan - sebagai gantinya, penamaan variabel Qcode QCODE digunakan pada baris kedua.

Nama yang dicadangkan

Berkas .VV menggunakan tanda kurung kurawal kiri dan kanan untuk nama yang dicadangkan. Saat impor, string ini diganti dengan:

  • {question_not_shown} : nilai NULL di basis data. LimeSurvey menggunakan [string kosong] untuk pertanyaan yang tidak dijawab, dan nilai NULL untuk pertanyaan yang tidak ditampilkan (oleh Expression Manager atau langkah maksimum dalam survei).
  • {quote} : " (tanda kutip ganda)
  • {cr} : Carriage return
  • {newline} : Baris baru
  • {lbrace} : Tanda kurung kiri (misalnya, jika Anda ingin memiliki {cr} dalam tanggapan: gunakan {lbrace}cr} )

Pengeditan VV Versi 1

Menambahkan tanggapan baru ke tanggapan survei yang sudah ada

Hal ini tidak didukung untuk format versi 1 karena mudah menimbulkan berbagai masalah, termasuk data yang diimpor ke kolom yang salah. Berkas .vv versi 1 selalu dimaksudkan untuk verifikasi vertikal data di alat eksternal seperti Excel, bukan sebagai sarana untuk menggabungkan data dari sumber yang berbeda (misalnya survei yang sama yang berjalan di server lain).

Mengubah semua tanggapan survei

Jika Anda ingin mengubah tanggapan survei, Anda cukup mengedit berkas tersebut.

Contoh:

Langkah 1: Buka berkas

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
183	09.11.11 11:44	3	de	4
184	09.11.11 11:53	3	de	2
190	09.11.11 11:44	3	de	1


Langkah 2: Ubah tanggapan

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
1000	09.11.11 11:44	3	de	3
1001	09.11.11 11:53	3	de	3
1002	09.11.11 11:44	3	de	3

Setelah itu Anda dapat mengimpor survei, pastikan untuk menimpa tanggapan yang sudah ada (lihat "Mengimpor berkas survei VV").

Mengimpor berkas survei VV

File:LimeSurveyImportVVen.jpg

Selama dua baris pertama tetap utuh, Anda dapat mengimpor kembali data dalam berkas survei VV ke survei LimeSurvey yang aktif.

Jika Anda menggunakan Microsoft Excel untuk mengedit berkas vv yang diekspor, struktur data berkas tersebut mungkin rusak sehingga LimeSurvey tidak dapat mengimpor berkas yang telah diedit. Anda dapat mencoba solusi berikut agar impor berjalan tanpa kesalahan:

  • Buka berkas vv yang diekspor di Excel dan lakukan perubahan Anda (kami asumsikan Anda sudah melakukannya)
  • Simpan sebagai berkas teks yang dipisahkan tab (ini akan membuat berkas baru dengan ekstensi .txt)
  • Lakukan ekspor vv "bersih" lainnya dari LimeSurvey
  • Buka berkas vv hasil ekspor baru ini dengan editor teks seperti notepad atau lainnya (saya menggunakan textwrangler di mac)
  • Tekan CTRL + A untuk memilih seluruh isi, lalu hapus
  • Buka berkas vv yang diedit dengan Excel (berkas .txt yang dipisahkan tab) menggunakan editor teks, lalu tekan CTRL + A untuk memilih seluruh isi
  • Tekan CTRL + C untuk menyalin isi tersebut dan tempelkan ke berkas vv baru (yang kini kosong)
  • Tekan CTRL + S untuk menyimpan berkas apa adanya (sebagai .csv)
  • Sekarang coba impor berkas ini

Kemudian, dari layar penelusuran, pilih ikon "Impor berkas survei VV".

Layar "Impor berkas survei VV" meminta Anda memilih berkas "vvexport" yang akan diimpor. Jika Anda memilih "Kecualikan ID data?", data akan diimpor dan ID data yang benar-benar baru akan dibuat untuknya (gunakan opsi ini untuk kasus penggunaan "Menambahkan tanggapan baru ke tanggapan survei yang sudah ada"). Jika Anda menghapus centang pada kotak ini, ID data asli akan diimpor (gunakan opsi ini untuk kasus penggunaan "Menimpa semua tanggapan survei").

Ada sejumlah opsi yang dapat Anda pilih untuk menentukan bagaimana LimeSurvey menangani entri ganda atau berulang.

  • Laporkan kesalahan (dan abaikan data baru).
  • Nomori ulang data baru
  • Ganti data yang ada (gunakan ini untuk kasus penggunaan "Menimpa semua tanggapan survei")

<span id="Importing_a_VV_survey_file_ (New in 2.05 )">

Mengimpor berkas survei VV (New in 2.05 )

  • Berkas : Pilih berkas yang akan diunggah. Berkas harus berupa berkas TSV: berkas teks dengan setiap kolom dipisahkan oleh TAB.
  • Kecualikan ID data? : Jika kolom 'id' ada dalam berkas, Anda dapat mengecualikan baris ini atau tidak. Jika pengaturan ini dicentang, data baru ditambahkan untuk setiap baris berkas .vv. Jika tidak dicentang, Anda dapat memilih:
  • Sewaktu data yang diimpor cocok dengan suatu ID data yang ada:
    • skip : Laporkan dan abaikan data baru. Setelah unggahan, Anda akan melihat apakah data tersebut sudah ada - jika sudah ada, data tidak diimpor.
    • renumber : Nomori ulang data baru. Data baru ditambahkan ke tabel tanggapan dengan jawaban dari berkas VV.
    • replace : Ganti data yang ada. Data lama dihapus dan diganti sepenuhnya oleh data dari berkas VV
    • replaceanswer : Ganti detail tanggapan dari berkas pada data yang ada. Data lama diperbarui dengan tanggapan baru dari berkas VV. Ini memungkinkan penggantian hanya satu pertanyaan dalam tabel tanggapan.
  • Impor sebagai tanggapan yang belum difinalisasi? : Jika dicentang, submitdate diatur ke NULL sehingga tanggapan ditetapkan sebagai tidak lengkap.
  • Set karakter berkas : Anda dapat memilih set karakter berkas - nilai default dan yang disarankan adalah UTF-8, tetapi beberapa program spreadsheet tidak memungkinkan pemilihan set karakter.
  • Baris pertama berisi kode pertanyaan : Secara default, baris pertama berkas VV berisi pertanyaan yang mudah dibaca manusia, sedangkan nama kolom sebenarnya ada di baris kedua. Opsi ini memungkinkan penggunaan baris pertama sebagai nama kolom sebenarnya.
  • Paksa untuk impor : Jika kode pertanyaan tidak ditemukan dalam nama basis data atau dalam Qcode Variable Naming, kolom akan ditetapkan berdasarkan urutan. Ini dapat digunakan untuk mengimpor berkas VV dari instans LimeSurvey lain, tetapi setiap survei harus persis sama. Kami sangat menyarankan untuk menggunakannya hanya jika Anda tahu apa yang Anda lakukan. Hal ini sangat berbahaya dan dapat menyebabkan hasil masuk ke kolom yang salah.

Opsi ekspor lainnya

Mengekspor satu tanggapan

Jika Anda ingin mengekspor satu tanggapan, Anda dapat melakukannya dengan 3 cara:

1. Masuk ke backend admin LimeSurvey, pilih survei Anda, buka "Edit pengaturan survei" -> "Pemberitahuan dan manajemen data" dan pastikan Anda menerima pemberitahuan surel dasar.

Setiap kali seseorang menyelesaikan survei, Anda akan menerima surel berisi tautan: "Click the following link to see the individual response"

Tautan ini akan membawa Anda ke halaman dengan tombol di atas data bertuliskan "Ekspor tanggapan ini"

2. Masuk ke backend admin LimeSurvey, pilih survei Anda dan "Lihat Tanggapan" untuk survei ini. Klik "Display responses" dan nomor id yang ingin Anda ekspor di kolom kiri. Kemudian Anda dapat mengklik "Export this survey" di atas data.

3. Masuk ke backend admin LimeSurvey, pilih survei Anda dan "Hasil ekspor" ke aplikasi. Pada kolom terakhir di atas "Ekspor data", Anda dapat memilih entri yang ingin Anda ekspor.

Mencocokkan tanggapan dari survei yang berbeda

Jika Anda ingin melacak tanggapan survei dari individu tertentu dari waktu ke waktu, LimeSurvey dapat membantu Anda. Salah satu contoh penggunaannya adalah melacak tanggapan suatu kelompok sebelum dan sesudah kelompok tersebut mengikuti seminar tertentu.

Langkah-langkah untuk melakukannya adalah sebagai berikut:

1. Buat survei

2. Pastikan survei tidak anonim dan menggunakan token. Untuk membuat survei yang tidak anonim:

a - Klik ikon Pengaturan umum.

b - Kemudian pada tab Token, pilih "Tidak" untuk Tanggapan anonim.

3. Aktifkan survei.

Saat Anda mengaktifkan survei, klik tombol "Tukar ke modus akses tertutup" untuk membuat tabel token:

4. Isi tabel token dengan metode apa pun yang Anda inginkan (ikuti petunjuk pada halaman Token).

5. Ekspor hasil survei dan pastikan Anda menyertakan informasi token.

Untuk mengekspor, klik lihat hasil...

...lalu ekspor:

Ingatlah untuk memilih satu atau beberapa elemen dari tabel token untuk dikaitkan dengan tanggapan survei:

6. Saat Anda menjalankan survei lagi, yang dapat dilakukan dengan mudah dengan menyalin tabel survei dan token melalui ekspor/impor, cukup ulangi langkah-langkah tersebut dan pastikan kueri yang sama digunakan untuk membuat berkas impor token csv.

Masalah & Solusi

Excel

Mengubah tanggapan di Excel sebelum diimpor

Untuk melakukan banyak perubahan pada tanggapan, Anda dapat mengekspor dan membuka berkas di Excel. Ubah data (selain baris-baris teratas) lalu simpan sebagai berkas .txt. Jika Anda menyimpan sebagai .csv, Excel menggunakan pemisah koma yang tidak dapat diimpor ke LimeSurvey. Dengan menyimpan sebagai berkas .txt, Excel menyimpannya sebagai berkas yang dipisahkan tab sehingga dapat diimpor kembali ke LimeSurvey.

Mengedit .csv dengan Excel

Secara umum kami tidak menyarankan penggunaan Excel untuk mengedit berkas .csv hasil ekspor karena Excel melakukan beberapa perubahan pada struktur data internal sehingga impor gagal. Jika Anda tetap ingin menggunakan Excel, Anda harus mengatur pemisah untuk Excel menjadi koma di Control Panel (sistem Windows):

Control Panel|Opsi Wilayah dan Bahasa|Pengaturan Regional, sesuaikan...|Tab Angka|Simbol pengelompokan digit| ganti ; dengan ,

Solusi alternatif untuk mengedit berkas .csv dengan Excel

Menggunakan Excel untuk mengedit pertanyaan dapat membuat Anda tidak bisa mengimpornya kembali. Namun, mengedit tetap menjadi pilihan terbaik jika Anda memiliki lebih dari sekitar 5 opsi atau opsi peringkat, atau ingin memakai kemampuan Excel seperti pengurutan, dll.

Ini adalah solusi alternatif parsial yang tampaknya berfungsi di versi 1.82 - intinya, gunakan Excel hanya pada bagian berkas yang berisi data:

  • Ekspor pertanyaan yang mirip dengan yang ingin Anda gunakan kembali sebagai berkas .csv
  • Buka berkas CSV tersebut di editor teks biasa
  • Salin bagian yang berisi jawaban ke Excel, lalu pisahkan dengan Text to Columns atau fitur yang setara.
  • Manfaatkan kemampuan Excel untuk menempelkan teks ke dalam kolom guna menempelkan 20, 50, atau 100 jawaban sesuai kebutuhan
  • Simpan berkas sebagai Excel CSV, yang kemungkinan besar tidak memiliki tanda kutip.
  • Buka berkas ini di editor, lalu Pilih semua dan Salin
  • Kembali ke berkas yang Anda buka dengan editor teks biasa
  • Tempelkan di atas bagian jawaban di sana
  • Simpan sebagai (Save AS) dengan nama yang berbeda, mungkin nama yang mudah Anda ingat untuk digunakan kembali
  • Impor berkas ini.

Excel - ekspor terbatas pada 255 kolom

Karena keterbatasan Excel (versi 2003 ke bawah), LimeSurvey hanya dapat mengekspor 255 kolom sekaligus. Microsoft telah mengusulkan solusi alternatif berupa makro VB.

Meskipun spreadsheet yang lebih baru (Excel >= 2007, OpenOffice) dapat menampilkan lebih dari 255 kolom, modul internal yang digunakan LimeSurvey masih belum dapat mengekspor lebih dari 255 kolom.

Namun, ada dua solusi alternatif yang dapat digunakan. Pilih salah satu dari berikut:

  • Ekspor ke CSV lalu impor ke spreadsheet Anda
  • Atau gunakan beberapa kali ekspor (dengan memilih maksimal 250 kolom setiap kali), lalu gabungkan hasil ekspornya

Excel/.csv - ekspor gagal

Jika Anda tidak dapat mengekspor data ke Excel atau ke berkas .csv, coba hapus cache dan cookie peramban Anda.

CSV

CSV secara default dibatasi 255 kolom

Saat mengekspor survei yang besar, antarmuka secara default membatasi ekspor hanya pada 255 kolom pertama. Untuk mengatasinya, cukup tandai semua set data untuk diekspor.

Ekspor SPSS

Langkah-langkah umum

Untuk mengimpor data tanggapan LimeSurvey, ikuti langkah-langkah berikut:

  1. Klik ikon 'Export to SPSS'.
  2. Dari kotak pilihan, pilih tanggapan yang ingin Anda ekspor dan Versi SPSS Anda.
  3. Unduh kedua berkas, yaitu berkas .sps (berkas perintah sintaks SPSS) dan berkas .dat (berkas data)
  4. Buka berkas .sps dengan SPSS: buka SPSS, lalu pilih 'Choose another type of file' dan pilih berkas .sps yang telah diunduh.
  5. Sekarang sebuah editor terbuka di dalam SPSS tempat Anda dapat mengedit perintah dalam berkas tersebut. Cari baris yang diawali dengan '/FILE=...'
  6. Edit baris tersebut dan sesuaikan path-nya agar mengarah ke berkas .dat Anda. Contoh: berkas *.dat Anda berada di c:\temp, maka ubah baris ini menjadi /FILE='c:\temp\survey_(xxxx)_SPSS_data_file.dat'
  7. Sekarang pilih semua perintah di dalam editor dengan menekan CTRL-A.
  8. Dari menu SPSS pilih Run/All.
  9. Harap bersabar, proses impor seluruh data dan label membutuhkan waktu. Periksa bilah status untuk melihat progresnya.
  10. Selesai!

Kemungkinan pesan kesalahan di SPSS

ERROR. command name:Get Data

Jika Anda menerima pesan kesalahan ERROR. command name:Get Data. 2267 Unexpected Token missing., edit baris keempat pada berkas sintaks Anda agar mengarah ke path absolut berkas data, seperti

C:\spss\Data\limesurvey\SPSS\survey_35276_SPSS_data_file.dat

Error: "Text value unmappable in the current server locale"

Kesalahan ini dapat terjadi jika Anda mencoba membuka berkas sintaks hasil ekspor di SPSS 16. Solusinya adalah memaksa SPSS menafsirkan berkas sintaks sebagai unicode.

Buka SPSS. Buka Edit > Options > Character encoding for data and syntax. Ubah opsinya menjadi "unicode".

Data LimeSurvey kini dapat diekspor ke SPSS 16 tanpa masalah.

Menentukan skala yang digunakan untuk variabel Anda

Anda dapat menimpa skala default yang digunakan untuk sebuah variabel dengan mengatur atribut pertanyaan scale_export ke nilai yang sesuai.

Ekspor/Impor VV

VV - Masalah pada impor vv

Jika Anda mengalami kesulitan saat mengimpor berkas vv, coba gunakan berkas yang dipisahkan tab (Tab-delimited) dan seharusnya berfungsi dengan baik.

Masalah dan solusi lainnya

Menyalin tanggapan ke survei lain (menggunakan token)

  1. Buat survei baru, tambahkan tanggapan contoh, ekspor berkas tanggapan, lalu buka di Excel. Langkah ini membuat format untuk berkas impor yang baru.
  2. Ekspor tanggapan dari survei lama, termasuk token, lalu buka di Excel.
  3. Gunakan data ini untuk membuat lembar kerja Excel untuk impor berkas token standar (mis. Firstname, Lastname, Token, Alamat surel, Status surel (OK), Language (En)). Simpan sebagai .csv dan impor token ke survei baru di LimeSurvey.
  4. Di Excel, salin kolom tanggapan dari survei lama yang ingin Anda gunakan di survei baru (termasuk token) ke kolom Excel yang sesuai pada format survei baru.
  5. Simpan sebagai berkas .txt.
  6. Gunakan VVImport untuk mengimpor data baru ke survei baru.
  7. Kemungkinan kesalahan impor mencakup Format tanggal - beberapa kolom tanggal sistem tidak mengizinkan nilai NULL, sementara yang lain mengizinkan. Jika tanggal tampak benar tetapi tetap menimbulkan kesalahan, gunakan format sel Excel "2009-12-01".