x

Glavna poglavlja

  1. LimeSurvey Cloud u usporedbi s LimeSurvey CE
  2. Vodič za brzi početak - LimeSurvey 3.0+
  3. Instalacija - LimeSurvey CE
  4. Kako izraditi dobar upitnik (vodič)
  5. Početak rada
  6. Administriranje LimeSurveya
  7. Upitnici - uvod
  8. Postavke upitnika
  9. Izbornik upitnika
  10. Struktura upitnika
  11. Pitanja - uvod
  12. Skupine pitanja - uvod
  13. Upitnici - upravljanje
  14. Opcije alatne trake upitnika
  15. Višejezični upitnik
  16. ExpressionScript Engine - Vodič za brzi početak
  17. Nekategorizirane i napredne značajke
  18. Opći FAQ
  19. Rješavanje problema
  20. Zaobilazna rješenja
  21. Licenca
  22. Popis izmjena po verzijama
  23. Dodaci
 Actions

Izvoz rezultata

From LimeSurvey Manual

Ova je stranica možda strojno prevedena i može sadržavati pogreške. Prikaži engleski izvornik · Poboljšaj ovaj prijevod
This page is a translated version of the page Exporting results and the translation is 100% complete.
  Pažnja : Sljedeći odjeljak je zastario. Za ažurne informacije pogledajte:




Kada vaš upitnik postane aktivan, možete početi pregledavati odgovore i izvoziti ih. Za pristup pregledu odgovora na upitnik kliknite: Odgovori -> Odgovori & statistike

Izvoz u aplikaciju (Excel/.csv)

Na vrhu stranice navedeno je nekoliko opcija izvoza.

Prilikom izvoza rezultata dostupno je nekoliko opcija filtera:

  • Općenito
    • Postavite raspon (na primjer, "izvezi zapise od X do Y")
    • Postavite izvoz svih zapisa ILI samo dovršenih zapisa ILI samo nedovršenih zapisa
  • Pitanja
    • Odredite kako će se prikazati naslov: skraćeni naslov ILI puni naslovi ILI kodovi pitanja
    • Konvertiraj prazna mjesta unutar pitanja u crtice
  • Odgovori
    • Možete izvesti potpune odgovore ili pretvoriti kôdove odgovora Y i N u definiranu varijablu
  • Format
    • Microsoft Word (latinski skup znakova)
    • Microsoft Excel (svi skupovi znakova)
    • CSV datoteka (svi skupovi znakova)
    • HTML
    • PDF
  • Kontrola stupaca
    • Odredite koji odgovori trebaju biti izvezeni. Svi odgovori na ovom popisu prikazani su svojim SGQA identifikatorom
    • Odredite koji se podaci o tokenima trebaju izvesti. Ova je opcija dostupna samo ako vaš upitnik nije anoniman!

SPSS izvoz

Općenito

SPSS Statistics je softver koji se koristi za logičku skupnu i neskupnu statističku analizu. Možete koristiti službeni SPSS paket ili GNU PSPP, zamjenu za vlasnički program SPSS.

Za izvoz podataka odgovora u SPSS idite na odjeljak Odgovori & statistike i kliknite ikonu za izvoz u SPSS.

Izvoz i filtriranje podataka

Prilikom izvoza podataka u SPSS dostupne su dvije opcije filtera. Možete odabrati koji podaci će se odabrati (svi zapisi/samo dovršeni zapisi/samo nedovršeni zapisi) i za koju SPSS verziju će se koristiti izvezene datoteke (prije verzije 16/16 ili više).

SPSS izvoz uključuje dvije datoteke:

  1. datoteku sintakse (survey_xxxx_SPSS_syntax_file.sps)
  2. i datoteku podataka (survey_xxxx_SPSS_data_file.dat).

Nakon preuzimanja ovih datoteka možete ih otvoriti pomoću uređivača običnog teksta, poput Notepada, kako biste vidjeli kako izgledaju izvezeni podaci. Datoteka sintakse sadrži naredbe koje je potrebno pokrenuti za uvoz podataka. To je nalik programskom jeziku unutar SPSS-a. Datoteka podataka je datoteka odvojena zarezima koja sadrži sve podatke. Ako ove podatke jednostavno uvezete kao csv putem čarobnjaka, izgubit ćete informacije o pitanjima, skupovima oznaka itd., stoga to ne radimo.

Uvoz podataka u SPSS

Postavite obje datoteke u istu mapu na vašem disku (primjer: c:\data\survey_xxxx_SPSS_syntax_file.sps i c:\data\survey_xxxx_SPSS_data_file.dat)

Sada imamo dvije mogućnosti:

1. Ako koristite Windows, pomoću Explorera otvorite gore navedenu mapu. Ako je SPSS povezan s ekstenzijom datoteke .sps, datoteku možete otvoriti dvostrukim klikom:

Sada u otvorenom prozoru možete odabrati Run->All i nakon nekog vremena dobit ćete izlazni skup podataka koji možete spremiti kao uobičajenu .sav datoteku.

2. Ponekad gornje jednostavno rješenje ne radi. Tada možete postupiti na sljedeći način:

  • Otvorite SPSS
  • Odaberite File->Open->Syntax
  • Odaberite odgovarajuću datoteku: c:\data\survey_xxxx_SPSS_syntax_file.sps
  • Sintaksa će se sada otvoriti.
  • Promijenite redak /FILE='survey_xxxx_SPSS_data_file.dat' tako da uključuje putanju na kojoj se nalaze datoteke: /FILE='c:\data\survey_xxxx_SPSS_data_file.dat' , a za korisnike Maca: /FILE='HD/Users/username/survey_xxxx_SPSS_data_file.dat'
  • Sada označite cijeli tekst naredbi i u izborniku odaberite Run->All; nakon nekog vremena (budite strpljivi) dobit ćete skup podataka sa svim informacijama poput pitanja, oznaka itd.

R izvoz

Slobodno dodajte više informacija ako ih imate!

Besplatni softver R alternativa je SPSS-u. U LimeSurveyu je to izvoz u aplikaciju.

Upute za uvoz vašeg skupa podataka u R:

  1. Preuzmite datoteku sintakse i datoteku podataka.
  2. Spremite obje datoteke u radni direktorij programa R (koristite getwd() i setwd() u R naredbenom prozoru za dohvaćanje i postavljanje).
  3. U svom kodu unesite source("Surveydata_syntax.R", encoding = "UTF-8") u R naredbeni prozor, čime će se podaci uvesti u ispravnom formatu u podatkovni okvir pod nazivom "data".


Odgovori s ograničenim opcijama bit će faktorizirani tako da razine odgovaraju kôdu pitanja, a oznake opcijama.

Pitanja s opcijom "Ostalo" imat će polje pitanja s dodanim nastavkom _Other kao novi stupac za podatke unesene u polje "Ostalo".

Napomena: R izvoz je dodatak u LimeSurveyu. Ako ne možete pronaći opcije R izvoza (R (sintaksna datoteka), R (podatkovna datoteka)) pod Izvezi rezultate u aplikaciju, provjerite je li dodatak za R izvoz omogućen u izborniku dodataka.

STATA-xml izvoz

STATA je komercijalni softverski paket za analizu podataka i statistiku.

Ova rutina izvoza stvorena je kako bi olakšala brzu analizu podataka prikupljenih pomoću LimeSurveya. Stvara XML datoteku u STATA-inom vlastitom formatu, koja se može uvesti neovisno o platformi na kojoj se STATA pokreće. Korištenje ovog formata nudi nekoliko prednosti u odnosu na uvoz običnih CSV datoteka:

  • Skupovi podataka u potpunosti su označeni, uključujući oznake varijabli (pitanje, potpitanje) i oznake vrijednosti (odgovori, ako je primjenjivo).
  • Datumi su već pretvoreni u STATA-in interni format datuma pa se mogu izravno koristiti za izračun razlike među danima i slično.
  • Nazivi varijabli se, po potrebi, pretvaraju u format kompatibilan sa STATA-om.
  • Formati podataka varijabli (string, integer, float itd.) već su postavljeni prema podacima na kojima se temelje. (Više nema brojeva kodiranih kao tekst!).

Kako učitati datoteku u STATA-i: Verzije programa Stata do verzije 14 nudile su za to stavku izbornika File → Import → XML data. Od verzije Stata 15 ta stavka izbornika više ne postoji. Umjesto toga upišite sljedeću naredbu u STATA-in prozor Command:

xmluse "survey_123456_STATA.xml", doctype(dta)

(zamijenite naziv datoteke putanjom do vlastite izvezene datoteke). Nakon što su podaci učitani, možete ih spremiti u STATA-in binarni .dta format kako ne biste morali ponavljati uvoz:

save "survey_123456.dta"


Napomena: Naredbe xmluse/xmlsave korištene gore uklonjene su iz STATA-inog službeno dokumentiranog i podržanog skupa naredbi od verzije Stata 15, iako i dalje rade u aktualnim verzijama kao nedokumentirana naslijeđena funkcionalnost. Budući da bi ih buduće izdanje programa STATA moglo ukloniti bez najave, preporučujemo da podatke odmah nakon uvoza spremite kao .dta datoteku (vidi gore) umjesto da se oslanjate na XML datoteku kao dugoročnu pohranu. Ako xmluse nije dostupna u vašoj instalaciji programa STATA, umjesto toga koristite LimeSurveyjev CSV izvoz zajedno sa STATA-inom naredbom import delimited.

Imajte na umu:

  • Zbog ograničenja STATA-inog formata podataka, duljina string (tekstualnih) varijabli ima maksimum od 244 znaka (verzije programa Stata 8-12) odnosno 2045 znakova (verzija programa Stata 13 i novije). Navedite svoju verziju programa Stata u postavkama dodatka za izvoz.
  • STATA podržava pridruživanje oznaka vrijednosti samo numeričkim vrijednostima. Kako biste dobili kratke odgovore (obično jedna ili dvije znamenke) koji su pravilno označeni, u LimeSurveyu treba koristiti numeričke kôdove odgovora (1=Potpuno se slažem). Ako se koriste nenumerički kôdovi odgovora (A=Potpuno se slažem), kao odgovor će se koristiti cijeli tekst odgovora (npr. 'Potpuno se slažem').

VV izvoz i VV uvoz

 Hint: This feature changed with version 2.05


Nakon što počnete prikupljati odgovore, mogu se pojaviti situacije u kojima trebate izravno urediti i izmijeniti velike količine podataka iz tablice odgovora, a alat za proračunske tablice može biti korisniji.

VV izvoz ("VV" označava vertikalnu provjeru, engl. vertical verification) omogućuje izvoz tablice odgovora u .csv datoteku. Sve dok opća struktura datoteke ostaje netaknuta, u njoj možete urediti vrijednosti, a zatim datoteku ponovno uvesti u tablicu odgovora pomoću značajke "VV uvoz".

Što trebate imati na umu:

  • Ako želite uvesti odgovore pomoću "VV uvoza", provjerite trebaju li se odgovori dodati postojećim odgovorima ili se svi odgovori trebaju prepisati.
  • Ako pokušavate uvesti odgovore iz drugog, ali identičnog upitnika (npr. identična pitanja/odgovori iz drugog upitnika), provjerite koristite li ispravnu vv datoteku i jesu li prva dva retka .csv datoteke ispravna.
  • Ako uvezete upitnik u svoju instalaciju LimeSurveya, SID se (ako je moguće) neće promijeniti. ID grupe i ID pitanja ipak se mogu promijeniti. Stoga ćete možda morati prilagoditi prva dva zaglavna retka kako bi odgovarala novom ID-u grupe/ID-u pitanja. Pogledajte Prilagodba zaglavlja vv datoteke

<span id="VVExport_file_version_2_ (New in 2.05 )">VV izvoz datoteke verzije 2 (New in 2.05 )

Ova nova značajka omogućuje nazive stupaca drugačije od onih u bazi podataka. Ako su kôdovi vaših pitanja jedinstveni, odabire se nova verzija. U novoj verziji svaki naziv stupca koristi imenovanje varijabli Qcode. To, na primjer, omogućuje lakše ažuriranje postojećeg upitnika u drugoj instalaciji.

Izvoz VV datoteke upitnika

File:LimesurveyExportVVen.jpg

Kada odaberete izvoz odgovora pomoću VV izvoza, moći ćete odabrati koji će se upitnik izvesti te želite li izvesti sve odgovore, samo potpune ili samo nepotpune odgovore. Ekstenzija datoteke omogućuje vam odabir ekstenzije izvezene datoteke. Za jednostavnu uporabu preporučuje se odabrati .csv.

'vv datoteka upitnika' omogućuje uvoz odgovora u upitnik kada su se kombinacije pitanja/odgovora promijenile. To praktično omogućuje dodavanje ili uklanjanje pitanja u aktivnom upitniku.

Klikom na "Izvezi kao VV datoteku upitnika" nastaje datoteka odvojena tabulatorima koju možete otvoriti u programu Excel ili sličnom programu za proračunske tablice. Prva dva retka proračunske tablice su oznake stupaca. Prvi redak je "čitljivo" zaglavlje stupca koje detaljno navodi naziv polja pitanja/odgovora. Drugi redak je interni PHP/naziv stupca u bazi podataka za taj odgovor.

Ne smijete mijenjati prva dva retka ove proračunske tablice ako želite kasnije moći "uvesti" podatke natrag u LimeSurvey.

<span id="Exporting_a_VV_survey_file_ (New in 2.05 )">

Izvoz VV datoteke upitnika (New in 2.05 )

 Hint: This feature is available starting in version 2.05


  • Izvoz upitnika : ID upitnika koji se izvozi (samo za čitanje)
  • Izvoz : Status završetka odgovora koji se izvoze
  • Ekstenzija datoteke : Ekstenzija datoteke. Datoteka je TSV (vrijednosti odvojene tabulatorima) datoteka. Za jednostavno otvaranje u programu MS Excel postavite ekstenziju na .txt, a s programima LibreOffice, OpenOffice ili drugim programom za proračunske tablice možete ostaviti .csv.
  • Verzija VV izvoza : Verzija 1.0 koristi zaglavlja stupaca iz baze podataka, a verzija 2.0 koristi imenovanje varijabli Qcode. Verzija 2.0 odabrana je prema zadanim postavkama ako su svi kôdovi vaših pitanja jedinstveni.

Prva dva retka proračunske tablice su oznake stupaca. Prvi redak je "čitljivo" zaglavlje stupca koje detaljno navodi naziv pitanja. Drugi redak je stvarni naziv stupca (interni naziv u bazi podataka ili Qcode naziv) za taj odgovor.

Uređivanje VV datoteke upitnika

Nakon što je .vv datoteka uspješno izvezena, za njezino otvaranje i uređivanje možete koristiti alat za proračunske tablice. Ako pri otvaranju datoteke trebate odabrati separator stupaca, koristite znak "Tab". Ako koristite znakove koji nisu ASCII, provjerite je li kao skup znakova postavljen "UTF-8".

  Ako za uređivanje izvezene vv datoteke koristite Microsoft Excel, imajte na umu da Excel uništava izvornu strukturu podataka datoteke. To uzrokuje pogrešku kada pokušate ponovno uvesti uređenu .vv datoteku.


Prema zadanim postavkama prva dva retka .vv datoteke su zaglavlja. Ako je potrebno, možete ukloniti prvi redak kako biste dobili pravu TSV datoteku. Postoje različiti slučajevi uporabe za uvoz .vv datoteke pa ćemo razlikovati dodavanje novih odgovora u upitnik i prepisivanje svih odgovora upitnika.

Primjer strukture .vv datoteke:

VV verzija 1 TSV datoteka

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	46492X40X1991
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1

VV verzija 2 TSV datoteka

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	QCODE
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1


Ovdje se SGQA identifikatori ne koriste - umjesto njih u drugom retku koristi se imenovanje varijabli pomoću Qcode oznaka QCODE.

Rezervirani nazivi

.VV datoteka koristi lijeve i desne zagrade za rezervirane nazive. Prilikom uvoza ovaj se niz zamjenjuje na sljedeći način:

  • {question_not_shown} : NULL vrijednost u bazi podataka. LimeSurvey koristi [prazan niz] za pitanje bez odgovora, a NULL vrijednost za pitanje koje nije prikazano (zbog Expression Managera ili maksimalnog koraka u upitniku).
  • {quote} : " (dvostruki navodnik)
  • {cr} : Povratak na početak retka (Carriage return)
  • {newline} : Novi redak
  • {lbrace} : Lijeva zagrada (na primjer, ako u odgovoru želite imati {cr}: upotrijebite {lbrace}cr} )

Uređivanje VV verzije 1

Dodavanje novih odgovora postojećim odgovorima upitnika

Ovo nije podržano za verziju 1 formata jer lako može dovesti do raznih problema, uključujući uvoz podataka u pogrešne stupce. Verzija 1 .vv datoteke oduvijek je bila namijenjena vertikalnoj provjeri podataka u vanjskom alatu poput Excela, a ne kao način za spajanje podataka iz različitih izvora (primjerice istog upitnika koji se izvodi na drugom poslužitelju).

Izmjena svih odgovora upitnika

Ako želite izmijeniti odgovore upitnika, jednostavno možete urediti datoteku.

Primjer:

Korak 1: Otvorite datoteku

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
183	09.11.11 11:44	3	de	4
184	09.11.11 11:53	3	de	2
190	09.11.11 11:44	3	de	1


Korak 2: Izmijenite odgovore

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
1000	09.11.11 11:44	3	de	3
1001	09.11.11 11:53	3	de	3
1002	09.11.11 11:44	3	de	3

Zatim možete uvesti upitnik; pazite da prepišete postojeće odgovore (pogledajte "Uvoz VV datoteke upitnika").

Uvoz VV datoteke upitnika

File:LimeSurveyImportVVen.jpg

Sve dok su prva dva retka netaknuta, podatke iz svoje VV datoteke upitnika možete uvesti natrag u aktivan LimeSurvey upitnik.

Ako ste za uređivanje izvezene vv datoteke koristili Microsoft Excel, struktura podataka u toj datoteci možda je oštećena pa LimeSurvey ne može uvesti uređenu datoteku. Kako biste uvoz uspješno proveli bez pogreške, možete isprobati sljedeće rješenje:

  • Otvorite izvezenu vv datoteku u Excelu i napravite izmjene (pretpostavljam da ste to već učinili)
  • Spremite je kao tekstualnu datoteku odvojenu tabulatorima (stvara se nova datoteka s ekstenzijom .txt)
  • Napravite još jedan "čist" vv izvoz iz LimeSurveya
  • Otvorite ovu novu izvezenu vv datoteku u uređivaču teksta poput Notepada ili nekog drugog (ja sam na Macu koristio TextWrangler)
  • Pritisnite CTRL + A kako biste označili cijeli sadržaj i izbrišite ga
  • Otvorite vv datoteku uređenu u Excelu (tekstualnu .txt datoteku odvojenu tabulatorima) u uređivaču teksta i pritisnite CTRL + A kako biste označili cijeli sadržaj
  • Pritisnite CTRL + C za kopiranje sadržaja i zalijepite ga u novu (sada praznu) vv datoteku
  • Pritisnite CTRL + S kako biste datoteku spremili takvu kakva jest (kao .csv)
  • Sada pokušajte uvesti ovu datoteku

Zatim na zaslonu za pregled odaberite ikonu "Uvezi VV upitnik datoteku".

Zaslon "Uvezi VV upitnik datoteku" traži da odaberete "vvexport" datoteku koju uvozite. Ako odaberete "Isključiti ID zapisa?", zapisi će se uvesti i za njih će se generirati potpuno novi ID-jevi zapisa (koristite ovu opciju za slučaj "Dodavanje novih odgovora postojećim odgovorima upitnika"). Ako isključite ovaj potvrdni okvir, uvest će se izvorni ID-jevi zapisa (koristite ovu opciju za slučaj "Prepisivanje svih odgovora upitnika").

Postoji niz opcija kojima LimeSurveyu možete reći kako postupati s dvostrukim ili višestrukim unosima.

  • Prijavi grešku (i preskoči novi zapis).
  • Promjeni broj novom zapisu
  • Zamjeni postojeći zapis (koristite ovo za slučaj "Prepisivanje svih odgovora upitnika")

<span id="Importing_a_VV_survey_file_ (New in 2.05 )">

Uvoz VV datoteke upitnika (New in 2.05 )

  • Datoteka : Odaberite datoteku koju želite učitati. Datoteka mora biti TSV datoteka: tekstualna datoteka u kojoj je svaki stupac odvojen tabulatorom (TAB).
  • Isključiti ID zapisa? : Ako u datoteci postoji stupac 'id', ovaj redak možete isključiti ili ne. Ako je ova postavka uključena, za svaki redak .vv datoteke dodaje se novi zapis. Ako nije uključena, možete odabrati:
  • Kada se uvezeni zapis poklapa sa postojećim ID-jem:
    • skip : Prijavi grešku i idi na novi zapis. Nakon učitavanja vidjet ćete je li zapis već postojao - ako je postojao, ne uvozi se.
    • renumber : Promjeni broj novom zapisu. U tablicu odgovora dodaje se novi zapis s odgovorom iz VV datoteke.
    • replace : Zamjeni postojeći zapis. Stari zapis se briše i u potpunosti zamjenjuje zapisom iz VV datoteke.
    • replaceanswer : Zamijeni detalje odgovora iz datoteke u postojećem zapisu. Stari zapis se ažurira novim odgovorom iz VV datoteke. To omogućuje zamjenu samo jednog pitanja u tablici odgovora.
  • Uvezi kao nedovršen odgovor? : Ako je uključeno, submitdate se postavlja na NULL pa je odgovor označen kao nedovršen.
  • Set karaktera sadržaja datoteke : Možete odabrati skup znakova datoteke - zadana i preporučena vrijednost je UTF-8, ali neki programi za proračunske tablice ne dopuštaju odabir skupa znakova.
  • Prvi redak sadrži kodove pitanja : Prema zadanim postavkama prvi redak VV datoteke sadrži pitanja čitljiva ljudima, a stvarni nazivi stupaca nalaze se u drugom retku. Ovo omogućuje da se prvi redak koristi kao stvarni nazivi stupaca.
  • Prisilni uvoz : Ako se kodovi pitanja ne pronađu u nazivu baze podataka ili u imenovanju varijabli pomoću Qcode oznaka, stupci se dodjeljuju prema redoslijedu. To se može koristiti za uvoz VV datoteke iz druge LimeSurvey instance, ali svaki upitnik mora biti potpuno isti. Izričito preporučujemo da ovo koristite samo ako znate što radite. Može biti vrlo opasno i dovesti do toga da rezultati završe u pogrešnom stupcu.

Ostale opcije izvoza

Izvoz pojedinačnog odgovora

Ako želite izvesti pojedinačni odgovor, to možete učiniti na 3 načina:

1. Prijavite se u LimeSurvey administraciju, odaberite svoj upitnik, idite na "Uredi postavke upitnika" -> "Obavijesti i upravljanje podacima" i provjerite da primate osnovne obavijesti e-poštom.

Svaki put kada netko dovrši upitnik, primit ćete e-poruku s poveznicom: "Click the following link to see the individual response"

Ta će vas poveznica odvesti na stranicu s gumbom iznad podataka na kojem piše "Izvezi ovaj odgovor"

2. Prijavite se u administracijsko sučelje LimeSurveyja, odaberite svoj upitnik i "Pregled odgovora" za taj upitnik. Kliknite na "Display responses" i na ID broj koji želite izvesti u lijevom stupcu. Zatim iznad podataka možete kliknuti na "Export this survey".

3. Prijavite se u administracijsko sučelje LimeSurveyja, odaberite svoj upitnik i "Izvezi rezultate" u aplikaciju. U posljednjem polju iznad opcije "Izvezi podatke" možete odabrati koji unos želite izvesti.

Povezivanje odgovora iz različitih upitnika

Ako želite pratiti odgovore pojedinih osoba na upitnik tijekom vremena, LimeSurvey vam u tome može pomoći. Mogući primjer upotrebe je praćenje odgovora grupe prije i nakon što grupa pohađa određeni seminar.

Koraci za provedbu su sljedeći:

1. Izradite upitnik

2. Provjerite da upitnik nije anoniman i da koristi tokene. Za izradu upitnika koji nije anoniman:

a - Kliknite na ikonu Općenite postavke.

b - Zatim na kartici Tokens za Anonimni odgovori odaberite "Ne".

3. Aktivirajte upitnik.

Kada aktivirate upitnik, kliknite na gumb "Prebaci na način rada zatvorenog pristupa" kako biste izradili tablicu tokena:

4. Popunite tablicu tokena bilo kojom metodom (slijedite upute na stranici Tokeni).

5. Izvezite rezultate upitnika i obavezno uključite podatke o tokenima.

Za izvoz kliknite pregled rezultata...

...a zatim izvoz:

Ne zaboravite odabrati jedan ili više elemenata iz tablice tokena koje želite povezati s odgovorima upitnika:

6. Kada ponovno pokrenete upitnik, što možete jednostavno učiniti kopiranjem upitnika i tablice tokena pomoću izvoza/uvoza, samo ponovite korake i pazite da se koristi isti upit za izradu CSV datoteke za uvoz tokena.

Problemi i rješenja

Excel

Izmjena odgovora u programu Excel prije uvoza

Kako biste napravili više izmjena odgovora, možete izvesti i otvoriti datoteku u programu Excel. Izmijenite podatke (osim gornjih redaka) i zatim spremite kao .txt datoteku. Ako spremite kao .csv, Excel koristi zarez kao razdjelnik, a takva se datoteka neće moći uvesti u LimeSurvey. Spremanjem kao .txt datoteke Excel sprema datoteku s tabulatorom kao razdjelnikom, koja se može ponovno uvesti u LimeSurvey.

Uređivanje .csv datoteke u programu Excel

Općenito ne preporučujemo korištenje programa Excel za uređivanje izvezenih .csv datoteka jer Excel mijenja unutarnju strukturu podataka, što dovodi do neuspješnog uvoza. Ako ipak želite koristiti Excel, morate u upravljačkoj ploči (Windows sustavi) postaviti razdjelnik za Excel na zarez:

System Control|Region- Languageoptions|Regional Settings, customize...|Tab Numbers|Digit grouping symbol| replace ; with ,

Zzaobilazno rješenje za uređivanje .csv datoteka u programu Excel

Korištenje programa Excel za uređivanje pitanja može vas spriječiti da ih ponovno uvezete. No uređivanje je najbolje rješenje ako imate više od otprilike 5 opcija ili opcija rangiranja te želite koristiti mogućnosti programa Excel, poput sortiranja i sl.

Ovo je djelomično zaobilazno rješenje koje, čini se, radi u verziji 1.82 - u biti, Excel koristite samo za dio datoteke koji sadrži podatke:

  • Izvezite pitanje slično onome koje želite ponovno koristiti kao .csv datoteku
  • Otvorite CSV datoteku u uređivaču običnog teksta
  • Kopirajte dio s odgovorima u Excel i razdvojite ga pomoću funkcije Text to Columns ili ekvivalentne
  • Iskoristite mogućnosti programa Excel za lijepljenje teksta u stupce kako biste zalijepili 20, 50, 100 odgovora, prema želji
  • Spremite datoteku kao Excel CSV, koji će vjerojatno biti bez navodnika.
  • Otvorite ovu datoteku u uređivaču, odaberite sve i kopirajte
  • Vratite se na datoteku koju ste otvorili u uređivaču običnog teksta
  • Zalijepite preko tamošnjih odgovora
  • Spremite kao (Save AS) pod drugim nazivom, možda onim koji ćete zapamtiti za ponovnu upotrebu
  • Uvezite ovu datoteku.

Excel - izvoz ograničen na 255 stupaca

Zbog ograničenja programa Excel (verzije 2003 i starije), LimeSurvey može istovremeno izvesti samo 255 stupaca. Microsoft je predložio zaobilazno rješenje kao VB makro.

Iako novije proračunske tablice (Excel >= 2007, OpenOffice) mogu prikazati više od 255 stupaca, interni modul koji koristi LimeSurvey i dalje ne može izvesti više od 255 stupaca.

Moguća su ipak dva zaobilazna rješenja, upotrijebite jedno od sljedećih:

  • Izvezite u CSV i uvezite u svoju proračunsku tablicu
  • Ili koristite višestruke izvoze (odabirom najviše 250 stupaca odjednom), a zatim spojite izvezene rezultate

Excel/.csv - izvoz ne uspijeva

Ako ne možete izvesti podatke u Excel ili u .csv datoteku, pokušajte očistiti predmemoriju (cache) i kolačiće svojeg preglednika.

CSV

CSV je prema zadanim postavkama ograničen na 255 stupaca

Pri izvozu velikih upitnika grafičko sučelje prema zadanim postavkama ograničava izvoz na prvih 255 stupaca. Da biste to zaobišli, jednostavno označite sve skupove podataka za izvoz.

SPSS izvoz

Opći koraci

Za uvoz podataka odgovora iz LimeSurveya slijedite ove korake:

  1. Kliknite ikonu 'Export to SPSS'.
  2. U padajućim izbornicima odaberite koje odgovore želite izvesti i svoju SPSS verziju.
  3. Preuzmite obje datoteke, .sps (SPSS datoteku sa sintaksom naredbi) i .dat datoteku (datoteku s podacima)
  4. Otvorite .sps datoteku u SPSS-u tako da otvorite SPSS, zatim odaberite 'Choose another type of file' i odaberite preuzetu .sps datoteku.
  5. Sada se unutar SPSS-a otvara uređivač u kojem možete uređivati naredbe u toj datoteci. Potražite redak koji počinje s '/FILE=...'
  6. Uredite taj redak i prilagodite putanju tako da pokazuje na vašu .dat datoteku. Primjer: Vaša *.dat datoteka nalazi se u c:\temp pa postavite redak na /FILE='c:\temp\survey_(xxxx)_SPSS_data_file.dat'
  7. Sada odaberite sve naredbe u uređivaču pritiskom na CTRL-A.
  8. U SPSS izborniku odaberite Run/All.
  9. Budite strpljivi, uvoz svih podataka i oznaka potrajat će neko vrijeme. Napredak možete pratiti na statusnoj traci.
  10. Gotovo!

Moguće poruke o pogrešci u SPSS-u

ERROR. command name:Get Data

Ako dobijete poruku o pogrešci ERROR. command name:Get Data. 2267 Unexpected Token missing., uredite četvrti redak svoje datoteke sa sintaksom tako da pokazuje na apsolutnu putanju datoteke s podacima, npr.

C:\spss\Data\limesurvey\SPSS\survey_35276_SPSS_data_file.dat

Pogreška: "Text value unmappable in the current server locale"

Ova se pogreška može pojaviti ako pokušate otvoriti izvezenu datoteku sa sintaksom u SPSS-u 16. Rješenje je prisiliti SPSS da datoteku sa sintaksom protumači kao unicode.

Open SPSS. Go to Edit > Options > Character encoding for data and syntax. Change the option to "unicode".

LimeSurvey podaci sada se mogu bez problema izvesti u SPSS 16.

Definiranje skale za vašu varijablu

Zadanu skalu koja se koristi za varijablu moguće je nadjačati postavljanjem atributa pitanja scale_export na odgovarajuću vrijednost.

VV izvoz/uvoz

VV - problemi s uvozom vv datoteke

Ako imate poteškoća s uvozom vv datoteke, pokušajte s datotekom odvojenom tabulatorima i trebalo bi raditi bez problema.

Ostali problemi i rješenja

Kopiranje odgovora u drugi upitnik (pomoću tokena)

  1. Izradite novi upitnik, dodajte probni odgovor, izvezite datoteku s odgovorima i otvorite je u programu Excel. Time se stvara format za novu datoteku za uvoz.
  2. Izvezite odgovore iz starog upitnika, uključujući tokene, i otvorite ih u programu Excel.
  3. Pomoću tih podataka izradite Excel radni list za standardni uvoz datoteke s tokenima (npr. Firstname, Lastname, Token, Email address, Email status (OK), Language (En)). Spremite kao .csv i uvezite tokene u novi upitnik u LimeSurveyu.
  4. U programu Excel kopirajte polja odgovora iz odgovora starog upitnika koja želite u novom upitniku (uključujući token) u odgovarajući Excel stupac formata novog upitnika.
  5. Spremite kao .txt datoteku.
  6. Pomoću VVImport uvezite nove podatke u novi upitnik.
  7. Moguće pogreške pri uvozu uključuju format datuma - neka sistemska polja datuma ne dopuštaju vrijednost NULL, a neka dopuštaju. Ako datum izgleda ispravno, ali se pojavljuje pogreška, koristite format ćelije u Excelu "2009-12-01".