x

主要章节

  1. LimeSurvey Cloud 与 LimeSurvey CE 对比
  2. 快速入门指南 - LimeSurvey 3.0+
  3. 软件安装
  4. 如何设计一个不错的调查(向导)
  5. 入门指南
  6. 管理 LimeSurvey
  7. 调查 - 说明
  8. 调查设置
  9. 问卷调查菜单
  10. 调查问卷结构
  11. 问题 - 简介
  12. 题组 - 简介
  13. 调查 - 管理
  14. 调查工具栏选项
  15. 多语言调查
  16. ExpressionScript 引擎 - 快速入门指南
  17. 其他和高级功能
  18. 常规问答
  19. 故障排除
  20. 变通方法
  21. 许可证
  22. 版本更改日志
  23. 插件
 Actions

导出结果

From LimeSurvey Manual

本页面可能为机器翻译,可能包含错误。 查看英文原文 · 改进此翻译
This page is a translated version of the page Exporting results and the translation is 100% complete.
  注意 : 以下内容已过时。如需最新信息,请查看:




调查激活后,您就可以查看并导出反馈。要进入调查反馈概览,请点击:反馈 -> 反馈和统计

导出到应用程序(Excel/.csv)

页面顶部列出了多个导出选项。

导出结果时有多个筛选选项:

  • 常规
    • 设置范围(例如,“导出第 X 条至第 Y 条记录”)
    • 设置导出全部记录,或仅导出已完成的记录,或仅导出未完成的记录
  • 问题
    • 确定标题的显示方式:缩写标题、完整标题或问题代码
    • 把问题文本内空格转换为下划线
  • 答案
    • 您可以导出完整答案,也可以将答案代码 Y 和 N 转换为指定的变量
  • 格式
    • 微软Word(拉丁字符集)
    • 微软Excel(所有字符集)
    • CSV文件(所有字符集)
    • HTML
    • PDF
  • 列控制
    • 设置要导出的答案。此列表中的所有答案均以其SGQA标识符表示
    • 设置要导出的邀请码数据。仅当您的调查不是匿名调查时,此选项才可用!

SPSS导出

常规

SPSS Statistics 是一款用于批处理和非批处理逻辑统计分析的软件。您可以使用官方 SPSS 软件包,也可以使用 GNU PSPP 来替代专有程序 SPSS。

要将反馈数据导出到 SPSS,请进入反馈和统计部分,然后点击导出到 SPSS 的图标。

导出和筛选数据

向 SPSS 导出数据时有两个筛选选项。您可以选择要导出哪些数据(全部记录/仅已完成的记录/仅未完成的记录),以及导出文件将用于哪个 SPSS 版本(16之前的版本/16或以上)。

SPSS 导出包含两个文件:

  1. 一个语法文件(survey_xxxx_SPSS_syntax_file.sps)
  2. 和一个数据文件(survey_xxxx_SPSS_data_file.dat)。

下载这些文件后,您可以使用记事本等纯文本编辑器打开它们,查看导出数据的样子。语法文件包含导入数据时需要运行的命令,类似于 SPSS 内部的一种编程语言。数据文件是包含全部数据的逗号分隔文件。如果仅通过向导将这些数据作为 csv 导入,会丢失有关问题、标签集等的信息,因此我们不建议这样做。

在 SPSS 中导入数据

将这两个文件放在磁盘上的同一个文件夹中(例如:c:\data\survey_xxxx_SPSS_syntax_file.sps 和 c:\data\survey_xxxx_SPSS_data_file.dat)

现在有两种方法:

1. 使用 Windows 时,用资源管理器浏览到上述文件夹。如果 SPSS 已与 .sps 文件扩展名关联,您只需双击即可打开该文件:

现在,您可以在打开的窗口中选择 Run->All,稍等片刻即可得到输出数据集,您可以将其保存为普通的 .sav 文件。

2. 有时上述简便方法行不通,此时您可以按以下步骤操作:

  • 打开 SPSS
  • 选择 File->Open->Syntax
  • 选择相应的文件:c:\data\survey_xxxx_SPSS_syntax_file.sps
  • 此时语法文件已打开。
  • 将 /FILE='survey_xxxx_SPSS_data_file.dat' 这一行修改为包含文件所在路径:/FILE='c:\data\survey_xxxx_SPSS_data_file.dat' ;Mac 用户请使用:/FILE='HD/Users/username/survey_xxxx_SPSS_data_file.dat'
  • 现在选中全部命令文本,并从菜单中选择 Run->All,稍等片刻(请耐心等待),您就会得到包含问题、标签等全部信息的数据集。

R导出

如果您有更多信息,欢迎补充!

免费软件 R 是 SPSS 的替代品。在 LimeSurvey 中,它属于导出到应用程序的导出方式。

如何将数据集导入 R 的说明:

  1. 下载语法文件和数据文件。
  2. 将两个文件保存到 R 工作目录中(在 R 命令窗口中使用 getwd() 和 setwd() 来获取和设置工作目录)。
  3. 在 R 命令窗口中输入代码 source("Surveydata_syntax.R", encoding = "UTF-8"),即可将数据以正确的格式导入到名为“data”的数据框中。


选项有限的反馈将被转换为因子,其水平对应问题的代码,标签对应各选项。

如果问题包含“其他”选项,则会在问题字段后追加 _Other,作为存放“其他”数据的新列。

注意:R 导出是 LimeSurvey 中的一个插件。如果您在“导出结果到应用程序”下找不到 R 导出选项(R(语法文件)、R(数据文件)),请确保已在插件菜单中启用 R 导出插件。

STATA-xml 导出

STATA 是一款商业数据分析和统计软件包。

此导出功能旨在帮助您快速分析通过 LimeSurvey 收集的数据。它会以 STATA 专有格式创建一个 XML 文件,无论 STATA 运行在哪个平台上,都可以导入该文件。与导入普通 CSV 文件相比,使用这种格式有以下几个优点:

  • 数据集带有完整的标签,包括变量标签(问题、子问题)和值标签(答案,如适用)。
  • 日期已转换为 STATA 内部日期格式,因此可以直接用于计算日期之间的差值等。
  • 如有必要,变量名会被转换为与 STATA 兼容的格式。
  • 变量的数据格式(字符串、整数、浮点数等)已根据底层数据设置好。(不会再出现被编码为字符串的数字!)

如何在 STATA 中加载该文件: STATA 14 及更早版本提供了 File → Import → XML data 菜单项。从 Stata 15 起,该菜单项已不存在。请改为在 STATA 的命令窗口中输入以下命令:

xmluse "survey_123456_STATA.xml", doctype(dta)

(请将文件名替换为您自己导出文件的路径。)数据加载完成后,您可以将其保存为 STATA 的二进制 .dta 格式,这样就无需重复导入:

save "survey_123456.dta"


注意: 上述使用的 xmluse/xmlsave 命令自 Stata 15 起已从 STATA 官方文档和支持的命令集中移除,不过在当前版本中它们仍作为未公开的旧版功能可用。由于未来的 STATA 版本可能会在不另行通知的情况下取消这些命令,我们建议您在导入后立即将数据保存为 .dta 文件(见上文),而不要依赖 XML 文件作为长期存储。如果您的 STATA 安装中没有 xmluse,请改用 LimeSurvey 的 CSV 导出,并配合 STATA 的 import delimited 命令。

请注意:

  • 由于 STATA 数据格式的限制,字符串(文本)变量的长度最大为 244 个字符(Stata 8-12 版本)和 2045 个字符(Stata 13 及以上版本)。请在导出插件的设置中指明您的 Stata 版本。
  • STATA 仅支持为数值添加值标签。因此,若要获得简短的答案(通常为一位或两位数字)并为其正确添加标签,应在 LimeSurvey 中使用数字答案代码(1=完全同意)。如果使用非数字答案代码(A=完全同意),则会使用完整的答案文本作为答案(例如:“完全同意”)。

VV导出和VV导入

 Hint: This feature changed with version 2.05


开始收集反馈后,您有时可能需要直接编辑和修改反馈表中的大量数据,此时使用电子表格工具可能会更方便。

VV导出(“VV”代表垂直验证,vertical verification)允许您将反馈表导出为 .csv 文件。只要文件的总体结构保持不变,您就可以编辑其中的值,然后使用“VV导入”功能将该文件重新导入到反馈表中。

请注意以下事项:

  • 如果您想使用“VV导入”导入反馈,请务必确认是将反馈添加到现有反馈中,还是覆盖所有反馈。
  • 如果您要从另一个相同的调查(例如另一个调查中完全相同的问题/答案)导入反馈,请确保使用了正确的 vv 文件,并且 .csv 文件的前两行是正确的。
  • 如果您将调查导入到 LimeSurvey 安装中,SID 将(尽可能)保持不变,但组 ID 和问题 ID 可能会改变。因此,您可能需要调整前两行标题,使其与新的组 ID/问题 ID 相匹配。请参阅调整 vv 文件标题

<span id="VVExport_file_version_2_ (New in 2.05 )">VV导出文件版本 2 (New in 2.05 )

这项新功能允许使用与数据库不同的列名。如果您的问题代码是唯一的,则会选用新版本。在新版本中,每个列名都使用 Qcode 变量命名。例如,这样可以更方便地在不同的安装中更新现有调查。

导出VV调查文件

File:LimesurveyExportVVen.jpg

选择使用VV导出来导出反馈时,您可以选择要导出的调查,以及导出所有反馈、仅已完成反馈还是仅未完成反馈。文件扩展名用于选择导出文件的扩展名。为方便使用,建议选择 .csv。

当问题/答案的组合发生变化时,可以通过“vv 调查文件”将反馈导入到调查中。实际上,这使您可以在已激活的调查中添加或删除问题。

点击“导出VV调查文件”后,将生成一个以制表符分隔的文件,可以用 Excel 或类似的电子表格程序打开。电子表格的前两行是列标签。第一行是“便于阅读”的列标题,详细说明了问题/答案字段的名称。第二行是该反馈在 PHP/数据库中的内部列名。

如果您希望以后能够将数据“导入”回 LimeSurvey,请不要修改此电子表格的前两行。

<span id="Exporting_a_VV_survey_file_ (New in 2.05 )">

导出VV调查文件 (New in 2.05 )

 Hint: This feature is available starting in version 2.05


  • 导出调查 :要导出的调查 ID(只读)
  • 导出 :要导出的反馈的完成状态
  • 文件扩展名 :文件扩展名。该文件是 TSV(制表符分隔值)文件。若要方便地用 MS-Excel 打开,请将扩展名设置为 .txt;使用 LibreOffice、OpenOffice 或其他电子表格程序时,可保留为 .csv。
  • vv导出版本 :1.0 版本使用数据库列标题,2.0 版本使用 Qcode 变量命名。如果您所有的问题代码都是唯一的,则默认选择 2.0 版本。

电子表格的前两行是列标签。第一行是“便于阅读”的列标题,详细说明了问题的名称。第二行是该反馈的真实列名(内部数据库列名或 Qcode 名称)。

编辑VV调查文件

成功导出 .vv 文件后,您可以使用电子表格工具打开并编辑该文件。如果打开文件时需要选择列分隔符,请选择“Tab”(制表符)。如果您使用了非 ASCII 字符,请确保将字符集设置为“UTF-8”。

  如果您使用 Microsoft Excel 编辑导出的 vv 文件,请注意 Excel 会破坏文件原有的数据结构。这会导致您在重新导入编辑后的 .vv 文件时出错。


默认情况下,.vv 文件的前两行是标题行。如有需要,您可以删除第一行,以得到真正的 TSV 文件。导入 .vv 文件有多种使用场景,因此我们将区分向调查中添加新反馈和覆盖调查的所有反馈这两种情况。

.vv 文件的结构示例:

VV 版本 1 TSV 文件

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	46492X40X1991
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1

VV 版本 2 TSV 文件

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	QCODE
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1


此处不使用 SGQA 标识符,而是在第二行使用 Qcode 变量命名 QCODE。

保留名称

.VV 文件使用左右花括号表示保留名称,导入时这些字符串会被替换为:

  • {question_not_shown} : 数据库中的 NULL 值。LimeSurvey 对未回答的问题使用[空字符串],对未显示的问题(由表达式管理器或调查中的最大步骤导致)使用 NULL 值。
  • {quote} : "(双引号)
  • {cr} : 回车符
  • {newline} : 换行符
  • {lbrace} : 左花括号(例如,如果您希望反馈中包含 {cr},请使用 {lbrace}cr} )

VV 版本 1 的编辑

将新反馈添加到调查的现有反馈中

格式的版本 1 不支持此操作,因为这很容易导致各种问题,包括数据被导入到错误的列中。.vv 文件的版本 1 一直是为了在 Excel 等外部工具中对数据进行纵向校验而设计的,而不是用于汇总来自不同来源的数据(例如在另一台服务器上运行的同一调查)。

修改调查的所有反馈

如果您想修改调查的反馈,只需编辑该文件即可。

示例:

步骤1:打开文件

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
183	09.11.11 11:44	3	de	4
184	09.11.11 11:53	3	de	2
190	09.11.11 11:44	3	de	1


步骤2:修改反馈

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
1000	09.11.11 11:44	3	de	3
1001	09.11.11 11:53	3	de	3
1002	09.11.11 11:44	3	de	3

然后您可以导入该调查,请务必覆盖现有反馈(参见“导入VV调查文件”)。

导入VV调查文件

File:LimeSurveyImportVVen.jpg

只要前两行保持完整,您就可以将 vv 调查文件中的数据重新导入到已激活的 LimeSurvey 调查中。

如果您使用微软Excel编辑了导出的 vv 文件,该文件的数据结构可能已损坏,导致 LimeSurvey 无法导入编辑后的文件。您可以尝试以下变通方法,使导入不再出错:

  • 在 Excel 中打开导出的 vv 文件并进行修改(相信您已经完成了这一步)
  • 将其另存为以制表符分隔的文本文件(会创建一个扩展名为 .txt 的新文件)
  • 从 LimeSurvey 再进行一次“干净”的 vv 导出
  • 用记事本等文本编辑器打开这个新导出的 vv 文件(我在 Mac 上使用的是 textwrangler)
  • 按 CTRL + A 全选所有内容并删除
  • 用文本编辑器打开经 Excel 编辑的 vv 文件(以制表符分隔的 .txt 文件),然后按 CTRL + A 全选所有内容
  • 按 CTRL + C 复制内容,并将其粘贴到新的(现已清空的)vv 文件中
  • 按 CTRL + S 按原样保存文件(保存为 .csv)
  • 现在尝试导入此文件

然后,在浏览界面中,点击“导入VV调查文件”图标。

在“导入VV调查文件”界面中,您需要选择要导入的“vvexport”文件。如果您选择“排除的记录号?”,则会导入这些记录,并为它们生成全新的记录号(此选项适用于“将新反馈添加到调查的现有反馈中”的使用场景)。如果取消勾选此框,则会导入原始记录号(此选项适用于“覆盖调查的所有反馈”的使用场景)。

您可以选择多种选项,告诉 LimeSurvey 如何处理重复或多次出现的条目。

  • 报告错误(并跳过这条新记录)。
  • 对这条新记录重新编号
  • 替换存在的记录(“覆盖调查的所有反馈”的使用场景请使用此选项)

<span id="Importing_a_VV_survey_file_ (New in 2.05 )">

导入VV调查文件 (New in 2.05 )

  • 文件 : 选择要上传的文件。该文件必须是 TSV 文件:各列以 TAB 分隔的文本文件。
  • 排除的记录号? : 如果文件中存在“id”列,您可以选择是否排除该列。如果勾选此设置,则 .vv 文件中的每一行都会添加为新记录。如果未勾选,您可以选择:
  • 当导入的记录匹配已经存在记录号的时候:
    • skip : 报告并跳过这条新记录。上传后您将看到该记录是否已存在——如果已存在,则不会导入。
    • renumber : 对这条新记录重新编号。VV 文件中的答案将作为新记录添加到答复表中。
    • replace : 替换存在的记录。旧记录将被删除,并完全由 VV 文件中的记录取代。
    • replaceanswer : 用文件中的反馈详细信息替换现有记录。旧记录将以 VV 文件中的新反馈进行更新。这样可以只替换答复表中的某一个问题。
  • Import as not finalized response? : 如果勾选,则 submitdate 将设置为 NULL,该反馈会被设为未完成。
  • 文件的字符集: : 您可以选择文件的字符集——默认且推荐的值为 UTF-8,但某些电子表格程序不允许选择字符集。
  • First line contains question codes : 默认情况下,VV 文件的第一行包含便于阅读的问题,真正的列名位于第二行。此选项允许将第一行用作真正的列名。
  • 强制导入: : 如果在数据库名或 Qcode 变量命名 中找不到问题代码,则按顺序分配列。这可用于从不同的 LimeSurvey 实例导入 VV 文件,但每个调查必须完全相同。我们强烈建议仅在您清楚自己在做什么时才使用此选项。这可能非常危险,并导致结果出现在错误的列中。

其他导出选项

导出单个反馈

如果您想导出单个反馈,可以通过 3 种方式实现:

1. 登录 LimeSurvey 管理后台,选择您的调查,进入“编辑调查设置” -> “通知和数据管理”,并确保您会收到基本的电子邮件通知。

每当有人完成一份调查后,您将收到一封包含链接的电子邮件:“点击以下链接查看单个反馈”

该链接会将您带到一个页面,数据上方有一个“导出该反馈”按钮

2. 登录 LimeSurvey 管理后台,选择您的调查,然后选择“浏览反馈”。点击“显示反馈”,并在左侧列中点击您要导出的 ID 号。然后您可以点击数据上方的“导出此调查”。

3. 登录 LimeSurvey 管理后台,选择您的调查,然后选择“导出结果”。在“导出数据”上方的最后一个字段中,您可以选择要导出哪一条记录。

匹配来自不同调查的反馈

如果您想长期跟踪特定个人的调查反馈,LimeSurvey 可以帮助您实现。一个可能的使用场景是:跟踪某个群体在参加特定研讨会前后的反馈。

实现步骤如下:

1. 创建调查

2. 确保该调查为非匿名调查并使用邀請碼。创建非匿名调查的方法:

a - 点击“常规设定”图标。

b - 然后在“邀請碼”选项卡下,将“匿名反馈”选择为“否”。

3. 激活调查。

激活调查时,点击“切换至封闭式访问模式”按钮以创建邀請碼表:

4. 使用您喜欢的任何方法填充邀請碼表(请按照 邀請碼 页面中的说明操作)。

5. 导出调查结果,并确保包含邀請碼信息。

要导出,请点击浏览反馈...

...然后点击导出:

请记得从邀請碼表中选择一个或多个元素,以便与调查反馈关联:

6. 当您再次运行该调查时(通过导出/导入复制调查和邀請碼表即可轻松实现),只需重复上述步骤,并确保使用相同的查询来生成 CSV 邀請碼导入文件。

问题与解决方案

Excel

导入前在 Excel 中修改反馈

若要对反馈进行多处修改,您可以导出并在 Excel 中打开文件。修改数据(顶部两行除外),然后另存为 .txt 文件。如果保存为 .csv,Excel 会使用逗号分隔,而这种格式无法导入 LimeSurvey。保存为 .txt 文件时,Excel 会将其保存为制表符分隔的文件,这种文件可以重新导入 LimeSurvey。

使用 Excel 编辑 .csv

一般情况下,我们不建议使用 Excel 编辑导出的 .csv 文件,因为 Excel 会更改内部数据结构,导致导入失败。如果您仍然想使用 Excel,则需要在系统控制面板中将 Excel 的分隔符设置为逗号(Windows 系统):

System Control|Region- Languageoptions|Regional Settings, customize...|Tab Numbers|Digit grouping symbol| replace ; with ,

使用 Excel 编辑 .csv 文件的变通方法

使用 Excel 编辑问题可能会导致您无法重新导入这些问题。但是,如果您有超过 5 个左右的选项或排序选项,或者想使用 Excel 的排序等功能,编辑仍然是最佳方式。

这是一个似乎在 1.82 中有效的部分变通方法——本质上,只对文件中的数据部分使用 Excel:

  • 将一个与您想要重复使用的问题相似的问题导出为 .csv 文件
  • 在纯文本编辑器中打开该 CSV 文件
  • 将包含答案的部分复制到 Excel 中,并使用“分列”或类似功能进行解析
  • 利用 Excel 在列中粘贴文本的功能,按需粘贴 20、50、100 个答案
  • 将文件保存为 Excel CSV,该文件可能不带引号
  • 在编辑器中打开此文件,全选并复制
  • 返回到您用纯文本编辑器打开的文件
  • 将答案部分粘贴覆盖
  • 使用不同的名称另存为,最好是便于您记住以便重复使用的名称
  • 导入此文件。

Excel - 导出限制为 255 列

由于 Excel(2003 及更低版本)的限制,LimeSurvey 一次只能导出 255 列。Microsoft 提出了一个使用 VB 宏的变通方法。

虽然较新的电子表格程序(Excel 2007 及以上版本、OpenOffice)可以显示超过 255 列,但 LimeSurvey 使用的内部模块仍然无法导出超过 255 列。

不过,有两种变通方法可供选择,请使用下列其中一种方案:

  • 导出为 CSV,然后导入到您的电子表格程序中
  • 或者进行多次导出(每次最多选择 250 列),然后合并导出的结果

Excel/.csv - 导出失败

如果您无法将数据导出为 Excel 或 .csv 文件,请尝试清除浏览器缓存和 Cookie。

CSV

CSV 默认为 255 列

导出大型调查时,图形界面默认将导出限制为前 255 列。要解决此问题,只需将所有数据集标记为导出即可。

SPSS 导出

一般步骤

要导入 LimeSurvey 反馈数据,请按以下步骤操作:

  1. 点击“导出到 SPSS”图标。
  2. 在选择框中选择要导出的反馈以及您的 SPSS版本。
  3. 下载两个文件:.sps(SPSS 语法命令文件)和 .dat 文件(数据文件)
  4. 打开 SPSS,选择“选择其他类型的文件”,然后选择已下载的 .sps 文件,以便用 SPSS 打开它。
  5. 此时 SPSS 中会打开一个编辑器,您可以在其中编辑该文件中的命令。找到以 '/FILE=...' 开头的行。
  6. 编辑该行并调整路径,使其指向您的 .dat 文件。例如:您的 *.dat 文件位于 c:\temp,则将该行设置为 /FILE='c:\temp\survey_(xxxx)_SPSS_data_file.dat'
  7. 按 CTRL-A 选中编辑器中的所有命令。
  8. 在 SPSS 菜单中选择 Run/All。
  9. 请耐心等待,导入所有数据和标签需要一些时间。您可以查看状态栏了解进度。
  10. 完成!

SPSS 中可能出现的错误信息

ERROR. command name:Get Data

如果您收到错误信息 ERROR. command name:Get Data. 2267 Unexpected Token missing.,请编辑语法文件的第四行,使其指向数据文件的绝对路径,例如:

C:\spss\Data\limesurvey\SPSS\survey_35276_SPSS_data_file.dat

错误:"Text value unmappable in the current server locale"

尝试在 SPSS 16 中打开导出的语法文件时可能会出现此错误。解决方法是强制 SPSS 将语法文件按 Unicode 解释。

打开 SPSS。转到 Edit > Options > Character encoding for data and syntax。将该选项更改为 "unicode"。

现在可以将 LimeSurvey 数据顺利导出到 SPSS 16 了。

定义变量所使用的尺度

您可以通过将问题属性 scale_export 设置为适当的值,来覆盖变量使用的默认尺度。

VV 导出/导入

VV - vv 导入的问题

如果您在导入 vv 文件时遇到困难,请尝试使用制表符分隔的文件,这样通常可以正常工作。

其他问题与解决方案

将反馈复制到另一个调查中(使用邀請碼)

  1. 创建新调查,添加一条虚拟反馈,导出该反馈文件,然后在 Excel 中打开。这样就创建了新的导入文件的格式。
  2. 从旧调查中导出反馈(包括邀請碼),并在 Excel 中打开。
  3. 使用这些数据创建一个用于标准邀請碼文件导入的 Excel 工作表(例如:名、姓、邀請碼、邮件地址、电邮状态 (OK)、语言 (En))。保存为 .csv,并将邀請碼导入到 LimeSurvey 中的新调查。
  4. 在 Excel 中,将旧调查反馈中您希望放入新调查的反馈字段(包括邀請碼)复制到新调查格式中相应的 Excel 列。
  5. 保存为 .txt 文件。
  6. 使用 VVImport 将新数据导入到新调查中。
  7. 可能的导入错误包括日期格式问题——某些系统日期字段不允许 NULL 值,而有些则允许。如果日期看起来没问题却仍出错,请使用 Excel 单元格格式 "2009-12-01"。