x

Основні розділи

  1. LimeSurvey Cloud проти LimeSurvey CE
  2. Короткий посібник із початку роботи - LimeSurvey 3.0+
  3. Встановлення - LimeSurvey CE
  4. Як створити хороше опитування (посібник)
  5. Початок роботи
  6. Адміністрування LimeSurvey
  7. Опитування - вступ
  8. Налаштування опитування
  9. Меню опитування
  10. Структура опитування
  11. Питання - вступ
  12. Групи питань - вступ
  13. Опитування - керування
  14. Параметри панелі інструментів опитування
  15. Багатомовне опитування
  16. ExpressionScript Engine - Короткий посібник
  17. Некатегоризовані та розширені функції
  18. Загальні поширені запитання
  19. Усунення несправностей
  20. Обхідні рішення
  21. Ліцензія
  22. Журнал змін версій
  23. Плагіни
 Actions

Експорт результатів

From LimeSurvey Manual

Ця сторінка, можливо, перекладена машинним способом і може містити помилки. Показати англійський оригінал · Покращити цей переклад
This page is a translated version of the page Exporting results and the translation is 100% complete.
  Увага : Наведений нижче розділ застарів. Актуальну інформацію дивіться тут:




Щойно ваше опитування стане активним, ви зможете переглядати відповіді та експортувати їх. Щоб перейти до огляду відповідей опитування, натисніть: Відповіді -> Відповіді та статистика

Експорт до застосунку (Excel/.csv)

Угорі сторінки наведено кілька варіантів експорту.

Під час експорту результатів доступно кілька параметрів фільтра:

  • Загальні
    • Задайте діапазон (наприклад, «експортувати записи з X по Y»)
    • Виберіть, що експортувати: усі записи АБО лише завершені записи АБО лише незавершені записи
  • Питання
    • Визначте, як має відображатися заголовок: скорочений заголовок АБО повні заголовки АБО коди питань
    • Перетворити пробіли в тексті питання на знаки підкреслення
  • Відповіді
    • Ви можете експортувати повні відповіді або перетворити коди відповідей Y і N на визначену змінну
  • Формат
    • Microsoft Word (латинський набір символів)
    • Microsoft Excel (усі набори символів)
    • CSV-файл (усі набори символів)
    • HTML
    • PDF
  • Керування стовпцями
    • Виберіть, які відповіді слід експортувати. Усі відповіді в цьому списку представлені своїм ідентифікатором SGQA
    • Виберіть, які дані токенів слід експортувати. Цей параметр доступний, лише якщо ваше опитування не є анонімним!

Експорт до SPSS

Загальні відомості

SPSS Statistics — це програмне забезпечення для логічного пакетного та непакетного статистичного аналізу. Ви можете використовувати офіційний пакет SPSS або GNU PSPP — заміну для пропрієтарної програми SPSS.

Щоб експортувати дані відповідей до SPSS, перейдіть до розділу Відповіді та статистика і натисніть значок експорту до SPSS.

Експорт і фільтрування даних

Під час експорту даних до SPSS доступні два параметри фільтра. Ви можете вибрати, які дані слід експортувати (усі записи/лише завершені записи/лише незавершені записи), і для якої версії SPSS будуть використовуватися експортовані файли (версії до 16/16 або більше).

Експорт до SPSS містить два файли:

  1. файл синтаксису (survey_xxxx_SPSS_syntax_file.sps)
  2. і файл даних (survey_xxxx_SPSS_data_file.dat).

Після завантаження цих файлів ви можете відкрити їх у простому текстовому редакторі, наприклад у Блокноті, щоб подивитися, як виглядають експортовані дані. Файл синтаксису містить команди, які потрібно виконати для імпорту даних. Це схоже на мову програмування всередині SPSS. Файл даних містить файл зі значеннями, розділеними комами, з усіма даними. Якщо просто імпортувати ці дані як CSV за допомогою майстра, ви втратите інформацію про питання, набори міток тощо, тому ми так не робимо.

Імпорт даних до SPSS

Помістіть обидва файли в одну папку на диску (наприклад: c:\data\survey_xxxx_SPSS_syntax_file.sps і c:\data\survey_xxxx_SPSS_data_file.dat)

Тепер є два варіанти:

1. Якщо ви використовуєте Windows, за допомогою Провідника перейдіть до папки, вказаної вище. Якщо SPSS пов’язано з розширенням файлу .sps, ви можете просто відкрити файл подвійним клацанням:

Тепер у відкритому вікні виберіть Run->All і через деякий час отримайте вихідний набір даних, який можна зберегти як звичайний файл .sav.

2. Іноді наведене вище просте рішення не працює. Тоді можна діяти так:

  • Відкрийте SPSS
  • Виберіть File->Open->Syntax
  • Виберіть потрібний файл: c:\data\survey_xxxx_SPSS_syntax_file.sps
  • Тепер синтаксис відкрито.
  • Змініть рядок /FILE='survey_xxxx_SPSS_data_file.dat' , додавши шлях до папки з файлами: /FILE='c:\data\survey_xxxx_SPSS_data_file.dat' , для користувачів Mac: /FILE='HD/Users/username/survey_xxxx_SPSS_data_file.dat'
  • Тепер виділіть весь текст команд і виберіть у меню Run->All, і через деякий час (будь ласка, наберіться терпіння) ви отримаєте набір даних з усією інформацією, як-от питання, мітки тощо.

Експорт до R

Не соромтеся додати більше інформації, якщо вона у вас є!

Безкоштовне програмне забезпечення R є альтернативою SPSS. Це один із варіантів експорту до застосунку в LimeSurvey.

Інструкція з імпорту набору даних до R:

  1. Завантажте і файл синтаксису, і файл даних.
  2. Збережіть обидва файли в робочому каталозі R (використовуйте getwd() і setwd() у командному вікні R, щоб дізнатися та встановити його).
  3. У командному вікні R введіть source("Surveydata_syntax.R", encoding = "UTF-8") — це імпортує дані в правильному форматі до фрейма даних під назвою «data».


Відповіді з обмеженим набором варіантів буде перетворено на фактори, рівні яких відповідають коду питання, а мітки — варіантам відповідей.

Для запитань з опцією «Інше» буде додано нове поле з суфіксом _Other як окремий стовпець для даних «Інше».

Примітка: експорт R — це плагін LimeSurvey. Якщо ви не можете знайти опції експорту R (R (файл ситнаксису), R (файл даних)) у розділі Експортувати результати до застосунку, переконайтеся, що плагін експорту R увімкнено в меню плагінів.

Експорт STATA-xml

STATA — це комерційний пакет програмного забезпечення для аналізу даних і статистики.

Цей механізм експорту створено для швидкого аналізу даних, зібраних за допомогою LimeSurvey. Він створює XML-файл у власному форматі STATA, який можна імпортувати незалежно від платформи, на якій запущено STATA. Використання цього формату має кілька переваг порівняно з імпортом звичайних CSV-файлів:

  • Набори даних повністю марковані, зокрема мітки змінних (питання, підпитання) та мітки значень (відповіді, за наявності).
  • Дати вже перетворено у внутрішній формат дати STATA, тому їх можна одразу використовувати для обчислення різниці між днями тощо.
  • Назви змінних за потреби перетворюються на формат, сумісний зі STATA.
  • Формати даних змінних (рядок, ціле число, число з плаваючою комою тощо) уже встановлено відповідно до вихідних даних. (Більше жодних чисел, закодованих як рядки!).

Як завантажити файл у STATA: У версіях Stata до 14 для цього існував запис меню File → Import → XML data. Починаючи зі Stata 15, цього запису меню більше немає. Натомість введіть таку команду у вікні Command програми STATA:

xmluse "survey_123456_STATA.xml", doctype(dta)

(замініть назву файлу на шлях до вашого експортованого файлу). Після завантаження даних ви можете зберегти їх у бінарному форматі STATA .dta, щоб не повторювати імпорт:

save "survey_123456.dta"


Примітка: Команди xmluse/xmlsave, використані вище, починаючи зі Stata 15 вилучено з офіційно задокументованого та підтримуваного набору команд STATA, хоча в поточних версіях вони все ще працюють як недокументована застаріла функція. Оскільки в майбутньому випуску STATA їх можуть прибрати без попередження, радимо одразу після імпорту зберегти дані у файл .dta (див. вище), а не покладатися на XML-файл як на довгострокове сховище. Якщо xmluse недоступна у вашій установці STATA, натомість скористайтеся експортом CSV з LimeSurvey разом із командою STATA import delimited.

Зверніть увагу:

  • Через обмеження формату даних STATA довжина рядкових (текстових) змінних має максимум 244 символи (Stata версій 8–12) і 2045 символів (Stata версії 13 і новіше). Вкажіть вашу версію Stata в налаштуваннях плагіна експорту.
  • STATA підтримує прив'язування міток значень лише до числових значень. Тому, щоб отримати короткі відповіді (зазвичай одна-дві цифри) з правильними мітками, слід використовувати числові коди відповідей у LimeSurvey (1=Повністю згоден). Якщо використовуються нечислові коди відповідей (A=Повністю згоден), то як відповідь буде використано повний текст відповіді (напр.: «Повністю згоден»).

VVExport і VVImport

 Hint: This feature changed with version 2.05


Після початку збору відповідей можуть виникнути ситуації, коли потрібно безпосередньо редагувати та змінювати великі обсяги даних із таблиці відповідей, і тоді зручнішим може бути інструмент для роботи з електронними таблицями.

VVExport («VV» означає vertical verification — вертикальна перевірка) дозволяє експортувати таблицю відповідей у файл .csv. Поки загальна структура файлу залишається незмінною, ви можете редагувати значення в ньому, а потім знову імпортувати файл до таблиці відповідей за допомогою функції «VVImport».

Що слід враховувати:

  • Якщо ви хочете імпортувати відповіді за допомогою «VVImport», обов'язково перевірте, чи слід додати відповіді до наявних, чи перезаписати всі відповіді.
  • Якщо ви намагаєтеся імпортувати відповіді з іншого, але ідентичного опитування (наприклад, з ідентичними питаннями/відповідями з іншого опитування), переконайтеся, що ви використовуєте правильний файл vv і що перші два рядки файлу .csv правильні.
  • Якщо ви імпортуєте опитування до вашої установки LimeSurvey, SID (за можливості) не зміниться. Однак ідентифікатор групи та ідентифікатор питання можуть змінитися. Тому вам може знадобитися скоригувати перші два рядки заголовків відповідно до нового ідентифікатора групи/питання. Див. Adjusting vv file headings

<span id="VVExport_file_version_2_ (New in 2.05 )">Файл VVExport версії 2 (New in 2.05 )

Ця нова функція дозволяє використовувати назви стовпців, відмінні від назв у базі даних. Якщо коди ваших питань унікальні, буде вибрано нову версію. У новій версії кожна назва стовпця використовує іменування змінних Qcode. Це, наприклад, дозволяє легше оновлювати наявне опитування в іншій установці.

Експорт файлу опитування VV

File:LimesurveyExportVVen.jpg

Коли ви вибираєте експорт відповідей за допомогою VVExport, вам буде запропоновано вибрати, яке опитування експортувати, і чи потрібно експортувати всі відповіді, лише завершені чи лише незавершені відповіді. Розширення файлу дозволяє вибрати, яке розширення матиме експортований файл. Для зручності слід вибрати .csv.

«Файл опитування vv» дозволяє імпортувати відповіді до опитування, коли комбінації питань/відповідей змінилися. Фактично це дозволяє додавати або видаляти питання в активному опитуванні.

Після натискання «Експортувати файл опитування VV» буде створено файл із роздільниками-табуляціями, який можна відкрити в Excel або подібній програмі для роботи з електронними таблицями. Перші два рядки таблиці — це мітки стовпців. Перший рядок — це «зрозумілий людині» заголовок стовпця, що описує назву поля питання/відповіді. Другий рядок — це внутрішня назва стовпця PHP/бази даних для цієї відповіді.

Не слід змінювати перші два рядки цієї таблиці, якщо ви хочете мати змогу пізніше «імпортувати» дані назад до LimeSurvey.

<span id="Exporting_a_VV_survey_file_ (New in 2.05 )">

Експорт файлу опитування VV (New in 2.05 )

 Hint: This feature is available starting in version 2.05


  • Експорт опитування : ID опитування, що експортується (лише для читання)
  • Експорт : Стан виконання відповідей, що експортуються
  • Розширення файлу : Розширення файлу. Файл є TSV (значення, розділені табуляцією). Для зручного відкриття в MS-Excel встановіть розширення .txt, а для LibreOffice, OpenOffice чи іншої програми для роботи з електронними таблицями можна залишити .csv.
  • Версія експорту VV : Версія 1.0 використовує заголовки стовпців бази даних, версія 2.0 використовує іменування змінних Qcode. Версія 2.0 вибрана за замовчуванням, якщо всі коди ваших питань унікальні.

Перші два рядки таблиці — це мітки стовпців. Перший рядок — це «зрозумілий людині» заголовок стовпця, що описує назву питання. Другий рядок — це справжня назва стовпця (внутрішня назва БД або Qcode) для цієї відповіді.

Редагування файлу опитування VV

Після успішного експорту файлу .vv ви можете відкрити та відредагувати його в програмі для роботи з електронними таблицями. Якщо під час відкриття файлу потрібно вибрати роздільник стовпців, використовуйте символ табуляції («Tab»). Якщо ви використовуєте не-ASCII символи, переконайтеся, що встановлено кодування «UTF-8».

  Якщо ви використовуєте Microsoft Excel для редагування експортованого файлу vv, майте на увазі, що Excel руйнує початкову структуру даних файлу. Це спричиняє помилку під час спроби повторно імпортувати відредагований файл .vv.


За замовчуванням перші два рядки файлу .vv є заголовками. За потреби ви можете видалити перший рядок, щоб отримати справжній файл TSV. Існують різні випадки використання імпорту файлу .vv, тому ми розрізнятимемо додавання нових відповідей до опитування та перезапис усіх відповідей опитування.

Приклад структури файлу .vv:

TSV-файл VV версії 1

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	46492X40X1991
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1

TSV-файл VV версії 2

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	QCODE
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1


Тут ідентифікатори SGQA не використовуються — натомість у другому рядку використовується іменування змінних Qcode QCODE.

Зарезервовані імена

Файл .VV використовує фігурні дужки для зарезервованих імен. Під час імпорту ці рядки замінюються на:

  • {question_not_shown} : значення NULL у базі даних. LimeSurvey використовує [порожній рядок] для питання без відповіді та значення NULL для питання, яке не було показано (через Expression Manager або максимальний крок в опитуванні).
  • {quote} : " (подвійні лапки)
  • {cr} : повернення каретки
  • {newline} : новий рядок
  • {lbrace} : ліва дужка (наприклад, якщо потрібно отримати {cr} у відповіді, використовуйте {lbrace}cr} )

Редагування VV версії 1

Додавання нових відповідей до наявних відповідей опитування

Це не підтримується для версії 1 формату, оскільки легко може призвести до різних проблем, зокрема до імпорту даних у неправильні стовпці. Версія 1 файлу .vv завжди призначалася для вертикальної верифікації даних у зовнішньому інструменті, як-от Excel, а не для об’єднання даних з різних джерел (наприклад, того самого опитування, що працює на іншому сервері).

Зміна всіх відповідей опитування

Якщо потрібно змінити відповіді опитування, просто відредагуйте файл.

Приклад:

Крок 1: відкрийте файл

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
183	09.11.11 11:44	3	de	4
184	09.11.11 11:53	3	de	2
190	09.11.11 11:44	3	de	1


Крок 2: змініть відповіді

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
1000	09.11.11 11:44	3	de	3
1001	09.11.11 11:53	3	de	3
1002	09.11.11 11:44	3	de	3

Після цього можна імпортувати опитування, обов’язково замінивши наявні відповіді (див. «Імпорт файлу опитування VV»).

Імпорт файлу опитування VV

File:LimeSurveyImportVVen.jpg

Якщо перші два рядки не пошкоджені, ви можете імпортувати дані з файлу опитування vv назад в активне опитування LimeSurvey.

Якщо для редагування експортованого файлу vv використовувався Microsoft Excel, структура даних цього файлу може бути пошкоджена, і LimeSurvey не зможе імпортувати відредагований файл. Щоб імпорт пройшов без помилок, можна скористатися таким обхідним шляхом:

  • Відкрийте експортований файл vv в Excel і внесіть зміни (імовірно, ви це вже зробили)
  • Збережіть його як текстовий файл із розділенням табуляцією (буде створено новий файл із розширенням .txt)
  • Виконайте ще один «чистий» експорт vv із LimeSurvey
  • Відкрийте цей новий експортований файл vv у текстовому редакторі, наприклад у Блокноті або іншому (я використовував textwrangler на Mac)
  • Натисніть CTRL + A, щоб виділити весь вміст, і видаліть його
  • Відкрийте файл vv, відредагований в Excel (текстовий файл .txt із розділенням табуляцією), у текстовому редакторі та натисніть CTRL + A, щоб виділити весь вміст
  • Натисніть CTRL + C, щоб скопіювати вміст, і вставте його в новий (тепер порожній) файл vv
  • Натисніть CTRL + S, щоб зберегти файл як є (як .csv)
  • Тепер спробуйте імпортувати цей файл

Потім на екрані перегляду виберіть значок «Імпортувати файл опитування VV».

На екрані «Імпортувати файл опитування VV» потрібно вибрати файл «vvexport», який ви імпортуєте. Якщо ви виберете «Виключити запис IDs?», записи буде імпортовано, і для них буде згенеровано абсолютно нові ID записів (використовуйте цей параметр для сценарію «Додавання нових відповідей до наявних відповідей опитування»). Якщо зняти цей прапорець, буде імпортовано початкові ID записів (використовуйте цей параметр для сценарію «Перезапис усіх відповідей опитування»).

Можна вибрати один із варіантів, які визначають, як LimeSurvey має обробляти дубльовані або множинні записи.

  • Повідомити про помилку (та пропустити новий запис).
  • Перенумерувати новий запис
  • Замінити існуючий запис (використовуйте для сценарію «Перезапис усіх відповідей опитування»)

<span id="Importing_a_VV_survey_file_ (New in 2.05 )">

Імпорт файлу опитування VV (New in 2.05 )

  • Файл : виберіть файл для завантаження. Файл має бути файлом TSV: текстовим файлом, у якому стовпці розділені табуляцією.
  • Виключити запис IDs? : якщо у файлі є стовпець «id», ви можете виключити цей рядок або ні. Якщо цей параметр позначено, для кожного рядка файлу .vv додається новий запис. Якщо не позначено, можна вибрати:
  • Коли імпортований запис відповідає існуючому запису ID:
    • skip : Повідомити та пропустити новий запис. Після завантаження ви побачите, чи запис уже існував — якщо він існував, його не буде імпортовано.
    • renumber : Перенумерувати новий запис. До таблиці відповідей додається новий запис з відповіддю з файлу VV.
    • replace : Замінити існуючий запис. Старий запис видаляється й повністю замінюється записом із файлу VV.
    • replaceanswer : Замінити деталі відповіді з файлу в існуючому записі. Старий запис оновлюється новою відповіддю з файлу VV. Це дозволяє замінити лише одне питання в таблиці відповідей.
  • Імпортувати як незавершену відповідь? : якщо позначено, submitdate встановлюється в NULL, тому відповідь вважається незавершеною.
  • Набір символів з файлу : ви можете вибрати набір символів файлу — типове й рекомендоване значення UTF-8, але деякі програми для роботи з електронними таблицями не дозволяють вибирати набір символів.
  • Перший рядок містить коди питань : за замовчуванням перший рядок файлу VV містить питання в зручному для читання вигляді, а справжні назви стовпців розташовані в другому рядку. Цей параметр дозволяє використовувати перший рядок як справжні назви стовпців.
  • Примушений імпорт : якщо коди питань не знайдено ні в імені бази даних, ні в іменуванні змінних Qcode, стовпці призначаються відповідно до порядку. Це можна використати для імпорту файлу VV з іншого екземпляра LimeSurvey, але кожне опитування має бути абсолютно однаковим. Наполегливо рекомендуємо використовувати це, лише якщо ви розумієте, що робите. Це може бути дуже небезпечно й призвести до того, що результати опиняться в неправильному стовпці.

Інші параметри експорту

Експорт окремої відповіді

Якщо потрібно експортувати окрему відповідь, це можна зробити трьома способами:

1. Увійдіть в адміністративну частину LimeSurvey, виберіть своє опитування, перейдіть до «Змінити налаштування опитування» -> «Notification and data management» і переконайтеся, що ви отримуєте базові сповіщення електронною поштою.

Щоразу, коли хтось завершує опитування, ви отримуватимете електронний лист із посиланням: "Click the following link to see the individual response"

Це відкриє сторінку з кнопкою над даними "Експортувати цю відповідь"

2. Увійдіть в адміністративну частину LimeSurvey, виберіть своє опитування та "Проглянути відповіді". Натисніть "Display responses" та номер ідентифікатора, який потрібно експортувати, у лівому стовпці. Потім над даними можна натиснути "Export this survey".

3. Увійдіть в адміністративну частину LimeSurvey, виберіть своє опитування та "Експортувати результати". В останньому полі над "Експортувати дані" можна вибрати, який запис потрібно експортувати.

Зіставлення відповідей з різних опитувань

Якщо ви хочете відстежувати відповіді певних осіб на опитування з плином часу, LimeSurvey може вам у цьому допомогти. Наприклад, можна відстежувати відповіді групи до та після проходження нею певного семінару.

Для цього виконайте такі кроки:

1. Створіть опитування

2. Переконайтеся, що опитування не є анонімним і використовує токени. Щоб створити неанонімне опитування:

a - Натисніть на піктограму Загальні налаштування.

b - Потім на вкладці Tokens виберіть "Ні" для параметра Анонімні відповіді.

3. Активуйте опитування.

Під час активації опитування натисніть кнопку "Перейдіть у режим закритого доступу", щоб створити таблицю токенів:

4. Заповніть таблицю токенів будь-яким зручним способом (дотримуйтесь інструкцій на сторінці Токени).

5. Експортуйте результати опитування та переконайтеся, що ви включили інформацію про токени.

Щоб експортувати, натисніть Проглянути відповіді...

...а потім Експорт:

Не забудьте вибрати один або кілька елементів із таблиці токенів, щоб пов’язати їх із відповідями на опитування:

6. Коли ви запускаєте опитування знову, що легко зробити, скопіювавши опитування й таблицю токенів за допомогою експорту/імпорту, просто повторіть ці кроки та переконайтеся, що для створення CSV-файлу імпорту токенів використовується той самий запит.

Проблеми та рішення

Excel

Зміна відповідей в Excel перед імпортом

Щоб внести багато змін до відповідей, можна експортувати файл і відкрити його в Excel. Змініть дані (окрім верхніх рядків), а потім збережіть як файл .txt. Якщо зберегти як .csv, Excel використовує роздільники-коми, і такий файл не буде імпортовано в LimeSurvey. Якщо зберегти як .txt, Excel зберігає файл із табуляцією як роздільником, який можна імпортувати назад у LimeSurvey.

Редагування .csv за допомогою Excel

Загалом ми не радимо використовувати Excel для редагування експортованих файлів .csv, оскільки Excel вносить зміни до внутрішньої структури даних, через що імпорт завершується помилкою. Якщо ви все ж хочете використовувати Excel, потрібно встановити кому як роздільник у Панелі керування (системи Windows):

Панель керування|Мова та регіональні стандарти|Регіональні параметри, налаштувати...|Числа|Роздільник груп розрядів| замініть ; на ,

Обхідний шлях для редагування .csv-файлів в Excel

Використання Excel для редагування питань може унеможливити їх повторний імпорт. Проте редагування в Excel — найкращий варіант, якщо у вас більше 5 варіантів відповіді або варіантів для ранжування і ви хочете скористатися можливостями Excel, наприклад сортуванням тощо.

Це частковий обхідний шлях, який, схоже, працює у версії 1.82. По суті, використовуйте Excel лише для тієї частини файлу, що містить дані:

  • Експортуйте питання, схоже на те, яке ви хочете використати повторно, як .csv-файл
  • Відкрийте CSV-файл у текстовому редакторі
  • Скопіюйте частину з відповідями в Excel і розбийте її за допомогою «Текст за стовпцями» або аналогічної функції.
  • Скористайтеся можливостями Excel для вставлення тексту в стовпці, щоб вставити 20, 50, 100 відповідей — скільки потрібно
  • Збережіть файл як Excel CSV, у якому, імовірно, не буде лапок.
  • Відкрийте цей файл у редакторі, виберіть усе та скопіюйте
  • Поверніться до файлу, який ви відкрили в текстовому редакторі
  • Вставте скопійоване поверх тамтешніх відповідей
  • Збережіть як, з іншою назвою, можливо, такою, яку ви зможете запам’ятати для повторного використання
  • Імпортуйте цей файл.

Excel — експорт обмежений 255 стовпцями

Через обмеження Excel (версії 2003 і нижчі) LimeSurvey може експортувати одночасно лише 255 стовпців. Microsoft запропонувала обхідний шлях у вигляді VB-макросу.

Хоча новіші електронні таблиці (Excel >= 2007, OpenOffice) можуть відображати більше ніж 255 стовпців, внутрішній модуль, який використовує LimeSurvey, усе ще не може експортувати більше 255 стовпців.

Проте можливі два обхідні шляхи, скористайтеся одним із них:

  • Або експортуйте в CSV та імпортуйте в електронну таблицю
  • Або виконайте кілька експортів (вибираючи щоразу не більше 250 стовпців), а потім об’єднайте експортовані результати

Excel/.csv — експорт не вдається

Якщо вам не вдається експортувати дані в Excel або в .csv-файл, спробуйте очистити кеш і файли cookie браузера.

CSV

CSV за замовчуванням містить 255 стовпців

Під час експорту великих опитувань графічний інтерфейс за замовчуванням обмежує експорт першими 255 стовпцями. Щоб обійти це обмеження, просто позначте всі набори даних для експорту.

Експорт у SPSS

Загальні кроки

Щоб імпортувати дані відповідей LimeSurvey, виконайте такі кроки:

  1. Натисніть піктограму «Експорт у SPSS».
  2. У полях вибору виберіть, які відповіді потрібно експортувати, і вашу версію SPSS.
  3. Завантажте обидва файли: .sps (файл команд синтаксису SPSS) і .dat (файл даних)
  4. Відкрийте .sps-файл у SPSS: запустіть SPSS, виберіть «Choose another type of file» і виберіть завантажений .sps-файл.
  5. Тепер усередині SPSS відкриється редактор, де можна редагувати команди з цього файлу. Знайдіть рядок, що починається з '/FILE=...'
  6. Відредагуйте цей рядок і змініть шлях так, щоб він вказував на ваш .dat-файл. Приклад: ваш *.dat-файл знаходиться в c:\temp, тому задайте рядок як /FILE='c:\temp\survey_(xxxx)_SPSS_data_file.dat'
  7. Тепер виберіть усі команди в редакторі, натиснувши CTRL-A.
  8. У меню SPSS виберіть Run/All.
  9. Будьте терплячими: імпорт усіх даних і міток триватиме певний час. Стежте за ходом виконання в рядку стану.
  10. Готово!

Можливі повідомлення про помилки в SPSS

ERROR. command name:Get Data

Якщо ви отримуєте повідомлення про помилку ERROR. command name:Get Data. 2267 Unexpected Token missing., відредагуйте четвертий рядок файлу синтаксису так, щоб він вказував на абсолютний шлях до файлу даних, наприклад

C:\spss\Data\limesurvey\SPSS\survey_35276_SPSS_data_file.dat

Помилка: "Text value unmappable in the current server locale"

Ця помилка може виникнути, якщо ви намагаєтеся відкрити експортований файл синтаксису в SPSS 16. Рішення — примусово змусити SPSS інтерпретувати файл синтаксису як unicode.

Відкрийте SPSS. Перейдіть до Edit > Options > Character encoding for data and syntax. Змініть параметр на "unicode".

Тепер дані LimeSurvey можна без проблем експортувати в SPSS 16.

Визначення шкали для вашої змінної

Можна змінити шкалу за замовчуванням для змінної, встановивши для атрибута питання scale_export відповідне значення.

Експорт/імпорт VV

VV — проблеми з імпортом vv

Якщо у вас виникають труднощі з імпортом vv-файлу, спробуйте файл із табуляцією як роздільником — він має працювати без проблем.

Інші проблеми та рішення

Копіювання відповідей в інше опитування (за допомогою токенів)

  1. Створіть нове опитування, додайте фіктивну відповідь, експортуйте файл відповідей і відкрийте його в Excel. Це створить формат для нового файлу імпорту.
  2. Експортуйте відповіді зі старого опитування разом із токенами та відкрийте в Excel.
  3. Використайте ці дані, щоб створити аркуш Excel для стандартного імпорту файлу токенів (наприклад, Firstname, Lastname, Token, Email адреса, Статус листа (OK), Language (En)). Збережіть як .csv та імпортуйте токени в нове опитування в LimeSurvey.
  4. В Excel скопіюйте поля відповідей зі старих відповідей опитування, які потрібні в новому опитуванні (разом із токеном), у відповідний стовпець Excel формату нового опитування.
  5. Збережіть як .txt-файл.
  6. Скористайтеся VVImport, щоб імпортувати нові дані в нове опитування.
  7. Можливі помилки імпорту стосуються формату дати: деякі системні поля дати не допускають значення NULL, а деякі допускають. Якщо дата виглядає правильно, але виникає помилка, використайте формат клітинки Excel "2009-12-01".