x

주요 장

  1. LimeSurvey Cloud vs LimeSurvey CE
  2. 빠른 시작 가이드 - LimeSurvey 3.0+
  3. 설치 - LimeSurvey CE
  4. 좋은 설문조사를 디자인하는 방법(가이드)
  5. 시작하기
  6. LimeSurvey 관리
  7. 설문조사 - 소개
  8. 설문조사 설정
  9. 설문조사 메뉴
  10. 설문 조사 구조
  11. 질문 - 소개
  12. 질문 그룹 - 소개
  13. 설문조사 관리
  14. 설문조사 도구 모음 옵션
  15. 다국어 설문조사
  16. ExpressionScript 엔진 - 빠른 시작 가이드
  17. 미분류 및 고급 기능
  18. 일반 FAQ
  19. 문제 해결
  20. 해결 방법
  21. 특허
  22. 버전 변경 로그
  23. 플러그인 - 고급
 Actions

결과 내보내기

From LimeSurvey Manual

이 페이지는 기계 번역되었을 수 있으며 오류가 포함되어 있을 수 있습니다. 영어 원문 보기 · 이 번역 개선하기
This page is a translated version of the page Exporting results and the translation is 100% complete.
  주의 : 다음 섹션은 오래된 내용입니다. 최신 정보는 아래 문서를 확인해 주세요:




설문조사를 활성화하면 답변을 확인하고 내보낼 수 있습니다. 설문조사 응답 개요로 이동하려면 답변 -> 답변 & 통계를 클릭하세요.

애플리케이션으로 내보내기 (Excel/.csv)

페이지 상단에 여러 가지 내보내기 옵션이 표시됩니다.

결과를 내보낼 때 여러 가지 필터 옵션을 사용할 수 있습니다:

  • 일반
    • 범위 설정 (예: "X번부터 Y번까지의 레코드 내보내기")
    • 모든 레코드 또는 완료된 레코드만 또는 미완료 레코드만 내보내도록 설정
  • 질문
    • 제목 표시 방식 결정: 축약된 제목 또는 전체 제목 또는 질문 코드
    • 질문의 공백을 언더스코어로 바꾸기
  • 응답
    • 모든 응답을 내보내거나 응답 코드 Y와 N을 지정한 값으로 변환하여 내보낼 수 있습니다.
  • 서식
    • Microsoft Word (라틴 문자 집합)
    • Microsoft Excel (모든 문자 집합)
    • CSV 파일 (모든 문자 집합)
    • HTML
    • PDF
  • 열 제어
    • 내보낼 응답을 설정합니다. 이 목록의 모든 응답은 SGQA 식별자로 표시됩니다.
    • 내보낼 토큰 데이터를 설정합니다. 이 옵션은 설문조사가 익명이 아닌 경우에만 사용할 수 있습니다!

SPSS 내보내기

일반

SPSS Statistics는 일괄 및 비일괄 방식의 논리적 통계 분석에 사용되는 소프트웨어입니다. 공식 SPSS 패키지를 사용하거나, 상용 프로그램인 SPSS의 대체 프로그램인 GNU PSPP를 사용할 수 있습니다.

답변 데이터를 SPSS로 내보내려면 답변 & 통계 섹션으로 이동하여 SPSS로 내보내기 아이콘을 클릭하세요.

데이터 내보내기 및 필터링

SPSS로 데이터를 내보낼 때는 두 가지 필터 옵션이 있습니다. 어떤 데이터를 선택할지(모든 레코드/완료된 레코드만/미완료 레코드만)와 내보낸 파일을 어떤 SPSS 버전에서 사용할지(16 이전 버전/16 이상)를 선택할 수 있습니다.

SPSS 내보내기에는 두 개의 파일이 포함됩니다:

  1. 구문 파일 (survey_xxxx_SPSS_syntax_file.sps)
  2. 그리고 데이터 파일 (survey_xxxx_SPSS_data_file.dat)

이 파일들을 다운로드한 후 메모장과 같은 일반 텍스트 편집기로 열어 내보낸 데이터의 모양을 확인할 수 있습니다. 구문 파일에는 데이터를 가져오기 위해 실행해야 하는 명령이 들어 있습니다. SPSS 내부의 프로그래밍 언어와 비슷합니다. 데이터 파일은 모든 데이터가 쉼표로 구분된 파일입니다. 이 데이터를 마법사를 통해 단순히 csv로 가져오면 질문, 라벨 세트 등에 대한 정보가 손실되므로 그렇게 하지 않습니다.

SPSS로 데이터 가져오기

두 파일을 드라이브의 같은 폴더에 두세요. (예: c:\data\survey_xxxx_SPSS_syntax_file.sps 및 c:\data\survey_xxxx_SPSS_data_file.dat)

이제 두 가지 방법이 있습니다:

1. Windows를 사용하는 경우 탐색기에서 위에서 사용한 폴더로 이동합니다. SPSS가 .sps 파일 확장자와 연결되어 있다면 파일을 더블 클릭하여 바로 열 수 있습니다:

이제 열린 창에서 Run->All을 선택하면 잠시 후 출력 데이터 세트가 생성되며, 이를 일반 .sav 파일로 저장할 수 있습니다.

2. 위의 간단한 방법이 작동하지 않는 경우가 있습니다. 이럴 때는 다음과 같이 진행하세요:

  • SPSS를 엽니다.
  • File->Open->Syntax를 선택합니다.
  • 알맞은 파일을 선택합니다: c:\data\survey_xxxx_SPSS_syntax_file.sps
  • 이제 구문이 열립니다.
  • /FILE='survey_xxxx_SPSS_data_file.dat' 줄을 파일이 있는 경로를 포함하도록 변경합니다: /FILE='c:\data\survey_xxxx_SPSS_data_file.dat' , Mac 사용자의 경우: /FILE='HD/Users/username/survey_xxxx_SPSS_data_file.dat'
  • 이제 명령 텍스트 전체를 선택하고 메뉴에서 Run->All을 선택하면, 잠시 후(기다려 주세요) 질문, 라벨 등 모든 정보가 포함된 데이터 세트가 생성됩니다.

R 내보내기

더 많은 정보가 있다면 자유롭게 추가해 주세요!

무료 소프트웨어인 R은 SPSS의 대안입니다. LimeSurvey의 애플리케이션으로 내보내기 기능 중 하나입니다.

데이터 세트를 R로 가져오는 방법:

  1. 구문 파일과 데이터 파일을 모두 다운로드합니다.
  2. 두 파일을 R 작업 디렉터리에 저장합니다 (R 명령 창에서 getwd()와 setwd()를 사용하여 확인하고 설정할 수 있습니다).
  3. R 명령 창에 source("Surveydata_syntax.R", encoding = "UTF-8")를 입력하면 데이터가 올바른 형식으로 "data"라는 데이터 프레임에 가져와집니다.


선택지가 제한된 답변은 수준(level)이 질문의 코드와 일치하고 라벨이 선택지와 일치하는 팩터(factor)로 처리됩니다.

"기타" 옵션이 있는 질문은 기타 데이터를 위한 새 열로 질문 필드 뒤에 _Other가 추가된 필드가 생성됩니다.

참고: R 내보내기는 LimeSurvey의 플러그인입니다. 결과 내보내기 아래에서 R 내보내기 옵션(R (신택스 파일), R (데이터 파일))을 찾을 수 없다면 플러그인 메뉴에서 R 내보내기 플러그인이 활성화되어 있는지 확인하십시오.

STATA-xml 내보내기

STATA는 상용 데이터 분석 및 통계 소프트웨어 패키지입니다.

이 내보내기 기능은 LimeSurvey로 수집한 데이터를 빠르게 분석할 수 있도록 만들어졌습니다. STATA 고유 형식의 XML 파일을 생성하며, STATA가 실행되는 플랫폼에 관계없이 가져올 수 있습니다. 이 형식을 사용하면 일반 CSV 파일을 가져오는 것보다 다음과 같은 여러 장점이 있습니다.

  • 데이터 세트에 변수 레이블(질문, 하위 질문)과 값 레이블(해당하는 경우 응답)이 모두 포함됩니다.
  • 날짜가 이미 STATA 내부 날짜 형식으로 변환되어 있어 날짜 간 차이 계산 등에 바로 사용할 수 있습니다.
  • 필요한 경우 변수 이름이 STATA와 호환되는 형식으로 변환됩니다.
  • 변수의 데이터 형식(문자열, 정수, 실수 등)이 기본 데이터에 맞게 이미 설정됩니다. (더 이상 문자열로 인코딩된 숫자가 없습니다!)

STATA에서 파일을 불러오는 방법: Stata 14 이하 버전에서는 이를 위해 File → Import → XML data 메뉴 항목을 제공했습니다. Stata 15부터는 해당 메뉴 항목이 더 이상 존재하지 않습니다. 대신 STATA의 Command 창에 다음 명령을 입력하십시오.

xmluse "survey_123456_STATA.xml", doctype(dta)

(파일 이름을 내보낸 파일의 경로로 바꾸십시오.) 데이터를 불러온 후에는 가져오기를 반복할 필요가 없도록 STATA의 바이너리 .dta 형식으로 저장할 수 있습니다.

save "survey_123456.dta"


참고: 위에서 사용한 xmluse/xmlsave 명령은 Stata 15부터 공식 문서화 및 지원 명령 목록에서 제거되었지만, 문서화되지 않은 레거시 기능으로 현재 버전에서도 여전히 작동합니다. 향후 STATA 릴리스에서 예고 없이 삭제될 수 있으므로, XML 파일을 장기 보관용으로 사용하지 말고 가져온 직후 데이터를 .dta 파일로 저장하는 것을 권장합니다(위 내용 참조). STATA 설치 환경에서 xmluse를 사용할 수 없는 경우, 대신 LimeSurvey의 CSV 내보내기와 STATA의 import delimited 명령을 함께 사용하십시오.

유의 사항:

  • STATA 데이터 형식의 제한으로 인해 문자열(텍스트) 변수의 길이는 최대 244자(Stata 버전 8-12), 2045자(Stata 버전 13 이상)입니다. 내보내기 플러그인의 설정에서 사용하는 Stata 버전을 지정하십시오.
  • STATA는 숫자 값에만 값 레이블을 연결할 수 있습니다. 따라서 짧은 응답(보통 한두 자리)을 사용하고 이를 올바르게 레이블링하려면 LimeSurvey에서 숫자 응답 코드(1=매우 그렇다)를 사용해야 합니다. 숫자가 아닌 응답 코드(A=매우 그렇다)를 사용하면 전체 응답 텍스트(예: '매우 그렇다')가 응답으로 사용됩니다.

VV 내보내기 및 VV 가져오기

 Hint: This feature changed with version 2.05


답변 수집을 시작한 후 답변 테이블의 대량 데이터를 직접 편집하고 수정해야 하는 경우가 있을 수 있으며, 이때는 스프레드시트 도구가 더 유용할 수 있습니다.

VVExport("VV"는 vertical verification의 약자)를 사용하면 답변 테이블을 .csv 파일로 내보낼 수 있습니다. 파일의 전체 구조가 유지되는 한 파일 안의 값을 편집한 다음 "VVImport" 기능을 사용하여 해당 파일을 답변 테이블로 다시 가져올 수 있습니다.

알아 두어야 할 사항:

  • "VVImport"를 사용하여 답변을 가져오려면 답변을 기존 답변에 추가할지, 모든 답변을 덮어쓸지 확인하십시오.
  • 다른 설문조사에서 동일한 답변(예: 다른 설문조사의 동일한 질문/응답)을 가져오려는 경우, 올바른 vv 파일을 사용하고 있는지, 그리고 .csv 파일의 처음 두 줄이 올바른지 확인하십시오.
  • LimeSurvey 설치 환경으로 설문조사를 가져오면 SID는 (가능한 경우) 변경되지 않습니다. 그러나 그룹 ID와 질문 ID는 변경될 수 있습니다. 따라서 새 그룹 ID/질문 ID에 맞게 처음 두 개의 머리글 줄을 조정해야 할 수 있습니다. vv 파일 머리글 조정을 참조하십시오.

<span id="VVExport_file_version_2_ (New in 2.05 )">VVExport 파일 버전 2 (New in 2.05 )

이 새로운 기능을 사용하면 데이터베이스와 다른 열 이름을 사용할 수 있습니다. 질문 코드가 고유하면 새 버전이 선택됩니다. 새 버전에서는 각 열 이름이 Qcode 변수 이름 지정 방식을 사용합니다. 예를 들어 다른 설치 환경에 있는 기존 설문조사를 더 쉽게 업데이트할 수 있습니다.

VV 서베이 파일 내보내기

File:LimesurveyExportVVen.jpg

VVExport를 사용하여 답변을 내보내도록 선택하면 내보낼 설문조사를 선택하고, 모든 답변, 완료된 답변만 또는 미완료된 답변만 내보낼지 선택할 수 있습니다. 파일 확장자를 통해 내보낼 파일의 확장자를 선택할 수 있습니다. 쉽게 사용하려면 .csv를 선택하는 것이 좋습니다.

'vv 서베이 파일'을 사용하면 질문/응답 조합이 변경된 경우에도 설문조사에 답변을 가져올 수 있습니다. 즉, 활성화된 설문조사에서 질문을 추가하거나 제거할 수 있습니다.

"VV 서베이 파일 내보내기"를 클릭하면 Excel 또는 유사한 스프레드시트 프로그램에서 열 수 있는 탭으로 구분된 파일이 생성됩니다. 스프레드시트의 처음 두 행은 열 레이블입니다. 첫 번째 행은 질문/응답 필드의 이름을 설명하는 "사람이 읽을 수 있는" 열 머리글입니다. 두 번째 행은 해당 답변의 내부 PHP/데이터베이스 열 이름입니다.

나중에 데이터를 LimeSurvey로 다시 "가져오"려면 이 스프레드시트의 처음 두 행을 수정하면 안 됩니다.

<span id="Exporting_a_VV_survey_file_ (New in 2.05 )">

VV 서베이 파일 내보내기 (New in 2.05 )

 Hint: This feature is available starting in version 2.05


  • 설문조사 출력 : 내보낼 설문조사 ID (읽기 전용)
  • 내보내기 : 내보낼 답변의 완성 상태
  • 파일 확장자 : 파일 확장자입니다. 이 파일은 TSV(탭으로 구분된 값) 파일입니다. MS-Excel에서 쉽게 열려면 확장자를 .txt로 설정하고, LibreOffice, OpenOffice 또는 기타 스프레드시트 프로그램에서는 .csv로 그대로 두어도 됩니다.
  • VV 내보내기 버전 : 1.0 버전은 데이터베이스 열 머리글을 사용하고, 2.0 버전은 Qcode 변수 이름 지정을 사용합니다. 모든 질문 코드가 고유한 경우 2.0 버전이 기본으로 선택됩니다.

스프레드시트의 처음 두 행은 열 레이블입니다. 첫 번째 행은 질문의 이름을 설명하는 "사람이 읽을 수 있는" 열 머리글입니다. 두 번째 행은 해당 답변의 실제 열 이름(내부 DB 이름 또는 Qcode 이름)입니다.

VV 서베이 파일 편집

.vv 파일을 성공적으로 내보낸 후에는 스프레드시트 도구를 사용하여 파일을 열고 편집할 수 있습니다. 파일을 열 때 열 구분 기호를 선택해야 하는 경우 "탭" 문자를 사용하십시오. ASCII가 아닌 문자를 사용하는 경우 문자 집합을 "UTF-8"로 설정하십시오.

  내보낸 vv 파일을 편집하는 데 Microsoft Excel을 사용하는 경우, Excel이 파일의 원래 데이터 구조를 손상시킨다는 점을 알아 두십시오. 이로 인해 편집한 .vv 파일을 다시 가져올 때 오류가 발생합니다.


기본적으로 .vv 파일의 처음 두 행은 머리글입니다. 필요한 경우 첫 번째 줄을 제거하여 실제 TSV 파일로 만들 수 있습니다. .vv 파일을 가져오는 사용 사례는 다양하므로 설문조사에 새 답변을 추가하는 경우와 설문조사의 모든 답변을 덮어쓰는 경우를 구분하여 설명합니다.

.vv 파일의 구조 예시:

VV 버전 1 TSV 파일

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	46492X40X1991
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1

VV 버전 2 TSV 파일

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	QCODE
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1


여기에서는 SGQA 식별자를 사용하지 않고, 두 번째 줄에 Qcode 변수 명명 규칙 QCODE를 사용합니다.

예약된 이름

.VV 파일은 예약된 이름에 중괄호를 사용하며, 가져오기 시 이 문자열은 다음과 같이 대체됩니다:

  • {question_not_shown} : 데이터베이스의 NULL 값. LimeSurvey는 답변하지 않은 질문에는 [빈 문자열]을, 표시되지 않은 질문(표현식 관리자 또는 설문조사의 최대 단계에 의해 표시되지 않은 경우)에는 NULL 값을 사용합니다.
  • {quote} : " (큰따옴표)
  • {cr} : 캐리지 리턴
  • {newline} : 줄 바꿈
  • {lbrace} : 왼쪽 중괄호 (예를 들어, 답변에 {cr}을 그대로 넣고 싶다면 {lbrace}cr}을 사용하세요)

VV 버전 1 편집

설문조사의 기존 답변에 새 답변 추가하기

이 기능은 VV 형식 버전 1에서는 지원되지 않습니다. 데이터가 잘못된 열로 가져와지는 등 여러 문제가 쉽게 발생할 수 있기 때문입니다. .vv 파일 버전 1은 처음부터 Excel과 같은 외부 도구에서 데이터를 수직 검증하기 위한 용도로 만들어졌으며, 다른 서버에서 실행되는 동일한 설문조사와 같이 서로 다른 출처의 데이터를 통합하기 위한 용도가 아니었습니다.

설문조사의 모든 답변 수정하기

설문조사의 답변을 수정하려면 파일을 그대로 편집하면 됩니다.

예시:

단계 1: 파일 열기

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
183	09.11.11 11:44	3	de	4
184	09.11.11 11:53	3	de	2
190	09.11.11 11:44	3	de	1


단계 2: 답변 수정

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
1000	09.11.11 11:44	3	de	3
1001	09.11.11 11:53	3	de	3
1002	09.11.11 11:44	3	de	3

그런 다음 설문조사를 가져오면 됩니다. 이때 기존 답변을 덮어쓰도록 설정하세요("VV 설문조사 파일 가져오기" 참조).

VV 설문조사 파일 가져오기

File:LimeSurveyImportVVen.jpg

처음 두 줄이 그대로 유지되어 있다면, vv 설문조사 파일의 데이터를 활성화된 LimeSurvey 설문조사로 다시 가져올 수 있습니다.

Microsoft Excel로 내보낸 vv 파일을 편집했다면 파일의 데이터 구조가 손상되어 LimeSurvey가 편집된 파일을 가져오지 못할 수 있습니다. 다음 해결 방법을 사용하면 오류 없이 가져오기를 진행할 수 있습니다:

  • 내보낸 vv 파일을 Excel에서 열고 변경 작업을 수행합니다(이미 하셨을 것입니다).
  • 탭으로 구분된 텍스트 파일로 저장합니다(확장자가 .txt인 새 파일이 생성됩니다).
  • LimeSurvey에서 "깨끗한" vv 내보내기를 한 번 더 수행합니다.
  • 새로 내보낸 vv 파일을 메모장과 같은 텍스트 편집기로 엽니다(저는 Mac에서 TextWrangler를 사용했습니다).
  • CTRL + A를 눌러 전체 내용을 선택한 후 삭제합니다.
  • Excel에서 편집한 vv 파일(탭으로 구분된 .txt 파일)을 텍스트 편집기로 열고 CTRL + A를 눌러 전체 내용을 선택합니다.
  • CTRL + C를 눌러 내용을 복사한 후 새로운(이제 비어 있는) vv 파일에 붙여넣습니다.
  • CTRL + S를 눌러 그대로 저장합니다(.csv로 저장).
  • 이제 이 파일을 가져와 봅니다.

그런 다음 찾아보기 화면에서 "VV 설문조사 파일 가져오기" 아이콘을 선택하세요.

"VV 설문조사 파일 가져오기" 화면에서는 가져올 "vvexport" 파일을 선택해야 합니다. "기록된 ID들을 제외하시겠습니까?"를 선택하면 레코드를 가져오면서 새로운 레코드 ID가 생성됩니다("설문조사의 기존 답변에 새 답변 추가하기" 사용 사례에서 이 옵션을 사용하세요). 이 확인란의 선택을 해제하면 원래의 레코드 ID가 그대로 가져와집니다("설문조사의 모든 답변 덮어쓰기" 사용 사례에서 이 옵션을 사용하세요).

중복되거나 여러 번 입력된 항목을 LimeSurvey가 처리하는 방식을 지정하는 다양한 옵션을 선택할 수 있습니다.

  • 오류를 보고하고 새 레코드를 무시하고 넘어갑니다.
  • 새 기록에 새로운 번호를 부여합니다.
  • 기존 기록을 대체하세요("설문조사의 모든 답변 덮어쓰기" 사용 사례에서 이 옵션을 사용하세요).

<span id="Importing_a_VV_survey_file_ (New in 2.05 )">

VV 설문조사 파일 가져오기 (New in 2.05 )

  • 파일 : 업로드할 파일을 선택합니다. 파일은 TSV 파일이어야 합니다. 각 열이 탭(TAB)으로 구분된 텍스트 파일입니다.
  • 기록된 ID들을 제외하시겠습니까? : 파일에 'id' 열이 있는 경우 해당 열을 제외할지 여부를 선택할 수 있습니다. 이 설정을 선택하면 .vv 파일의 각 줄마다 새 레코드가 추가됩니다. 선택하지 않으면 다음 중에서 선택할 수 있습니다:
  • 가져온 기록이 존재하는 레코드 ID와 일치할 때:
    • skip : 보고 후 새 레코드를 무시하고 넘어갑니다. 업로드 후 해당 레코드가 이미 존재했는지 확인할 수 있으며, 이미 존재했다면 가져오지 않습니다.
    • renumber : 새 기록에 새로운 번호를 부여합니다. VV 파일의 답변이 담긴 새 레코드가 응답 테이블에 추가됩니다.
    • replace : 기존 기록을 대체하세요. 기존 레코드는 삭제되고 VV 파일의 레코드로 완전히 대체됩니다.
    • replaceanswer : 기존 레코드의 답변 세부 정보를 파일의 내용으로 대체합니다. 기존 레코드가 VV 파일의 새 답변으로 업데이트됩니다. 이를 통해 응답 테이블에서 질문 하나만 대체할 수 있습니다.
  • 완료되지 않은 답변으로 가져오시겠습니까? : 선택하면 submitdate가 NULL로 설정되어 답변이 완료되지 않은 상태가 됩니다.
  • 파일의 문자 세트 선택 : 파일의 문자 세트를 선택할 수 있습니다. 기본값이자 권장값은 UTF-8이지만, 일부 스프레드시트 프로그램에서는 문자 세트를 선택할 수 없습니다.
  • 첫 번째 줄에 질문 코드 포함 : 기본적으로 VV 파일의 첫 번째 줄에는 사람이 읽을 수 있는 질문이 들어 있고, 실제 열 이름은 두 번째 줄에 있습니다. 이 옵션을 사용하면 첫 번째 줄을 실제 열 이름으로 사용할 수 있습니다.
  • 강제 가져오기 : 질문 코드가 데이터베이스 이름이나 Qcode 변수 명명 규칙에서 발견되지 않으면 열이 순서에 따라 할당됩니다. 이 기능은 다른 LimeSurvey 인스턴스의 VV 파일을 가져올 때 사용할 수 있으나, 각 설문조사가 완전히 동일해야 합니다. 무엇을 하는지 정확히 알고 있는 경우에만 사용하시기를 강력히 권장합니다. 결과가 잘못된 열에 들어가는 매우 위험한 상황이 발생할 수 있습니다.

기타 내보내기 옵션

단일 답변 내보내기

개별 답변을 내보내려면 다음 3가지 방법 중 하나를 사용할 수 있습니다:

1. LimeSurvey 관리자 백엔드에 로그인하여 설문조사를 선택하고 "설문조사 설정 변경" -> "알림 및 데이터 관리"로 이동한 후, 기본 이메일 알림을 받도록 설정되어 있는지 확인하세요.

누군가 설문조사를 완료할 때마다 "개별 답변을 보려면 다음 링크를 클릭하십시오"라는 링크가 포함된 이메일을 받게 됩니다.

링크를 클릭하면 데이터 위에 "해당 답변 내보내기" 버튼이 있는 페이지로 이동합니다.

2. LimeSurvey 관리자 백엔드에 로그인하여 설문조사를 선택하고 "이 설문조사의 답변 열람"을 선택합니다. "답변 표시"를 클릭한 다음 왼쪽 열에서 내보내려는 ID 번호를 클릭합니다. 그런 다음 데이터 위의 "이 답변 내보내기"를 클릭하면 됩니다.

3. LimeSurvey 관리자 백엔드에 로그인하여 설문조사를 선택하고 "결과 내보내기"를 선택합니다. "자료 내보내기" 위의 마지막 필드에서 내보낼 항목을 선택할 수 있습니다.

서로 다른 설문조사의 답변 일치시키기

특정 개인의 설문조사 답변을 시간에 따라 추적하려는 경우 LimeSurvey를 사용할 수 있습니다. 예를 들어 그룹이 특정 세미나를 수강하기 전과 후의 그룹 답변을 추적하는 경우를 들 수 있습니다.

구현 단계는 다음과 같습니다.

1. 설문조사를 생성합니다.

2. 설문조사가 익명이 아니며 토큰을 사용하는지 확인합니다. 익명이 아닌 설문조사를 생성하려면 다음과 같이 합니다.

a - 일반 설정 아이콘을 클릭합니다.

b - 그런 다음 토큰 탭에서 익명 답변에 대해 "아니오(N)"를 선택합니다.

3. 설문조사를 활성화합니다.

설문조사를 활성화할 때 "비공개-접근 모드로 전환" 버튼을 클릭하여 토큰 테이블을 생성합니다.

4. 원하는 방법으로 토큰 테이블을 채웁니다(토큰 페이지의 안내를 따르십시오).

5. 설문조사 결과를 내보내고 토큰 정보를 포함해야 합니다.

내보내려면 답변 열람을 클릭합니다...

...그런 다음 내보내기를 클릭합니다.

설문조사 답변과 연결할 토큰 테이블의 요소를 하나 이상 선택해야 합니다.

6. 설문조사를 다시 실행할 때는(내보내기/가져오기로 설문조사와 토큰 테이블을 복사하면 쉽게 할 수 있습니다) 같은 단계를 반복하고, CSV 토큰 가져오기 파일을 만들 때 동일한 쿼리를 사용해야 합니다.

문제 및 해결 방법

Excel

가져오기 전에 Excel에서 답변 수정하기

여러 답변을 한꺼번에 변경하려면 파일을 내보내서 Excel에서 열 수 있습니다. 맨 위 줄을 제외한 데이터를 변경한 다음 .txt 파일로 저장하십시오. .csv로 저장하면 Excel이 쉼표 구분 형식을 사용하므로 LimeSurvey로 가져올 수 없습니다. .txt 파일로 저장하면 Excel이 탭 구분 파일로 저장하며, 이 파일은 LimeSurvey로 다시 가져올 수 있습니다.

Excel로 .csv 편집하기

일반적으로 내보낸 .csv 파일을 Excel로 편집하는 것은 권장하지 않습니다. Excel이 내부 데이터 구조를 변경하여 가져오기에 실패할 수 있기 때문입니다. 그래도 Excel을 사용하려면 시스템 제어(Windows 시스템)에서 Excel의 구분 기호를 쉼표로 설정해야 합니다.

System Control|Region- Languageoptions|Regional Settings, customize...|Tab Numbers|Digit grouping symbol| replace ; with ,

Excel로 .csv 파일을 편집하기 위한 해결 방법

Excel로 질문을 편집하면 나중에 다시 가져오지 못할 수 있습니다. 하지만 옵션이나 순위 옵션이 5개 이상이거나 정렬과 같은 Excel 기능을 사용하려는 경우에는 편집하는 것이 좋은 방법입니다.

다음은 1.82 버전에서 동작하는 것으로 보이는 부분적인 해결 방법이며, 기본적으로 파일에서 데이터에 해당하는 부분에만 Excel을 사용합니다.

  • 다시 사용하려는 질문과 비슷한 질문을 .csv 파일로 내보냅니다.
  • CSV 파일을 일반 텍스트 편집기로 엽니다.
  • 답변이 들어 있는 부분을 Excel로 복사한 다음 '텍스트 나누기' 또는 이에 상응하는 기능으로 열을 분리합니다.
  • Excel의 열 붙여넣기 기능을 활용하여 원하는 만큼(20개, 50개, 100개 등) 답변을 붙여넣습니다.
  • 파일을 Excel CSV로 저장합니다. 이 경우 따옴표가 없을 가능성이 높습니다.
  • 이 파일을 편집기에서 열어 모두 선택한 후 복사합니다.
  • 일반 텍스트 편집기로 열어 두었던 파일로 돌아갑니다.
  • 기존 답변 부분에 덮어쓰도록 붙여넣습니다.
  • 나중에 다시 사용할 수 있도록 기억하기 쉬운 다른 이름으로 저장합니다.
  • 이 파일을 가져옵니다.

Excel - 내보내기가 255개 열로 제한됨

Excel(2003 이하 버전)의 제한으로 인해 LimeSurvey는 한 번에 최대 255개 열만 내보낼 수 있습니다. Microsoft는 VB 매크로를 이용한 해결 방법을 제안했습니다.

최신 스프레드시트(Excel 2007 이상, OpenOffice)는 255개가 넘는 열을 표시할 수 있지만, LimeSurvey에서 사용하는 내부 모듈은 여전히 255개를 초과하는 열을 내보낼 수 없습니다.

그러나 다음 두 가지 해결 방법 중 하나를 사용할 수 있습니다.

  • CSV로 내보낸 후 스프레드시트에서 가져옵니다.
  • 한 번에 최대 250개 열을 선택하여 여러 번 내보낸 후, 내보낸 결과를 병합합니다.

Excel/.csv - 내보내기 실패

데이터를 Excel 또는 .csv 파일로 내보낼 수 없는 경우 브라우저의 캐시와 쿠키를 삭제해 보십시오.

CSV

CSV는 기본적으로 255개 열로 제한됨

규모가 큰 설문조사를 내보낼 때 GUI는 기본적으로 처음 255개 열로 내보내기를 제한합니다. 이를 해결하려면 내보낼 모든 데이터 집합을 선택하십시오.

SPSS 내보내기

일반 단계

LimeSurvey 답변 데이터를 가져오려면 다음 단계를 따르십시오.

  1. 'SPSS로 내보내기' 아이콘을 클릭합니다.
  2. 선택 상자에서 내보낼 답변과 SPSS 버전을 선택합니다.
  3. .sps 파일(SPSS 구문 명령 파일)과 .dat 파일(데이터 파일), 두 파일을 모두 다운로드합니다.
  4. SPSS를 실행한 후 '다른 유형의 파일 선택'을 선택하고 다운로드한 .sps 파일을 선택하여 엽니다.
  5. SPSS 안에서 편집기가 열리며 해당 파일의 명령을 편집할 수 있습니다. '/FILE=...'로 시작하는 줄을 찾습니다.
  6. 해당 줄의 경로를 .dat 파일이 있는 위치로 수정합니다. 예: *.dat 파일이 c:\temp에 있으면 이 줄을 /FILE='c:\temp\survey_(xxxx)_SPSS_data_file.dat'로 설정합니다.
  7. CTRL-A를 눌러 편집기 안의 모든 명령을 선택합니다.
  8. SPSS 메뉴에서 Run/All을 선택합니다.
  9. 모든 데이터와 레이블을 가져오는 데 시간이 걸리므로 기다려 주십시오. 진행 상황은 상태 표시줄에서 확인할 수 있습니다.
  10. 완료되었습니다!

SPSS에서 발생할 수 있는 오류 메시지

ERROR. command name:Get Data

ERROR. command name:Get Data. 2267 Unexpected Token missing. 오류 메시지가 나타나면 구문 파일의 네 번째 줄을 편집하여 다음과 같이 데이터 파일의 절대 경로를 지정하십시오.

C:\spss\Data\limesurvey\SPSS\survey_35276_SPSS_data_file.dat

오류: "Text value unmappable in the current server locale"

SPSS 16에서 내보낸 구문 파일을 열려고 할 때 이 오류가 발생할 수 있습니다. 해결 방법은 SPSS가 구문 파일을 유니코드로 해석하도록 설정하는 것입니다.

SPSS를 엽니다. Edit > Options > Character encoding for data and syntax로 이동하여 옵션을 "unicode"로 변경합니다.

이제 LimeSurvey 데이터를 SPSS 16으로 문제없이 내보낼 수 있습니다.

변수에 사용할 척도 정의

질문 속성 scale_export를 적절한 값으로 설정하면 변수에 사용되는 기본 척도를 재정의할 수 있습니다.

VV 내보내기/가져오기

VV - vv 가져오기 문제

vv 파일을 가져오는 데 어려움이 있으면 탭으로 구분된 파일을 사용해 보십시오. 문제없이 동작할 것입니다.

기타 문제 및 해결 방법

답변을 다른 설문조사로 복사하기(토큰 사용)

  1. 새 설문조사를 생성하고 더미 답변을 추가한 후 답변 파일을 내보내 Excel로 엽니다. 이렇게 하면 새 가져오기 파일의 형식을 만들 수 있습니다.
  2. 이전 설문조사의 답변을 토큰을 포함하여 내보낸 후 Excel로 엽니다.
  3. 이 데이터를 사용하여 표준 토큰 파일 가져오기를 위한 Excel 워크시트를 만듭니다(예: Firstname, Lastname, Token, 이메일 주소, 이메일 현황(OK), Language(En)). .csv로 저장한 후 LimeSurvey의 새 설문조사로 토큰을 가져옵니다.
  4. Excel에서 새 설문조사에 넣으려는 이전 설문조사의 답변 필드(토큰 포함)를 새 설문조사 형식의 해당 Excel 열로 복사합니다.
  5. .txt 파일로 저장합니다.
  6. VVImport를 사용하여 새 데이터를 새 설문조사로 가져옵니다.
  7. 가져오기 오류가 발생할 수 있는 원인으로는 날짜 형식이 있습니다. 일부 시스템 날짜 필드는 NULL 값을 허용하지 않고 일부는 허용합니다. 날짜가 올바르게 보이는데도 오류가 발생하면 Excel 셀 형식을 "2009-12-01"로 지정하십시오.