x

Capítulos principais

  1. LimeSurvey Cloud vs LimeSurvey CE
  2. LimeSurvey Cloud - Guia de início rápido
  3. Instalação - LimeSurvey CE
  4. Como criar um bom inquérito (guia)
  5. Iniciando
  6. Administrando o LimeSurvey
  7. Questionários - introdução
  8. Configurações do questionário
  9. Menu da pesquisa
  10. Estrutura da pesquisa
  11. Perguntas - introdução
  12. Grupos de perguntas - introdução
  13. Questionários - gerenciamento
  14. Opções da barra de ferramentas do questionário
  15. Questionário multilíngue
  16. ExpressionScript Engine - Guia de início rápido
  17. Recursos avançados e não categorizados
  18. FAQ geral
  19. Solução de problemas
  20. Soluções alternativas
  21. Licença
  22. Registro de mudanças da versão
  23. Plugins
 Actions

Exportando resultados

From LimeSurvey Manual

Esta página pode ter sido traduzida automaticamente e conter erros. Ver o original em inglês · Melhorar esta tradução
This page is a translated version of the page Exporting results and the translation is 100% complete.
  Atenção : A seção a seguir está desatualizada. Para obter informações atualizadas, consulte:




Depois que o seu questionário estiver ativo, você poderá começar a visualizar as respostas e exportá-las. Para acessar a visão geral das respostas do questionário, clique em: Registros -> Respostas & estatísticas

Exportar para um aplicativo (Excel/.csv)

No topo da página, várias opções de exportação são listadas.

Ao exportar resultados, há várias opções de filtro:

  • Geral
    • Defina um intervalo (por exemplo, "exportar registros de X a Y")
    • Defina para exportar todos os registros OU apenas os registros completos OU apenas os registros incompletos
  • Perguntas
    • Determine como o cabeçalho deve aparecer: cabeçalho abreviado OU cabeçalhos completos OU códigos de pergunta
    • Converter espaços no texto das perguntas para sublinhado (underscore)
  • Respostas
    • Você pode exportar as respostas completas ou converter os códigos de resposta Y e N para uma variável definida
  • Formato
    • Microsoft Word (conjunto de caracteres latinos)
    • Microsoft Excel (todos os conjuntos de caracteres)
    • Arquivo CSV (todos os conjuntos de caracteres)
    • HTML
    • PDF
  • Controle de colunas
    • Defina quais respostas devem ser exportadas. Todas as respostas nesta lista são representadas pelo seu identificador SGQA
    • Defina quais dados de código devem ser exportados. Esta opção só está disponível se o seu questionário não for anônimo!

Exportação para SPSS

Geral

O SPSS Statistics é um software usado para análise estatística lógica, em lote e não em lote. Você pode usar o pacote oficial do SPSS ou usar o GNU PSPP, uma alternativa ao programa proprietário SPSS.

Para exportar os dados de resposta para o SPSS, acesse a seção Respostas & estatísticas e clique no ícone de exportação para o SPSS.

Exportar e filtrar dados

Ao exportar dados para o SPSS, há duas opções de filtro. Você pode selecionar quais dados devem ser selecionados (todos os registros/apenas registros completos/apenas registros incompletos) e para qual versão do SPSS os arquivos de exportação serão usados (versão anterior à 16/16 ou acima).

A exportação para o SPSS inclui dois arquivos:

  1. um arquivo de sintaxe (survey_xxxx_SPSS_syntax_file.sps)
  2. e um arquivo de dados (survey_xxxx_SPSS_data_file.dat).

Depois de baixar esses arquivos, você pode abri-los com um editor de texto simples, como o Bloco de Notas, para ver como ficam os dados exportados. O arquivo de sintaxe contém os comandos que devem ser executados para importar os dados. É como uma linguagem de programação dentro do SPSS. O arquivo de dados contém um arquivo separado por vírgulas com todos os dados. Se você simplesmente importar esses dados como CSV por meio de um assistente, perderá informações sobre perguntas, conjuntos de rótulos etc., por isso não fazemos isso.

Importar dados no SPSS

Coloque os dois arquivos na mesma pasta do seu disco (exemplo: c:\data\survey_xxxx_SPSS_syntax_file.sps e c:\data\survey_xxxx_SPSS_data_file.dat)

Agora temos duas opções:

1. No Windows, use o Explorer para navegar até a pasta usada acima. Se o SPSS estiver associado à extensão de arquivo .sps, basta abrir o arquivo com um clique duplo:

Agora você pode escolher Run->All na janela aberta e, após algum tempo, terá o seu conjunto de dados de saída, que pode ser salvo como um arquivo .sav normal.

2. Às vezes a solução simples acima não funciona. Nesse caso, você pode proceder da seguinte forma:

  • Abra o SPSS
  • Escolha File->Open->Syntax
  • Escolha o arquivo apropriado: c:\data\survey_xxxx_SPSS_syntax_file.sps
  • Agora a sintaxe é aberta.
  • Altere a linha que contém /FILE='survey_xxxx_SPSS_data_file.dat' para incluir o caminho onde os arquivos estão: /FILE='c:\data\survey_xxxx_SPSS_data_file.dat' ; para usuários de Mac: /FILE='HD/Users/username/survey_xxxx_SPSS_data_file.dat'
  • Agora selecione todo o texto do comando e escolha Run->All no menu e, depois de algum tempo (seja paciente), você terá o conjunto de dados com todas as informações, como perguntas, rótulos etc.

Exportação para R

Sinta-se à vontade para adicionar mais informações, se tiver!

O software gratuito R é uma alternativa ao SPSS. No LimeSurvey, ele está disponível como uma exportação para aplicativo.

Instruções para importar o seu conjunto de dados no R:

  1. Baixe o arquivo de sintaxe e o arquivo de dados.
  2. Armazene ambos os arquivos no diretório de trabalho do R (use getwd() e setwd() na janela de comandos do R para obter e definir).
  3. No seu código, digite source("Surveydata_syntax.R", encoding = "UTF-8") na janela de comandos do R, o que importará os dados no formato correto para um data frame chamado "data".


As respostas com opções limitadas serão transformadas em fatores, com os níveis correspondendo ao código da pergunta e os rótulos correspondendo às opções.

As perguntas que têm "outro" como opção terão o campo da pergunta com _Other anexado como uma nova coluna para os dados de "outro".

Obs.: a exportação para R é um Plugin do LimeSurvey. Se você não encontrar as opções de exportação para R (R (arquivo de sintaxe), R (arquivo de dados)) em Exportar resultados para aplicativo, verifique se o Plugin de exportação para R está ativado no menu de Plugins.

Exportação para STATA-xml

O STATA é um pacote de software comercial de análise de dados e estatística.

Esta rotina de exportação foi criada para facilitar a análise rápida dos dados coletados com o LimeSurvey. Ela cria um arquivo XML no formato proprietário do STATA, que pode ser importado independentemente da plataforma em que o STATA é executado. O uso desse formato oferece várias vantagens em relação à importação de arquivos CSV simples:

  • Os conjuntos de dados são totalmente rotulados, incluindo rótulos de variáveis (pergunta, pergunta secundária) e rótulos de valores (respostas, se aplicável).
  • As datas já são transformadas para o formato interno de datas do STATA e, portanto, podem ser usadas diretamente para calcular a diferença entre dias etc.
  • Os nomes das variáveis são, se necessário, convertidos para um formato compatível com o STATA.
  • Os formatos de dados das variáveis (string, inteiro, ponto flutuante etc.) já são definidos de acordo com os dados subjacentes. (Chega de números codificados como strings!).

Como carregar o arquivo no STATA: As versões do Stata até a 14 ofereciam uma entrada de menu File → Import → XML data para isso. A partir do Stata 15, essa entrada de menu não existe mais. Em vez disso, digite o seguinte comando na janela Command do STATA:

xmluse "survey_123456_STATA.xml", doctype(dta)

(substitua o nome do arquivo pelo caminho do seu próprio arquivo exportado). Depois que os dados forem carregados, você pode salvá-los no formato binário .dta do STATA, para não precisar repetir a importação:

save "survey_123456.dta"


Nota: Os comandos xmluse/xmlsave usados acima foram removidos do conjunto de comandos oficialmente documentados e suportados do STATA a partir do Stata 15, embora ainda funcionem nas versões atuais como um recurso legado não documentado. Como uma versão futura do STATA pode removê-los sem aviso prévio, recomendamos salvar seus dados como um arquivo .dta (veja acima) imediatamente após a importação, em vez de depender do arquivo XML como armazenamento de longo prazo. Se xmluse não estiver disponível na sua instalação do STATA, use a exportação CSV do LimeSurvey junto com o comando import delimited do STATA.

Atenção:

  • Devido a uma limitação no formato de dados do STATA, o comprimento das variáveis de string (texto) tem um máximo de 244 caracteres (Stata versões 8-12) e 2045 caracteres (Stata versão 13 e superior). Indique a sua versão do Stata nas configurações do plugin de exportação.
  • O STATA só permite associar rótulos de valor a valores numéricos. Portanto, para obter respostas curtas (geralmente um ou dois dígitos) e com os rótulos corretos, deve-se usar códigos de resposta numéricos no LimeSurvey (1=Concordo totalmente). Se forem usados códigos de resposta não numéricos (A=Concordo totalmente), o texto completo da resposta será usado como resposta (ex.: 'Concordo totalmente').

VVExport e VVImport

 Hint: This feature changed with version 2.05


Depois de começar a coletar respostas, pode haver ocasiões em que você precise editar e modificar diretamente grandes quantidades de dados da sua tabela de respostas, e uma ferramenta de planilha pode ser mais útil.

O VVExport (o "VV" significa verificação vertical, do inglês "vertical verification") permite exportar a sua tabela de respostas para um arquivo .csv. Desde que a estrutura geral do arquivo permaneça intacta, você pode editar os valores nele contidos e depois importar o arquivo novamente para a sua tabela de respostas usando o recurso "VVImport".

Coisas que você deve saber:

  • Se você quiser importar respostas usando o "VVImport", verifique se as respostas devem ser adicionadas às respostas existentes ou se todas as respostas devem ser sobrescritas.
  • Se você estiver tentando importar respostas de um questionário diferente, porém idêntico (por exemplo, com perguntas/respostas idênticas de outro questionário), certifique-se de usar o arquivo vv correto e de que as duas primeiras linhas do arquivo .csv estejam corretas.
  • Se você importar um questionário para a sua instalação do LimeSurvey, o SID (se possível) não será alterado. No entanto, o ID do grupo e o ID da pergunta podem mudar. Assim, talvez seja necessário ajustar as duas primeiras linhas de cabeçalho para corresponder ao novo ID do grupo/ID da pergunta. Veja Ajustando os cabeçalhos do arquivo vv

<span id="VVExport_file_version_2_ (New in 2.05 )">Arquivo VVExport versão 2 (New in 2.05 )

Este novo recurso permite nomes de coluna diferentes dos do banco de dados. Se os códigos das suas perguntas forem únicos, a nova versão é selecionada. Na nova versão, cada nome de coluna usa a nomenclatura de variáveis Qcode. Por exemplo, isso permite atualizar com mais facilidade um questionário existente em uma instalação diferente.

Exportando um arquivo de questionário VV

File:LimesurveyExportVVen.jpg

Ao optar por exportar respostas usando o VVExport, você poderá escolher qual questionário será exportado e se deseja exportar todos os registros, somente os registros completos ou somente os registros incompletos. A extensão do arquivo permite escolher qual extensão o arquivo exportado terá. Para facilitar o uso, deve-se escolher .csv.

Um 'arquivo de questionário vv' permite importar as respostas de um questionário quando as combinações de pergunta/resposta foram alteradas. Na prática, isso permite adicionar ou remover perguntas em um questionário ativo.

Ao clicar em "Exportar um arquivo de questionário VV", será gerado um arquivo delimitado por tabulações que pode ser aberto pelo Excel ou por um programa de planilhas semelhante. As duas primeiras linhas da planilha são os rótulos das colunas. A primeira linha é um cabeçalho de coluna "legível por humanos" que detalha o nome do campo de pergunta/resposta. A segunda linha é o nome interno da coluna PHP/banco de dados para essa resposta.

Você não deve modificar as duas primeiras linhas desta planilha se quiser poder "importar" os dados de volta para o LimeSurvey posteriormente.

<span id="Exporting_a_VV_survey_file_ (New in 2.05 )">

Exportando um arquivo de questionário VV (New in 2.05 )

 Hint: This feature is available starting in version 2.05


  • Exportar questionário : O ID do questionário a ser exportado (somente leitura)
  • Exportar : O estado de conclusão das respostas a serem exportadas
  • Extensão do arquivo : A extensão do arquivo. O arquivo é um arquivo TSV (valores separados por tabulação). Para abrir facilmente no MS-Excel, defina a extensão como .txt; com LibreOffice, OpenOffice ou outro programa de planilhas, você pode deixá-la como .csv.
  • Versão de exportação VV : A versão 1.0 usa os cabeçalhos de coluna do banco de dados, a versão 2.0 usa a nomenclatura de variáveis Qcode. A versão 2.0 é selecionada por padrão se todos os códigos das suas perguntas forem únicos.

As duas primeiras linhas da planilha são os rótulos das colunas. A primeira linha é um cabeçalho de coluna "legível por humanos" que detalha o nome da pergunta. A segunda linha é o nome real da coluna (nome interno do banco de dados ou Qcode) para essa resposta.

Editando um arquivo de questionário VV

Depois que um arquivo .vv for exportado com sucesso, você pode usar uma ferramenta de planilha para abri-lo e editá-lo. Se for necessário escolher um separador de colunas ao abrir o arquivo, use o caractere "Guia" (tabulação). Se estiver usando caracteres não ASCII, certifique-se de definir "UTF-8" como conjunto de caracteres.

  Se você estiver usando o Microsoft Excel para editar o arquivo vv exportado, saiba que o Excel destrói a estrutura de dados original do arquivo. Isso causa um erro ao tentar reimportar o arquivo .vv editado.


Por padrão, as duas primeiras linhas do arquivo .vv são cabeçalhos. Se necessário, você pode remover a primeira linha para obter um arquivo TSV verdadeiro. Há diferentes casos de uso para importar um arquivo .vv, por isso vamos diferenciar entre adicionar novas respostas a um questionário e sobrescrever todas as respostas do questionário.

Exemplo de estrutura de um arquivo .vv:

Arquivo TSV VV versão 1

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	46492X40X1991
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1

Arquivo TSV VV versão 2

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	QCODE
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1


Aqui os identificadores SGQA não são usados; em vez disso, a nomenclatura de variáveis Qcode QCODE é usada na segunda linha.

Nomes reservados

O arquivo .VV usa chaves esquerda e direita para nomes reservados. Ao importar, essa string é substituída por:

  • {question_not_shown} : valor NULL no banco de dados. O LimeSurvey usa [string vazia] para perguntas não respondidas e valor NULL para perguntas não exibidas (pelo Gerenciador de Expressões ou pelo passo máximo no questionário).
  • {quote} : " (aspas duplas)
  • {cr} : Retorno de carro
  • {newline} : Uma nova linha
  • {lbrace} : Chave esquerda (por exemplo, se você quiser ter {cr} na resposta: use {lbrace}cr} )

Edição da versão 1 do VV

Adicionando novas respostas às respostas existentes de um questionário

Isso não é suportado na versão 1 do formato, pois pode facilmente causar diversos problemas, incluindo a importação de dados nas colunas erradas. A versão 1 do arquivo .vv sempre foi concebida para a verificação vertical de dados em uma ferramenta externa, como o Excel, e não como meio de reunir dados de diferentes fontes (como o mesmo questionário em execução em outro servidor).

Modificar todas as respostas de um questionário

Se você quiser modificar as respostas de um questionário, basta editar o arquivo.

Exemplo:

Passo 1: Abra o arquivo

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
183	09.11.11 11:44	3	de	4
184	09.11.11 11:53	3	de	2
190	09.11.11 11:44	3	de	1


Passo 2: Modifique as respostas

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
1000	09.11.11 11:44	3	de	3
1001	09.11.11 11:53	3	de	3
1002	09.11.11 11:44	3	de	3

Em seguida, você pode importar o questionário, certificando-se de sobrescrever as respostas existentes (consulte "Importando um arquivo de questionário VV").

Importando um arquivo de questionário VV

File:LimeSurveyImportVVen.jpg

Desde que as duas primeiras linhas estejam intactas, você pode importar os dados do seu arquivo de questionário vv de volta para um questionário ativo do LimeSurvey.

Se você usou o Microsoft Excel para editar o arquivo vv exportado, a estrutura de dados desse arquivo pode ter sido corrompida, e o LimeSurvey não conseguirá importar o arquivo editado. Você pode tentar a seguinte solução alternativa para que a importação funcione sem erros:

  • Abra o arquivo vv exportado no Excel e faça suas alterações (presumimos que você já tenha feito isso)
  • Salve-o como arquivo de texto separado por tabulações (isso cria um novo arquivo com a extensão .txt)
  • Faça outra exportação vv "limpa" no LimeSurvey
  • Abra esse novo arquivo vv exportado com um editor de texto, como o Bloco de Notas ou outro (usei o TextWrangler no Mac)
  • Pressione CTRL + A para selecionar todo o conteúdo e exclua-o
  • Abra o arquivo vv editado no Excel (o arquivo .txt separado por tabulações) com um editor de texto e pressione CTRL + A para selecionar todo o conteúdo
  • Pressione CTRL + C para copiar o conteúdo e cole-o no novo arquivo vv (agora vazio)
  • Pressione CTRL + S para salvar o arquivo como está (como .csv)
  • Agora tente importar esse arquivo

Em seguida, na tela de exibição, escolha o ícone "Importar um arquivo de questionário VV".

A tela "Importar um arquivo de questionário VV" solicita que você escolha o arquivo "vvexport" que está importando. Se você escolher "Excluir IDs de registros", os registros serão importados e novos IDs de registro serão gerados para eles (use essa opção no caso de uso "Adicionando novas respostas às respostas existentes de um questionário"). Se você desmarcar essa caixa, os IDs de registro originais serão importados (use essa opção no caso de uso "Sobrescrevendo todas as respostas do questionário").

Há várias opções que você pode escolher para indicar ao LimeSurvey como lidar com entradas duplicadas ou múltiplas.

  • Reportar um erro (e pular o novo registro).
  • Renumerar o novo registro
  • Substituir o registro existente (use esta opção no caso de uso "Sobrescrevendo todas as respostas do questionário")

<span id="Importing_a_VV_survey_file_ (New in 2.05 )">

Importando um arquivo de questionário VV (New in 2.05 )

  • Arquivo : Selecione o arquivo a ser carregado. O arquivo deve ser um arquivo TSV: um arquivo de texto com cada coluna separada por TAB.
  • Excluir IDs de registros? : Se a coluna 'id' existir no arquivo, você pode excluir essa linha ou não. Se esta configuração estiver marcada, um novo registro será adicionado para cada linha do arquivo .vv. Se estiver desmarcada, você pode escolher:
  • Quando um registro importado coincidir com o ID de um registro existente:
    • skip : Reportar e pular o novo registro. Após o carregamento, você verá se o registro já existia - se existia, ele não é importado.
    • renumber : Renumerar o novo registro. Um novo registro é adicionado à tabela de respostas com a resposta do arquivo VV.
    • replace : Substituir o registro existente. O registro antigo é excluído e completamente substituído pelo registro do arquivo VV.
    • replaceanswer : Substituir os detalhes da resposta do registro existente pelos do arquivo. O registro antigo é atualizado com a nova resposta do arquivo VV. Isso permite substituir apenas uma pergunta na tabela de respostas.
  • Importar como resposta não finalizada? : Se marcado, o submitdate é definido como NULL, e a resposta fica como não concluída.
  • Conjunto de caracteres do arquivo : Você pode escolher o conjunto de caracteres do arquivo - o valor padrão e recomendado é UTF-8, mas alguns programas de planilha não permitem escolher um conjunto de caracteres.
  • A primeira linha contém códigos de pergunta : Por padrão, a primeira linha do arquivo VV contém a pergunta em formato legível, e os nomes reais das colunas estão na segunda linha. Isso permite usar a primeira linha como nomes reais das colunas.
  • Forçar a importação : Se os códigos de pergunta não forem encontrados no nome do banco de dados nem na nomenclatura de variáveis Qcode, as colunas serão atribuídas de acordo com a ordem. Isso pode ser usado para importar um arquivo VV de outra instância do LimeSurvey, mas cada questionário deve ser exatamente igual. Recomendamos fortemente usar isso somente se você souber o que está fazendo. Pode ser muito perigoso e fazer com que os resultados acabem na coluna errada.

Outras opções de exportação

Exportar uma única resposta

Se você quiser exportar uma resposta individual, pode fazer isso de 3 maneiras:

1. Inicie sessão no painel administrativo do LimeSurvey, escolha seu questionário, vá em "Editar configurações do questionário" -> "Notificação e gerenciamento de dados" e certifique-se de receber as notificações básicas por e-mail.

Sempre que alguém concluir um questionário, você receberá um e-mail com uma hiperligação: "Clique na seguinte hiperligação para ver a resposta individual"

Isso levará você a uma página com um botão acima dos dados com o texto "Exportar esta resposta"

2. Inicie sessão no painel administrativo do LimeSurvey, escolha seu questionário e "Exibir respostas deste questionário". Clique em "Exibir respostas" e no número de ID que você deseja exportar na coluna da esquerda. Em seguida, você pode clicar em "Exportar este questionário" acima dos dados.

3. Inicie sessão no painel administrativo do LimeSurvey, escolha seu questionário e "Exportar resultados para aplicativo". No último campo acima de "Exportar dados", você pode escolher qual entrada deseja exportar.

Correspondência de respostas de diferentes questionários

Se você quiser acompanhar as respostas de determinadas pessoas ao longo do tempo, o LimeSurvey pode ajudar. Um possível caso de uso é acompanhar as respostas de um grupo antes e depois de participar de um seminário específico.

As etapas para implementar isso são as seguintes:

1. Crie o inquérito

2. Certifique-se de que o inquérito não seja anônimo e utilize códigos (tokens). Para criar um inquérito não anônimo:

a - Clique no ícone Configurações gerais.

b - Em seguida, na aba Códigos (tokens), selecione "Não" em Respostas anônimas.

3. Ative o inquérito.

Ao ativar o inquérito, clique no botão "Mudar para modo de acesso restrito" para criar a tabela de códigos (tokens):

4. Preencha a tabela de códigos (tokens) pelo método que preferir (siga as instruções encontradas na página Códigos (tokens)).

5. Exporte os resultados do inquérito e certifique-se de incluir as informações dos códigos (tokens).

Para exportar, clique em navegar pelos resultados...

...e depois em Exportar:

Lembre-se de escolher um ou mais elementos da tabela de códigos (tokens) para associar às respostas do inquérito:

6. Ao executar o inquérito novamente, o que pode ser feito facilmente copiando o inquérito e a tabela de códigos (tokens) por meio de exportação/importação, basta repetir as etapas e garantir que a mesma consulta seja usada para construir o arquivo CSV de importação de códigos (tokens).

Problemas e soluções

Excel

Modificando respostas no Excel antes da importação

Para fazer várias alterações nas respostas, você pode optar por exportar e abrir um arquivo no Excel. Faça as alterações nos dados (exceto nas linhas superiores) e depois salve como um arquivo .txt. Se você salvar como .csv, o Excel usa vírgulas como delimitador, e o arquivo não poderá ser importado no LimeSurvey. Ao salvar como arquivo .txt, o Excel o salva como um arquivo delimitado por tabulações, que pode ser importado de volta no LimeSurvey.

Editar .csv com o Excel

Em geral, não recomendamos usar o Excel para editar os arquivos .csv exportados, pois o Excel faz alterações na estrutura interna dos dados, o que faz a importação falhar. Se mesmo assim você quiser usar o Excel, é necessário definir o separador do Excel como vírgula no Painel de Controle (sistemas Windows):

Painel de Controle|Opções de Região e Idioma|Configurações regionais, personalizar...|Aba Números|Símbolo de agrupamento de dígitos| substitua ; por ,

Solução alternativa para editar arquivos .csv com o Excel

Usar o Excel para editar perguntas pode impedir que você as reimporte. Mas a edição é o melhor caminho se você tiver mais de 5 opções ou opções de classificação, ou se quiser usar recursos do Excel, como ordenação, etc.

Esta é uma solução alternativa parcial que parece funcionar na versão 1.82 — basicamente, use o Excel somente na parte do arquivo que contém os dados:

  • Exporte como arquivo .csv uma pergunta semelhante à que você deseja reutilizar
  • Abra o arquivo CSV em um editor de texto simples
  • Copie a parte que contém as respostas para o Excel e separe-a em colunas com Texto para Colunas ou equivalente.
  • Aproveite os recursos do Excel para colar texto em colunas e inserir 20, 50, 100 respostas, como preferir
  • Salve o arquivo como CSV do Excel, que provavelmente não terá aspas.
  • Abra este arquivo no editor, selecione tudo e copie
  • Volte ao arquivo que você abriu com o editor de texto simples
  • Cole sobre as respostas ali existentes
  • Use Salvar como, com um nome diferente, talvez um que você consiga lembrar para reutilizar
  • Importe este arquivo.

Excel - exportação limitada a 255 colunas

Devido a limitações do Excel (versões 2003 e anteriores), o LimeSurvey só consegue exportar 255 colunas ao mesmo tempo. A Microsoft propôs uma solução alternativa com uma macro VB.

Embora planilhas mais recentes (Excel >= 2007, OpenOffice) consigam exibir mais de 255 colunas, o módulo interno usado pelo LimeSurvey ainda não consegue exportar mais de 255 colunas.

No entanto, há duas soluções alternativas possíveis. Use uma das seguintes:

  • Exporte para CSV e importe na sua planilha
  • Ou use várias exportações (selecionando no máximo 250 colunas por vez) e depois combine os resultados exportados

Excel/.csv - falha na exportação

Se você não conseguir exportar seus dados para o Excel ou para um arquivo .csv, tente limpar o cache e os cookies do seu navegador.

CSV

CSV limitado a 255 colunas por padrão

Ao exportar inquéritos grandes, a interface limita por padrão a exportação às primeiras 255 colunas. Para contornar isso, basta marcar todos os conjuntos de dados para exportação.

Exportação para SPSS

Etapas gerais

Para importar os dados de respostas do LimeSurvey, siga as etapas abaixo:

  1. Clique no ícone 'Exportar para SPSS'.
  2. Nas caixas de seleção, escolha quais respostas você deseja exportar e a sua versão do SPSS.
  3. Baixe os dois arquivos: o .sps (arquivo de comandos de sintaxe do SPSS) e o arquivo .dat (arquivo de dados)
  4. Abra o arquivo .sps no SPSS: abra o SPSS, selecione 'Choose another type of file' e escolha o arquivo .sps baixado.
  5. Um editor será aberto dentro do SPSS, onde você pode editar os comandos desse arquivo. Procure a linha que começa com '/FILE=...'
  6. Edite essa linha e ajuste o caminho para que aponte para o seu arquivo .dat. Exemplo: se o seu arquivo *.dat estiver em c:\temp, defina esta linha como /FILE='c:\temp\survey_(xxxx)_SPSS_data_file.dat'
  7. Agora selecione todos os comandos dentro do editor pressionando CTRL-A.
  8. No menu do SPSS, selecione Run/All.
  9. Seja paciente: a importação de todos os dados e rótulos levará algum tempo. Acompanhe o progresso na barra de status.
  10. Pronto!

Possíveis mensagens de erro no SPSS

ERROR. command name:Get Data

Se você receber a mensagem de erro ERROR. command name:Get Data. 2267 Unexpected Token missing., edite a quarta linha do seu arquivo de sintaxe para que ela aponte para o caminho absoluto do arquivo de dados, como em

C:\spss\Data\limesurvey\SPSS\survey_35276_SPSS_data_file.dat

Erro: "Text value unmappable in the current server locale"

Esse erro pode ocorrer ao tentar abrir um arquivo de sintaxe exportado no SPSS 16. A solução é forçar o SPSS a interpretar o arquivo de sintaxe como Unicode.

Abra o SPSS. Vá em Edit > Options > Character encoding for data and syntax. Altere a opção para "unicode".

Agora os dados do LimeSurvey podem ser exportados para o SPSS 16 sem nenhum problema.

Definir a escala a ser usada para a sua variável

É possível substituir a escala padrão usada para uma variável definindo o atributo de pergunta scale_export com o valor apropriado.

Exportação/importação VV

VV - Problemas com a importação de VV

Se você tiver dificuldades para importar um arquivo vv, tente usar um arquivo delimitado por tabulação, que deve funcionar corretamente.

Outros problemas e soluções

Copiar respostas para um inquérito diferente (usando códigos)

  1. Crie um novo inquérito, adicione uma resposta fictícia, exporte o arquivo de respostas e abra-o no Excel. Isso cria o formato do novo arquivo de importação.
  2. Exporte as respostas do inquérito antigo, incluindo os códigos, e abra-as no Excel.
  3. Use esses dados para criar uma planilha do Excel no formato padrão de importação de arquivo de códigos (por exemplo: Nome, Sobrenome, Código, E-mail, Status do e-mail (OK), Idioma (En)). Salve como .csv e importe os códigos para o novo inquérito no LimeSurvey.
  4. No Excel, copie os campos de resposta do inquérito antigo que você deseja no novo inquérito (incluindo o código) para a coluna correspondente do Excel no formato do novo inquérito.
  5. Salve como arquivo .txt.
  6. Use o VVImport para importar os novos dados para o novo inquérito.
  7. Entre os possíveis erros de importação está o formato de data: alguns campos de data do sistema não aceitam valor NULL, outros aceitam. Se a data parecer correta, mas gerar um erro, use o formato de célula do Excel "2009-12-01".