Invalid argument supplied for foreach()

More
9 months 2 weeks ago #149365 by Antonimo
Antonimo created the topic: Invalid argument supplied for foreach()
From time-to-time I am experiencing errors when I save.

The attached screen-shot shows the error produced when I deleted a group.

Is this related to a server mis-configuration? Is it possible to identify the fault from the screen-shot?

Version 2.62.2+170203
Attachments:

Please Log in to join the conversation.

More
9 months 2 weeks ago #149423 by DenisChenu
DenisChenu replied the topic: Invalid argument supplied for foreach()
Can be :
- An existing fixed now (after 2.62.2 version)
- An existing bug not fixed currently
- Another things

Best solution
1. Update to 2.63.1
2. Try to reproduce the issue
3. If able to reproduce
3.1. www.limesurvey.org/community-services/bug-tracker
3.2. In the bug : remind to attach your survey (lss file)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
9 months 2 weeks ago #149425 by Antonimo
Antonimo replied the topic: Invalid argument supplied for foreach()
Thanks DenisChenu,

I shall perform an upgrade right now and see if this fixes the issue.

Regards,

Please Log in to join the conversation.

More
9 months 2 weeks ago #149426 by Antonimo
Antonimo replied the topic: Invalid argument supplied for foreach()
I have upgraded and I have the same issue. I shall try creating a new survey to see if the issue persists.

Please Log in to join the conversation.

More
9 months 2 weeks ago #149427 by jelo
jelo replied the topic: Invalid argument supplied for foreach()

Antonimo wrote: I have upgraded and I have the same issue. I shall try creating a new survey to see if the issue persists.

You might copy the survey and try to delete the group in the copy.

Please Log in to join the conversation.

More
9 months 2 weeks ago #149428 by Antonimo
Antonimo replied the topic: Invalid argument supplied for foreach()
Here are the steps I followed:
  • Create new survey
  • Add group
  • Add short free text question
  • Initialise participant table
  • Add 2 attributes

Invalid argument supplied for foreach()

/home/SITE/survey/application/helpers/expressions/em_manager_helper.php(4234)
4234                 foreach ($token as $key => $val)

Should this be submitted to the Bug Tracker?
The following user(s) said Thank You: LouisGac

Please Log in to join the conversation.

More
9 months 2 weeks ago #149452 by jelo
jelo replied the topic: Invalid argument supplied for foreach()

Antonimo wrote: Should this be submitted to the bug tracker?

Seems the next logical step.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!