Question Group Description container empty when previewing survey

More
11 months 4 weeks ago #149149 by Greg81
Greg81 created the topic: Question Group Description container empty when previewing survey
Hello,

I am using the latest version of Limesurvey. When I preview my survey, the group names always appear but the group descriptions do not. The group description container is always there, but it is empty. The text had always been there before, but seems to have stopped appearing for no reason.

I have selected 'show both' under the 'Presentation & Navigation' section in the general settings, and I even switched it to the other options and back again just to see if this did anything, but it did not. I even tried the following solution, but was unsuccessful:

www.limesurvey.org/forum/design-issues/6...t-shown-on-questions

I also checked an earlier bug report that suggests if a question group is empty (i.e., there are no questions in it), the question descriptions will not appear in the survey. This is interesting, however I am not missing any questions in my survey.

I even checked the font to make sure it is an appropriate colour, but everything seems in order. I simply cannot understand why the text is not showing in the container.

Anything you could tell me would be great.

Please Log in to join the conversation.

More
11 months 4 weeks ago #149161 by jelo
jelo replied the topic: Question Group Description container empty when previewing survey
Did you check it with different templates?

Please Log in to join the conversation.

More
11 months 4 weeks ago #149164 by Greg81
Greg81 replied the topic: Question Group Description container empty when previewing survey
Yes, but there was no change.

Please Log in to join the conversation.

More
11 months 4 weeks ago - 11 months 4 weeks ago #149172 by tpartner
tpartner replied the topic: Question Group Description container empty when previewing survey

The text had always been there before, but seems to have stopped appearing for no reason.

What changed between when they were working and when not working? An update? A template change?

Can you provide a link to a sample survey using the default template?

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Last Edit: 11 months 4 weeks ago by tpartner.

Please Log in to join the conversation.

More
11 months 4 weeks ago #149177 by Greg81
Greg81 replied the topic: Question Group Description container empty when previewing survey
The only thing I changed recently is that I turned off the welcome screen and added a new question at the very beginning of the survey. I have always used a modified version of the default template, and there was never an issue.

What do you mean by sending a link to a sample survey? Do you mean send a link to a preview of my survey?

Please Log in to join the conversation.

More
11 months 4 weeks ago #149178 by holch
holch replied the topic: Question Group Description container empty when previewing survey
No, you can't use the preview if you are not logged in into the system. As long as you don't want to give us logins as well, you will have to activate a sample survey that let's people see the problem and the source code.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
11 months 4 weeks ago #149180 by jelo
jelo replied the topic: Question Group Description container empty when previewing survey

Greg81 wrote: What do you mean by sending a link to a sample survey? Do you mean send a link to a preview of my survey?

Yes, just a link to a activated survey, which uses a standard template, to reproduce the issue you mentioned.

Standard/Default template means an unmodified template shipped with LimeSurvey.
Just one of the shipped templates which cannot be modified by the user.
People often forget that no other template receive fixes when updating LimeSurvey.

Please Log in to join the conversation.

More
11 months 4 weeks ago #149182 by Greg81
Greg81 replied the topic: Question Group Description container empty when previewing survey
Great, thank you. Below is the link to the active survey. I used the default template, but modified it slightly so that the "exit and clear survey" button does not appear. If this is a problem, let me know. The group instructions were still showing up after I made that modification, and the error did not occur until much later.

surveys.msvu.ca/index.php?r=survey/index&sid=349343&lang=en

Thanks!

Please Log in to join the conversation.

More
11 months 4 weeks ago #149189 by jelo
jelo replied the topic: Question Group Description container empty when previewing survey

Greg81 wrote: I used the default template, but modified it slightly so that the "exit and clear survey" button does not appear. If this is a problem, let me know.

No modified template. As I stated, a copy (even) of a default template isn't updated by LimeSurvey.
So just select the default templates (which is a template which cannot be modified by you).
The source of the issue can be the template, the surveydata or LimeSurvey itself.

And what version/build of LimeSurvey is used?

Please Log in to join the conversation.

More
11 months 4 weeks ago #149192 by Greg81
Greg81 replied the topic: Question Group Description container empty when previewing survey
Ok, I switched the survey back to the default template. Here is the link again:

surveys.msvu.ca/index.php?r=survey/index&sid=349343&lang=en

I am using Version 2.50+ Build 160620.

Please Log in to join the conversation.

More
11 months 4 weeks ago #149199 by tpartner
tpartner replied the topic: Question Group Description container empty when previewing survey
Hmm...I cannot reproduce with version 2.6.3. Try updating to the latest version and retesting.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
11 months 4 weeks ago #149204 by Greg81
Greg81 replied the topic: Question Group Description container empty when previewing survey
Sorry, I cannot upgrade as the LimeSurvey account is administered by my university.

Please Log in to join the conversation.

More
11 months 4 weeks ago #149205 by jelo
jelo replied the topic: Question Group Description container empty when previewing survey

tpartner wrote: Hmm...I cannot reproduce with version 2.6.3. Try updating to the latest version and retesting.

You test on the LTS? Or did you mean 2.63.X ? Till LS 3.0 every dot is counting.

Please Log in to join the conversation.

More
11 months 4 weeks ago #149206 by tpartner
tpartner replied the topic: Question Group Description container empty when previewing survey
Sorry, 2.63.1

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
1 month 2 weeks ago #162284 by cruchichu
cruchichu replied the topic: Question Group Description container empty when previewing survey
Hi! I'm having this same issue. Was there any solution to this issue?
I'm using Version 2.72.3+.
Here is a link to the survey: surveys.bcbl.eu/index.php/867639?lang=en

Thank you!

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!