Group description not shown on questions

More
6 years 6 days ago #65653 by algarvio
algarvio created the topic: Group description not shown on questions
Hi!

I'm using version 1.91+ Build 10951. I created a survey and set the option "Show group name and/or group description" to "Both".

When entering a new group, a page with group name and group description shows. But in the questions, only the group name shows. Is this the normal behavior? Or there should be the group description also?

Is there a way not to show the separator with group name and group description or is it only possible when there is no group description?

Thanks.

Please Log in to join the conversation.

More
6 years 6 days ago #65660 by tpartner
tpartner replied the topic: Group description not shown on questions
Are you you are using "question by question" mode?

Which template are you using?

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
6 years 6 days ago #65671 by algarvio
algarvio replied the topic: Group description not shown on questions
Hi!

I've tried several templates, all had the same behavior. Now I'm using the default from the version 1.91+ Build 10951.

It's in "question by question" mode, yes.

Thanks.

Please Log in to join the conversation.

More
6 years 5 days ago - 6 years 5 days ago #65689 by tpartner
tpartner replied the topic: Group description not shown on questions
To get the group description to appear on question pages, add the {GROUPDESCRIPTION} placeholder to startgroup.pstpl.

To get rid of the group description pages, add the following to the end of template.js:
	$(document).ready(function() {
 
		if($('#fieldnames').attr('value') =='') {
			$('body').hide();
			$('form#limesurvey').submit();
		}
 
	});

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Last Edit: 6 years 5 days ago by tpartner.
The following user(s) said Thank You: algarvio

Please Log in to join the conversation.

More
6 years 5 days ago #65711 by algarvio
algarvio replied the topic: Group description not shown on questions
Hi Tony!

Thank you. It solved the problem. But isn't this a bug? Shouldn't it appear if in General Settings -> Presentation & navigation -> Show group name and/or group description I have selected "Show both"? Shouldn't then be inserted the file groupdescription.pstpl?

If so, I can report the bug, if it helps you.

Thanks.

Fernando Algarvio

Please Log in to join the conversation.

More
6 years 5 days ago #65719 by tpartner
tpartner replied the topic: Group description not shown on questions
I don't think it's a bug. They are only supposed to be inserted where the placeholders are in the template. It's simply a matter of template design.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
6 years 2 days ago - 6 years 2 days ago #65766 by algarvio
algarvio replied the topic: Group description not shown on questions
Hello!

As documented , the placeholder should be in file groupdescription.pstl not in startgroup.pstpl:

groupdescription.pstpl: This template file is used to display a description of a group. It is separate to the startgroup.pstpl file because in a "question by question" survey it will be displayed on its own unique page in between groups, whereas in a "group by group" or "all in one" survey it provides a header to the subsequent questions. groupdescription.pstpl does not have a corresponding 'closing' template file, so all tags should be closed.

In the default template, where I traced the problem, the placeholder is there.

Now, my doubt is if I miss interpret the option "Show group name and/or group description". Should, in a question-by-question survey, the group description never appears in each question?

Thank you for your attention.

Fernando Algarvio
Last Edit: 6 years 2 days ago by algarvio.

Please Log in to join the conversation.

More
6 years 2 days ago #65771 by tpartner
tpartner replied the topic: Group description not shown on questions
Thanks, I know what the documentationn says - the workaround I gave you is for a specific case. I was under the impression you wanted the group description in every page of a question-by-question survey. If not, just leave things as they are.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
1 year 6 months ago - 1 year 6 months ago #131925 by rsimoesr
rsimoesr replied the topic: Group description not shown on questions
hello, the "problem" is still present.

I added the following text to startgroup.pstpl:
<div class="survey-groupdescription">{GROUPDESCRIPTION}</div>

This working...
Bye
Last Edit: 1 year 6 months ago by rsimoesr.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now