'Ranking' Question with Computed Answers Is Allocating Insufficient Row Height

Plus d'informations
il y a 8 mois 1 semaine #178932 par nh905
I am working on a survey where answers to a 'ranking' question are taken from the responses to an earlier ranking question. Everything worked fine on 3.14.2 but after upgrading to 3.15.5, the text of the computed answers is cut off at the bottom because the rows are not high enough. The computed text is fine - I can read it after I drag it to the answer box, even though the row height is still too small (I only allow one answer, so the answer can spill into the following space. If I use static answers, the row heights are fine. I have attached a screenshot showing the ranking display with computed answers and another one with static answers.
.
I had a look at the generated HTML. The first ranking has three <li> tags with style="height: 0px;". The second ranking question has style="height: 20px;".

Any help would be greatly appreciated!

Thanks, Norbert
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

LimeSurvey Partners
Plus d'informations
il y a 8 mois 1 semaine #178943 par tpartner
If you have tried with a core theme, please file a bug report.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 1 semaine #178953 par nh905
Tony, I reproduced with Fruity and Vanilla. I just opened issue 14406.

Thanks, Norbert

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 1 semaine #178971 par DenisChenu
Reported here : bugs.limesurvey.org/view.php?id=14406
In your survey : disable same choice height : it's fix the issue in all version.

It's semi-fixed in 3.15.6 : i move from height to min-height (to allow external image with a long delay) but i have a better fix.

There are another issue too : bugs.limesurvey.org/view.php?id=14410

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 1 semaine #179013 par nh905
Denis, thanks for the fast response! I successfully implemented the work-around and will be launching the survey shortly.

Norbert

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!