aSurveyInfo not available on registration page?

Plus d'informations
il y a 11 mois 2 semaines #169401 par acp_tests
COM_KUNENA_MESSAGE_CREATED_NEW
I added my survey name to the layout_global.twig file of my template, an extension of bootswatch.


Here is the code:


<h1>{{ aSurveyInfo.name }}</h1>


This works on every page except the registration page, where it simply displays nothing, but does not give an error.

Can anyone verify that this should work, or if I've done something wrong? I have a support issue open but the 24 response time is too slow.

Any help would be very much appreciated. I have a deadline very soon to get this done.

Connexion ou Créer un compte pour participer à la conversation.

LimeSurvey Partners
Plus d'informations
il y a 11 mois 2 semaines #169453 par LouisGac
COM_KUNENA_MESSAGE_REPLIED_NEW
Les utilisateur(s) suivant ont remercié: tpartner

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 2 semaines #173424 par medhat
COM_KUNENA_MESSAGE_REPLIED_NEW
Hi,
I'm having the same issue in the token page (survey's title is not showing in the "enter a valid token" page).
Is it also a bug?


Regards,
Medhat

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 2 jours #174057 par medhat
COM_KUNENA_MESSAGE_REPLIED_NEW
Still having the same issue in Version 3.14.8+180829
Any ideas guys?

Regards,
Medhat

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 2 jours #174068 par LouisGac
COM_KUNENA_MESSAGE_REPLIED_NEW
1st : update
then:
github.com/LimeSurvey/LimeSurvey/blob/ma...rController.php#L519

so it should be available
Les utilisateur(s) suivant ont remercié: medhat

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 2 jours #174093 par DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
@Louis : this was not set by LSTwig view directly ? We can't fill aSurveyInfo if there are a surveyid (with current language) ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 2 jours #174101 par LouisGac
COM_KUNENA_MESSAGE_REPLIED_NEW
I'm not sure to understand your question.
But basically, RegisterController was not calling getSurveyInfo to generate the data (in 2.x neither).
So the data available in the register view were pretty poor.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 2 jours #174110 par DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
I think we can always get and fill aSurveyInfo here : github.com/LimeSurvey/LimeSurvey/blob/85...iewRenderer.php#L463

Maybe with a merge ? And with default with all used part (title , adminname etc … maybe adding ressourceurl + asseturl etc …)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!