aSurveyInfo not available on registration page?

More
4 months 2 weeks ago #169401 by acp_tests
acp_tests created the topic: aSurveyInfo not available on registration page?
I added my survey name to the layout_global.twig file of my template, an extension of bootswatch.


Here is the code:


<h1>{{ aSurveyInfo.name }}</h1>


This works on every page except the registration page, where it simply displays nothing, but does not give an error.

Can anyone verify that this should work, or if I've done something wrong? I have a support issue open but the 24 response time is too slow.

Any help would be very much appreciated. I have a deadline very soon to get this done.

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #169453 by LouisGac
LouisGac replied the topic: aSurveyInfo not available on registration page?
The following user(s) said Thank You: tpartner

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #173424 by medhat
medhat replied the topic: aSurveyInfo not available on registration page?
Hi,
I'm having the same issue in the token page (survey's title is not showing in the "enter a valid token" page).
Is it also a bug?


Regards,
Medhat

Please Log in or Create an account to join the conversation.

More
4 weeks 1 day ago #174057 by medhat
medhat replied the topic: aSurveyInfo not available on registration page?
Still having the same issue in Version 3.14.8+180829
Any ideas guys?

Regards,
Medhat

Please Log in or Create an account to join the conversation.

More
4 weeks 1 day ago #174068 by LouisGac
LouisGac replied the topic: aSurveyInfo not available on registration page?
1st : update
then:
github.com/LimeSurvey/LimeSurvey/blob/ma...rController.php#L519

so it should be available
The following user(s) said Thank You: medhat

Please Log in or Create an account to join the conversation.

More
4 weeks 8 hours ago #174093 by DenisChenu
DenisChenu replied the topic: aSurveyInfo not available on registration page?
@Louis : this was not set by LSTwig view directly ? We can't fill aSurveyInfo if there are a surveyid (with current language) ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
4 weeks 5 hours ago #174101 by LouisGac
LouisGac replied the topic: aSurveyInfo not available on registration page?
I'm not sure to understand your question.
But basically, RegisterController was not calling getSurveyInfo to generate the data (in 2.x neither).
So the data available in the register view were pretty poor.

Please Log in or Create an account to join the conversation.

More
4 weeks 4 hours ago #174110 by DenisChenu
DenisChenu replied the topic: aSurveyInfo not available on registration page?
I think we can always get and fill aSurveyInfo here : github.com/LimeSurvey/LimeSurvey/blob/85...iewRenderer.php#L463

Maybe with a merge ? And with default with all used part (title , adminname etc … maybe adding ressourceurl + asseturl etc …)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!