Caricamento mappa OpenStreetMap

More
4 months 2 weeks ago #184940 by pierluigi1
Buonasera,

ho creato un questionario, ed ho inserito la domanda "Testo breve" con la visualizzazione della mappa. Ho utilizzato la mappa di OpenStreetMap poichè quella di Google Maps è stata modificata e personalizzata per un altro questionario. Nel momento in cui effettuo un'anteprima dell'indagine però la mappa non viene caricata correttamente (come potete notare nell'immagine allegata). Quale potrebbe essere il problema?

Vi rigrazio anticipatamente
Attachments:

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
4 months 2 weeks ago #184943 by lfanfoni
Io ho una versione 3.17, e la OpenStreetMap la vedo bene.
Hai verificato le dimensioni in pixel della mappa nelle impostazioni avanzate?
Comunque questa cosa che non puoi usare una mappa google non mi è tanto chiara. Non puoi attivare una seconda Google Maps API key?

Aiutaci a far crescere la comunità italiana di LimeSurvey: vai sul forum Italiano per richieste e soluzioni citando sempre la versione usata, non scrivere in privato, suggerisci modifiche o nuove traduzioni - www.limesurvey.org/forum/italian-forum/118441

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #184945 by pierluigi1
La mia è una 3.16. Il problema è che la vedo bene nell'anteprima della domanda, ma non riesce a caricarla bene nell'anteprima dell'immagine.
Per quanto riguarda la mappa google, dato che ho ancora un questionario in corso che si "appoggia" su quell'API , ho paura che cambiandola potrei creare qualche problema, ecco perché ho preferito usare la OpenStreetMap.

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #184959 by lfanfoni
Sulla mia 3.17 attiva mi funziona:
www.opensurvey.it/limesurvey/index.php/646657
Ho lasciato le dimensioni di default: 500X300 pixel e livello di zoom a 11

Aiutaci a far crescere la comunità italiana di LimeSurvey: vai sul forum Italiano per richieste e soluzioni citando sempre la versione usata, non scrivere in privato, suggerisci modifiche o nuove traduzioni - www.limesurvey.org/forum/italian-forum/118441

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #184960 by pierluigi1
Si, funziona anche a me. Ho provato anche sul mio e non ci sono problemi. Il problema è che quella domanda sul questionario è condizionata da una domanda precedente, perciò "compare" solamente se viene spuntata una risposta ad una domanda precedente. E' un problema di refresh o caricamento?

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #184961 by lfanfoni
Si: deve essere un problema di refresh, ma non di pagina, perchè è sufficente ridimensionare la finestra del browser (ingrandisci o ripristina) per visualizzarla bene. Io ho provato con Chrome
Se non puoi spostare la domanda con mappa a una pagina successiva del questionario, ti consiglio di postare la problematica sul forum in inglese, ma cerca di descrivere bene la problematica, mettendo gli screenshot anche con la domanda che filtra la mappa.

Aiutaci a far crescere la comunità italiana di LimeSurvey: vai sul forum Italiano per richieste e soluzioni citando sempre la versione usata, non scrivere in privato, suggerisci modifiche o nuove traduzioni - www.limesurvey.org/forum/italian-forum/118441

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #184965 by pierluigi1
Va bene! Grazie di tutto!

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!