Invalid user credentials after update - plase help

More
2 years 10 months ago #115988 by blazko
blazko created the topic: Invalid user credentials after update - plase help
Hi there,
today I discovered every single user (including myself) lost his access to the admin Panel - 650 users :/
Part of users where created manually by me, as a superadmin, and part (500+) with the use of Wordpress Auth Plugin. For a reason I can't explain nobody can log anymore. Is there anything that changed between 141229 and 141210 thay could cause it?

Could you plase help me troubleshoot it? As a sidenote, I think the database itself is ok - all user created surveys are working. Only the login part is messed up.

I would appreciate any help greatly. We run LimeSurvey as a student course for simple psych experiments and there are hundrets of confused studets out there.

Thank you very much

Please Log in to join the conversation.

More
2 years 10 months ago #116024 by Mazi
Mazi replied the topic: Invalid user credentials after update - plase help
I recommend having a look at the change log first (I attach it below). Maybe you can find something suspicious. There seem to have been some changes to the auth process.

Please note that we can't provide support for adjusted Limesurvey versions. That custom version with the Wordpress Plugin isn't maintained anymore: wordpress.org/plugins/surveypress/

CHANGE LOG:
Changes from 2.05+ (build 141210) to 2.05+ (build 141229) Dec 29, 2014
-Fixed issue #9171: Unable to subscribe to event (Alfredo Esteban)
-Fixed issue #9326: High memory usage if non-superadmin imports survey with acivated XSS filter (Carsten Schmitz)
-Fixed issue #9386: XSS issue related to survey deletion (Carsten Schmitz)
-Fixed issue #9400: Export Started but not yet completed tokens don't work (Denis Chenu)
-Fixed issue #9408: Excel statistics for question types "5 point array" and "5 point choice" show wrong aggregated percentage (Carsten Schmitz)
-Fixed issue #9409: PDF export by user contains html tag (Alfredo Esteban)
-Fixed issue #9415: Invalid url for image broke Print to PDF with debug 2 (Alfredo Esteban)
-Fixed issue #9418: Plugin Settings | The class name is being showed, instead of name of the plugin. (gabrieljenik)
-Fixed issue #9419: Unable to delete survey (Alfredo Esteban)
-Fixed issue #9422: Answers PDF from admin gui doesn't show question group name (Alfredo Esteban)
-Fixed issue #9425: Absence of delimeter at the end of a question group (Alfredo Esteban)
-Fixed issue #9426: No title at beginning of new respondent answers in HTML export from admin gui (Alfredo Esteban)
-Fixed issue: LimesurveyApi->getOldResponseTables return timing table (Denis Chenu)
-Fixed issue: Removing HTML tags from pdf title (Alfredo Esteban)
-Fixed issue: {TOKEN} is not replaced by token in quota message and url (Denis Chenu)
-Fixed issue: Trailing space in token key leads to unrecoverable survey situation (Carsten Schmitz)
-Removed feature: 'allowmandbackwards' config option is deprecated (Carsten Schmitz)
-Updated feature: Answers PDF export from admin GUI. (Alfredo Esteban)
-Updated feature: Audit plugin logs login, logout and failed login attempt (Alfredo Esteban)


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!