SMTP Mail gives error

More
3 years 2 months ago #115559 by githeko
githeko created the topic: SMTP Mail gives error
When I set up LimeSurvey 2.05 all works well until I try to send a token. The Global Settings is set to send mail to via the Google mail relay at: smtp-relay.gmail.com:25

I can connect to that server via telnet but LimeSurvey says: "Email to Some Name (xxx@yyy) failed. Error Message: SMTP connect() failed."

Anyone know what could be the problem?

My LimeSurvey doesn't send mail via the PHP mai functions nor Qmail and I am running this on my Windows 8 computer connected via a broadband link to the Internet.

Are there ways to generate a manual token?

Please Log in to join the conversation.

More
3 years 2 months ago #115561 by holch
holch replied the topic: SMTP Mail gives error
So respondents are supposed to fill in the survey on your local computer? Do you have a fixed IP? Otherwise they won't be able to connect to your computer through your broadband internet.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
3 years 2 months ago #115567 by githeko
githeko replied the topic: SMTP Mail gives error
I am testing friend - my laptop is not a server for sure...

Please Log in to join the conversation.

More
3 years 2 months ago #115596 by Mazi
Mazi replied the topic: SMTP Mail gives error
For sending emails via Gmail SMTP try port 465 or 587.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 2 months ago #115639 by githeko
githeko replied the topic: SMTP Mail gives error
I realised survey software wasn't going to do the job I needed done. Am looking at alternative data collection tools

Please Log in to join the conversation.

More
3 years 2 months ago #115649 by Mazi
Mazi replied the topic: SMTP Mail gives error
Which requirement(s) does Limesurvey not fulfill?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 2 months ago #115711 by menyus005
menyus005 replied the topic: SMTP Mail gives error
Hi,

I have the same issue with LimeSurvey 2.05. I'm running it on a CentOS 6.x machine. When I create a user the following message appears:
"Email to Some Name (xxx@yyy) failed. Error Message: SMTP connect() failed."
We have an internal smtp server. I can telnet port 25 on the smtp server from the LimeSurvey server. I also checked the logs on the smtp server. It seems LimeSurvey doesn't try to make a connection to it.
Is there any logs related to the application which would show where is the problem?
I use the same smtp settings on a Turnkey Linux Limesurvey appliance. Email sending just works fine from there.

Please Log in to join the conversation.

More
3 years 2 months ago #115726 by menyus005
menyus005 replied the topic: SMTP Mail gives error
My problem is solved. This was a php socket error problem. For more details please check this URL: stackoverflow.com/questions/17037649/php...sion-denied-on-linux

Please Log in to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #115744 by DenisChenu
DenisChenu replied the topic: SMTP Mail gives error

menyus005 wrote: My problem is solved. This was a php socket error problem. For more details please check this URL: stackoverflow.com/questions/17037649/php...sion-denied-on-linux

It's safe_mode on ? That break smtp ?

It'se linux ? Rigth ?
Can you put some information for se linux in our wiki please ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 3 years 2 months ago by DenisChenu.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!