New installation on Apache + MSSQL doesn't display any questions

More
3 years 2 weeks ago #114215 by chris1337
chris1337 created the topic: New installation on Apache + MSSQL doesn't display any questions
Hello,
I've setup a new LimeSurvey installation on a Debain 7.6 with Apache2 conected to a MSSQL database running on Windows Server 2008 R2.
Everything seems to run well. I've even fixed the freeTDS timeformat issue when running LimeSurvey on Linux connected to MSSSQL (locales.conf).

But when i create a simple survey for testing, no questions will be displayed in the survey. Even if i import another survey which works on a different LimeSurvey installation, the imported survey will not display any questions. There are no rules which could hide some questions.
I've tried different templates and settings for the question layout (all questions on one page)
How can i get it working?

I'm using LimeSurvey 2.05+ build141020

Best regards,
Chris


Attachments:

Please Log in to join the conversation.

More
3 years 2 weeks ago #114216 by Mazi
Mazi replied the topic: New installation on Apache + MSSQL doesn't display any questions
Please post a link to an activated sample survey.

Are there any hints at the server's error log?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 1 week ago #114281 by chris1337
chris1337 replied the topic: New installation on Apache + MSSQL doesn't display any questions

Mazi wrote: Please post a link to an activated sample survey.

Are there any hints at the server's error log?


Sorry, i can't post a link, because our LimeSurvey isn't aviable over internet.
In the error logs of the Apache server i can't find any hints. does LimeSurvey log any helpful information?

Please Log in to join the conversation.

More
3 years 1 week ago #114283 by Mazi
Mazi replied the topic: New installation on Apache + MSSQL doesn't display any questions
Nope, Limesurvey doesn't log any such errors.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 1 week ago #114290 by chris1337
chris1337 replied the topic: New installation on Apache + MSSQL doesn't display any questions
So how can i debug such a problem?
Do you have any idea what could be the cause for such a problem?
It looks like LimeSurvey supposes that everything is well, but the items of my survey are not displayed.
In the administration frontend i can do everything without any issues, changing settings, create useres, create surveys, question groups and questions/items. But how you can see in the screenshots above the display of the questions fails.

Are there known issues with Limesurvey on Debian+Apache connected to a MSSQL database on a Windows Server?

Please Log in to join the conversation.

More
3 years 1 week ago #114292 by Mazi
Mazi replied the topic: New installation on Apache + MSSQL doesn't display any questions
There have been some MS SQL related fixes recently and another version was just released today so trying the latest code would be a reasonable option.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 1 week ago #114308 by chris1337
chris1337 replied the topic: New installation on Apache + MSSQL doesn't display any questions
The current build shows up the following error after a fresh instalaltion.
Attachments:

Please Log in to join the conversation.

More
3 years 1 week ago #114311 by Mazi
Mazi replied the topic: New installation on Apache + MSSQL doesn't display any questions
Thanks for reporting this. Please file a bug report at our Bugtracker so we can assign the problem to the appropriate developer.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
3 years 1 week ago #114330 by chris1337
chris1337 replied the topic: New installation on Apache + MSSQL doesn't display any questions

Please Log in to join the conversation.

More
3 years 1 week ago #114331 by Mazi
Mazi replied the topic: New installation on Apache + MSSQL doesn't display any questions
Thanks, issue assigned.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!