Comfort Update Fails

More
3 years 1 week ago - 3 years 1 week ago #113188 by jasonweir
jasonweir created the topic: Comfort Update Fails
I'm trying to update from Version 2.05+ Build 140915 to Version 2.05+ Build 141003 using Comfort Update and during step 4 I'm getting the following error after a 2-3 minute timeout

Error : PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

This is running on a fully patched Debian Wheezy box running PHP Version 5.4.33

Any ideas?

Thanks,
Jason
Last Edit: 3 years 1 week ago by jasonweir. Reason: update version numbers

Please Log in to join the conversation.

More
3 years 1 week ago #113225 by jasonweir
jasonweir replied the topic: Comfort Update Fails
come on guys - nobody else having this problem..

I do have some additional info..

During step 4 update.zip is downloaded to /var/www/tmp (2560KB)

This zip file is incomplete - 7zip cannot open it, gives an error message saying its not a valid zip archive.

Can someone correct the download file?

Thanks,
Jason

Please Log in to join the conversation.

More
3 years 1 week ago #113231 by holch
holch replied the topic: Comfort Update Fails
I highly doubt that this is a problem with the actual zip archive that is provided by the update server.

I just recently updated as well to build 141003 and there was no problem at all.

Do you have enough space on your webspace/server?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
3 years 1 week ago #113232 by jasonweir
jasonweir replied the topic: Comfort Update Fails
I would tend to agree - but I've been using Comfort Update for years without issue.

Disk space isn't an issue with 2.2GB free on /var. Can you tell me how big the update.zip file should be?

I assume 2560KB isn't correct as the manual download is 43MB..

Thanks,
Jason

Please Log in to join the conversation.

More
3 years 1 week ago #113233 by jasonweir
jasonweir replied the topic: Comfort Update Fails
I've tried it half a dozen times and on step 4 the download stops at 2.5MB (2560KB)

I can however do a wget www.limesurvey.org/en/stable-release/fin...plus-build141003-zip and download the entire file to /var/www/tmp without issue.

The download does take 5-6 minutes, could this be a php\limesurvey timeout issue?

Jason

Please Log in to join the conversation.

More
3 years 1 week ago #113234 by jasonweir
jasonweir replied the topic: Comfort Update Fails
ok - I changed the timeout in php.ini from 60 to 300

default_socket_timeout = 300

and the upgrade worked without issue on the very next try.

Either it was a timeout issue or you guys fixed something on your end.

Either way thanks!!

BTW - the update file was still 2.5M...

Jason

Please Log in to join the conversation.

More
3 years 1 week ago #113236 by holch
holch replied the topic: Comfort Update Fails
Hi Jason,

I would guess it was a timeout issue.

Good that it worked now. If not, you can always do a manual update, but the comfort update is really great and easy to use. Wouldn't want to miss it either.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 11 months ago #113753 by MVT
MVT replied the topic: Comfort Update Fails
Hi

I've the same problem (comfort upgrade from 2.0+ to the last release).
First, I had that error : INTERNAL SERVER ERROR: Property update.updaterversion is not defined
I applied the patch described here : Patch
After that, I've the same error described above.

I've modified my php.ini file (in the root dir of my lime survey web installation (1&1))

It doesn't work.
I didn't find any files containing default_socket_timeout = nnn. It is the reason I've a php.ini file in my root dir.

Thanks for your help.
Regards

Please Log in to join the conversation.

More
2 years 10 months ago #115426 by harvas
harvas replied the topic: Comfort Update Fails
I am experiencing the exact same issue and the followed the exact same process below. During my error I do not even reach Step-1. The error appears straight after I click the "Upgrade" button. Any help please?

MVT wrote: Hi

I've the same problem (comfort upgrade from 2.0+ to the last release).
First, I had that error : INTERNAL SERVER ERROR: Property update.updaterversion is not defined
I applied the patch described here : Patch
After that, I've the same error described above.

I've modified my php.ini file (in the root dir of my lime survey web installation (1&1))

It doesn't work.
I didn't find any files containing default_socket_timeout = nnn. It is the reason I've a php.ini file in my root dir.

Thanks for your help.
Regards

Please Log in to join the conversation.

More
2 years 10 months ago #115464 by Mazi
Mazi replied the topic: Comfort Update Fails
Did you apply the patch from bugs.limesurvey.org/view.php?id=9064 previously?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
2 years 10 months ago #115469 by harvas
harvas replied the topic: Comfort Update Fails
Hello Mazi. Thanks for the response. Yes, I have utilised the patch under application\controllers\admin. Now I am getting the following error before any step starts: Error : PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature. The current version is 2.00+ Build 131009 and I want to upgrade to 2.05+ (141210). I am running PHP 5.4.17 and MySQL 5.2.

Thanks.

X.

Please Log in to join the conversation.

More
2 years 10 months ago #115497 by Mazi
Mazi replied the topic: Comfort Update Fails
In this case only a manual update can fix it.

If you need help with that check www.limesurvey-consulting.com/installation_update/


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
2 years 6 months ago #119317 by sysco
sysco replied the topic: Comfort Update Fails
Same here: 2.00+ -> 2.05+ upgrade

without 'updater.php' update -> Property "update.updaterversion" is not defined.

And with 'updater.php' update -> Error : PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature because the zip file contains ASCII stating File '/var/www/update.limesurvey.org/tmp/LimeSurvey/admin/update/updater.php' does not exist

Looks like a loose-loose situation. ComfortUpdate really does not deserve its name :-(

Please Log in to join the conversation.

More
2 years 6 months ago #119324 by Mazi
Mazi replied the topic: Comfort Update Fails

sysco wrote: Same here: 2.00+ -> 2.05+ upgrade

without 'updater.php' update -> Property "update.updaterversion" is not defined.

And with 'updater.php' update -> Error : PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature because the zip file contains ASCII stating File '/var/www/update.limesurvey.org/tmp/LimeSurvey/admin/update/updater.php' does not exist

Looks like a loose-loose situation. ComfortUpdate really does not deserve its name :-(

That does not happen with every update from 2.0 to 2.05. It is an issue with some release only. For all others the ComfortUpdate works very well.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
2 years 6 months ago #119325 by holch
holch replied the topic: Comfort Update Fails
OK, so you experienced a problem with the "ComfortUpdate". That is very unfortunate.

I personally find the comfort update VERY comfortable. I didn't FTP anything to my Limesurvey installation for probably 2 years or so. All comfort updates went through smooth.

So just because in some occasions an error occurs, there is no need to doubt the "comfort update" itself immediately. I can understand that you are frustrated because this error happend, but no need to scare away other from the comfort update.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now