Can't upgrade LimeSurvey from version 1.8.7 to any later version

More
3 years 3 months ago #111625 by decanatb
decanatb created the topic: Can't upgrade LimeSurvey from version 1.8.7 to any later version
Hello,

We are using LimeSurvey 1.8.7 and it's working great. As we are changing our server (RHEL5) for another one (RHEL6), it's a good opportunity to update the application.

But we have a lot of issues with the operation. It's not working at all with any version.

First attempt
I first tried to upgrade manually from 1.8.7 to 2.0.5 following this manual manual.limesurvey.org/Upgrading_from_a_previous_version
It frozes at the database conversion and the database is broken after that. I changed the timeout, duration, etc. in PHP but no luck.

Second attempt
I tried to upgrade manually from 1.8.7 to 1.9.2 (for a futur upgrade 1.9.2 to 2.0.5).

It works better but after a few time (and an unfrozen page with dots) I have a "gettemplatelist() no template directory" and the operation fails. The templates directories are existing and the RWX rights and ownership are ok...

Third attempt
I tried the "3 clics method" but the third step froze on a white page, and nothing else...


I really need your help because I made the operation at least 20 time and I really don't have any idea left :huh:

Have a nice day

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!