Problem upgrading from 1.91+ to 1.92+

More
3 years 5 days ago - 3 years 5 days ago #111028 by ardee00
ardee00 created the topic: Problem upgrading from 1.91+ to 1.92+
Hi! When I use the 3-Click ComfortUpdate to go from 1.91+ to 1.92+, it says everything is OK and executes the first two steps fine. On the third and final step, it displays some information on the page (see below) but then nothing else happens and the upgrade does not occur.

The information that step 3 puts on the page:

ComfortUpdate step 3
Creating DB & file backup
Creating file backup...
File backup created: /var/www/limesurvey/tmp/files-20140720081808-962dce9bb0c5ec297f6b43f0848fb529.zip


I have tried increasing the amount of memory that PHP can use, as suggested in the manual (was 50M, now 128M), but that didn't help.

Really hoping to go to 1.92+ for access to the Expression Manager.

Am I doing something wrong? Have you encountered this issue before?

Thanks for your responses!
Last Edit: 3 years 5 days ago by ardee00.

Please Log in to join the conversation.

More
3 years 4 days ago - 3 years 4 days ago #111052 by ardee00
ardee00 replied the topic: Problem upgrading from 1.91+ to 1.92+
Replying to my own post:

Just found out that this was a known bug in earlier versions of 1.91+. Getting one updated PHP file fixes the bug (details below). After updating that file, running the ComfortUpdate works. :)

The page for the bug report is:

bugs.limesurvey.org/view.php?id=5199

And the file to download is:

bugs.limesurvey.org/file_download.php?file_id=3949&type=bug
Last Edit: 3 years 4 days ago by ardee00. Reason: Clarification

Please Log in to join the conversation.

Did you already participate in our customer survey?

Don't miss your chance for great prices.

Please click here to participate:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now