Check out the LimeSurvey source code on GitHub!

Issue Installing Locally

More
2 years 7 months ago #108928 by garyking
I have followed the installation instructions for a local machine (on a windows 7 machine) for the purpose of testing (LimeSurvey version on date 2014-05-02).
After completion, the '/admin' URL opened as a 404 page. When I checked the XAMPP Control Panel the Apache was not running. After changing the port from 80 to 8080, Apache now ran and the 404 issue was removed, however I am now getting this error;

Internal Server Error

CDbConnection failed to open the DB connection

Does anybody have any idea what may be the cause/solution?

Please Log in to join the conversation.

More
2 years 7 months ago #109191 by jelo
What the error message said. Limesurvey couldn't get a connection to the database.

What database are you using? If you using the mysql it might be the case that the database isn't runnung. Just like Apache wasn't running in the first place on your PC.

If you unused to XAMPP please consult the forum of the project
community.apachefriends.org/f/viewforum.php?f=16

Infos about XAMPP and Limesurvey:
manual.limesurvey.org/Installation_of_th...Survey_XAMPP_package

Please Log in to join the conversation.

More
2 years 7 months ago #109195 by Ben_V
You may have a look at this previous post

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
All LS releases => bit.ly/1VMuTDu | 2.06lts => bit.ly/1Qv44A1
Demo surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form