Check out the LimeSurvey source code on GitHub!

2.00+ CDbConnection failed to open the DB connection.

More
3 years 1 month ago #102510 by sanjayrdesai
4 months ago I had successfully installed limesurvey200plus-build131009. But because of one feature not working I deleted the whole database & am now trying to re-install it.

I reach successfully upto the "Optional settings" after which I get the following notice:

"Internal Server Error

CDbConnection failed to open the DB connection.

An internal error occurred while the Web server was processing your request. Please contact the webmaster to report this problem."

Kindly note that the tables are indeed created.

Please help. Nothing seems to be working, neither 2.05 or 2.00!

Please Log in to join the conversation.

More
3 years 1 month ago #102515 by DenisChenu
Hi,

Maybe the DB connection are updated : you have to find the new connection methode (username/password/dbname etc ..)
And update application/config/config.php according to this new information.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
3 years 1 month ago #102587 by sanjayrdesai
I am a bit confused. In the config folder there are 5 files:
config-defaults.php, config-sample-dblib.php, config-sample-mysql.php,config-sample-pqsql.php, & config-sample-sqlsry.php!!! Which one am I supposed to reset?

I tried manually entering db username + password in all the files (except defaults) but now I get stuck at stage:
"6: Optional settings"; It says: "Passwords don't match." But they do!

Please kindly advice Sir.

Sanjay.

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form