Version 4

More
1 week 4 days ago #173866 by robertofranchi
robertofranchi created the topic: Version 4
Hello.

we are doing a big investment to change the template of more than 200 surveys to move on vers 3.

Now, today, I received a mail that inform about release 4 (it's waited to the end of this years )

Do you know if the template of vers 4 will be compatible with ver 3?

We have moved from 2.xx to 2.7 changing all the template, now are working to move from 2.7 to 3.xx, and hope that the template will be the same between version 3 and 4.

Can you said me something?

Where I can see the changement planned?

Thanks a lot

Please Log in or Create an account to join the conversation.

More
1 week 4 days ago #173870 by holch
holch replied the topic: Version 4
From what I have heard, the template engine should be the same as in 3.x, so templates should be compatible. However, nothing is guaranteed and I am no developer, so I don't have any 100% insights.

Template of more than 200 surveys: Still just one template, right? ;-)

I can understand the frustration a bit. But I think the change in template system was long overdue. It was a pity that it had to be changed from 2.7.x to 3.x again. Hopefully the system is now stable for a while (as it was before 2.7.x).

However, the investment of creating a new custom template shouldn't be that big if you just use one of the new templates as a base. If you used a lot of workarounds though, than it can be quite a bit of work.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
1 week 3 days ago - 1 week 3 days ago #173877 by jelo
jelo replied the topic: Version 4
The thread for Limesurvey 4 is here:
www.limesurvey.org/forum/development/116264-limesurvey-4-wip

LS4 will not enforce new templates. An LS3 template will work under LS4.

Are you a student conducting a survey? If yes, tell me why you use LimeSurvey?
www.limesurvey.org/forum/development/116...y-you-use-limesurvey
Last Edit: 1 week 3 days ago by jelo.

Please Log in or Create an account to join the conversation.

More
1 week 3 days ago #173888 by DenisChenu
DenisChenu replied the topic: Version 4
Currently, except for question template, survey template are compatible. I don't think there are big update that totally broken whole system.
Maybe one or thre view updated ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
1 week 3 days ago #173894 by jelo
jelo replied the topic: Version 4

DenisChenu wrote: Currently, except for question template, survey template are compatible. I don't think there are big update that totally broken whole system.
Maybe one or thre view updated ?


The only statement I found about LS4 and templates was this.

LS4 will provide retro-compatibility with LS3 themes.

All other statements are collected here too.
www.limesurvey.org/forum/development/116264-limesurvey-4-wip

We will have to wait for a roadmap and confirmation.
If you rely your business on LimeSurvey, it might be better to ask LimeSurvey GmbH directly.

Are you a student conducting a survey? If yes, tell me why you use LimeSurvey?
www.limesurvey.org/forum/development/116...y-you-use-limesurvey

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!