Postgres database upgrade error

More
3 months 2 weeks ago #172728 by hgreenwald
hgreenwald created the topic: Postgres database upgrade error
A few weeks ago, I started encountering errors with the database upgrade script starting with 3.14.1. Another user posted a bug, so I reverted to 3.13.2 and waited for a fix. I tried updating to 3.14.5 today and am getting the same error:

An non-recoverable error happened during the update. Error details:
SQLSTATE[42602]: Invalid name: 7 ERROR: invalid name syntax

File updatedb_helper.php, line 2291.


How can I fix this? I'm running Postgres 10.5 on RHEL 7.

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #172730 by jelo
jelo replied the topic: Postgres database upgrade error
You already commented on this bugticket.
bugs.limesurvey.org/view.php?id=13958
Just in case others look for the issue.

Are you a student conducting a survey? If yes, tell me why you use LimeSurvey?
www.limesurvey.org/forum/development/116...y-you-use-limesurvey

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #172731 by hgreenwald
hgreenwald replied the topic: Postgres database upgrade error
The bug ticket has been marked resolved. How can I reopen it or otherwise get it attention?

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #172732 by jelo
jelo replied the topic: Postgres database upgrade error
Ticket is still open (Marked as resolved, but not closed). So your comment will be seen.
Since PostgreSQL and MS SQL is not that much tested during development it may take a while.

Are you a student conducting a survey? If yes, tell me why you use LimeSurvey?
www.limesurvey.org/forum/development/116...y-you-use-limesurvey

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #172741 by LouisGac
LouisGac replied the topic: Postgres database upgrade error
Yes it was supposed to be fixed...

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #172873 by Trimbos
Trimbos replied the topic: Postgres database upgrade error
Just updated with comfortupdate and getting:

An non-recoverable error happened during the update. Error details:
CDbCommand failed to execute the SQL statement: SQLSTATE[25P02]: In failed sql transaction: 7 ERROR: current transaction is aborted, commands ignored until end of transaction block


File updatedb_helper.php, line 2289.
Please fix this error in your database and try again

Obviously something completely wrong, and totally messed up stuff.
What is this??

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #172893 by markusfluer
markusfluer replied the topic: Postgres database upgrade error
The issue is fixed now.
Coming nex release also updates on postgresql should work as expected.

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #172896 by jelo
jelo replied the topic: Postgres database upgrade error

markusfluer wrote: The issue is fixed now.

This one?
github.com/LimeSurvey/LimeSurvey/commit/...97b4a6ef8ef7260bcf8e

Are you a student conducting a survey? If yes, tell me why you use LimeSurvey?
www.limesurvey.org/forum/development/116...y-you-use-limesurvey
The following user(s) said Thank You: markusfluer

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!