LS -CDbCommand failed- to Change Password (LS 3.7.2)

More
1 year 3 months ago - 1 year 3 months ago #168853 by John_K
Hi LS community.
I was attempting to change a LS generated password for a user- But keep getting this failure error. "CDbCommand failed to execute-Implicit conversion from data type char to binary is not allowed" C full error msg below.

Tried using diff browsers. Is this a possible bug?
Need ur help in troubleshooting.
Thanks
JK


Full LS Error Msg:
Internal Server Error
CDbCommand failed to execute the SQL statement: SQLSTATE[42000]: [Microsoft][ODBC Driver 11 for SQL Server][SQL Server]
Implicit conversion from data type char to binary is not allowed.
Use the CONVERT function to run this query.
An internal error occurred while the Web server was processing your request. Please contact the webmaster to report this problem.
Thank you.
2018-05-17 10:06:16PST
---
ODBC Error Codes: 42000 = Syntax error or access violation
=============
My Environment:
LimeSurvey 3.7.2
Windows Server 2012 r2(64bit)
Apache 2.4.33(64bit)
PHP 7.2.5(64bit)
MS SQL Server Drivers 5.2_ForPHP(64bit)
Microsoft ODBC Driver 11 for SQL Server-Windows(64bit)
--New password format is like 'LSPa$$Word37'
Last edit: 1 year 3 months ago by John_K. Reason: Updated info

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
1 year 3 months ago #168927 by John_K
Hi LS eXperts,
I hope to hear from you about any corrective actions I can do at my side or are you able to re-produce this at your end?
Looking fwd to ur Feedback-comments.
Regards
JK

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #168973 by holch
I would create a bug report. This way you will get the attention of the developers quicker. I assume that it is a MSSQL problem. As LS is developed mostly in LAMP environments, problems with MSQL and ISS are often not detected as quickly.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #168999 by John_K
Hi Holch.
Thanks for ur reply-I'm not using ISS but Apache 2.4.33(64bit).
Have created a bug for this-https://bugs.limesurvey.org/view.php?id=13700
Regards;

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #169000 by holch
yeah, I saw that. I just had mentioned ISS as well, just because I think most LS developers don't use it or have it available. But I often see problems here in the forum that are solely due to MSSQL.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!