Error after updating LimeSurvey to latest version

More
3 days 21 hours ago #168816 by Matadeleo
Matadeleo created the topic: Error after updating LimeSurvey to latest version
Hi,

I've set up a new server running the Latest version of LimeSurvey and I'm using ComfortUpdate to keep it up to date.


Current LS:
Version 3.7.3+180516

However, I'm seeing an error appear all over the place - but especially when editing existing questions.

The error:
Internal Server Error
Property "SurveyDynamic.refurl" is not defined.

The error doesn't seem to prevent things from happening - if I edit the question text of a question then save, I get that error, but if I go back to the page, the change has been made.

Anyone got any ideas how I can get rid of this annoyance?

Please Log in or Create an account to join the conversation.

More
3 days 19 hours ago #168831 by elissa
elissa replied the topic: Error after updating LimeSurvey to latest version
Hi, I'm not an expert in those server issues but recently I had problems with Internal Server Error and colleagues suggested that this may be caused by some damaged files that may be corrupted during ftp transfer ( www.limesurvey.org/community/forums/inst...stallation-and-error ). Actually, that was the issue. I transferred the (same) files again and everything is OK now. Of course your issue may be completely different. Just a suggestion.

Cheers

Elzbieta Lesinska
LS voluntary Polish translator and supervisor

Please Log in or Create an account to join the conversation.

More
3 days 18 hours ago #168835 by Matadeleo
Matadeleo replied the topic: Error after updating LimeSurvey to latest version
I've experienced similar issues myself with uploading via FTP, however this install was done on an AWS linux server, I downloaded the tarball from LimeSurvey straight to the server and extracted.

Since the code seems to be looking for something it can't find, it sounds like a similar issue - but I don't know how I would go about tracking down the problem file and replacing it with a fresh one.

Please Log in or Create an account to join the conversation.

More
3 days 9 hours ago #168867 by John_K
John_K replied the topic: Error after updating LimeSurvey to latest version
Yes- I too get a similar error when attempting to create a new user in LS 3.7.2 or when attempting to import an existing survey from LS 2.0.6 - Displays an error, but when I open LS in a new tab, I can see the new entry. Though I'm not sure if all relevant data is getting populated to required referential tables at DB level. Not sure what/where to check.
Interestingly, the import of an .lss survey to LS 3.7.2 does not populate the diff groups & questions in the survey- Only the survey summary & not the rest of the survey structure.
JK

Please Log in or Create an account to join the conversation.

More
2 days 18 hours ago #168921 by holch
holch replied the topic: Error after updating LimeSurvey to latest version
I guess you guys won a bug report. Please go to bugs.limesurvey.org to retrieve your prize... ;-)

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!