Errors in theme editor

More
4 months 2 weeks ago - 4 months 2 weeks ago #168326 by Drewskie
Drewskie created the topic: Errors in theme editor
I upgraded from 2.65.0+ 170502 to 3.7.1+ 180424.
All sees to be succesful, still testing but I have pickedup the following issues in the theme editor.

I extend the bootswatch theme and when I try open the Navigation Screen to edit it, I get the following error
file_get_contents(E:\WebSites\limesurvey\upload\themes\survey\Lonmin_New\views\): failed to open stream: No such file or directory



E:\WebSites\limesurvey\application\core\LSETwigViewRenderer.php(136)

124 * This method is called from Template Editor.
125 * It returns the HTML string needed for the tmp file using the template twig file.
126 * @param string $sView the view (layout) to render
127 * @param array $aDatas the datas needed for the view rendering
128 * @param Template $oEditedTemplate the template to use
129 *
130 * @return string the generated html
131 */
132 public function renderTemplateForTemplateEditor($sView, $aDatas, $oEditedTemplate)
133 {
134 $oTemplate = $this->getTemplateForView($sView, $oEditedTemplate);
135 if ($oTemplate) {
136 $line = file_get_contents($oTemplate->viewPath.$sView);
137 $result = $this->convertTwigToHtml($line, $aDatas, $oEditedTemplate);
138 return $result;
139 } else {
140 trigger_error("Can't find a theme for view: ".$sView, E_USER_ERROR);
141 }
142 }
143
144 /**
145 * Render the option page of a template for the admin interface
146 * @param Template $oTemplate the template where the custom option page should be looked for
147 * @param array $renderArray Array that will be passed to the options.twig as variables.
148 * @return string

Any idea how to fix this?
Last Edit: 4 months 2 weeks ago by Drewskie.

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!