LimeSurvey Version 2.72.4+171110 ne longer compatible with version 5.3.3 of php

More
4 weeks 1 day ago #160726 by gabriel01
gabriel01 created the topic: LimeSurvey Version 2.72.4+171110 ne longer compatible with version 5.3.3 of php
Hello,

I have version 5.3.3 of php and I just updated my installation of limesuvey to Version 2.72.4+171110.
Since this update, it is impossible to export the answers. I activated the debug function and see this error :
"Parse error: syntax error, unexpected '[', expecting ')' in /data/www/limesurvey/application/helpers/export_helper.php on line 2139"
Line 2139 of the export_helper.php file is:
$maxIntegerLen=max([$integerMaxLen,$integerMinLen]);

It seems that we need to be running PHP 5.4+ to use shorthand arrays.

Could you help me find a solution? I can not update my version of php.
Thank you
Gabriel

Please Log in to join the conversation.

More
4 weeks 1 day ago - 4 weeks 1 day ago #160727 by LouisGac
LouisGac replied the topic: LimeSurvey Version 2.72.4+171110 ne longer compatible with version 5.3.3 of php
Last Edit: 4 weeks 1 day ago by LouisGac.
The following user(s) said Thank You: gabriel01

Please Log in to join the conversation.

More
4 weeks 1 day ago #160733 by DenisChenu
DenisChenu replied the topic: LimeSurvey Version 2.72.4+171110 ne longer compatible with version 5.3.3 of php

LouisGac wrote: Denis: blame on you!
:-D

:evil: Blame on, user who still use an outdated PHP version ;)

I fix it in a minute

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: LouisGac

Please Log in to join the conversation.

More
4 weeks 1 day ago - 4 weeks 1 day ago #160738 by DenisChenu
DenisChenu replied the topic: LimeSurvey Version 2.72.4+171110 ne longer compatible with version 5.3.3 of php
Done : github.com/LimeSurvey/LimeSurvey/commit/...fa2bc060a5542a3da64e

Remind : don't update to 3.0 release , not compat with 5.3 .
And more : version lesser than 5.6 are not supported : php.net/supported-versions.php
If you have an hacked server, it's not our fault

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 4 weeks 1 day ago by DenisChenu. Reason: http://php.net/supported-versions.php not wikipedia
The following user(s) said Thank You: gabriel01, LouisGac

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!