Minimum Memory error on install

More
1 month 22 hours ago #160663 by jenhoyte
jenhoyte created the topic: Minimum Memory error on install
I am trying to install version 2.72.4+171110 on my server.
On the pre-installation check, it shows that Minimum memory available should be 128M, but my system is showing 32M.

I have reviewed the actual available memory on the server and it shows:
- Running php 5.6.32
- OS is linux
- Total memory: 11,836,720
- free memory: 4,063,164

Memory setting in all php.ini files: 128M

So, any ideas where else I need to be looking, or what to do about this?
Thanks in advance.

Please Log in to join the conversation.

More
1 month 21 hours ago #160664 by jelo
jelo replied the topic: Minimum Memory error on install

jenhoyte wrote: Memory setting in all php.ini files: 128M.

In all php.ini files? What does "all" mean? And what memory settings did you changed?

What kind of hosting is used? The memory limit can be enforced or overridden.
IWhat Linux distribution is used? Any kind of control panel?

Please Log in to join the conversation.

More
1 month 20 hours ago #160665 by jenhoyte
jenhoyte replied the topic: Minimum Memory error on install
I found a php.ini file in the /usr/lib folder. This is changed by updates in the Control Panel.
I also found one in the public_html folder.

Changed setting: memory_limit = 128M
That is how it looks now.

Unsure what you mean by "what kind of hosting" and "what linux distribution".
The control panel shows GNU/Linux.
I do have my own server that is provided by Hostway.

Please Log in to join the conversation.

More
1 month 11 hours ago #160688 by jelo
jelo replied the topic: Minimum Memory error on install
A linux distribution is e.g. Debian, Ubuntu or CentOS.
Different kinds of hosting are e.g. Webhosting (shared), Dedicated server, Virtual server.

Depending on the setup on your server the memory_limit change in php.ini isn't working.
Sometimes you need to at a .htaccess file in the directory of your webspace to raise memory.
Whoever setup the server knows what kind of restrictions and software is used.
Since this seems to be managed server you should ask Hostway how to raise the memory limit of your server. Since you use a controlpanel just editing php.ini can be the wrong approach.
What controlpanel is used? If it is CPanel you need to edit php settings via the controlpanel and might edit some template files as well.

Please Log in to join the conversation.

More
1 month 10 hours ago #160694 by LouisGac
LouisGac replied the topic: Minimum Memory error on install

jenhoyte wrote: I found a php.ini file in the /usr/lib folder. This is changed by updates in the Control Panel.
I also found one in the public_html folder.

Changed setting: memory_limit = 128M
That is how it looks now.

Unsure what you mean by "what kind of hosting" and "what linux distribution".
The control panel shows GNU/Linux.
I do have my own server that is provided by Hostway.



After you change such a setting you should restart the web server.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!