White admin screen after limesurvey2.72.3+171020 installation on RHEL 7.4

More
1 month 2 weeks ago #160025 by pauli
pauli created the topic: White admin screen after limesurvey2.72.3+171020 installation on RHEL 7.4
Hi,

We have a fresh install of limesurvey on an RHEL server with MariaDB 5.5, PHP 7.1.2.

The front end displays but, the admin screen is white after installation, we have tried debug=1 and debug=2 in the config file but nothing is being output to the screen.

The NGINX log shows that files in tmp/assets/* are unavailable:

2017/10/25 16:27:02 [error] 11067#11067: *316 open() "/app/www/limesurvey/tmp/assets/cbcf2115/css/font-awesome.min.css" failed (2: No such file or directory), client: 180.90.2.5, server: example.com, request: "GET /tmp/assets/cbcf2115/css/font-awesome.min.css HTTP/1.1", host: "example.com", referrer: " example.com/index.php?r=admin/authentication/sa/login "

2017/10/25 16:27:02 [error] 11067#11067: *316 open() "/app/www/limesurvey/tmp/assets/fa5af5c8/css/bootstrap.css" failed (2: No such file or directory), client: 180.90.2.5, server: example.com, request: "GET /tmp/assets/fa5af5c8/css/bootstrap.css HTTP/1.1", host: "example.com", referrer: " example.com/index.php?r=admin/authentication/sa/login "

2017/10/25 16:27:02 [error] 11067#11067: *316 open() "/app/www/limesurvey/tmp/assets/fa5af5c8/css/yiistrap.css" failed (2: No such file or directory), client: 180.90.2.5, server: example.com, request: "GET /tmp/assets/fa5af5c8/css/yiistrap.css HTTP/1.1", host: "example.com", referrer: " example.com/index.php?r=admin/authentication/sa/login "


We have set the limesurvey/tmp/* folders to be writeable, /tmp/assets/fa5af5c8 exists but is empty.

Please help! :)

Thanks in advance

Paul

Please Log in to join the conversation.

More
1 month 2 weeks ago #160029 by LouisGac
LouisGac replied the topic: White admin screen after limesurvey2.72.3+171020 installation on RHEL 7.4
Hi Paul,

could you check in the first place if the files exist or not in the tmp directory?

Please Log in to join the conversation.

More
1 month 2 weeks ago #160035 by pauli
pauli replied the topic: White admin screen after limesurvey2.72.3+171020 installation on RHEL 7.4
Hi Louis

The folders exist but are empty - the js/css files are not present there

thanks
Paul

Please Log in to join the conversation.

More
1 month 2 weeks ago - 1 month 2 weeks ago #160049 by LouisGac
LouisGac replied the topic: White admin screen after limesurvey2.72.3+171020 installation on RHEL 7.4
the operation of copying the files is made by the Yii Framework itself, so it's not a problem related to LimeSurvey.

I bet on a server configuration problem, most probably SE Linux:
access.redhat.com/documentation/en-US/Re...rity-Enhanced_Linux/
Last Edit: 1 month 2 weeks ago by LouisGac.

Please Log in to join the conversation.

More
1 month 2 weeks ago #160171 by pauli
pauli replied the topic: White admin screen after limesurvey2.72.3+171020 installation on RHEL 7.4
Hi Louis

SELinux was already disabled, so...

We deleted the installation and downloaded/installed the zip archive instead of the gz one. An installation from this download proceded trouble-free.

thanks

Paul

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!