Incorrect placeholders in email templatesi

More
1 month 1 week ago - 1 month 6 days ago #159496 by pdaubresse
pdaubresse created the topic: Incorrect placeholders in email templatesi
Hi,
We setup a Limesurvey server in our premises. It is published on Internet through a reverse proxy on https. But internal communication between the reverse proxy and the LS server is in http. By default the URL produced were lsname.example.com:443/ ...
In order to solve this issue I changed the setting 'public_url' in the config.php file in the /application/config/ folder. But this is apparently not taken into account for placeholders in e-mail templates: placeholders like {RELOADURL}, {VIEWRESPONSEURL}, {EDITRESPONSEURL} and{STATISTICSURL} do use the wrong URL : lsname.example.com:443/ ...

Any idea for solving this issue?

Thanks
Last Edit: 1 month 6 days ago by DenisChenu. Reason: Usage of example.com

Please Log in to join the conversation.

More
1 month 6 days ago #159550 by DenisChenu
DenisChenu replied the topic: Incorrect placeholders in email templatesi
publicurl : manual.limesurvey.org/Optional_settings#Advanced_path_settings

Done for this.

Else : remind usage of example.com , please don't use another website for example

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
1 month 5 days ago #159578 by pdaubresse
pdaubresse replied the topic: Incorrect placeholders in email templatesi
Hello again,
Sorry: I mistyped the variable in my post: I wrote public_url in the post, but in my settings.php file it is correctly entered as 'publicurl'. And as explained it doesn't work for notification e-mails. However it works well for invitation e-mails.

Kind regards,

Pierre

Please Log in to join the conversation.

More
1 month 5 days ago #159589 by DenisChenu
DenisChenu replied the topic: Incorrect placeholders in email templatesi
Oh yes , please report the bug.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: pdaubresse

Please Log in to join the conversation.

More
1 month 2 days ago #159670 by pdaubresse
pdaubresse replied the topic: Incorrect placeholders in email templatesi
I reported the bug on the bug tracker.
Fix was committed to master branch: bugs.limesurvey.org/plugin.php?page=Source/view&id=24104

Thank you for your assistance.
Pierre

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!