Old surveys missing after upgrade

More
4 months 4 weeks ago #156849 by jbean1
jbean1 created the topic: Old surveys missing after upgrade
I recently upgraded from LimeSurvey version 2.50+build 160426 to version 2.67.1+build 170626 and I made backup copies of the old data base and old installation files. I restored the /upload directory back per instructions. After completing the installation, when I login to LimeSurvey, I don't see any of the previous surveys that I was working on. Looking at the old and new databases, I see the surveys in the old database but not in the new. How do I go about moving those surveys that I was working on from the old saved database to the new one? Can I do a simple export/import? If so, can you give me some instructions on how to go about doing this? Did I do something wrong in the installation?

Thanks in advance.

Don Dykstra

Please Log in to join the conversation.

More
4 months 4 weeks ago #156856 by DenisChenu
DenisChenu replied the topic: Old surveys missing after upgrade
When upgrading : you mlust use SAME database , else you loose old information. The upgrade process use existing database.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
4 months 4 weeks ago #156860 by jbean1
jbean1 replied the topic: Old surveys missing after upgrade
That's what I did when the upgrade asked me for the database name. It told me that the database already existed and offered me 2 choices: "Previous" or "Next". I went with "Next" and it overwrote the existing database. Again, is exporting from saved database and importing to new database a viable option?

Please Log in to join the conversation.

More
4 months 3 weeks ago #156872 by DenisChenu
DenisChenu replied the topic: Old surveys missing after upgrade
Hi,

Yes : if you have a copy of DB : you can remove the new DB and make a new copy to the config DB.
When you install : if DB exist and is setup : oinly update must be done.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
4 months 3 weeks ago #156995 by jbean1
jbean1 replied the topic: Old surveys missing after upgrade
After re-loading the saved copy of the database and going through the installation process again, the same problem exists. I have screen shots of each step of the installation.

On step 4. Configuration, below where I enter the Database Name*, it tells me "If the database does not yet exist it will be created (make sure your database user has the necessary permissions). In contrast, if there are existing LimeSurvey tables in that database they will be upgraded automatically after installation"

On step 5. Database settings, the message "Database creation - A database named i1953950_ls1 already exists. - Do you want to populate that database now by creating the necessary tables?" I select "Populate database"

On step 6. Optional settings, it says "Database i1953950_ls1 has been successfully populated" and then goes on to say "LimeSurvey has been installed successfully" and lets me login to LimeSurvey. I can see the templates that I've created but do not see any surveys that I was working on.

So where/how does this Step 4 "upgrade" automatically take place? How do I get the tables containing my in-progress surveys back? Do I export the tables from the database backup and then import them into the new database? I haven't seen anything in the upgrade documentation that addresses the automatic upgrade.

Thanks
Don Dykstra

Please Log in to join the conversation.

More
4 months 3 weeks ago #156997 by Ben_V
Ben_V replied the topic: Old surveys missing after upgrade
To upgrade an installation you don't have to launch the installer

The whole process is clearly explained here:
manual.limesurvey.org/Upgrading_from_a_p....0x_to_2.50_or_later


Said in other words, just skip the "installation process":


1) don't touch the old db

2) upload the new package

3) upload your old config.php file (application/config/config.php). Note that this file does not exist in new packages because generated during the installation.

4) replace the upload directory by your old one if needed (custom templates use)


Now the first time you will log-in to the admin you will get a message that the db will be automatically updated


Nothing else.

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
The following user(s) said Thank You: DenisChenu, jbean1

Please Log in to join the conversation.

More
4 months 3 weeks ago #157016 by jbean1
jbean1 replied the topic: Old surveys missing after upgrade
Ben,
The link that you gave me for the document describing the whole process is what I was using and there was nothing "clearly explained" about it. I was following the instructions following the paragraph "Upgrading from version 1.50 or later to any later 2.xx version". Your explanation was much more concise and clearer. After I restored my database, I followed your instructions and "SUCCESS". The only real difference that I noticed between your description and the "How to" instructions was that you explicitly said to upload/replace the "config.php" as well as the "/upload" directory, I was not replacing the "config.php" file. The instructions in step 6 of the instructions after logging into LimeSurvey just state "you can use the old config.php as reference", which to me meant that I could use the information in there to answer the installation questions not to be restored.

Thanks for all your help. It's been a learning experience.
Don Dykstra

Please Log in to join the conversation.

More
4 months 3 weeks ago - 4 months 3 weeks ago #157020 by Ben_V
Ben_V replied the topic: Old surveys missing after upgrade
I'm glad if everything is ok for you now.

As you are not using LS “ComfortUpdate” I think you may be interested in changing the default configuration to disable related notifications... and manage LS updates when it will be the best moment for you...

Just edit application/config/version.php and set:
$config['updatable'] = false;


jbean1 wrote: It's been a learning experience.
Don Dykstra

IMHO it's a key point ! Time invested in solving an issue is not 100% wasted time when you learn something that you can reuse in the future for yourself... or to help someone else...

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
Last Edit: 4 months 3 weeks ago by Ben_V.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!