Comfort Upgrade Failed

More
5 months 2 weeks ago #156262 by beachspa
beachspa created the topic: Comfort Upgrade Failed
I tried to use Comfort Upgrade, but after quite a while, the system simply put up this message (with debug=2):

An non-recoverable error happened during the update. Error details:

CDbCommand failed to execute the SQL statement: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '\'default\', `created` datetime not null, `first_read` datetime null ) ENGINE=' at line 9. The SQL statement executed was: CREATE TABLE `lime_notifications` ( `id` int(11) NOT NULL AUTO_INCREMENT PRIMARY KEY, `entity` varchar(15) not null, `entity_id` int(11) not null, `title` varchar(255) not null, `message` text not null, `status` varchar(15) not null default 'new' , `importance` int(11) default 1, `display_class` varchar(31) default \'default\', `created` datetime not null, `first_read` datetime null ) ENGINE=MyISAM DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci


I am running Debian GNU/Linux 7.11 (wheezy), fully updated via apt-get. My PHP is version 5.4.45-0+deb7u8 and my MySQL version is 5.5.55-0+deb7u1. My current LimeSurvey version is 258 and it is trying to upgrade to 263.

How can I get my LimeSurvey working again? Thanks!

Please Log in to join the conversation.

More
5 months 2 weeks ago #156263 by olle
olle replied the topic: Comfort Upgrade Failed
Hi,

Really sorry, we had a bug in 2.67.0 which caused this issue. Please update to 2.67.1.

Please Log in to join the conversation.

More
5 months 2 weeks ago #156264 by olle
olle replied the topic: Comfort Upgrade Failed
In case you're not able to update using ComfortUpdate, just unzip the attached file into your LimeSurvey root folder.

File Attachment:

File Name: patch.zip
File Size:22 KB
Attachments:

Please Log in to join the conversation.

More
5 months 2 weeks ago #156289 by flegall
flegall replied the topic: Comfort Upgrade Failed
Hello

I made a quickcomfort update last Friday and have a different error when I go to my mysurveysiteURL/admin (which then switch to mysurveysiteURL/index.php/admin):
Internal Server Error
CDbConnection failed to open the DB connection.
 
An internal error occurred while the Web server was processing your request. Please contact the webmaster to report this problem.
 
Thank you.

The survey site was fonctionning well before :(
Note: it hadn't be updated for quite a while.

Any guidance would be appreciated. I tested the patch from Olle but this does not impact.


Many thanks
Franck

Please Log in to join the conversation.

More
5 months 2 weeks ago #156301 by olle
olle replied the topic: Comfort Upgrade Failed
Hi,

Sorry about the problem. Can you enable debug = 2? Edit file application/config/config.php and change debug => 0 to debug => 2. Then reload the page and give us the error message.

Also, in config.php, check that your database credentials are correct.

Olle

Please Log in to join the conversation.

More
5 months 2 weeks ago #156316 by flegall
flegall replied the topic: Comfort Upgrade Failed
Hi

Thank you for the fast reaction: here you can have a look to the debug mode: survey.eglobalmark.com/


Franck

Please Log in to join the conversation.

More
5 months 2 weeks ago #156317 by olle
olle replied the topic: Comfort Upgrade Failed
Please check that your database is the required version.

manual.limesurvey.org/General_FAQ#Hard-_...oftware_requirements

Please Log in to join the conversation.

More
5 months 2 weeks ago #156331 by flegall
flegall replied the topic: Comfort Upgrade Failed
Hi

Indeed, looking here: manual.limesurvey.org/Installation#Make_...rvey_on_your_website states thatrequired MySQL version is 5.5.3 minimum. My current version is 5.1. I am going to investigate how I can best upgrade my database, hoping that everything is not mixed up in it.

Note: It may be good to add a check of MySQL version in the comfortupdate procedure

Franck

Please Log in to join the conversation.

More
5 months 2 weeks ago #156332 by qwerty2002
qwerty2002 replied the topic: Comfort Upgrade Failed
I'm sure I'm lucky I saw this forum.

Please Log in to join the conversation.

More
5 months 2 weeks ago #156337 by aofnoy01
aofnoy01 replied the topic: Comfort Upgrade Failed
Hello

I got a quick update on Friday and had a different error when I went to

Please Log in to join the conversation.

More
5 months 2 weeks ago #156350 by flegall
flegall replied the topic: Comfort Upgrade Failed
I managed to recreate a database in version but now get the error "The table "{{settings_global}}" for active record class "SettingGlobal" cannot be found in the database. "

I am using PHP5.6. I do not see were the issue come from.

Question: Is there a way to revert back from a Comfort Update ? Coming back to initial version, duplicating the 2 surveys I need and reimporting into a fresh limesurvey instance would probably be faster.

Thank you

Please Log in to join the conversation.

More
5 months 2 weeks ago #156358 by wanda0123456
wanda0123456 replied the topic: Comfort Upgrade Failed
I am a new member. What's in the new, please introduce me.

Please Log in to join the conversation.

More
5 months 2 weeks ago #156359 by nana123
nana123 replied the topic: Comfort Upgrade Failed
Hi, I got a quick update on Friday and had a different error when I went to.

Please Log in to join the conversation.

More
5 months 2 weeks ago #156372 by olle
olle replied the topic: Comfort Upgrade Failed
@flegall, did you solve your problem?

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!