All sort of problems after upgrading to the new version

More
4 months 1 week ago #155753 by Sweden
Sweden created the topic: All sort of problems after upgrading to the new version
I have a couple of surveys that are working fine with Version 2.06+. I tried to install the newest version of limesurvey from scratch - imported my surveys and now I have all kind of problems. It will take me days or weeks to figure out why there are so many problems.JavaScript that I have inserted doesn't work, questions don't get prefilled from URL as expected, the graphic design of my surveys need to be changed in many ways etc. etc. I also find part of the new admin menu design rather confusing. I am very sorry to say this because I do like some of the new admin design, but right now I prefer the old version. I am sure that the new version has some nice improvements that I haven't discovered yet and I will probably get used to some of the changes, but it is taking me longer to get used to than usual.

My question is - can the old version (Version 2.06+) be updated to the same security level as the new version or can the new version be changed to that is looks and act more like the old version?
The following user(s) said Thank You: pcerny

Please Log in to join the conversation.

More
4 months 1 week ago #155754 by Ben_V
Ben_V replied the topic: All sort of problems after upgrading to the new version
Hi,

in your case I would go back and replace my current not working 2.6x folder by the last 2.06 LTS application without touching the database (from my own experience 100% compatible).

So:

1) download latest 2.06 => github.com/LimeSurvey/LimeSurvey/tree/2.06lts
2) replace your 2.6x LS folder
3) copy 2.6x /application/config/config.php file (or backuped file from your old 2.06 one) and paste in new 2.06 /application/config/ folder
4) replace your backuped 2.06 /upload/ folder containing your customed templates
5) to avoid LS checking for available updates, in LimeSurvey/application/config/version.php, set:
$config = false;

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
The following user(s) said Thank You: Sweden, pcerny

Please Log in to join the conversation.

More
4 months 1 week ago #155758 by Sweden
Sweden replied the topic: All sort of problems after upgrading to the new version
Thank you very much - didn't know I could do that so maybe it could be a solution. However, I thought that the files in the 2.6 folder contained all the security enhancements - won't I have a less secure version if I replace all the files with the files from version 2.06?

Really not sure what is going on here - I don't understand why code that worked fine for years suddenly doesn't work and why questions don't get prefilled from URL etc. I know it is difficult to troubleshoot without more information but does anyone have any ideas what could be wrong?

Thanks again for your help and to anyone else who can help - I really appreciate it!

Please Log in to join the conversation.

More
4 months 1 week ago #155764 by Ben_V
Ben_V replied the topic: All sort of problems after upgrading to the new version
Aside official LS 2.6 LTS (aka 2.06 LTS) you can be interested by Denis's fork living at framagit.org/Shnoulle/LimeSurvey/ (actually it's the version I'm personnaly using for several good reasons like included native PHP7 support).

As far as I know (but need confirmation), those versions are receiving security fixes when required, and IMHO get the same security level compared with new 2.6x stable releases you are trying to install.

This said, I think it will be great for you to investigate why you can't install the last release… sounds weird even if I have no doubt that you did your best to check server conf, LS requirements etc.

Related:
www.limesurvey.org/community/forums/deve...-06-with-2-64/153362

manual.limesurvey.org/LimeSurvey_roadmap...9_-_Status:_Released

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
The following user(s) said Thank You: Sweden, pcerny

Please Log in to join the conversation.

More
4 months 1 week ago - 4 months 1 week ago #155772 by holch
holch replied the topic: All sort of problems after upgrading to the new version
There have been major changes from the older 2.06 / LTS to the newest 2.6x branch, so I am not overly suprised that not everything works with old surveys, especially when it comes to javascript and templates.

I usually don't upgrade versions, but rather run them in parallel for a while. New surveys will be developed in the new version, old surveys stay in the old version until they can be retired.

In my opinion the launch of 2.5 was not ideal, but for other reasons. However, I hope most of them will be corrected with the upcoming 3.0 release. So be aware, a new chance for breaking things will come out (hopefully) soon.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Last Edit: 4 months 1 week ago by holch.
The following user(s) said Thank You: Sweden, LouisGac

Please Log in to join the conversation.

More
4 months 1 week ago #155781 by LouisGac
LouisGac replied the topic: All sort of problems after upgrading to the new version
1. No retro compatibility between 2.06 and 2.60 for Templates:
HTML flow of 2.60 has been rewritten to use Bootstrap natively. But it keeps the old 2.06 template engine, so you can't update all the HTML from the template itself. In LS3, the new template engine is more flexible, and you'll be able to change any part of the frontend HTML from templates.

2. No portability of workarounds
Workarounds have never been stable solutions, that's why it's called "workaround". Again, one of the main point of LS3 will be to make the workaround easy to share, publish, upload, with version control + possibility to add question advanced parameter by configuration (HTML + CSS + JS + XML)

3. Denis fork is a good one, but it's not in a LTS state.
Denis fork is interesting, and he continues improving the good old 2.06 with interesting commits. So, keep in mind his branch is not "LTS": he's still changing some core code not directly related to security issues.
en.wikipedia.org/wiki/Long-term_support

4. Holch approach is the best one
Keep your old surveys on the old engine, create the new ones with the new engine.
The following user(s) said Thank You: Sweden, pcerny

Please Log in to join the conversation.

More
4 months 1 week ago - 4 months 1 week ago #155799 by Sweden
Sweden replied the topic: All sort of problems after upgrading to the new version
Thanks to all of you - very helpful. I wasn't home yesterday so I will look into the different options. It sounds like there are many ways to solve my problem.

I am redesigning my surveys, but I hoped that I could import my questions, groups, code etc. without too many problems... hmmm I will have to use a little more time testing tings... Will report back when I find out what the problem is, maybe it can help others. I wish I could wait for the upcoming 3.0 release - if anyone knows when it will be out, please tell :)

Thanks again. Many great people on this forum!
Last Edit: 4 months 1 week ago by Sweden.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now