unexpected 2.06lts upgrade

More
4 months 3 weeks ago #155265 by first
first created the topic: unexpected 2.06lts upgrade
Hi - I had ls Version 2.65 on my server inside a folder name "survey". I wanted to replace my intallation as ls2.06lts without changing url so I renamed the folder as surveyold and created new folder with the same name "survey". I then downloaded ls2.06lts as zip from github and installed in this new folder "survey" and everything worked fine for two days. Today when I tried to login ls2.06 I found it is updated to Version 2.65.1+170522. Please suggest how this may happen.

Some more observations:
#I have ls2.06lts(downloaded from github) on two other servers for an year and they never got updateded to 2.6.
#I think ls source code downloaded from github do not update via comfort update.
#Is this something that happened because earlier I had 2.6 inside folder name "survey"(which I renamed to surveyold) and then installed ls2.06lts in a folder with same name as before. Maybe ls comfort update has some sort of links to update ls instalances?

Survey Designer and Programmer

Please Log in to join the conversation.

More
4 months 3 weeks ago #155266 by first
first replied the topic: unexpected 2.06lts upgrade
Also please note that several people have admin rights of ls installation. Is it possible that someone has accidentally/intentionally upgraded from 2.06 to 2.6 by clicking somewhere in admin area?

Survey Designer and Programmer

Please Log in to join the conversation.

More
4 months 3 weeks ago #155267 by Ben_V
Ben_V replied the topic: unexpected 2.06lts upgrade
Hi...

just switch in application/config/version.php
$config['updatable'] = false;

github.com/LimeSurvey/LimeSurvey/blob/2....n/config/version.php

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Please Log in to join the conversation.

More
4 months 3 weeks ago - 4 months 3 weeks ago #155271 by first
first replied the topic: unexpected 2.06lts upgrade
I now did this just after finishing the installation and before logging in for the first time. Or should I have I updated it even before initiating installation? Or this doesnt make any difference?

Survey Designer and Programmer
Last Edit: 4 months 3 weeks ago by first.

Please Log in to join the conversation.

More
4 months 3 weeks ago #155272 by first
first replied the topic: unexpected 2.06lts upgrade
I now see this message in comfort update tag. Hope It won't get update now.

Survey Designer and Programmer
Attachments:

Please Log in to join the conversation.

More
4 months 3 weeks ago - 4 months 3 weeks ago #155286 by LouisGac
LouisGac replied the topic: unexpected 2.06lts upgrade
the problem comes from that your users are administrators.
updates are announced on twitter, so just follow us and you'll now when an update is available for 2.06lts branch.
eg:

2.06LTS build 160524 released!
Last Edit: 4 months 3 weeks ago by LouisGac.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now