Login Slow 2.50+ Build 160715

More
1 year 2 months ago #139939 by ScottGage
ScottGage created the topic: Login Slow 2.50+ Build 160715
Working with v2.5 we're finding the login time is really slow. I put in a log message at the start of the run() function in controllers/admin/index.php and at the end and they're over a minute apart:

[Thu Aug 04 13:54:09.851063 2016] [:error] [pid 30793] [client] Admin area load, referer: /index.php/admin/authentication/sa/login
[Thu Aug 04 13:55:13.209907 2016] [:error] [pid 30793] [client] Admin area end, referer: /index.php/admin/authentication/sa/login

My first suspicion was the LDAP login as taking up the time but that all runs in under a second. So I narrowed it down to the renderWrappedTemplate command:

error_log('Start rendering');
$this->_renderWrappedTemplate('super', 'welcome', $aData);

error_log('Rendering complete');

And confirmed that's the part that's taking longest:
[Thu Aug 04 13:59:06.324646 2016] [:error] [pid 9110] [client] Start rendering, referer: /index.php/admin/authentication/sa/login
[Thu Aug 04 14:00:09.492073 2016] [:error] [pid 9110] [client] Rendering complete, referer: /index.php/admin/authentication/sa/login

We're using default templates everywhere so any ideas on why it's rendering so slowly?

Redhat 6.8
PHP 5.6.5

Please Log in to join the conversation.

More
1 year 2 months ago #139948 by jelo
jelo replied the topic: Login Slow 2.50+ Build 160715
Since you already put some effort in pinpointing the issue I recommend opening a bug report.
I haven't found a bug ticket which relates directly to your issue.
The devs will tell you to update to a newer build of LS 2.5 first.

Please Log in to join the conversation.

More
1 year 2 months ago #139985 by ScottGage
ScottGage replied the topic: Login Slow 2.50+ Build 160715
Thanks jelo, I've updated and I'm still having the issue so I'll raise a bug.

Please Log in to join the conversation.

More
6 months 3 weeks ago #151851 by XXXIII
XXXIII replied the topic: Login Slow 2.50+ Build 160715
Hi there.
I had the same issue.
What solved the issue for me, was to disable the ComfortUpdate. If it´s an Option for you to disable this Feature, you can find an instruction here: manual.limesurvey.org/ComfortUpdate

Windows Server 2012 R2
PHP 7
V 2.52+ 160920

Please Log in to join the conversation.

More
6 months 3 weeks ago #151856 by holch
holch replied the topic: Login Slow 2.50+ Build 160715
If your LS installation has no access to the internet, then disabling ComfortUpdate like XXXIII could be the solution. With access to the internet I don't think this will make much of a difference.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now