upgrading limesurvey from Version 2.00+ to Version 2.50+

More
2 years 4 months ago #136289 by rjlime
rjlime created the topic: upgrading limesurvey from Version 2.00+ to Version 2.50+
First, I would like to thank you for your massive efforts .

I have a few questions, I'm using limesurvey v2.00+ , and I'm studying what it takes to upgrade to v 2.50+ .
my questions are:

1) Do you advise me to upgrade, keeping in mind that limesurvey v3.0 is scheduled to be released soon (Q4 2016).
2) I'm working on preparing a study regarding the upgrade process pros and cons , any help or leads would be me much appreciated.
3) consider upgrading is done (either to v2.50+ or v3.0), do you advise me to migrate the old surveys to the new version, or keep the new version for new surveys?

Thanks in advance :)

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago - 2 years 4 months ago #136291 by DenisChenu
DenisChenu replied the topic: upgrading limesurvey from Version 2.00+ to Version 2.50+
Hi,

Actually , personnaly (and for my clients): i use 2.06 updated version : github.com/SondagesPro/LimeSurvey-SondagesPro

Because 2.00 to 2.06 : a lot of things are totally compatible. Admin GUI are updated but not completely. And new feature in 2.50 don't interest me (The only feature is RWD for default template, but there are a lot of RWD template existing for 2.06).

For upgrade : the best is to make a DB copy and upgrade the DB at the same time : then you keep all old surveys.

Regards,
Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 2 years 4 months ago by DenisChenu.

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #136390 by lubnayaqoob
lubnayaqoob replied the topic: upgrading limesurvey from Version 2.00+ to Version 2.50+
Hello, I am trying to upgrade limesurevy 2.0 to 2.5 on TS-653 Pro QNAP server.
But it is not available under App center.
When the new version app will appear in the QNAP site.
or what should i do.
could you please your latest version to QNAP App center.
I tried to download from your side and install it on my server but its not
allowing.

Could you please help.

Lubna Yaqoob

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #136391 by tammo
tammo replied the topic: upgrading limesurvey from Version 2.00+ to Version 2.50+
I think it would be wise to do this in multiple steps: first upgrade to 2.06. Then see what you have. This migration is mostly without any difficulties.

After that, and only when needed, migrate the 2.06installation to 2.50.


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey template
toolsforresearch.com/limesurvey-responsive-template

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #136394 by lubnayaqoob
lubnayaqoob replied the topic: upgrading limesurvey from Version 2.00+ to Version 2.50+
Hi, I have tried to upgrade to 2.06.
got an error message.

Attached please find.
Attachments:

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #136395 by tammo
tammo replied the topic: upgrading limesurvey from Version 2.00+ to Version 2.50+
I'm sorry that I cannot help you here: I always install via FTP. I have no experience with installation engines.


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey template
toolsforresearch.com/limesurvey-responsive-template

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #136397 by lubnayaqoob
lubnayaqoob replied the topic: upgrading limesurvey from Version 2.00+ to Version 2.50+
My FTP is also not allowing to connect with the server. Getting error

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #136406 by jelo
jelo replied the topic: upgrading limesurvey from Version 2.00+ to Version 2.50+

tammo wrote: I'm sorry that I cannot help you here: I always install via FTP. I have no experience with installation engines.

Since it is a QNAP NAS with special Installpackages you normally want to update via these packages.
Since there is no update from the Appstore, you have to update via comfortupdater or manually. The limesurvey installation can be accessed via the Filestation on QNAP.

Are you a student conducting a survey? If yes, tell me why you use LimeSurvey?
www.limesurvey.org/forum/development/116...y-you-use-limesurvey

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #136448 by lubnayaqoob
lubnayaqoob replied the topic: upgrading limesurvey from Version 2.00+ to Version 2.50+
Hi Jelo,
I tried each and every option to upgrade.
Still could not find a solution. I am in contact with QNAP team.
will keep posted here.

Many Thanks

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!