Welcome, Guest
Username: Password:

TOPIC: Fragegruppen werden nicht angezeigt?

Fragegruppen werden nicht angezeigt? 1 year 9 months ago #110819

  • ladinara
  • ladinara's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Guten Tag!

Ich habe folgendes Problem bei einer mit Limesurvey erstellten Umfrage:
Gewisse Fragegruppen, welche auch bereits verschiedene Fragen enthalten, werden in der Vorschau der Gruppe bzw. im Test der gesamten Befragung nicht angezeigt. Dies obwohl die Fragen keine Filter enthalten. Es handelt sich dabei um drei Fragegruppen am Schluss des Fragebogens und wenn ich diese nach vorne an den Anfang der Befragung schiebe (wohin sie aber eigentlich nicht gehören), werden sie auch in der Vorschau bzw. im Test angezeigt.

Wenn ich die Umfragelogik für die enstpechenden Fragegruppen prüfe, erscheint folgende Meldung:
"Ungültige Frage - möglicherweise fehlen Teilfragen oder sprachspezifische Einstellungen für die Sprache"

Kann mir jemand weiterhelfen?

Ich arbeite mit LimeSurvey Version 2.05+ Build 140520; in Windows 7 und Internet Explorer.

Vielen Dank!
The administrator has disabled public write access.

Fragegruppen werden nicht angezeigt? 10 months 3 weeks ago #121414

  • dotti
  • dotti's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Hallo,
ich habe das gleiche Problem.
Hat hier eventuell jemand eine Lösung?
mfg
Klaus
The administrator has disabled public write access.

Fragegruppen werden nicht angezeigt? 10 months 3 weeks ago #121443

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5930
  • Thank you received: 360
  • Karma: 258
1. Welche Limesurvey Version nutzt ihr denn?

2. Bitte mal die Umfrage in der Limesurvey Demoversion testen, die nutzt immer den aktuellen Code.

3. Weiterer Lösungsansatz: Gruppe exportieren, Gruppe löschen und neu importieren.
Es gab mal Bugs in älteren Versionen, wo Fragen nicht komplett gelöscht wurden, das könnte solche Fehler auch verursachen, daher dieser Workaround.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Fragegruppen werden nicht angezeigt? 10 months 3 weeks ago #121504

  • dotti
  • dotti's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Hallo Marcel,

ich hatte das Problem mit 2.05 und 2.06 und auf dem Demo System.
Ich hab sogar die 3er Version testen wollen, jedoch hab ich die noch nicht zum Laufen gebracht.
Lösung bei mir war, dass bei einer Frage keine Unterantworten angelegt waren.
Das hat sich auf eine ganz andere Fragegruppe ausgewirkt, bei welcher es gar keine Unterantworten gab, und so hat es eine ganze weile gedauert, bis ich dahinter gekommen bin.

Danke für die Tip's!

mfg

Klaus
The administrator has disabled public write access.

Fragegruppen werden nicht angezeigt? 10 months 3 weeks ago #121509

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5930
  • Thank you received: 360
  • Karma: 258
Besten Dank für das Feedback. Der Hinweis "Ungültige Frage - möglicherweise fehlen Teilfragen oder sprachspezifische Einstellungen für die Sprache" des anderen Nutzers spricht da eigentlich für sich :-)

Ich vermute, das betraf auch nur die Vorschau? Denn beim Aktivieren der Umfrage sollte ebenfalls eine Warnung erscheinen.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Fragegruppen werden nicht angezeigt? 6 months 1 week ago #127755

Hallo,

ich habe ein etwas anderes Problem als hier beschrieben. Ich habe einen Fragebogen erstellt, der aus einer randomisierten Fragengruppe besteht. Aus dem Fragenpool von 24 Fragen werden acht zufällig gezogen. Beim Versuch den Fragebogen zu testen tritt bei der beschriebenen Fragengruppeder der Fehler auf, dass die Pflichtfrage nicht beantwortet ist. Auch die Möglichkeit diese Fragen auf optionale Frage zu stellen hat keine Lösung ergeben da in diesem Fall nur leere Kästchen angezeigt werden und der Inhalt fehlt. Ich verstehe nicht ganz was das Problem ist.

Danke

Claudia
The administrator has disabled public write access.

Fragegruppen werden nicht angezeigt? 6 months 1 week ago #127767

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 4734
  • Thank you received: 689
  • Karma: 209
Wir auch nicht... ;-)

Spass beiseite: Mit deiner Beschreibung ist es recht schwer nachzuvollziehen, was genau passiert, wie es aussieht, was du gemacht hast, etc.

Hast du einen Testlink? Oder kannst du den Fragebogen zum Download bereitstellen? Wie werden die 8 Fragen aus den 24 Fragen gezogen? Wie werden die restlichen 16 Fragen versteckt?

Wir brauchen etwas mehr Infos um Dir helfen zu können.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Fragegruppen werden nicht angezeigt? 6 months 1 week ago #127770

Die Fragen werden mit folgendem Code (Beispiel für Frage "Y1111") gezogen, welchen ich im Zuge meiner Suchbemühungen zum Thema Randomisierung entdeckt habe.

sum(Y1112.relevanceStatus, Y1121.relevanceStatus, Y1122.relevanceStatus, Y1211.relevanceStatus, Y1212.relevanceStatus, Y1221.relevanceStatus, Y1222.relevanceStatus, Y2111.relevanceStatus, Y2112.relevanceStatus, Y2121.relevanceStatus, Y2122.relevanceStatus, Y2211.relevanceStatus, Y2212.relevanceStatus, Y2221.relevanceStatus, Y2222.relevanceStatus, Y3111.relevanceStatus, Y3112.relevanceStatus, Y3121.relevanceStatus, Y3122.relevanceStatus, Y3211.relevanceStatus, Y3212.relevanceStatus, Y3221.relevanceStatus, Y3222.relevanceStatus) LT 8

Alle 24 Fragen sind Teil der selben Randomisierungsgruppe.
Vor dieser Gruppe gibt es zwei allgemeine Fragen ohne Zufallsauswahl.

Das Problem scheint irgendwo am Code vorzuliegen. Wenn ich den Code lösche, werden alle 24 Fragen (in einer zufälligen Reihenfolge) korrekt gezeigt.Mit Code werden die einzelnen Fragen nicht angezeigt, wohl aber die Fragengruppe als "Rahmen" mit allgemeinem Hinweistext.
Nun ergeben sich aus den Einstellungen zwei unterschiedliche Fälle:

Fall A: alle Fragen sind Pflichtfragen
Nun erscheint mit der ersten Szenarienfrage der allgemeine Hinweistext zur Fragengruppe, aber kein Frageninhalt. Klickt man nun auf "weiter" wird natürlich die fehlende Eingabe bemängelt - welche man jedoch mangels Anzeige nicht tätigen konnte. Aber Achtung: Im Hintergrund der Fehlermeldung erscheint nun die gestellte Frage (ausgegraut)! Mit einem Klick auf "OK" ist diese jedoch wieder entschwunden.

Fall B: alle Fragen sind optional
Nun kann man sich acht mal (also "LT 8" scheint zu gehen) durch den Hinweistext klicken, ohne dass eine Frage erscheint.
Am Ende landet man bei den (wieder unrandomisierten) Abschlussfragen. Nochmals Achtung: Wenn man jetzt (wirklich erst jetzt) den "zurück"-Button nutzt, kann man sich durch die gestellten Fragen klicken. Rückwärts werden also alle angezeigt. :-S

Nun ist es etwas ausführlicher dargelegt. Wären euch die lsg-Files eine Hilfe?

Vielen Dank
Claudia
The administrator has disabled public write access.

Fragegruppen werden nicht angezeigt? 6 months 1 week ago #127771

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 4734
  • Thank you received: 689
  • Karma: 209
Welches Template verwendest du denn? Wenn es ein angepasstest Template ist, was passiert dann, wenn du auf ein Standard-Template gehst (Default oder Basic)?

Welche Limesurvey Version verwendest du?

Das LSS file wäre besser, dann kann die ganze Umfrage direkt importiert werden. Beim LSG file müsste man erst eine Umfrage anlegen um dann die Gruppe zu importieren.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Fragegruppen werden nicht angezeigt? 6 months 1 week ago #127773

Version 2.05+ Build 140821
Template für sächsiche Hochschulen/TU Dresden

Muss jetzt leider los, kann es morgen aber mal auf einem anderen Template testen? Wo wäre denn eins zugänglich?
Attachments:
The administrator has disabled public write access.

Fragegruppen werden nicht angezeigt? 6 months 1 week ago #127778

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 4734
  • Thank you received: 689
  • Karma: 209
Die sind normalerweise in der Limesurvey-Installation enthalten. Kann aber sein, dass der Admin die gelöscht oder zumindest für die Studenten gesperrt hat.

Problem tritt auch bei meinem Template und bei Default-Template in der neuesten Version von LS auf. Also es liegt wohl weder am Template noch an der Installation. Können wir also schon mal ausschliessen.

Mal sehen, ob ich in der LSS-Datei irgendwas verdächtiges finde. Kann es aber nicht garantieren.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Fragegruppen werden nicht angezeigt? 6 months 5 days ago #127828

  • queeni
  • queeni's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Super, vielen Dank das du dich meinem Problem annimmst. Ich habe zwischenzeitlich auch noch weitere mögliche Ansätze versucht- ergebnislos- und werde, wenn du auch nicht den Fehler findest mir wohl oder übel eine neue Relevanzgleichung überlegen müssen.

Gruß
Claudia
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.261 seconds