MP3 in Frage einbauen - Fehlermeldung?

More
2 months 1 week ago #157544 by fauxdeduction
fauxdeduction created the topic: MP3 in Frage einbauen - Fehlermeldung?
Liebes LS-Forum,

ich bin neu hier und habe mich in der letzten Zeit viel im deutschen und im englischen Forum herumgeklickt, doch keine der Lösungsansätze haben mir geholfen. Dazu muss ich sagen, dass ich, was HTML und LS angeht, ein Anfänger bin, und (noch) keine großen Kenntnisse besitze.

Ich arbeite mit den folgenden Versionen:
- LS Version: 2.63.1+170305
- Betriebssystem: Windows 10
- Browser: Google Chrome / Firefox

Nun zu meiner Frage. Ich möchte eine MP3 Datei in meine Fragen einbetten. Dazu habe ich mir das Workaround angesehen, welches mir diesen Code vorschlägt:

<embed height="20" width="128" autostart="false" controls="console"

loop="true" volume="50" src="{TEMPLATEURL}audio_1.mp3"></embed>


Diesen Code habe ich in den Quellcode eingegeben und die TEMPLATEURL mit der MP3 URL ersetzt, ebenso habe ich "audio_1.mp3" mit dem Audiodateinamen ersetzt, jedoch kommt eine Fehlermeldung.

Meine Fragen sind die Folgenden:
1. Muss ich die MP3 Dateien, die ich verwenden möchte, in den Ressourcen der Umfrage hochladen?
2. Wenn ja, wie bekomme ich die URL der Audiodatei in den Ressourcen? (Ich habe in dem Beispiel einen externen Link verwendet. In meinem Beispiel:

<embed height="20" width="128" autostart="false" controls="console"

loop="true" volume="50" src="{ wiki.selfhtml.org/local/Europahymne.mp3}Europahymne.mp3 "></embed>)
3. Ist das Einbetten von MP3 Dateien auch ohne Ausschalten des XSS Filters möglich? Der Admin, der an unserem Arbeitsplatz das Programm verwaltet, möchte ihn nur ungerne ausstellen.

Ich hoffe, ich habe mein Problem gut schildern können. Freue mich über jede Anregung!

Liebe Grüße und einen schönen Sonntag.

Please Log in to join the conversation.

More
2 months 1 week ago #157545 by Joffm
Joffm replied the topic: MP3 in Frage einbauen - Fehlermeldung?
Hallo,

Ich hoffe, ich habe mein Problem gut schildern können.


Hast Du nicht. Du hast uns nämlich die Fehlermeldung verschwiegen.

Aber: Hast Du Dir schon mal diese Beiträge angesehen?

https://www.limesurvey.org/de/foren/german-forum/111950-mp3-player
und
https://www.limesurvey.org/de/foren/design-issues/107193-include-audio-file

Und zu XSS hat ja Denis im zweiten der angegebenen Beiträge etwas gesagt.

Also: Demnächst zeige unds etwas mehr, z.B. genau Dein Einbinden des Audio-Links und wie schon gesagt, die Fehlermeldung.

Viel Erfolg
Joffm

Please Log in to join the conversation.

More
2 months 1 week ago #157546 by fauxdeduction
fauxdeduction replied the topic: MP3 in Frage einbauen - Fehlermeldung?
Lieber Joffm,

danke erst einmal für die Antwort! Die Fehlermeldung und meine Einbindung sind attached.
Ja, die anderen Einträge habe ich mir durchgelesen und die Anweisungen auch befolgt (soweit ich sie verstanden habe).

Ist der Code denn soweit richtig, also liegt das Problem an dem nicht ausgeschalteten XSS-Filter?

Liebe Grüße und vielen Dank nochmal!
Niimi
Attachments:

Please Log in to join the conversation.

More
2 months 1 week ago - 2 months 1 week ago #157548 by Joffm
Joffm replied the topic: MP3 in Frage einbauen - Fehlermeldung?
Hallo, Niimi,
in Deinem Attachment "Bild2" sehe ich in src="... zwei geschweifte Klammern und die Bezeichnung "Europahymne..." hinter dem Dateinamen.
Was machen die denn da?
Da stimmt ja die Syntax nicht.

Und wieso hängst Du so an dem "embed" statt das <audio> tag zu nehmen, wie es in den beiden Artikeln gezeigt ist?

Ich habe Dir einmal ein Beispiel angehängt.

Bis dann
Joffm
Attachments:
Last Edit: 2 months 1 week ago by Joffm.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now