Probleme SPSS-Export: keine Werte bei mehrfach numerischer Eingabe

More
7 months 4 days ago #150208 by FOGS
FOGS created the topic: Probleme SPSS-Export: keine Werte bei mehrfach numerischer Eingabe
Hallo zusammen!

Ich habe folgendes Problem:

Wenn ich die Antworten der Umfrage exportiere, werden mir für die mehrfach numerische Eingabe keine Werte (Antworten) angezeigt. Das Problem besteht nur beim Export der .dat-Datei. In der exportierten Excel-Datei werden mir die Werte angezeigt.

Wir haben die Daten schon oft exportiert, stehen aber zum ersten Mal vor diesem Problem.

Woran könnte das liegen?


Versionsnummer: 2.64.1 + 170310
Browser: Firefox / Chrome


Vielen Dank!

Anabel

Please Log in to join the conversation.

More
7 months 4 days ago #150213 by jelo
jelo replied the topic: Probleme SPSS-Export: keine Werte bei mehrfach numerischer Eingabe

FOGS wrote: Das Problem besteht nur beim Export der .dat-Datei. In der exportierten Excel-Datei werden mir die Werte angezeigt.

Hast Du die Werte in der .dat Datei direkt geprüft? Oder nur in SPSS die leeren Felder gesehen?

Bei einem Test unter Version 2.64.1+170310 konnte ich die Werte bei diesem Fragetype sauber gespeichert in der .dat-Datei finden.

'2','01-01-1980 00:00:00','1','de','9999999.0000000000','777777.0000000000',

Lege mal eine neue Befragung mit einer Frage an und exportiere die dat-Datei. Mit Texteditor reinschauen, ob dort die Zahlen sind.

Falls die Zahlen in der dat-Datei enthalten sind, bleibt Syntaxdatei oder SPSS-Installation als Fehlerquelle.

Welche SPSS Version unter welchem Betriebssystem kommt zum Einsatz?
The following user(s) said Thank You: FOGS

Please Log in to join the conversation.

More
7 months 4 days ago #150219 by jelo
jelo replied the topic: Probleme SPSS-Export: keine Werte bei mehrfach numerischer Eingabe
Die Syntax wird von LimeSurvey nicht völlig korrekt erstellt.
Die numerischen Antworten werden als Text/String-Variable in der Syntax vermerkt.
Das ist zwar falsch, aber ein Import in SPSS wird dadurch nicht verhindert.
Die Werte sollten also erscheinen, wenn auch als Text anstatt als Zahl




Du solltest eine Testbefragung erstellen und erneut prüfen.
Falls weiterhin das Problem besteht, dann hier Testumfrage, DAT und Syntax-Datei anhängen.
Attachments:

Please Log in to join the conversation.

More
7 months 4 days ago #150224 by FOGS
FOGS replied the topic: Probleme SPSS-Export: keine Werte bei mehrfach numerischer Eingabe
Hallo Jelo,

herzlichen dank für Deine Hilfe. Das Problem ist gelöst.

Ich habe mir die dat-Datei nochmal im Texteditor angeschaut. Dort waren die Werte tatächlich vorhanden.

Das Problem lag in der SPSS-Syntax. Hier war ein Fehler im Set Locale Befehl.

Besten Dank!
Anabel

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now