upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage

More
6 months 4 weeks ago #149158 by bwl21
bwl21 created the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage
Hi,

ich habe versucht, unsere Installation von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 updaten. Vorgehen nach

manual.limesurvey.org/Upgrading_from_a_previous_version -> The quick way (for minor version changes)

Wenn ich dann auf die Admin-Seite gehe, bekomme ich


Interner Serverfehler
 
Die Tabelle "{{notifications}}" für die ActiveRecord-Klasse "UniqueNotification" kann nicht in der Datenbank gefunden werden.
 
Beim Bearbeiten Ihrer Anfrage durch den Webserver ist ein interner Fehler aufgetreten. Bitte kontaktieren Sie the webmaster um dieses Problem zu melden.
 
Vielen Dank.
 
24.02.2017 18:13:34
 

Habe Backup wieder eingespielt, um den Betrieb aufrecht zu erhalten ...

Was kann ich tun?

Vielen Dank.

Please Log in to join the conversation.

More
6 months 4 weeks ago #149162 by jelo
jelo replied the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage

bwl21 wrote: Was kann ich tun?

Hast Du den Comfortupdater genutzt? Falls ja, dürfte es ein Fehler im Upgradescript sein.
Vermutlich gleicher Fehler wie hier:
www.limesurvey.org/community-services/fo...sql-server-db#149042

Dort wurde manuell aktualisiert, um nicht in den Fehler zu laufen. Der Fehler besagt ja nicht anderes, als das die Tabelle vergessen wurde anzulegen.

Grundsätzlich würde ich Updates stets an einer Testversion durchspielen. Denn es gibt keine Tests hier vorab. Du bist beim Updaten die Testperson.

Please Log in to join the conversation.

More
6 months 4 weeks ago #149170 by bwl21
bwl21 replied the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage
Nein, ich habe ein manuelles Update gemacht. Natürlich hatte ich ein Backup, so kam ich wieder zu einem lauffähgigen System.

Bislang hatte ich noch kein Testsystem aufgesetzt - werde das jetzt wohl aber tun.

Die Frage ist, ist es ein Fehler in dem DB-Update-Script? oder hätte die tabelle schon bei 2.5 da sein müssen.

Zunächst werde ich dieses Update einfach aussitzen.

-b

Please Log in to join the conversation.

More
6 months 4 weeks ago #149171 by jelo
jelo replied the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage

bwl21 wrote: Die Frage ist, ist es ein Fehler in dem DB-Update-Script? oder hätte die tabelle schon bei 2.5 da sein müssen.

Alles möglich. Dafür sollte ein Bugreport geöffnet werden. Dann kann man vielleicht die Daten mit dem anderenThread abgleichen. Dort war zumindest mal ein MS SQLServer im Spiel. Bei Dir auch?

Please Log in to join the conversation.

More
6 months 4 weeks ago #149176 by holch
holch replied the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage
Und aussitzen scheint ja kein Problem zu sein. Du hast jetzt über ein Jahr kein Update gemacht, hast also bestimmt 20 Updates oder mehr ausgessessen. ;-)

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 months 3 weeks ago #149183 by bwl21
bwl21 replied the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage

holch wrote: Und aussitzen scheint ja kein Problem zu sein. Du hast jetzt über ein Jahr kein Update gemacht, hast also bestimmt 20 Updates oder mehr ausgessessen. ;-)


Nein, ist wirklich kein problem:-) Wir machen einmal im Jahr eine Umfrage. Drum hab ich mich erst dieser Tage wieder mit LS befasst und bekam die Meldung dass Sicherheitsupdate da wäre.

Please Log in to join the conversation.

More
6 months 3 weeks ago #149184 by bwl21
bwl21 replied the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage
[quote="jelo" post=149171
Alles möglich. Dafür sollte ein Bugreport geöffnet werden. Dann kann man vielleicht die Daten mit dem anderenThread abgleichen. Dort war zumindest mal ein MS SQLServer im Spiel. Bei Dir auch?[/quote]

Nein bei uns läuft das auf einer vanilla php mit mysql.

Mal schaun ob ich rausfinde, wo man den Bugreport los wird - auf Github schon mal nicht :-)

Please Log in to join the conversation.

More
6 months 3 weeks ago #149185 by bwl21
bwl21 replied the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage

bwl21 wrote: Dafür sollte ein Bugreport geöffnet werden


leider komme ich in den Bugtracker nicht rein. Wenn ich dort auf "Registration" klicke vesucht er sich auf limesurvey.org anzumelden. Da bin ich aber schon angemeldet. Und so dreh ich mich ein bisschen im Kreis.

Ob es wohl daran liegt, dass ich hier meine Github-Id verwendet habe?

Please Log in to join the conversation.

More
6 months 3 weeks ago #149186 by bwl21
bwl21 replied the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage

bwl21 wrote: Dafür sollte ein Bugreport geöffnet werden


leider komme ich in den Bugtracker nicht rein. Wenn ich dort auf "Registration" klicke vesucht er sich auf limesurvey.org anzumelden. Da bin ich aber schon angemeldet. Und so dreh ich mich ein bisschen im Kreis.

Ob es wohl daran liegt, dass ich hier meine Github-Id verwendet habe?

Please Log in to join the conversation.

More
6 months 3 weeks ago #149190 by holch
holch replied the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage

bwl21 wrote: Nein, ist wirklich kein problem:-) Wir machen einmal im Jahr eine Umfrage. Drum hab ich mich erst dieser Tage wieder mit LS befasst und bekam die Meldung dass Sicherheitsupdate da wäre.


OK, aber Sicherheitsproblemen ist es egal ob du gerade eine Umfrage machst oder nicht, und Hacker sowieso. ;-)

In den Bugtracker solltest du eigentlich ganz normal mit deinen Zugangsdaten hier vom Forum kommen. Aber manchmal funktioniert die Synchronisierung nicht.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
6 months 3 weeks ago #149191 by jelo
jelo replied the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage

bwl21 wrote: Ob es wohl daran liegt, dass ich hier meine Github-Id verwendet habe?

Bugtracker auf Limesurvey.org sollte eigentliche die Benutzerdaten vom Forum und limesurvey.org verwenden.

Vielleicht mal über bugs.limesurvey.org/login_page.php versuchen, sich mit den Forum/LimeSurvey.org Zugangsdaten anmelden.

Please Log in to join the conversation.

More
6 months 3 weeks ago #149193 by bwl21
bwl21 replied the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage

jelo wrote:

bwl21 wrote: Ob es wohl daran liegt, dass ich hier meine Github-Id verwendet habe?

Bugtracker auf Limesurvey.org sollte eigentliche die Benutzerdaten vom Forum und limesurvey.org verwenden.

Vielleicht mal über bugs.limesurvey.org/login_page.php versuchen, sich mit den Forum/LimeSurvey.org Zugangsdaten anmelden.


Ich habe mir einen Passwort rücksetzlink schicken lassen. Damit konnte ich ein Passwort anlegen, das dann erstaunlicherweise auch im Forum funktionert.

Please Log in to join the conversation.

More
6 months 3 weeks ago #149194 by bwl21
bwl21 replied the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage

holch wrote:

bwl21 wrote: Nein, ist wirklich kein problem:-) Wir machen einmal im Jahr eine Umfrage. Drum hab ich mich erst dieser Tage wieder mit LS befasst und bekam die Meldung dass Sicherheitsupdate da wäre.


OK, aber Sicherheitsproblemen ist es egal ob du gerade eine Umfrage machst oder nicht, und Hacker sowieso. ;-)


Das stimmt schon, so lange die site online ist. Das ist aber nicht der Fall, wenn keine Umfrage läuft.

Wie immer dem auch sei, ich weiß nun nicht, wie ich das Update machen soll.

Please Log in to join the conversation.

More
6 months 3 weeks ago #149214 by jelo
jelo replied the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage

bwl21 wrote: Damit konnte ich ein Passwort anlegen, das dann erstaunlicherweise auch im Forum funktionert.

Das freut mich für Dich.
Dein Bugreport sollte noch hier verlinkt werden, falls andere Nutzer ähnliche Schwierigkeiten haben.

bugs.limesurvey.org/view.php?id=12155

Please Log in to join the conversation.

More
5 months 3 days ago #152634 by schmitz
schmitz replied the topic: upgrade von Version 2.50+ Build 160206 auf limesurvey2.63.1+170305 fehlgeschlage
Hatte das selbe Problem. Ausloggen aus dem Backend hat geholfen. Dafür habe ich die Cookies gelöscht.

VG

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now