Migration 2.6.3-lts -> 2.62 : analyse d'impact

More
7 months 2 weeks ago #148235 by gantier
gantier created the topic: Migration 2.6.3-lts -> 2.62 : analyse d'impact
Bonjour,

Je souhaite migrer mon LS de la version 2.6.x-lts -> 2.x (ou dernière stable au moment).

J'ai bien compris que mon thème ne sera pas compatible ( manual.limesurvey.org/Upgrading_from_a_p....0x_to_2.50_or_later ) et je cherche à identifier les autres impacts potentiels sur mon installation.

J'utilise un webservice d'authentification qui créé les utilisateurs dans la BDD de LS (si pas déjà créé) et leur affecte des droits minimalistes par défaut (création d'un sondage uniquement).
Est-ce que les évolutions entre ces 2 versions ont touché la partie authentification et/ou gestion des droits ?


Le format des url d'accès aux sondages a-t-il changé ?

Cordialement.

PS : Je n'arrive pas à insérer de lien dans mon message avec le bouton dédié, tout l'écran est "grisé" (Firefox 51.0.1).

Please Log in to join the conversation.

More
7 months 2 weeks ago #148236 by LouisGac
LouisGac replied the topic: Migration 2.6.3-lts -> 2.62 : analyse d'impact
Non, pas de changement au niveau des droits, ni au niveau des urls.

Vous pouvez aussi tester la nouvelle version avec la version gratuite du Professional Hosting Subscription.

Please Log in to join the conversation.

More
7 months 2 weeks ago #148237 by DenisChenu
DenisChenu replied the topic: Migration 2.6.3-lts -> 2.62 : analyse d'impact
Ben_V à déjà tester la migration vers la 2.5X , puis repassage en 2.6 : pas de soucis.

Mais à la base : l'API n'a pas changé en dehors des modèle public.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
6 months 2 weeks ago #149656 by gantier
gantier replied the topic: Migration 2.6.3-lts -> 2.62 : analyse d'impact
Bonjour,

Je suis en train de tester la remise en place de mon webservice d'authentification sur la dernière version stable.
J'obtiens le message "Service indisponible".

Quand j'essaie d'afficher les erreurs PHP (en modifiant le php.ini et en activant le debug mode '1' dans le fichier config.php) je n'arrive pas à voir d'erreur à l'écran.

Un conseil pour m'aider à comprendre ? :)

Cordialement.

Please Log in to join the conversation.

More
6 months 2 weeks ago #149659 by gantier
gantier replied the topic: Migration 2.6.3-lts -> 2.62 : analyse d'impact
Ah j'ai enfin réussi à afficher les erreurs...
SoapClient::SoapClient(): Failed to enable crypto
Ya plus qu'à... :/
The following user(s) said Thank You: DenisChenu

Please Log in to join the conversation.

More
6 months 2 weeks ago #149661 by DenisChenu
DenisChenu replied the topic: Migration 2.6.3-lts -> 2.62 : analyse d'impact
C'est LimeSurvey qui est client SOAP sur ton service d'identification ?

C'est un plugin public ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
6 months 2 weeks ago #149666 by gantier
gantier replied the topic: Migration 2.6.3-lts -> 2.62 : analyse d'impact
C'est un plugin privé (avec des infos que je ne souhaite pas partager ici en tous cas :D )

Je maitrise mal le code mais il me semble qu'on crée un client soap qui va solliciter le webservice. Après analyse le problème vient sûrement du webservice lui-même et sa configuration ;)

Merci en tout cas.

Please Log in to join the conversation.

More
6 months 2 weeks ago #149684 by DenisChenu
DenisChenu replied the topic: Migration 2.6.3-lts -> 2.62 : analyse d'impact
Bien sur pour le privé :)

Si tu as , en même temps, fait la mise à jour du PHP : en PHP5.6 : toutes connexion TLS valide (par défaut) le Certificat, si tu utilise un certificat autosigné : ca plante.

Pour le désactiver : recherche sur le web 'PHP 5.6 certificat autosigné' ca doit passer.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

Moderators: Nickko

Start now!

Just create your account and start using Limesurvey today.

Register now