LTS 2.6.7 and PHP support

More
5 months 2 weeks ago #173309 by jelo
The current description of requirements for LTS 2.6.7 contains

*PHP 5.3.3 or later with the following modules/libraries enabled

github.com/LimeSurvey/LimeSurvey/blob/2....cs/release_notes.txt


That would include PHP versions like 7.0, 7.1 or 7.2.


LTS 2.6.7 under PHP 7.2?
When doing a quick installation the preinstallation check already fails under PHP 7.2.

Internal Server Error
Function name must be a string

An internal error occurred while the Web server was processing your request. Please contact the webmaster to report this problem.

Thank you.


PHP 7.1 looks the same.

When moving a complete installation to PHP 7.2. I see no issues.

So the installer might be a bit to edgy ;-) You can run LTS on PHP 7.2, but you cannot install it.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #173312 by DenisChenu

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #173314 by jelo
Replied by jelo on topic LTS 2.6.7 and PHP support
42

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #173412 by jelo

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!