RemoteControl 2 API in export_responses method json output not getting

More
2 years 3 months ago - 2 years 3 months ago #151077 by manavaahuja07
HI,

I am able to get response of list_groups ,list_questions method.

But when i am getting response of export_responses method i am no getting that response in proper json.

I am getting some response it also looks like my response but i think its in difference format.


HERE is my code http://pastebin.com/PHUf3eAP

and HERE is my out put http://pastebin.com/a6SV2bNS
Last edit: 2 years 3 months ago by manavaahuja07.

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
2 years 3 months ago #151078 by jelo
You still should edit php.ini and change always_populate_raw_post_data' to '-1'.
In XAMPP it is already there, but a ";" is in front of the setting to comment it out.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
2 years 3 months ago - 2 years 3 months ago #151079 by manavaahuja07
Now My output look like this http://pastebin.com/z60Ratja

Still JSON is same as eralier...:( :(
Last edit: 2 years 3 months ago by manavaahuja07.

Please Log in or Create an account to join the conversation.

More
2 years 3 months ago #151083 by jelo
Is the survey activated and has some responses?
Personally I don't use the API via Java, but I would add the optional parameters and don't leave them empty. Perhaps it is a bug in the API.

You will have to play a bit with it. Perhaps use CSV to test if it is working at all.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
2 years 3 months ago - 2 years 3 months ago #151084 by manavaahuja07
YES survey is active and response ID is also correct.
I just tried with all the parameters then also result is same...

post.setEntity(new StringEntity("{\"method\": \"export_responses\", \"params\": "+ "[ \"" + sessionKey + "\" , \"289946\" , \"csv\" , \"en\" , \"all\" , \"full\" , \"long\", \"62\" , \"62\"], \"id\": 60}"));
Last edit: 2 years 3 months ago by manavaahuja07.

Please Log in or Create an account to join the conversation.

More
2 years 3 months ago #151086 by manavaahuja07
Thanx jelo

i am getting the output as i want it is base 64-encode string so its giving that type of things....;)

Please Log in or Create an account to join the conversation.

More
2 years 3 months ago #151171 by DenisChenu
Yep, base64 :).

Else i make a short snippet for json export responses : framagit.org/SondagePro-LimeSurvey-plugi...Control/snippets/403

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
2 years 3 months ago #151804 by manavaahuja07

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!