Design slightly moves in certain browsers (Firefox ok, Chrome nok, Safari nok)

More
2 years 9 months ago - 2 years 9 months ago #111512 by vincentgnieslaw
vincentgnieslaw created the topic: Design slightly moves in certain browsers (Firefox ok, Chrome nok, Safari nok)
Hello everyone,

I'm having the following issue:

- when I move the first slider, the design (header) jumps a bit to the left;
- when I hit the 'Next' button, the design jumps a bit to the right.

LimeSurvey Version 2.05+ Build 140730
Template: a copy of the 'basis' template (delivered with LimeSurvey), it does the same with the original template.

I'm currently using the following browsers to test my survey:
Firefox: v.31.0 - OK
Chrome: v.36.0.1985.125 - NOK (header moves, and table)
Safari: v.7.0.5 (9537.77.4) - NOK (only header moves)
Link to survey: limesurvey.vincentgnieslaw.com/index.php...94/newtest/Y/lang/en

Can someone advice?

Many thanks,
Vincent
Last Edit: 2 years 9 months ago by vincentgnieslaw. Reason: Typo

Please Log in to join the conversation.

More
2 years 9 months ago #111513 by holch
holch replied the topic: Design slightly moves in certain browsers (Firefox ok, Chrome nok, Safari nok)
Tested in Chrome latest Version (36.0.1985.125 m) nothing moves or jumps...

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 9 months ago #111532 by tpartner
tpartner replied the topic: Design slightly moves in certain browsers (Firefox ok, Chrome nok, Safari nok)
Chrome 35 on Android - nothing jumping.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
2 years 9 months ago #111533 by holch
holch replied the topic: Design slightly moves in certain browsers (Firefox ok, Chrome nok, Safari nok)
Maybe try to clear the cache of the browsers where the problem appears.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 9 months ago #111535 by vincentgnieslaw
vincentgnieslaw replied the topic: Design slightly moves in certain browsers (Firefox ok, Chrome nok, Safari nok)
Thanks for your replies. I tried to clear the cache but the problem's still there.

Can other forum members also have a look at this please? I have no clue how to solve this...

Thanks again for your support!

Vincent

Please Log in to join the conversation.

More
2 years 9 months ago #111536 by holch
holch replied the topic: Design slightly moves in certain browsers (Firefox ok, Chrome nok, Safari nok)
Try on other machines, try with friends computer.

As it doesn't appear on my Chrome, and it doesn't appear on Tpartners Chrome, chances are quite high that it is a problem with your computer. Tried to switch off the addons in Chrome and Firefox?

Tried with Firefox, also no "jumping". But that is what you experience as well.

Now seeing that you have Safari installed, I assume that you are working on a Mac. I have tested on a Windows 8 machine and Tpartner on Android. So maybe it is a problem on Mac?

By the way, to be honest, I don't think that the slider is a good choice for the questions you are asking. Slider questions are great when you want to show that it is some kind of continuum. But in your case there are 5 very clear defined points.

I think it would be a lot easier for respondents if this would be a normal array question. Doesn't look as fancy, but is for sure the better choice for understanding the question and also for answering. It is a lot easier to click the respective answer than to slide.

Actually you could use just one question on each page instead of 4 or 5. But that is of course a completely different topic.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: vincentgnieslaw

Please Log in to join the conversation.

More
2 years 9 months ago #111537 by vincentgnieslaw
vincentgnieslaw replied the topic: Design slightly moves in certain browsers (Firefox ok, Chrome nok, Safari nok)
Disabling my extensions in Chrome did the trick! Thank you so much for solving this.

Regarding the type of question: I tried to use the Array (5 point choice) but I'm not sure how to add the 'I don't know' answer (value = 0) next to it. All questions should also be mandatory.

Can you advise me on what to do?

Thanks again, Vincent

Please Log in to join the conversation.

More
2 years 9 months ago #111538 by holch
holch replied the topic: Design slightly moves in certain browsers (Firefox ok, Chrome nok, Safari nok)
Hi!

Here your question as an array. This is what it would look like:



And I have attached it as an .lsq file attached to this.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Attachments:

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now