Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Multiple choice question with exclusive option misbehaves when using "prev" butt

Multiple choice question with exclusive option misbehaves when using "prev" butt 2 years 5 months ago #109816

  • khoy01
  • khoy01's Avatar
  • Offline
  • Junior Lime
  • Posts: 20
  • Karma: 0
We have a survey with a question "multiple choice". This question is mandatory and has an "exclusive option". In the survey you can use the "prev" button.
When you check the "exclusive option" all other options are disabled. So far so good.
When you click "next" and afterwards "prev" you can uncheck the "exclusive" option but the other choices are not enabled again. When you want to go on you get the error "mandatory question" ... .
After that all the options of the multiple choice question are available again.
I tried in the demoversion too with the same result.
This is confusing for respondents.
Is this a bug or shoult I change something in the settings for the question?
The administrator has disabled public write access.

Multiple choice question with exclusive option misbehaves when using "prev" butt 2 years 5 months ago #109818

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9600
  • Thank you received: 1376
  • Karma: 390
Hi,

I think you can report this bug.

Denis
Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (use private message).
The administrator has disabled public write access.
Time to create page: 0.205 seconds
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form